Jump to content
hyfly

Video wird nicht komplett geladen

Recommended Posts

hyfly

Moin,

mir ist es jetzt das zweite mal aufgefallen, dass ein Video, welches ich mit DVBViewer aufgenommen habe im Video Editor nicht komplett geladen wird. Es handelte sich um Filme mit einer Länge von ca 2 Stunden Dauer. Sie sind vollständig aufgenommen worden und auch im Viewer vollständig anzusehen.

Im Editor erscheinen jeweils nur ca. 1 Stunde. Es ist keine Scrollbar vorhanden und auch die Veränderung des Maßstabs bringt keinen Erfolg.

 

Ich nutze Windows 10 Pro und die DVB-Version Pro 6.1.2.0 sowie den Editor in der Version 1.0.8.

Any idea?

 

Gruss

Harald

Share this post


Link to post
Webturtle

Hallo,

 

ich  hatte bisher keine Probleme mit der Länge der Aufnahme. Ich schneide mit dem Video Editor in der Regel nur Aufnahmen vom DVB-T2 HD. Die Aufnahmen vom DVB-S schneide ich in der Regel noch mit meinem alten BHV Easy Movie. Ich werde mal sehen ob ich eine Aufnahme von 2+x h Länge zur Hand habe und werde sie einmal zu laden versuchen.

 

Vielleicht hilft es, wenn Du die automatische Indexierung deaktivierst. Ich habe gelesen, daß @hackbart eine Art Log-Funktion implementiert hat. Wenn Du sie findest und postest, könnte das den Entwicklern eine Hilfe erleichtern. Sie müßte sich wohl entweder im Programmverzeichnis des DVBViewers oder des Video Editors oder im Konfigurationsverzeichnis des DVBViewers oder eine seiner Unterverzeichnisse befinden. Zum Konfigurationsverzeichnis findet man in den Optionen des DVBVewers einen Link.

 

Ich habe gerade noch mal bei https://www.DVBViewer.tv/forum/topic/61785-filme-mit-überlänge/ nachgesehen. Dort dreht es sich wohl um dasselbe Problem. @hackbart hat dort geschrieben, daß die Timeline scrollbar sein sollte.

 

 

Viele Grüße

 

Webturtle

 

 

 

 

 

 

 

Edited by Webturtle

Share this post


Link to post
hackbart

Es gibt ja 3 verschiedene Arten die Datei zu laden. Methode 1 ist die normale. Bei der wird vor dem Laden eine Indexdatei erstellt. Methode 2 erstellt den Index im Hintergrund und die letzte Variante erstellt keinen Index. Der Index ist leider nötig, wenn es um GOP genaue Schnittpunkte geht. Ohne die Indexdatei ist das recht ungenau. 

Im Explorer erkennt man übrigens ob die Indexdatei im Eimer ist, wenn die Erstellungszeit der Indexdatei nicht der selbe ist, wie des Videos.

 

Die Timeline kannst du natürlich scrollen:

editor.PNG

Wie auf dem Bild zu sehen ist, hast du unter der Zeitleiste eine Scrollleiste. Über den Knopf ganz rechts unten, öffnet man ein Popup-Menü in dem, je nach Videolänge, Zoom-Stufen aufgeführt werden. 

 

Screenshot 2018-10-17 um 15.59.57.png

 

Damit kann man recht genau die gewünschten Abschnitte vergrößern. 

Wie gesagt mir sind hier mit den teilweise 20gb großen Aufnahmen keine Probleme diesbezüglich aufgefallen. Es ist halt extrem wichtig, dass wenn Indexdateien benutzt werden diese nicht kaputt sein dürfen. Im Zweifel löscht man die Indexdatei halt.

Share this post


Link to post
Webturtle

Hallo,

 

ich habe es mit der längsten Aufnahme, die ich auf die Schnelle gefunden habe versucht. Auch bei 3:15 h Länge wurde die Aufnahme problemlos geladen. Bei mir wird der Index wohl im Hintergrund erstellt, da die blaue Kurve erste nach dem Öffnen fertiggestellt wird.

 

Scrollen kann man die Timeline bei mir zunächst nicht, da der Video Editor zuerst die ganze Aufnahme komplett "anzeigt", also die Timeline so viel Zeit anzeigt, wie die Aufnahme lang ist. Verändert man aber den Maßstab der Timeline, wird darauf ein Slider sichtbar und die Pfeilschaltflächen rechts und links verschieben den Slider und den Ausschnitt.

 

@hyfly: Falls es bei Dir weiterhin nicht funktioniert, würde ich mal die 32-Bit Version versuchen, sofern Du die 64-Bit Version verwendest. Bei mir gabe es bei letzterer anfangs Probleme. Außerdem würde ich den Index im Hintergrund erstellen lassen, sonst wartet man mitunter sehr lange bis etwas sichtbar wird.

 

@hackbart: Wo findet man denn die Support--Informationen wenn man Probleme hat?

 

 

Viele Grüße

 

Webturtle

 

Share this post


Link to post
gleddamax

Den Video Editor mit dem Parameter   -debug   starten.

 

Nach dem Schneiden findet man die Log-Datei im Konfigurationsverzeichnis (Tools > Umgebungsoptionen > Zeige Konfigurationsverzeichnis).

  • Like 1

Share this post


Link to post
Webturtle

Hallo gleddamax,

 

vielen Dank für den hilfreichen Hinweis! :thumbsup:

 

Man hat ab und zu davon etwas gelesen, aber nie richtig erfahren, wie man damit etwas anfangen kann.

Share this post


Link to post
hyfly
Am 18.10.2018 um 14:38 schrieb Webturtle:

Hallo,

 

ich habe es mit der längsten Aufnahme, die ich auf die Schnelle gefunden habe versucht. Auch bei 3:15 h Länge wurde die Aufnahme problemlos geladen. Bei mir wird der Index wohl im Hintergrund erstellt, da die blaue Kurve erste nach dem Öffnen fertiggestellt wird.

 

Scrollen kann man die Timeline bei mir zunächst nicht, da der Video Editor zuerst die ganze Aufnahme komplett "anzeigt", also die Timeline so viel Zeit anzeigt, wie die Aufnahme lang ist. Verändert man aber den Maßstab der Timeline, wird darauf ein Slider sichtbar und die Pfeilschaltflächen rechts und links verschieben den Slider und den Ausschnitt.

 

@hyfly: Falls es bei Dir weiterhin nicht funktioniert, würde ich mal die 32-Bit Version versuchen, sofern Du die 64-Bit Version verwendest. Bei mir gabe es bei letzterer anfangs Probleme. Außerdem würde ich den Index im Hintergrund erstellen lassen, sonst wartet man mitunter sehr lange bis etwas sichtbar wird.

 

@hackbart: Wo findet man denn die Support--Informationen wenn man Probleme hat?

 

 

Viele Grüße

 

Webturtle

 

Moin,

naja, es funktioniert ja in den meisten Fällen. Da ich bereits Filme mit über 3 Std. Länge aufgenommen habe und diese auch im Editor bearbeiten konnte, verwundert es mich ja.

 

Es ist auch bei mir so, dass nach dem Laden die Gesamtlänge auf der Timeline angezeigt wird. Bei dem beanstandeten Film war die Filmlänge 90 Minuten, aber nur 62 wurden angezeigt. Nach dem Wechsel des Maßstabs ist sie dann scrollbar, allerdings nur bis 62 Minuten. Das Ende des Films fehlt.

 

Ich nutze ein 64-Bit Betriebssystem und eine 64-Bit Version der Software. Funktioniert ebendann überhaupt ein 32-Bit Softwarepaket?

 

Die verschiedenen "Ladeoptionen" habe ich ausprobiert. Leider ohne Erfolg.

 

Ich werde es weiter beobachten und werde ggf. berichten.

Vielen Dank für die Mühe

 

Gruß in die Runde

Harald

Share this post


Link to post
hackbart

Ja der DVBViewer ist ja auch 32Bit. Generell ist es einfacher, wenn die 32Bit Version von Editor benutzt wird, denn dann weiß zumindest das alle nötigen Dekoder schon vorhanden sind. Wie gesagt die Log Datei wäre schon praktisch.

Share this post


Link to post
Webturtle

Hallo,

 

ich habe mal nachgesehen. Ich habe die Indexierung generell deaktivirt. Mit Indexierung vor dem Laden passiert zunächst mal gar nix und bei Indexierung im Hintergrund wird mir zwar ein Bild der Aufnahme angezeigt, danach steht der Video Editor aber erst mal still. Scrollen oder über die Buttons jumpen ist nicht drin.

 

GOP-genaues Schneiden ist in vielen Fällen auch nicht erforderlich. Ich schneide in der Regel nur Vor- und Nachlauf weg und eventuell Werbeunterbrechungen. Da manche Sender z.B. ProSieben nach der Werbeunterbrechung - zum Glück! - einen Teil der Sendung vor der Werbeunterbrechung wiederholen, wäre es sehr mühsehlig, die Werbeunterbrechung mitsamt dem doppelten Teil der Sendung rauszuschneiden. Ich scheide daher so, daß noch ein kurzer Teil der Werbung übrig bleibt. Hier noch eine Erklärung zu der Bemerkung "zum Glück": So hat man wenigstens die Serie oder den Film vollständig, denn es gelingt, denen offenbar nicht, genau zu schneiden bzw. das auch zu so senden. Die "Sponsorenwerbung" nach den Trailern und vor der eigentlichen Sendung wird seit einiger Zeit vor dem Ende mitten im Satz abgebrochen. Mich wundert, daß da überhaupt noch jemand Werbung bucht und zumindest einen Teil des Geldes zurückverlangt.

 

 

Viele Grüße

 

Webturtle

Share this post


Link to post
hyfly

Moin,

 

wie kann ich denn eine LogDarei erstellen?

 

Wie wird die Indexierung deaktiviert und wofür benötigt man sie eigentlich?

 

Was ist "GOP-genaues schneiden?

 

Tja, Fragen über Fragen

 

Es grüßt der Anfänger

 

Harald

Share this post


Link to post
hackbart

Videokompression läuft so ab, dass man in Intervallen ganze Bilder speichert und dazwischen nur Änderungen. Schneidet man nun dazwischen hat man erstmal irgendwas nicht ansehnliches, bevor ein Vollbild erscheint. Das Indexieren ermöglicht es die Position der Vollbilder in einer Datenbank zu speichern, mit der man besser und genauer schneiden kann.

 

Das sind aber jetzt Fragen die auch Tante Google beantworten kann. In den Optionen kann man einstellen, ob man Indexing braucht oder nicht.

Share this post


Link to post
gleddamax
vor 3 Stunden schrieb hyfly:

wie kann ich denn eine LogDarei erstellen? 

 

die Erklärung dazu findet sich weiter oben in diesem Thread. Sollte nicht klar sein, wie man ein Programm mit Parametern starten kann entweder nachfragen oder über eine Suchmaschine eine Anleitung suchen.

Share this post


Link to post
hyfly

ok, habe ich verstanden.

 

nach dem schneiden, wenn es denn klappt, finde ich im Explorer eine zusätzliche Datei mit der Endung MLMIX. Was ist das für eine Datei, wofür benötigt das Programm sie oder kann ich sie löschen.

 

Und bitte nicht wieder den Hinweis auf Google, da kennt man diese Abkürzung nicht (lediglich MIX-Dateien). Das Wikki ist auch sprachlos.

Share this post


Link to post
gleddamax

Die MLMIX-Dateien beinhalten den Index, der vom Video-Editor erzeugt wird. Somit muss beim nächsten Schneiden der Videodatei der Index nicht erneut erstellt werden und man kann sofort anfangen zu schneiden. Sie kann auch gelöscht werden, sollte sie nicht mehr benötigt werden.

 

Wurde die Index-Datei gelöscht, wird sie vom Video Editor erneut erzeugt, sobald das Video dort bearbeitet wird und die Indexierung aktiviert ist.

Share this post


Link to post
Webturtle

Hallo,

 

also die Einstellungen zur Index-Erzeugung findet man unter Tools - Umgebungsoptionen. Es gibt, wie @hackbart erklärt hat, 3 Einstellungen an, im Hintergrund uns aus. Wenn man Probleme hat und es kein ganz genauer Schnitt erforderlich ist, würde ich erst mal auf "aus" stellen. Dann läuft der Editor auch viel schneller. Wenn nur die Werbung oder der Vor- und Nachlauf weggeschnitten werden soll, braucht man nicht unbedingt die Indexierung.

 

In den Umgebungsoptionen findet man auch einen Link (unten im Fenster) zum Konfigurationsverzeichnis. Es ist dasselbe wie beim DVBViewer, nämlich das CMUV-Verzeichnis. Wenn man den Editor mit dem Kommandozeilenparameter -debug gestartet hat, wird dort das Log gespeichert, aber erst beim Verlassen des Editors. Man klickt also auf den Link zum Konfigurationsverzeichnis. Dann wird das Verzeichnis angezeigt. Danach schließt man den Editor und aktualisiert die Ordneransicht. Dort findet man die Videoeditor.ini mit den Einstellungen und die Editor.log. Beide können bei Problemen hilfreich sein und in einem Posting für die Experten hochgeladen werden. Für den Debuggingmodus ist es bei Windows 10 am einfachsten, den Link für den Video Editor auf dem Desktop zu bearbeiten. Dazu rechts darauf klicken und Eigenschaften anwählen. Oben, wo "...Videoeditor.exe" steht, nach den abschließenden " -debug einfügen und auf ok klicken.

 

 

Viele Grüße

 

Webturtle

 

 

 

Edited by Webturtle

Share this post


Link to post
Webturtle

Hallo,

 

ich kann jetzt leider auch einen Fall anführen, in dem der Video-Editor eine Aufnahme nicht vollständig geladen hat. Es handelt sich um eine Aufnahme mit dem DVBViewer GE vom DVB-T2 HD von BR-Alpha (alias ARD-Alpha) von UFO (13!). Die Aufnahme ist 1:10 h lang und kann mit dem MPC-HC bis zum Ende angezeigt werden. Der Video-Editor lädt die Aufnahme aber nur bis ca. 0:55:38 h. Ich habe die Aufnahme daher zum Test mit dem TS-Doctor geöffnet. Der hat sie vollständig geladen. Ich habe den TS-Doctor die Aufnahme testen lassen und  der Test hat keine Fehler oder Warnungen ergeben. Ich habe versucht die Aufnahme um den Abbruchpunkt (2 Minuten davor und danach) zu schneiden, um diesen Ausschnitt hochladen zu können. Aber der Video-Editor hat diesen Ausschnitt anders als die komplette Aufnahme vollstädig geladen, auch nach dem ursprünglichen Endpunkt.

 

Hier die Logs:

DVBViewer GE Log: UFO (13) ARD-alpha HD (deu) 12-14 21-35-00.log

TS-Doctor Log: UFO (13) ARD-alpha HD (deu) 12-14 21-35-00_check.log

 

 

Viele Grüße

 

Webturtle

Share this post


Link to post
Webturtle

Hallo,

 

hier noch eine Ergänzung: Wenn man goto end program wählt, wird der "Bildschirm" (also der Bereich, der die Aufnahme anzeigt) grün und als Position wird ca. 2:48 angezeigt. Wenn man dann zur Position 0:55:38 springt, dem Ende des angezeigten Bereichs, wird wieder ein Bild angezeigt. Wenn man dann mehrfach auf jump forward klickt, kommt man Schritt für Schritt bis zum Ende der Serienfolge.

 

Die Aufnahme der Wiederholung der Sendung ließ sich problemlos mit dem Editor komplett laden. :iiam:

 

 

Hier noch das Video-Editor Debug-Log: editor.log

 

 

Viele Grüße

 

Webturtle

Share this post


Link to post
Webturtle

Hallo,

 

hier eine weiter Ergänzung: Wenn man mit jump forward über den Endpunkt hinausspringt, bis zu dem die Aufnahme geladen worden ist, ändert sich an der Timeline aber nichts. Dort bleibt der Endpunkt unverändert.

 

Ich habe den Startpunkt zwei Minuten vor den Zeitpunkt gesetzt, bis zu dem die Aufnahme geladen worden ist, und den Endpunkt zwei Minuten danach. Beim Speichern gab es keine Fehlermeldung, aber die gespeicherte Aufnahme ging nur bis zu dem Zeitpunkt, bis zu dem sie auch mit dem Video-Editor geladen worden ist. Auch beim MPC-HC. Danach wurden nichts mehr exportiert, obwohl es am Vorschaubildschirm beim jump forward angezeigt worden ist.

 

Editor-Log: editor.log

 

 

Viele Grüße

 

Webturtle

Share this post


Link to post
Webturtle

Hallo,

 

ich habe jetzt einen unfreiwilligen Test durchgeführt. Ich hatte mit dem DVBViewer GE mehrere Aufnahmen von einem Sender im DVB-T2 HD geplant. Die erste und zweite wurde gestartet. Danach hat der GE nicht mehr reagiert, die Aufnahmen aber fortgesetzt. Am nächsten Morgen mußte ich ihn abwürgen. Das Ergebnis waren zwei Dateien von ca. 10 und 11 GB. Die erste Datei, die ja auch den Inhalt der zweiten umfaßte, habe ich in den Video-Editor geladen. Dies ging sehr schnell, da ich die Indexierung abgeschaltet habe. Ich wollte ja nur dazwischenliegende Sendungen und einen sehr langen Nachlauf wegschneiden. Auf einen genauen Schnitt kam es mir nicht an. Deshalb habe ich auch in den wegzuschneidenden Teil hineingeschnitten.

 

Die Dauer der Gesamtaufnahme war über 7 Stunden. Der Schnitt dauerte laut Fortschrittsfenster ca. 15 Minuten. Die Dateigröße nach dem Schnitt war noc ca. 6,8 GB. Ob es sich um die 32bit oder 64bit Version gehandelt hat weiß ich nicht. Das wird ja (noch) nicht angezeigt.

 

 

Viele Grüße

 

Webturtle

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...