Jump to content
luxo_junior

Media Server funktioniert nur, wenn am Server DVBViewer läuft

Recommended Posts

luxo_junior

Liebe DVBViewer-Gemeinde,

 

mit meinem neuen Media Server habe ich ein "interessantes" Problem: Der Media Server läuft in einer virtuellen Maschine (ESXi-6.5.0) unter Windows 7 Pro (x64) mit einer Cine S2 V7, soweit so gut.

Fernsehen direkt am Server in der VM-Umgebung funktioniert über DVBViewer und Einbindung der Karte über RTSP ohne Probleme.

 

Nun zum Problem: Fernsehen auf den Clients funktioniert nur, wenn der DVBViewer am Server läuft und auch ein Sender eingestellt ist. Sobald aber der DVBViewer am Server beendet wird, laufen die Clients ein paar Sekunden noch nach und dann friert das Bild auf den Clients ein.

Am Client ist es egal, ob per VLC und m3u oder mittels DVBViewer und RTSP versucht wird fernzusehen.

Sobald der Viewer am Server wieder läuft, klappts auch bei den Clients wieder.

 

Was mache ich falsch? Welche Diagnoseinformationen muss ich hier zur Verfügung stellen, damit mir geholfen werden kann?

Bin schon etwas verzweifelt, da Neuinstallation von Viewer und Mediaserver, verschiedene Treiber für die DVB-Karte, einspielen von Windows-Updates, etc. alles nicht geholfen hat.

Mit DVBViewer war ich immer super zufrieden, wäre schön wenn mir hier jemand weiterhelfen könnte.

 

Vielen Dank & Gruß,

 

Thomas

 

Share this post


Link to post
Griga

Eine support.zip vom Server-PC könnte weiterhelfen.

 

Share this post


Link to post
luxo_junior

Sorry, natürlich ;)

 

Habe die Prozedur nochmal so nachgestellt: Media Server gestartet, lokal am Server DVBViewer aufgemacht, dann am Client einen Sender ausgewählt. Anschließend DVBViewer am Server beendet, Client hängt nach einer Weile und dann am Server DVBViewer wieder geöffnet.

support.zip

Share this post


Link to post
luxo_junior

Hat niemand einen Tipp für mich? 🥴

Share this post


Link to post
Griga

Mir fällt dazu nichts ein, und mit VMs kenne ich mich nicht aus. Im svcdebug.log ist kein Problem zu sehen.

 

Ich würde erst mal probieren, ob es etwas damit zu tun hat, dass der DMS als Service im Systemkonto läuft. Stoppe den DMS als Service und starte ihn als Anwendung im Benutzerkonto, indem du DVBVService.exe doppelklickst. Es erscheint ein provisorisches Fenster. Wenn du es schließt, beendest du den DMS. In dem Modus funktioniert der DMS im Prinzip normal, aber es gibt ein paar Einschränkungen: Unter anderem "sieht" das Traytool den DMS nicht mehr, und du musst ihn manuell beenden, bevor du in den DMS-Optionen (svcoptions.exe) etwas änderst.

 

Tritt das Problem so immer noch auf?

 

Share this post


Link to post
luxo_junior

Hallo und guten Abend,

 

danke für die Rückmeldung und den Tipp. Leider hat das auch nichts gebracht, gleiche Symptome wie oben beschrieben :(

 

Was vielleicht noch interessant zu erwähnen ist: Der DVBViewer, der dann ja am Server laufen muss, damit TV wie beschrieben auf den Clients funktioniert, greift nicht direkt auf die Hardware zu sondern nutzt auch nur die Netzwerkschnittstelle vom MediaServer.

 

Vielleicht ist das ganze aber auch ein Hardware-/Treiberthema der TV-Karte? Bei Zeiten versuche ich mal eine komplette Neuinstallation. Bin aber dennoch für jegliche Hinweise und Lösungsansätze dankbar! :)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...