Jump to content
markymark

iMON/Media Lab VFD/LCD Plugin

Recommended Posts

markymark
Thank you VM!!

 

I'm using your plugin with Imon Ultra Bay...it works great!

 

Just a question. Is it possible trought API programming to increase the LCD brightness? The contrast slide doesn't help.

 

It's a good LCD but brightness is really awful. I can't read it from 2 meters.

 

Nope. Its just a sad product B) i actually do not like it and use the VFD instead in my HTPCs.

Share this post


Link to post
markymark
Had some difficulties finding the Terminal font. Tried different applications but ended up with Notepad B) . And the answer is no, but that goes for all national specific characters, not only Øø.

 

Thanks and regards

DolKbg

 

Okay, thats the problem. So here comes your assignment: find a monospaced font that has all the characters and the proper size. I will then add support for that one :argue:

Share this post


Link to post
djpuzia

Hi,

 

On first, I apologise for my weak English - I am from Poland ;)

 

I have big problem with this plugin. When I start this program, my iMON remote control stopped working :) I tested 4 versions of this program: 0.98, 0.97d, 0.96 and 0.95. The remote control has always stopped acting ;)

Share this post


Link to post
cambies

The last version 0.98 should work. The most important thing is the order of starting the plugin and the iMon manager. In my case i have to run the imon manager first and after that i start the plugin. At last the DVBViewer is started.

 

In the appropriate german forum thread ("Alles zu Fernbedienungen") a user has described the following starting order:

 

1. Plugin

2. iMon manager

3. DVBViewer

 

Maybe you should try these both possibilities. The version of plugin doesn't matter i think ;-)

 

cambies

Share this post


Link to post
markymark

VFD (not LCD) users with remote control problems should check 0.99. It should fix the problem for those users where 0.90b does work, but no newer version of the plugin.

 

Best,

MM

Share this post


Link to post
kapa
VFD (not LCD) users with remote control problems should check 0.99. It should fix the problem for those users where 0.90b does work, but no newer version of the plugin.

 

Best,

MM

Hi this is language file for Finnish language. version 0.98

 

Kapa

Suomi.zip

Edited by kapa

Share this post


Link to post
alkasar

Finally a software that works with the Soundgraph LCD :D

I am using version 0.99 with Antec Micro Fusion (imon oem LCD display)

 

In my experience, the right order to make it work is "plugin" after "iMon Manager". And of course, Frontview set to never.

I use Startup Delayer to make sure the order is correct.

 

Improvement requests for you markymark if by any chance it's possible

1. customize the defautl display when DVBViewer is not running : let us chose the date/time format, or display something else from a text file updated ouside of the plugin

 

2. two lines (top/bottom) are displayed. Would be nicer without in my opinion. Could it be a user defined choice to display or not ?

 

3. use the bottom line as a progress bar during a television show

 

4. make your experience available to the LCD SMartie team ! they struggle to make their tool work with the iMon LCDs :bye:

Edited by alkasar

Share this post


Link to post
entrecour

This looks like a great plugin but I can't get it to work. I am running Vista 32bit, IMON Version 7.4, and plugin version 0.99. There is no enable 3rd part plugin switch in IMON 7.4.

 

Any suggestions?

Share this post


Link to post
markymark
This looks like a great plugin but I can't get it to work. I am running Vista 32bit, IMON Version 7.4, and plugin version 0.99. There is no enable 3rd part plugin switch in IMON 7.4.

 

Any suggestions?

 

There is no need for the third party stuff. Just go and disable frontview! Which display do you have?

Share this post


Link to post
entrecour
Just go and disable frontview! Which display do you have?

I had disabled frontview - unfortunately no luck.

 

I have an iMON VFD HID OEM (inbuilt in a SilverStone case).

 

By the way the plugin seems to forget the language setting after it's closed and defaults to German. I pinned the plugin to the start menu. When I run from the folder I can select the language again.

 

Edit: It says "Kein IMON VFD oder LCD gefun" besides the Settings button.

Edited by entrecour

Share this post


Link to post
markymark
I had disabled frontview - unfortunately no luck.

 

I have an iMON VFD HID OEM (inbuilt in a SilverStone case).

 

By the way the plugin seems to forget the language setting after it's closed and defaults to German. I pinned the plugin to the start menu. When I run from the folder I can select the language again.

 

Edit: It says "Kein IMON VFD oder LCD gefun" besides the Settings button.

 

Well, in general the plugin should work on your machine.

 

The fact that it is loosing the configuration hints that there may be an issue writing to the roaming profile folder - This is rather odd. Can you check if it saves the configuration to (yourhome)/appdata/roaming/imonplugin ?

Share this post


Link to post
entrecour

I moved the folder it is in out of the DVBViewer folder and put it directly under Program Files and now the language settings work ok.

 

However the plugin still isn't producing any output on the VFD. It now says "No iMON VFD or LCD found".

Share this post


Link to post
markymark
I moved the folder it is in out of the DVBViewer folder and put it directly under Program Files and now the language settings work ok.

 

However the plugin still isn't producing any output on the VFD. It now says "No iMON VFD or LCD found".

 

Did you make sure the correct display type is selected in the plugin (VFD vs. LCD) ?

Share this post


Link to post
entrecour

Sure! :bye:

Share this post


Link to post
markymark
Sure! :bye:

 

You still didnt tell me which type of display you have :D

Share this post


Link to post
alkasar

Entrecour : reboot and make sure the plugin is started after imon manager.

Share this post


Link to post
entrecour

markymark,

 

You still didnt tell me which type of display you have

 

Well it was late last night so you might have missed it. :bye:

 

I have an iMON VFD HID OEM (inbuilt in a SilverStone case).

 

The firmware version is 3601.

 

 

alkasra, I think I tried that already, however I'll give it another go in a little while.

Share this post


Link to post
entrecour

I tried restarting, the IMON Manager is anyway part of my startup sequence. Here a screen shot

 

 

When I startup the plugin the VFD display is not detceted even though it is selected.

 

 

Of course there is no ouput from the plugin to the VFD display.

Edited by entrecour

Share this post


Link to post
markymark
markymark,

Well it was late last night so you might have missed it. :bye:

The firmware version is 3601.

alkasra, I think I tried that already, however I'll give it another go in a little while.

 

Not really, but many user confuse the LCD with the VFD so I wanted to make sure :D

Share this post


Link to post
stuboy

Am new to all this, just setting up an EZcool with a 4.3 inch display have Imon 7.40.0806 running and can't find a button called front view to never? Can you help please :bye:

Regards

Stuboy

Edited by stuboy

Share this post


Link to post
markymark
Am new to all this, just setting up an EZcool with a 4.3 inch display have Imon 7.40.0806 running and can't find a button called front view to never? Can you help please :wacko:

Regards

Stuboy

 

:oops: My guess is that you have a touchscreen LCD. Unfortunately, this plugin only works with the old schoolf 2 line 16 char VFD and the monochrome cheaptek LCD.

 

But hey, if you get me one of these touchscreens ... :);):rotfl:

Share this post


Link to post
markymark
I tried restarting, the IMON Manager is anyway part of my startup sequence. Here a screen shot

 

 

When I startup the plugin the VFD display is not detceted even though it is selected.

 

 

Of course there is no ouput from the plugin to the VFD display.

 

Well, in the german thread for the plugin i provided a tool for checking the device id of the display. Please try if that one finds "valid" ids for yours.

Share this post


Link to post
entrecour
Well, in the german thread for the plugin i provided a tool for checking the device id of the display. Please try if that one finds "valid" ids for yours.

 

I went through the thread but I couldn't find the tool. It would be a great help if you could you send me the link to the post.

 

Thanks.

Share this post


Link to post
Manu2
I went through the thread but I couldn't find the tool. It would be a great help if you could you send me the link to the post.

 

Thanks.

hello

i have the same problem with my Antec Fusion, imon vfd or lcd non trouvé (not found).

if you can help me too thanks a lot

Share this post


Link to post
markymark
I went through the thread but I couldn't find the tool. It would be a great help if you could you send me the link to the post.

 

Thanks.

 

I just noticed that the tool was specifically designed for the LCD anyway. I will care about this shortly.

Share this post


Link to post
markymark
hello

i have the same problem with my Antec Fusion, imon vfd or lcd non trouvé (not found).

if you can help me too thanks a lot

 

Once more: the LCD or the VFD version ? (both exist)

Share this post


Link to post
Manu2
Once more: the LCD or the VFD version ? (both exist)

sorry

it works great now

sorry :)

Edited by Manu2

Share this post


Link to post
8skellerns

Hi!

 

Does this plugin work properly in Vista 64 bit? I run the plugin, but get no VFD or LCD Found.

 

Thanks.

Share this post


Link to post
markymark
Hi!

 

Does this plugin work properly in Vista 64 bit? I run the plugin, but get no VFD or LCD Found.

 

Thanks.

 

Yes, it does. I am using Vista x64 with the iMON LCD.

Share this post


Link to post
embrion

Great plugin. Works fine with Antec Fusion v2 VFD.

If I understand correctly, it is not possible to display some of non english chars like in my case: ĄąĆćĘꣳŃńÓ󌜯żŹź.

Is it possible to convert them on the fly to basic AaCcEeLlNnOoSsZzZz ? It looks strange when non english chars are ommited on display.

Share this post


Link to post
8skellerns
Yes, it does. I am using Vista x64 with the iMON LCD.

 

Any idea why it wont function on my pc?

Share this post


Link to post
markymark
Any idea why it wont function on my pc?

 

Presumably a user fault :)

 

The details you gave are just so overwhelming ;)

Share this post


Link to post
8skellerns
Presumably a user fault :)

 

The details you gave are just so overwhelming ;)

 

Well I run the program, and the display does nothing. The display works fine when using the imon software, but the plugin does nothing, doesnt even detect the LCD display! Doesnt help that most of the instructions on here are in german, and theyre is no step by step guide to using it!

Edited by 8skellerns

Share this post


Link to post
8skellerns

So is it tough luck for me??

Share this post


Link to post
markymark
So is it tough luck for me??

 

- set "front view" to "never" in the imon software

- set the disply type to "LCD" (requires restarting the plugin program)

 

Should be working then.

Share this post


Link to post
8skellerns

Thanks mate! Just did as you said, but the LCD display stays blank, even the backlight doesnt come on, and the plugin says no LCD or VFD found even though it is showing what DVBViewer is playing. ;)

Share this post


Link to post
markymark
Thanks mate! Just did as you said, but the LCD display stays blank, even the backlight doesnt come on, and the plugin says no LCD or VFD found even though it is showing what DVBViewer is playing. ;)

 

Can you please check the device manager for the vendor id and product id of the display ?

Share this post


Link to post
8skellerns

The display when plugged in appears in device manager as 1 HID Compliant Device, 2 USB Human Interface Devices, and 1 USB Composite Device with drivers provided by Microsoft. where do I go from here? I'm in Vista 64 bit Home Premium. Thanks!

Share this post


Link to post
markymark
The display when plugged in appears in device manager as 1 HID Compliant Device, 2 USB Human Interface Devices, and 1 USB Composite Device with drivers provided by Microsoft. where do I go from here? I'm in Vista 64 bit Home Premium. Thanks!

 

Properties -> Details -> Hardware-IDs

Share this post


Link to post
byfly

Hi!

 

Thanks for a good plugin!

 

Is there anyway to disable the disc space monitor?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...