Jump to content

Recordingservice Beta


Lars_MQ

Recommended Posts

New version is support Chinese now. Thanks for your great job!

But it still has a little bit problem, is not support some characters of Big5-HKSCS.

Would you please add this encoding in next version?

Link to post
  • Replies 602
  • Created
  • Last Reply

Top Posters In This Topic

  • Lars_MQ

    155

  • janip

    42

  • uglyned

    35

  • smallant

    22

Top Posters In This Topic

Popular Posts

Thanks, timerwindow work now. Maybe is good if webinterface "show timerwindow" setting is only for normal web use? Not for mobile.

Pleas post your support.zip   @all Please do not start new topics in this topic.   We have now a section for the Recording Service and it is hard to find informations in such a big mix topic. ht

Posted Images

In the webinterface? I'm not sure what you mean. It's the same fix as for the webinterface for the DVBViewer and this is reported as working.

Link to post
In the webinterface? I'm not sure what you mean. It's the same fix as for the webinterface for the DVBViewer and this is reported as working.

Yes. In webinterface. Some special Chinese characters can't display correctly. (Became a "?"), I think that it is Unicode character.

Link to post

Why DVBViewer can't found the hardware after the following steps:

hibernate -> Auto bootup by service -> recording -> hibernate -> bootup manually -> Run DVBViewer (Show can't found hardware)

Link to post

Hello, I am user from Hong Kong, I have same problem like samllant

DVBViewer with Recording Services Beta sometimes cannot start normally, then when I start the DVBViewer again, It always say "Cannot found the hardware" and the recording job cannot start.

Edited by wwkwoo
Link to post

What is the red color of tray icon? I found that I the red icon is displayed, the web interface service will be held and the service couldn't be restart by control Panel. Of course the recording job can't be started.

Edited by smallant
Link to post

red does mean recording. Before we do any more guessing, I suggest you post a support.zip there is the log of the service in it and I may be able to see what is going on.

Link to post
red does mean recording. Before we do any more guessing, I suggest you post a support.zip there is the log of the service in it and I may be able to see what is going on.

Here is my support.zip file, thanks for your help!

(I truncated the log because it is too large)

Edited by smallant
Link to post

well from the looks of it: one time the device was most likely used by another software and could not be used by the service and the last entries show, there simply was no device (may be driver related or it was not connected, don't know).

Link to post
well from the looks of it: one time the device was most likely used by another software and could not be used by the service and the last entries show, there simply was no device (may be driver related or it was not connected, don't know).

Thank you for your fast response!

Link to post

Would you please add some new functions, add a shortcut menu of tray icon to show the hardware status, and add a shortcut for open the web interface directly?

Link to post

Hello,

 

I think I have found a bug in the latest Recording Service beta. All recordings done with recording service seem to corrupt My Recordings database. I use "All users" setting in Vista where database files are located at C:\ProgramData\CMUV\DVBViewer\Database\.

 

To reproduce:

1. Delete all database files from folder above.

2. Start DVBViewer, make any recording and it will appear in My recordings perfectly.

3. Close DVBViewer, let the Recording service start

4. Make any recording by using Recording service. The recording appears also nicely under "Recordings" web page. However it does not show the first recording done in phase 2.

5. Start DVBViewer, go to "My recordings" and notice that there are have two broken entries both showing just "30.12 0:00", which cannot be deleted from the GUI.

 

Actually I think this problem has been in the earlier versions, but I did not have to time to investigate this earlier. I even reinstalled both DVBViewer and recording service from scratch, but no help. Support.zip attached.

support.zip

Link to post
tat_keung

Now using Vista with HTTP server 1.4.4 without any chinese problem.

 

On recording service 1.4.1.23(beta), there's some error in showing chinese

1. if set language="Chinese (Traditional)", can't show chinese words. See "Chinese (Traditional).png"

2. if set language="chinese", 3 problematic pages show partial chinese words. See "Whats_on_today.png", "Whats_on_now.png" and "Programs overview.png" for reference.

3. Can't show chinese in DVB Service Controller, see "DVBServiceController.png"

post-62467-1214849804_thumb.png

post-62467-1214849846_thumb.png

Edited by tat_keung
Link to post

Did I miss something or are the images missing?

 

3. this won't change in the near future, because it would mean a complete rewrite of this "byproduct". It was primarly a quick hack for testing purposes and I though maybe someone might use it now and then. I didn't think t would be used this much (I myself use only the webinterface).

 

/edit

ok now I see pictures. :wacko:

Link to post
tat_keung
Did I miss something or are the images missing?

 

3. this won't change in the near future, because it would mean a complete rewrite of this "byproduct". It was primarly a quick hack for testing purposes and I though maybe someone might use it now and then. I didn't think t would be used this much (I myself use only the webinterface).

 

/edit

ok now I see pictures. :wacko:

 

Is there any other method that I can post more <800Kb images here?

Link to post
tat_keung
Now using Vista with HTTP server 1.4.4 without any chinese problem.

 

On recording service 1.4.1.23(beta), there's some error in showing chinese

1. if set language="Chinese (Traditional)", can't show chinese words. See "Chinese (Traditional).png"

2. if set language="chinese", 3 problematic pages show partial chinese words. See "Whats_on_today.png", "Whats_on_now.png" and "Programs overview.png" for reference.

3. Can't show chinese in DVB Service Controller, see "DVBServiceController.png"

 

Please get all images here, thx!

 

https://download.yousendit.com/FA1EBAD84D64CBBD

Link to post

I see your point. But I have no real clue why it happens. The code is in principle the same in both application. The only difference is, the DVBViewer runs in your useraccount with all your (windows)settings and the service runs in a systemaccount (with only MS knows which settings). So if there are epg entries transmitted with incorrect language settings, the code tries to use the (windows)usersettings and I guess that's the problem.

 

Is it always wrong shown for the same channels? If yes this might e a hint in this direction.

 

Does maybe this help? It could be a similar problem...

Link to post
smallant

Sometime Recording Service can't to record after hibernate, the size of recording file is 0 byte.

Here is attached the logs for your reference.

Link to post
tat_keung
I see your point. But I have no real clue why it happens. The code is in principle the same in both application. The only difference is, the DVBViewer runs in your useraccount with all your (windows)settings and the service runs in a systemaccount (with only MS knows which settings). So if there are epg entries transmitted with incorrect language settings, the code tries to use the (windows)usersettings and I guess that's the problem.

 

Is it always wrong shown for the same channels? If yes this might e a hint in this direction.

 

Does maybe this help? It could be a similar problem...

 

Problem 2 solved by applying all setting in HKEY_CURRENT_USERS\Control Panel\International to HKEY_USERS\.DEFAULT\Control Panel\International.

 

For problem 1, there's no urgence since I can use english as interface while content now in chinese.

 

However, GUI (not in web browser) still can't show the program name in chinese. (Problem 3 in #94, second pic)

Link to post
tat_keung
Problem 2 solved by applying all setting in HKEY_CURRENT_USERS\Control Panel\International to HKEY_USERS\.DEFAULT\Control Panel\International.

 

For problem 1, there's no urgence since I can use english as interface while content now in chinese.

 

However, GUI (not in web browser) still can't show the program name in chinese. (Problem 3 in #94, second pic)

 

In addition to problem 3, the recorded .ts file also in strange character other that chinese.

Link to post

I get a duplicate recording whenever I exit DVBViewer and let the recording service continue on.

 

EG: DVBViewer is running, I schedule a recording via EPG, and it kicks off.

 

I then go to bed, close DVBViewer, Answer (Y)ES I know a recording is still underway. And as it closes the recording service icon goes red and continues the recording. It appears that it kicks off another reording so I end up having 2 files beginning and ending at different times.

Link to post

Dear support,

 

I always can't record success using recording service.

the program is record, but the file size is very small and non-playable.

what extra information need to give u for investigation?

 

attachment is the file capture by supporttool

 

Thanks.

support.zip

Link to post

Lars, can you explain how to get the Netstreaming plugin working with the service? I have followed the instructions and created a directory called c:\program files\DVBViewer\plugins\plugins1 and copied netstreaming.dll into it from the main plugins dir. I then restarted the service (making sure it had been added to windows firewall) and added a recording. However, I cannot connect to it from my Popcorn Hour when the recording is running (which works fine conencting to DVBViewer/Netstreaming itself). It just times out.

 

I have Netlimiter running on the PC which allows me to see what progs are listening on which ports - the Recording Service does not appear to be listening at all.

 

I've probably missed something here - are there any other files needed to get this working? This is on Vista again, BTW.

 

Thanks

Link to post
Lars_MQ

you have to edit the plugin settngs manually. they are in the userdata folder in the Plugins\plugins1 folder. make sure it is activated and uses the right port.

Link to post

Dear Support,

 

I find that when I use Recording Service, I cannot recording for sometimes, It just record a small size file and cannot play it, here is support.zip and pic for reference, Thanks

post-62260-1215229399_thumb.jpg

support.zip

Link to post
you have to edit the plugin settngs manually. they are in the userdata folder in the Plugins\plugins1 folder. make sure it is activated and uses the right port.

 

Thanks Lars. On Vista the settings file is actually under C:\ProgramData\CMUV\DVBViewer\Plugins\Plugins1 so wasn't immediately obvious. I copied the ini file into the right place and it's now working. Thanks!

Link to post
Thanks! That's exactly what I need. I missed it before as there doesn't appear to be any English documentation for it so I had no idea what it did (my German is non-existent, I'm afraid). Anyway, I've figured out how it works, so will now try and get it working from Digiguide.

 

Thanks again.

Did you get any further with this, Renzz? (TVGenial/Commandline tool) I've been trying to get DabDig working but without much success and, like you, I know no German whatsoever (well, I can order a pizza and a beer but that's it so I lived on that for 3 days :)). Isn't TVgenial a German equivalent to Digiguide?

Edited by SimonP
Link to post
Did you get any further with this, Renzz? (TVGenial/Commandline tool) I've been trying to get DabDig working but without much success and, like you, I know no German whatsoever (well, I can order a pizza and a beer but that's it so I lived on that for 3 days :)). Isn't TVgenial a German equivalent to Digiguide?

 

Yes, I got it working ok. You should add the necessary bits in under the Wintvcap section of DABDIG , as there is no specific support for this command line tool. The key parts of my dabdig.ini are

 

WINTVCAPPATH=C:\Program Files\DVBViewer

WINTVCAPCMD=dvbv_tvg.exe

WINTVCAPCMDP1=

WINTVCAPCMDP2=

WINTVCAPCMDP3=

WINTVCAPCMDOVERRIDE=-d "$TI" -c "$CA" -e $DD.$DM.$DY -s $DH:$DN -p $EH:$EN

 

If you just want to drive the tool directly, just run it with no parameters and it does tell you what params you can pass (in English).

 

I found they key part of getting this working was to ensure your channel name in Digiguide matched that of DVBViewer - it didn't seem to matter what channel number you used. So just change the channel details and put the correct name in the second box in Digiguide.

 

I've no idea what TVGenial is, but you may be right about it being some sort of TV guide?

Edited by renzz
Link to post
Lars_MQ

tvgenial is a tvguide you install locally on your PC and it downloads the data from their server.

Link to post

Thanks Renzz, that's a great help. I plan to have another go at it over the weekend.

Link to post

Anyone whould tell me why I can't recording?

The job was started, but the file size is also 0 byte after the schedule job is completed.

An example is at 13.07.2008 00:10:00.

Hope someone would tell me the solutions!

Link to post
NIKKOpooh

dear Lars_MQ ,

I have installed the recording service

and i am using a network drive

DVBViewer can record in it

but when i use recording service

it cant record in it

Could u please fix this bug

i have found some members in a hk forum said that they have contacted the writer of recording service

and the writer siad that cant fix this bug because the recording service doesn't know anything about the drive but i think that the DVBViewer can record in the network drive propably but why the recordingservice not?

But i dont know are u the writer of the recordingservice if yes .So may u pls fix this problem?

Because i have bought the network drive with lots of money (because i need to change the router,lan card , network drive case and the 500gb harddisk.I think it cost me about 3200 hkd)

and i dont want to waste my money and the most important point is i cant record the tv programme when i go for a trip.

So please fix problem!!if you can fix this problem i am really really thank for your help.

thank you very very much!!!!!!!!!!!! ;):):);)

Link to post

This is no bug.

The recordingservice runs in a systemaccount with specific (by windows defined) rights.

You may have

a.) not enough rights to access the network (you have to look into the windows rights management)

b.) use a mapped drive which is user account dependend and does not work at all.

Link to post
NIKKOpooh
This is no bug.

The recordingservice runs in a systemaccount with specific (by windows defined) rights.

You may have

a.) not enough rights to access the network (you have to look into the windows rights management)

b.) use a mapped drive which is user account dependend and does not work at all.

but why i can record with DVBViewer probably??

Link to post
NIKKOpooh
The DVBViewer is not a service it is a normal programme and runs in a normal user account.

so how can i fix it??

how can i set the account that the recording service use or how can i know the account that the recordingservice is using so i can give the permission to the recordingservice?

Link to post

The Recordingservice is a serviece an runs in the SYSTEM user.

 

If you like a normel proggram and no serviece use DVBViewer.

 

how can i know the account that the recordingservice is using so i can give the permission to the recordingservice?
The account is named "SYSTEM" and no it is not possible to login as "SYSTEM".

 

Maybe a start ponit for searching the Internet, is searching for secpol.msc.

Link to post
NIKKOpooh

i have fix the network drive problem y change the path to \\######\###### instead of x:\######

But i found another problem .it is the recordingservice cant record multi subtitle and audio channel

how can i fix t?

Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...