Jump to content

Recordingservice Beta


Lars_MQ

Recommended Posts

My problem with recordings not starting has happened again, and I currently have retune set to 5 seconds. It never successfully retunes. Again, manually stopping and restarting the service permitted recordings to proceed.

 

Another problem I have is when there are two recording destinations available (E:\Videos and F:\Videos), it always uses F:\Videos even when I specify E:\Videos in the new timer page.

Edited by CX23882-19
Link to post
  • Replies 602
  • Created
  • Last Reply

Top Posters In This Topic

  • Lars_MQ

    155

  • janip

    42

  • uglyned

    35

  • smallant

    22

Top Posters In This Topic

Popular Posts

Thanks, timerwindow work now. Maybe is good if webinterface "show timerwindow" setting is only for normal web use? Not for mobile.

Pleas post your support.zip   @all Please do not start new topics in this topic.   We have now a section for the Recording Service and it is hard to find informations in such a big mix topic. ht

Posted Images

Another issue I have is with EPG collection. I have 6 tuners in total:

Cinergy 2400i DT Tuner 1 (1) - Preferred

Cinergy 2400i DT Tuner 2 (2) - Normal

Cinergy 2400i DT Tuner 1 (3) - Preferred

Cinergy 2400i DT Tuner 2 (4) - Normal

Pinnacle RoyalTS Tuner (5) - Do Not Use

Pinnacle RoyalTS Tuner (6) - Do Not Use

 

The two Pinnacle tuners are used by DVBServer and DVBViewer GE, leaving the 4 Terratec Cinergy tuners for the recording service. On the 2400i, Tuner 1 is slightly better than Tuner 2 (since Tuner 1 feeds Tuner 2) so I have Tuner 1 on each card set to preferred. Naturally I want these to be used as a priority for recording but it seems that they also get used by the EPG updater. So, the EPG update might make use of my preferred tuner.

 

I have set both Tuner 1 to not be used for receiving EPG data but it seems that this is overridden (by having them set to preferred?). Or have I mis-interpreted this setting? What I'm aiming for is for either Tuner 2 (2) or Tuner 2 (4) to be used as a priority for the EPG update and Tuner 1 (1) or Tuner 1 (3) as a priority for recording.

 

Regarding my previous problem with tuners dieing - I think that it may be related to the EPG update somehow. Namely, sometimes after the EPG update has proceeded I am then unable to use that tuner unless I stop and restart the EPG service. It doesn't appear to ever affect any other tuner but the one which had been used for an EPG update. Maybe it's not always getting released correctly???

Edited by CX23882-19
Link to post
Change: EPG Update is now stopped when a recording start and resumed, after the recording started.

See change log 1.4.6

Link to post

>Add: uPNP AV Server integrated. Settings/activation in the configuration program-> Web.

 

Installed 1.4.7 service, and tried the upnp av server in it. My Buffalo Linktheater finds it ok, but it says "unauthorized", and tells me to authorize it in server. Where should I find that setting in DVBViewer service setup? I can only find settings for lan interface and port.

 

Thanks!

Link to post

You don't need to authorize anything (for now).

I've uploaded a testversion to the membersarea (all the way down at the bottom of the page). Stop the service via the systray app, override the dvbvservice.exe in the DVBViewer program folder with the one from the zip and start the service with the systray app again.

 

I just extended the "MediaReceiverRegistrar" response with the isValid Method (maybe it helps) and added some logging, to see what the buffalo link theatre does want... :(

Link to post
You don't need to authorize anything (for now).

I've uploaded a testversion to the membersarea (all the way down at the bottom of the page). Stop the service via the systray app, override the dvbvservice.exe in the DVBViewer program folder with the one from the zip and start the service with the systray app again.

 

I just extended the "MediaReceiverRegistrar" response with the isValid Method (maybe it helps) and added some logging, to see what the buffalo link theatre does want... :(

 

 

It didn't help. Buffalo still says: "This device is currently not authrorized to access content on this server. Please go to the server and authorize the device." :)

support.zip

Link to post

What i have to do tvguide.html? I like if all "timecell" are open, when i start tvguide.

And would be nice, if chanel logo's does not go hide when i scroll down.

Link to post
Just rewrite the html template page. should not be too hard. :(

We really try that last night, can't really remember all. :)

"timecell" will be ok, but my friend say that he can't do nothing those hiding chanlel logos,

not so good, when you have many chanel.

Maybe is better, if only earlier program hide with those timecell?

 

But i have to say, that epg guide is pretty good hi hii...

Link to post

Well I don't know either how to do the stuff with the channelheaders (and keep it scrollable to the left and right).

For the rest, just remove the checktime in the onload event, this should do the trick. :(

Link to post

Ok, i can live with that.

 

Now i try latest service in my xp pc, and i see that vista version does not work right.

 

1. Recservice icon doesn't change color when record start.

2. That webinterface link does not work

3. No "Do you want to stop rec" caution, when i start configure.

4. No "Do you want to stop rec" caution, when i start DVBViewer.

 

Is those problem only in my vista install or all vista user?

In XP all those work fine.

Link to post

FAILED RECORDINGS THROUGH RECORDING SERVICE

 

This is a weird one and I'm mentioning it now because I know it's going to happen again in a week or so, therefore I can set up any necessary debug configuration in advance.

 

Some time ago, a recording set for ITV3, an FTA channel (I only have FTA), failed. Instead of an expected 2gb file it created a 45mb file which DVBViewer couldn't open. That's OK I thought, they repeat this show another twice this week so I set it up to record it the next time it was on. I also set up another recording from the same channel to make sure everything was OK - it worked fine. The next recording of the show I wanted failed again, exactly the same error. Then the third attempt, two days later and from the '+1' channel instead of the 'live' one, failed again. So I missed that episode.

 

The following week, though, the next episode in the series recorded fine, as has every one since.

 

Then last week it happened again, except stranger this time. I set something up to record a show on ITV1 and it failed with the usual 45mb file. I noticed it was repeated a couple of days later on ITV2 so set that up and it failed again with the 45mb file.

 

As everything else records OK, even from those channels, and that it's always a specific show, regardless of which channel it's on (I haven't checked to see if all of the channels are on the same transponder but due to +1 channels and regional variations it's not likely) I'd like to set up as much logging as possible for when it's next on so that I might be able to find the cause.

 

Apart from the obvious setting up logging in Recording Service and using your tool afterwards to collect up system info, is there anything else I can do to gather up as much info as possible when the show is next on? Is there any other advice you can give?

 

Thanks in advance.

Link to post

It seem really hard to guess... :)

...maybe a strange show name (perhaps a special chars in it...) that create problem in the creation/use of the recording file name???

 

;)

Edited by Gioxy
Link to post
I've uploaded another testversion for the buffalo. Please test.

 

Yes, it works now! Streaming live tv seems to work. I'll do more testing later this year. :)

Link to post

please post the "svcdebug.log" here (or a support.zip it will include this file).

 

I need to know how to identify a buffalo link station, so I can integrate the correct handling in the service for it.

Link to post
...maybe a strange show name (perhaps a special chars in it...) that create problem in the creation/use of the recording file name???

 

That's what I thought - but the first time round it was Inspector Morse, which recorded fine every other week.

 

I wondered if it was something in the programme description which has been imported from the Freesat EPG. When recordings have completed properly, if I 'hover' the mouse pointer over the resulting TS file, a small yellow box appears with the programme description from the EPG - so this must be saved into the TS file during recording.

 

I think it's much more likely that there's a bad character in there, and that might be causing it. I thought of trying to record into an MPEG file as a test as I don't think those files contain so much info, but I might be wrong.

Link to post
a small yellow box appears with the programme description from the EPG

..that's because "Settings / Options / Recording / Save EPG as fileinfo" was checked: the info taken from EPG was writed down in the NTFS FileInfo fields, a secondary data stream attached to the file; you can also read all that fields looking in the properties of the file...

 

:wacko:

Link to post

Hello.

 

[Removed]

 

And do you have any good guess about those problem?

1. Recservice icon doesn't change color when record start.

2. That webinterface link does not work

3. No "Do you want to stop rec" caution, when i start configure.

4. No "Do you want to stop rec" caution, when i start DVBViewer.

 

I think i might disable some wrong vista service.

I try to install dvbv and recservice.

 

§ 13

 

Do not ask for or discuss plugins for descrambling/decrypting pay-tv or key-codes.

Although the DVBViewer Pro provides full pay-tv functionality it must only be used in combination with a valid subscription of a pay-tv provider, a tv-card/box featuring a "conditional access module" (CAM)and/or the corresponding "common interface" (CI) with a smart-card. This applies regardless whether software-descrambling is allowed in your country or not.

Link to post

If I manage a programme clash by changing the end time of one recording to finish earlier than the standard time this causes a duplicate recording to be created next time I run an EPG search. At the moment I am guessing that the system must check start and finish times and if both of these match it doesn't create another entry. Could it just be set to say that if either the start or finish time match, plus the channel and programme name, then don't create an additional entry?

 

Also the result page after running a task is unpredictable. After I click my task, sometimes I get a message saying 'template not prepared', sometimes I get my timer screen and sometimes I get an EPG window or Programs screen in the pop-up box that the tasks link opens. I suspect that most of the time it is displaying a page that I have previously viewed.

 

This isn't major, as the task does run successfully.

Edited by uglyned
Link to post

DVB Recording Service Version 1.4.7:

 

Like the new UPNP AV Server :)

 

Playing of recorded shows now works from web-interface B)

Playing of live shows does not ;)

 

streaming.vlc contains:

http://munin:8099:7522/upnp/channelstream/3.ts

 

should be:

http://munin:7522/upnp/channelstream/3.ts

--

 

- Is there a way to get subtitle in VLC from live .ts stream ?

 

- Is it possible to get subtitle in PCH from live .ts stream ?

 

- Is it possible to transcode live sound to PCH (DVB-T Norway HE-AAC -> X) ?

 

- Will there be a DVBViewer OSD menu in PCH ?

Link to post
FAILED RECORDINGS THROUGH RECORDING SERVICE

 

This happened tonight with 2 shows on Channel 4.

 

Set to record fine but just created really small files - log file example below.

 

Turned on DVBViewer a bit later and it seemed fine. Also manual recording using DVBViewer from the same channel created a normal sized file.

 

Recorded around 20 seconds while a later show was failing to record and got it into a ts file small enough to send - so it's attached.

 

Nothing in Windows event viewer to suggest anything strange.

 

Log file:

 

Channel 4 (eng) 19/12/2008

 

C:\PVR\Recordings\12-19_20-55-01_Channel 4 (eng)_Peter Kays Britains Got an._.ts

 

Device: Hauppauge WinTV 88x DVB-S/S2 Tuner/Demod

 

20:55:01 / 00:00:00 (~ 0.0 MB) Start

22:10:00 / 01:14:59 (~ 76.8 MB) Stop

 

Average Data Rate: 0.017 MB/s

Total Size: 76.8 MB (80553676 Bytes)

Link to post

Hmm I doubt it is a direct problem in the recording service, then he would record nothing at all.

 

Please try:

Download transedit from the membersarea and analyze the file (it's somewhere in the main menu) and post a screenshot of the analyzer screen.

 

I guess audio and video stream are either marked as encrypted even if the aren't or the channel changes it's audio/video PIDs dynamically or the service gets simply the wrong channel.

 

EDIT:

OK I checked the posted ts (didn't notice before it was a ts because of it size :) ). There is everything missing. PAT and PMT and three(??) PCR are there nothing else. Could you send your channels.dat and timers.xml via PM to me, please?

Link to post
Could you send your channels.dat and timers.xml via PM to me, please?

 

Hi Lars - I would but I don't seem to be able to insert attachments on the PM screen. Am I missing something?!

Link to post
please post the "svcdebug.log" here (or a support.zip it will include this file).

 

I need to know how to identify a buffalo link station, so I can integrate the correct handling in the service for it.

 

 

Here you are!

svcdebug.zip

Link to post
  • 2 weeks later...

Hi Lars,

 

Thanks for the update. The following might be a hard one, but great for flexebility: Would it be possible to use the same virtual devices as we are used to in DVBViewer (unicast, multicast, etc) in the recording service or is this beyond?

 

Thanks, Eppo

Link to post

DVB Recording Service V1.4.7 increased uPNP AV Server is a very good idea, will cause not to install TV tuner the multimedia players also to be possible to watch the television.

 

Another advantage is, the DVBViewer user may penetrate the multimedia players to broadcast the video recording file on LCD TV.

 

I see DVBViewer to support Upnp very excitedly, therefore provides me two test reports, anticipated that in the future can have more enhancements.

 

1. The media title writing as if has not used the utf-8 code, therefore uPNP Client is unable to demonstrate the Asian writing correctly.

 

2.PS3 is unable to obtain the DVBViewer Media Server media title successfully.

Link to post

Recording Service 1.4.7 - Recording Folders Problem

 

I have a small issue with regards recording folders. On the Status page I can see two recording folders F:\Video and E:\Video. I can also choose between both locations when creating a timer, but it always uses F:\Video even if E:\Video is selected.

 

Last week I allowed F:\ to fill up (due to lazyness :biggrin:), and my recordings were stopped due to a "disk full" error. At that time, drive E:\ had over 400GB of free space. Can a future version of the Recording Service automatically use the drive with the most free space - or use the preferred drive until it's full and then automatically rollover to a "reserve" drive?

Link to post
Normaly this should work. I sent you a PM with my mail adress, somehow we get those file to me :biggrin:

 

Hi,

 

I sent this to you on email - I hope you got it.

 

Something I just tried - I hope it helps. I set something to record through Recording Service and as usual it just started creating a very small TS file with no contents. I paused the recording, ran DVBViewer, tuned into the channel the recording was set for, quit DVBViewer then set the recording going again and it worked - normal size TS file growing quickly.

 

So it looks like Recording Service can't grab the LNB or tune the channel, but if the channel is already tuned it works OK.

 

Help!

 

EDIT - With ITV2 (one of the problem channels) recording OK I stopped it and selected something from BBC1 (on a different transponder) recording and it started fine. I stopped that and set the ITV2 show recording again and thar started fine.

 

I have Freesat MHW EPG updater enabled and also had the EPG auto updater enabled although I disabled that before my test. Is there a chance that the EPG auto updater is grabbing the card and not letting go when the card is needed for a recording?

Edited by uglyned
Link to post
CX23882-19

Recording Service 1.4.7 - Search EPG Page

 

There is a button labelled "Delete selected Recordings". I believe it should be called something like "Delete search preset" instead.

 

P.S. When I add these comments, I'm not complaining about the recording service in any way. These are just suggestions for how I think it could be improved. Even as it is with a "beta" recording service, I would gladly pay up to £40 for this software. It is a bargain, so thanks for all the free updates and added functionality that you keep giving us. :)

Link to post
I have Freesat MHW EPG updater enabled and also had the EPG auto updater enabled although I disabled that before my test. Is there a chance that the EPG auto updater is grabbing the card and not letting go when the card is needed for a recording?

 

Good news and bad news.

 

Good news - since I disabled 'Use EPG updater' in the Configuration page, every single recording, including one which had previously failed, has recorded successfully.

Bad news - my freesat EPG has not updated since, even though I still have 'receive EPG data' and 'receive MHW EPG data' enabled.

 

So it looks like the EPG updater was preventing some recordings from taking place.

Link to post

that's rather strange. The updater is definetly disabled before a recording starts (V1.4.7).

BTW: sorry for taking so long for it, I had finally time to look at your mail and the data. What confuses me are the multiple entries of the channels. The recording you posted was of a an encrypted channel 4 which didn't decrypt (was it meant to be decrypted?).

 

I'm not sure whats happening with this channel 4, do they change their PIDs dynamically? It will cause trouble, cause the recording service does not support this.

The viewer only supports it for the playback, which would explain, why it worked after you run the viewer...

Link to post
that's rather strange. The updater is definetly disabled before a recording starts (V1.4.7).

BTW: sorry for taking so long for it, I had finally time to look at your mail and the data. What confuses me are the multiple entries of the channels. The recording you posted was of a an encrypted channel 4 which didn't decrypt (was it meant to be decrypted?).

 

I'm not sure whats happening with this channel 4, do they change their PIDs dynamically? It will cause trouble, cause the recording service does not support this.

The viewer only supports it for the playback, which would explain, why it worked after you run the viewer...

 

That could be it.

 

Channel 4 is a bit weird. It has only recently become free to air via satellite in the UK and is not FTA outside of the UK. It also has regional variations in the UK which is why so many Channel 4s show up in the channel list and why some of them are not FTA. I maybe picked the wrong Channel 4 to record from.

 

I've enabled the EPG again now so will post back here if anything unusual happens.

 

There was no delay really - it's the holidays!

Link to post

Problem related to a Popcorn Hour client and Microsoft Remote Desktop:

 

 

whenever i disconnect a remote desktop session while the recording service (running on the pc i rdp'ed to) is streaming tv to a popcorn hour client (A-110), the popcorn hour drops back to the channel selection screen. (i can immediately start a channel again)

 

can anyone reproduce this?

 

 

(am running windows xp pro sp3 and DVBViewer recording service 1.4.7.0 (beta))

 

 

 

if no one can reproduce, i'll create a support.zip (no point in upping my current since i don't remember at what time it last occurred)

Link to post

Firstly:The channel drop down list on the 'Programmes overview' page - Could it be sorted, please? It's a particular annoyance for me because I'm mostly (pretty much only) recording the FTA HD channels in the UK (I have Sky+ and a DTT PVR already). Trying to find just two channels out of an unsorted list of over a hundred is awkward to say the least :-/ It'd also help if there was a way to get a drop down list of favourites.

 

Secondly:Several of the pages don't have a back button or any other way to navigate. Obviously I can go straight to the home page but it's a little clunky.

 

Thirdly:The Configuration page doesn't seem to be rendering correctly on IE7. There are two tables betwee EPG Updater Settings and Popcorn Hour that have no visible title bar and appear to be being obscured by the panel above them. This is an example of a page without navigation. There's a link to itself (very helpful :)) but nowhere else. There's also two buttons next to the 'Configuration' link which do something but render so badly that I can't tell what - although one looks like the Create Timer dialog.

 

Lastly:When I launch the main application the service stops. It doesn't restart when I close the main application. It's not something I do very often but it doesn't seem right.

 

You might be interested to know that this is how I do 99% of my interaction with DVBViewer. I never watch anything live and just create timers. In effect for me the recording service Web pages are DVBViewer and sad to say they look a little rough :-/

Edited by AndrueC
Link to post
Firstly:The channel drop down list on the 'Programmes overview' page - Could it be sorted, please? It's a particular annoyance for me because I'm mostly (pretty much only) recording the FTA HD channels in the UK (I have Sky+ and a DTT PVR already). Trying to find just two channels out of an unsorted list of over a hundred is awkward to say the least :-/ It'd also help if there was a way to get a drop down list of favourites.

The recording service does not know the concept of favourites for now. I'm planing on adding them but they will be using a different concept than those in the DVBViewer. For now, you can simply sort your channel list in the DVBViewer. :wacko:

 

Secondly:Several of the pages don't have a back button or any other way to navigate. Obviously I can go straight to the home page but it's a little clunky.

Why should they? there's a perfectly good navigationbar at the top.

 

Thirdly:The Configuration page doesn't seem to be rendering correctly on IE7. There are two tables betwee EPG Updater Settings and Popcorn Hour that have no visible title bar and appear to be being obscured by the panel above them. This is an example of a page without navigation. There's a link to itself (very helpful grin.gif) but nowhere else. There's also two buttons next to the 'Configuration' link which do something but render so badly that I can't tell what - although one looks like the Create Timer dialog.

I can't replicate this. It might be missing translations (if you're using non english language). Although the blanks should at least be filled with the original english text. Could you please provide a sccreenshot?

 

Lastly:When I launch the main application the service stops. It doesn't restart when I close the main application. It's not something I do very often but it doesn't seem right.

Have you activated the "rec.serv" plugin in the DVBViewer -> Plugins menu?

 

[...] and sad to say they look a little rough :-/

I beg to differ. I'm using it all the time too and they work for me (over 1000 channels DVB-S/T, constantly around 40 timers, about 180 recordings) without problems.

They might not be the shiny "we paid a webdesigner thousands of euros" style because most of it is done by myself and I'm more into programming and not so much a html mangler ;)

But of course I'm always open for improvements, so if you have a good and working concept (or web design)... ;)

 

You might be interested to know that this is how I do 99% of my interaction with DVBViewer. I never watch anything live and just create timers. In effect for me the recording service Web pages are DVBViewer [...]

Always remember (from the DVBViewer Recording Service license):

Please note: DVBViewer Recording Service is not part of the official DVBViewer release. Improvements and updates are provided as far as possible. Any claims to support, updates, changes or bug fixes are explicitely excluded for DVBViewer Recording Service, though.

It's nice you see it as the face of the DVBViewer but it definetly isn't. It's my own little project (done in my free time as a hobby like all other things I do here). :blink:

Link to post

Okay, screen shot of config page:

 

http://img98.imageshack.us/img98/8273/epg1ap0.jpg

 

Somehow I missed the navigation buttons at the top. Not sure why. I'll check on Vista as I was writing on that at the time. Can't believe that's the cause though.

 

My message was actually a cut from another post and I neglected to make it clear that I'm happy with the functioning of the recording service. I just think that it could be more than it currently is.

 

I've looked at the channel list more carefully and noticed that it's the old list from before I last did a scan. That was a couple of days ago and the machine has been rebooted since (it powers off every night on a timer). Looks like the recording service isn't seeing the same channel list. I'll investigate.

Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...