Jump to content
nuts

CI-Reset Skript

Recommended Posts

nuts

Ich hab dazu ein Skript (s. Anhang). Damit lassen sich alle Prozess Tasks vom RS aufrufen.

Das kannst du dir z.B. mit Menüedit in den DVBV einbinden und aufrufen.

Versteht man das so ohne weiteres? Ja oder?

 

Sobald ich dazu komme werde ich diese Funktion hier einbauen: http://www.DVBViewer.tv/forum/topic/50485-sendcommand-v2/

run_prozesstask.zip

Share this post


Link to post
NatroNx

jop - läuft schon. Der DVBViewer findet es zwar nicht so prickelnd, dass man ihm den RS unterm Arsch wegreisst - aber es funktioniert trotzdem. Man muss lediglich nachdem der Service wieder läuft Sender wechseln.

 

Jetzt kann ichs kaum erwarten, dass mein CAM abschmiert. ;)

 

danke shconmal

Share this post


Link to post
nuts

Ja das ist ein Problem.

Deshalb kommt es demnächst ins sendcommand Skript und dort kann man sich die Befehle dann sinnvoll zusammenstellen.

 

z.B.

=>Schließe Graph

=>run prozesstaks

=>wiedergabe neuaufbauen

 

Vielleicht finde ich am Sonntag Zeit, versprechen kann ichs aber nicht.

Share this post


Link to post
nuts

Der Einbau ins sendcommand Skript war einfach und daher hab ichs schnell eingebaut.

Das Skript findet ihr im verlinkten Thread.

Share this post


Link to post
stno

Hallo nuts,

ich habe momentan das Problem, dass mein CI bei Neustart des Rechners oder nach Standby oft nicht erkannt wird. Deshalb wollte ich gerne dein ci_reset programm ausprobieren.

 

Leider funktioniert es bei mir nicht, ich bekomme im Logfile immer folgende Fehlermeldung:

 

2014-12-23 16:24:43 : exit
2014-12-23 16:24:43 : Zugangsdaten:
Passwort:
User:
IP: 127.0.0.1
Port: 80
2014-12-23 16:24:43 : _Stringbetween konnte kein Array erstellen - Programm beendet

 

 

Die Ini Datei sieht so aus:

 

[info]
Version=0.2.3
[settings]
User=
Passwort=
IP=127.0.0.1
Port=80
Sleep=5
disable_clientcheck=1
restart=0
disableservice=1
service=DVBVRecorder
servicetimeout=5
[Devcon]
Path=C:\Windows\System32\devcon.exe
Timeout=1
loops=5
rebootonerror=1
[iD]
CI=PCI\VEN_DD01&DEV_0003&SUBSYS_0001DD01&REV_00\4&CFE6D8B&0&00E1

 

Hast du eine Idee was da schiefläuft?

 

Gruß

stno

Share this post


Link to post
nuts

Du verwendest den Recording Service nicht?

Weil:

Das Skript funktioniert nur zusammen mit dem RS! (Ausnahme: -force Parameter)

Ansonsten müsste in der INI die Daten des RS eingeben werden:

[settings]

User=

Passwort=

IP=127.0.0.1

Port=80

P.S. Du kannst ohne RS mal mit dem -force Parameter testen.

Edited by nuts

Share this post


Link to post
stno

Hi nuts,

 

Doch ich nutze den Recording Service. User und Passwort habe ich vergessen zu setzen. Trotzdem eine seltsame Fehlermeldung.

Ich habe mein Problem jetzt mit einem einfachen Batch Script gelöst, dass ich als Aufgabe immer bei Start oder nach Hibernate ausführe.

Danke und Gruß

Stno

Share this post


Link to post
nuts

Naja so toll ist die Formulierung nicht, aber zumindest hat die Fehlermeldung mir sofort verraten wo das Problem liegt und hat damit ihren Zweck erfüllt.

Hintergrund ist, dass mein Skript versucht laufende Aufnahmen nicht zu gefährden und den RS vor dem Reset befragt. Wenn das fehlschlägt gibt's auch keinen Reset. ;)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...