Jump to content

SD/HD Wiedergabe Probleme mit DXVA AN


feuse8

Recommended Posts

Hallo Leute,

 

habe meinen HTPC noch immer nicht wie gewünscht zum Laufen gebracht. Habe folgendes Verhalten, das mir nicht passt (in SD und HD):

Wenn ich beim Cyberlink Codec DXVA aktiviere, kommt es öfters zu Rucklern. Diese können so weit gehen, dass das Bild mitunter komplett ausfällt und die Discontinues extrem schnell hochzählen (ca. 50/Sekunde). Auf der anderen Seite ist es manchmal so, dass das Bild kurz stockt und daraufhin eine flüssige Wiedergabe nicht mehr möglich ist. Nach einem Umschalten des Senders funktionierts dann wieder wie gewohnt.

 

Ich habe bereits folgende Betriebssysteme / Treiber / Codecs probiert:

Windows 7 Pro 32 Bit, Vista Business 64 Bit

ATI Treiber 10.06, 10.12

Terratec Treiber 1.00.05.601, 1.00.07.601

Cyberlink 8, 10, jenen von Terratec (wie seh ich da die Version)

 

Habe im Eventviewer gesehen, dass zeitgleich mit den Rucklern ein Eintrag steht:

amdkmdag - UVD Information.

 

Wie gesagt wenn ich DXVA deaktiviere, läufts gut, allerdings hab ich dann 50% CPU Auslastung auf einem Kern - hab da Angst, dass es irgendwann mal ruckelt weils die CPU nicht mehr packen könnte.

 

Jetzt ist meine Vermutung, dass die Onboard Grafikkarte Radeon HD4250 hier nicht wie gewünscht mitspielt. Möchte eigentlich nicht mehr lange rumfrickeln und bin bereit, eine Graka zu kaufen, welche optimal in meinen HTPC passt. Derartige Vorschläge sind herzlich willkommen.

 

Mein System:

Asus M4A88T-M/USB3 (AMD Radeon HD4250)

AMD Athlon II X2 240e

2 x KVR1333D3N9/2G

Samsung Spinpoint HD501LJ

Liteon Blu-Ray Rom IHOS104-32

Terratec H7

 

Danke für eure Hilfe!

Link to post
  • Replies 80
  • Created
  • Last Reply

Top Posters In This Topic

  • feuse8

    28

  • desweil

    10

  • guenti51

    7

  • Most Wanted

    5

ja, das wird an der onboard grafik liegen (zu wenig rechenleistung für postprocessing wie z.B. hochwertiges Deinterlacing). Kannst ggfs. im CCC die Deinetrlacing STufe manuell auf Kosten von Bildqualität runtersetzen, oder halt neue Grafikkarte kaufen. Da ab HD4550 aufwärts oder Nvidia gt220 aufwärts.

Link to post

Dann werd ich mir wohl ne GT430 holen. Ist das für meinen HTPC ok? Oder lieber ne GTS450?

 

Oder würdet ihr ne ATI Empfehlen? Da gibts den h.264 Bug oder?

Link to post

Habe jetzt die GT430 eingebaut und es funktioniert noch immer nicht tadellos. Mit dem 266.58er Treiber von Nvidia erhalte ich Microruckler so alle 3-4 Sekunden. Wenn ich den Custom EVR aktiviere, ruckelts ständig. Hat hier noch jemand eine zündende Idee, welchen Treiber ich verwenden soll?

 

Gibts GT430 User, die in irgendeiner Konstellation das perfekte, ruckelfreie Fernseherlebnis genießen?

Link to post

Hallo,

ich habe zwar keine GT430, aber eine Onboard-Grafik mit einer ATI hd4200 auf einem ASUS 785G board.

Ich hatte anfangs ebenfalls Ruckler (SD und HD).

Dies lag aber größtenteils an den codecs und an den Einstellungen im BIOS. Ich habedort denzugeordneten Speicher mal geändert.

Es ist jetzt schon besser, ab und zu ruckelt es trotzdem noch sporadisch.

 

Ist eine Entscheidungssache. Ob mir das ne neue Graka (ATI4550 passiv?) wert ist? hmm.....

Link to post

ja, das wird an der onboard grafik liegen (zu wenig rechenleistung für postprocessing wie z.B. hochwertiges Deinterlacing). Kannst ggfs. im CCC die Deinetrlacing STufe manuell auf Kosten von Bildqualität runtersetzen, oder halt neue Grafikkarte kaufen. Da ab HD4550 aufwärts oder Nvidia gt220 aufwärts.

SDTV geht selbst mit dem AMD 3200 (onboard GPU des AMD 780G) problemlos mit vector adaptive Deinterlacing und EVR Custom - problematisch wird's erst bei 1080i-HDTV. ;)

 

@feuse8: Poste mal eine support.zip - ich tippe auf ein Codec-Problem.

Link to post
Stinkbärchen

Habe jetzt die GT430 eingebaut und es funktioniert noch immer nicht tadellos. Mit dem 266.58er Treiber von Nvidia erhalte ich Microruckler so alle 3-4 Sekunden. Wenn ich den Custom EVR aktiviere, ruckelts ständig. Hat hier noch jemand eine zündende Idee, welchen Treiber ich verwenden soll?

 

Gibts GT430 User, die in irgendeiner Konstellation das perfekte, ruckelfreie Fernseherlebnis genießen?

 

Ausgabe auf 50HZ eingestellt? Bei mir ruckelt es auch bei 60Hz.

Link to post

Hallo Leute,

 

danke für eure Hilfe - die Support.zip findet ihr im Anhang.

 

Ja habe auf 50 Hertz eingestellt. Daran liegts leider nicht.

 

Wäre super, wenn ihr mir weiterhelfen könntet!

support.zip

Link to post

Hallo feus8,

bei meinem HTPC habe ich auch sehr lange gebraucht bis es keine Ruckler mehr gab, ich habe tonnenweise Codecs ausprobiert für H264 Material usw.

Ich habe das Gigabyte 880GMA-UD2H Mainboard mit integerierter Grafikkarte (ati 4200 oder 4250 weiss ich jetzt nicht genau). Der Chip ist eigetnlich absolut ausreichend selbst für 1080i Material der HD+ Sender.

 

 

Hier meine Empfehlungen:

Für HD-Sender nutze ich den Divx H264 Codec (kostenlos downloadbar, nur das Codec Pack reicht, den Player brauchst Du nicht) dieser beitet mir bisher das beste Bild und die schnellsten Umschaltzeiten und unterstützt von Haus aus DXVA. Vergiss bitte EVR, oder den Custom EVR, bisher haben diese bei mir nie richtig funktioniert. Ich nutze auschliesslich Overlay.

Falls Du die DVBViewer Version 4.2.1.0 nutzt brauchst Du nur den Divx Codec isntallieren und diesen im DVBViewer einstellen. Nutzt Du eine neuere Version des DVBViewer (4.6 z.B) dann rate ich Dir den DVB-Source-Filter (zu finden im Installationsordner des DVBViewers unter dem Ordner Filters mit dem Namen PushSource.ax) durch die Version 3.4.3.0 auszutauschen (wird standardmäßig mit der version 4.2.1.0 des DVBviewers installiert). Dieser bietet in Verbindung mit dem DIVX Codec die besten Umschaltzeiten und absolut ruckelfreies Fernsehen. Achte nach der Divx Installation auch, dass der Filter wirklich genutzt wird, dies überprüfst Du bei eigeschaltetem HD-Sender unter Ansicht/Filter. Im ATI Controlcenter ist das Deinterlaceing bei mir auf Auto eingestellt.

 

Ein Punkt der nicht zu vernachlässigen ist, ist die Temperatur. Üblicherweise werden die Onboardgrafikchips passiv gekühlt. Überprüfe mal die Temperatur der GPU bei eingetelltem HD-Sender. Bei mir trat früher nach einer Stunde in HD leichte Ruckler auf. Ich habe für die GPU extra ein Lüfter in der nähe des Kühlkörper befestigt, danach war Ruhe.

 

Eine Kleinigkeit noch, hat mehr was mit der CPU zu tun, deaktiviere CoolnQuiet und C1E Support im Bios...Frisst zwar etwas mehr Strom aber das System reagierte bei mir wesentlich flotter.

 

Ach ja, bist Du Dir sicher, dass die Ruckler nur vom Codec stammen und nicht Probleme beim Fernsehsignal, vielleicht mal unter Ansicht/Filter/DVB Source die Discontinuities im Auge behalten, steigen diese stark an während Du Ruckler hast liegt es nicht am Codec oder Grafikkarte, sondern eher an Fehler im TV-Signal oder der Tuner der DVB-Karte hat ein Problem)

 

 

Gruß,

tobias

Link to post

mit overlay renderer kannst du ab vista aufwärts KEIN DXVA mehr verwenden. Das geht nur noch bei XP. Also ist aber Vista EVR (custom) der way to go.

 

Und onboard grafik ist definitiv nicht "auf jeden fall" schnell genug für 1080i. Auch wenn da immer ganz toll "bluray fähig" darufsteht!

Link to post

Nur zum Verständnis:

 

Blu-Ray ist 1080p, braucht also kein rechenintensives Deinterlacing.

Deswegen ist die Werbeaussage schon richtig.

 

Nur 1080i bei HDTV mit DXVA (vektoradaptives Deinterlacing) braucht Rechenpower und noch etwas mehr, wenn die Shader mit ins Spiel kommen.

Deswegen ist der Wettbewerb, wer erreicht mit der billigsten Grafikkarte das schönste ruckelfreie Bild kontraproduktiv.

Link to post

ja mir ist das klar, nur vielen leuten nicht. Die hören in der Werbung NUR 1080p ist FULL HD, 1080i sei quasi nicht wirklich FULL HD, und da ja 1080p (bluray) ruckelfrei läuft muss das nicht mal wirkliche FULL HD 1080i natürlich auch laufen. Das sind so die Gedankengänge von vielen.

Link to post

mit overlay renderer kannst du ab vista aufwärts KEIN DXVA mehr verwenden. Das geht nur noch bei XP. Also ist aber Vista EVR (custom) der way to go.

 

Und onboard grafik ist definitiv nicht "auf jeden fall" schnell genug für 1080i. Auch wenn da immer ganz toll "bluray fähig" darufsteht!

 

Kann ich so nicht bestätigen!

Sobald ich DXVA bei mir einschalte geht die CPU in der Leistungsanzeige mindestens 15% wenn nicht sogar 20% runter und das bei Overlay unter Win 7 32bit, nix EVR. Das ist für mich ein Indiz, dass DXVA funktioniert.

Die Onboardgrafik liefert bei mir ein absolut ruckelfreies Bild mit den oben gennanten Einstllungen bei HD+, was soweit ich weiss 1080i ist.

Link to post

Hallo guenti,

den Link kannte ich schon...verstehe jedoch nicht was Du mir damit sagen willst.

 

Nun denn, also mit meinem Bild bin ich sehr zufrieden auch wenn es "nur" ein integrierter Grafikchip ist.

Link to post
  • 2 weeks later...

Danke tobias für die lange Ausführung.

 

Habe den DIVX nicht ausprobiert, weils vor allem bei SDTV hakt. Habe gestern noch den DVBViewer 4.2.1.0 installiert. Hat aber keine Besserung gebracht. Bin echt ratlos, was das Problem sein könnte. Habe inzwischen auch eine GT430 eingebaut, mit der die Probleme bestehen.

 

Bin schon kurz davor, das ganze aufzugeben oder Vista 32bit zu installierern. Hat vllt. noch jemand eine zündende Idee?

Link to post

Ja. Die Ruckler treten alle 5-10 Sekunden auf.

 

Derzeit habe ich wieder Powerdvd 8 installiert.

 

Die Bildwiederholfrequenz ist auf 50 Hz eingestellt.

 

Keine Ahnung woran die Ruckler liegen könnten. Habe mittlerweile schon Hintergrundprogramme (wobei ich nur die iMon Software und Microsoft Security Essentials installiert habe) unter Verdacht.

Link to post

du sagst, du hast ne GT430 installiert. In deienr support.zip die du mal geposted hast steht aber noch die ATI onboard grafik. Ist dei vielleicht noch aktiv und deine eingebaute Kartte wird gar nciht verwendet?

Link to post

Deine GT430 langweilt sich immer noch:

 

OS: Windows Vista Business Edition x64 Service Pack 2

DirectX: 10.0

d3dx9_33.dll: True

Memory: 4093 MB

CPU: AMD Athlon II X2 240e Processor

CPU Speed: 2812 Mhz

CPU Count: 2

Videocard: ATI Radeon HD 4250

Version: 8.710.0.0

Link to post

Also bei mir muß das im Bios eingestellt werden.(Asus M3N-HD/HDMI).

Ich habe die Onboard ganz deaktiviert. Für PhysX ist die auch nicht zu gebrauchen.

Link to post

So da hats wirklich gehakt mit der Onboard Graka. Hatte sie im Bios deaktiviert, dann gesehen, dass die Karte noch im Gerätemanager bei den ausgeblendeten Geräten angezeigt wurde (mit der device_mgr_shownonpresent_devices). Hab sie rausgelöscht und die Treibersoftware deinstallieren lassen. Jetzt steht sie nicht mehr im support.zip. Hab noch nicht testen können, obs noch ruckelt. Werd ich jetzt dann mal erledigen.

 

Danke erstmal für eure Hilfe!

support.zip

Link to post

Nach 45 Minuten ORF1 HD kann ich sagen, dass es immer noch ruckelt.. Mit dem PowerDVD Codec von Terratec ruckelt es noch heftiger, als mit Version 8.

 

Ideen sind willkommen, sonst klopp ich das Teil in die Tonne.

 

Hat jemand Vorschläge, welches Windows und vor allem welche Codecs ich installieren soll? Hab dank MSDNAA so ziemlich alles zur Auswahl..

Link to post

ORF1 HD? Hast du etwa eine Smartcard dafür, doer doch eher nicht? Wenn nicht dann liegts wohl an dem Plugin was du da möglicherweise nutzt. Und wenn dem so ist, dann ist mein Support heir zu Ende.

Link to post

OS: Windows Vista Business Edition x64 Service Pack 2

DirectX: 10.0

d3dx9_33.dll: True

Memory: 4093 MB

CPU: AMD Athlon II X2 240e Processor

CPU Speed: 2812 Mhz

CPU Count: 2

---------------------------------------

 

Jetzt ist gar keine Grafikkarte zu sehen.

Bring das in Ordnung. Die GT 430 sollte in der NVIDIA Systemsteuerung zu sehen sein.

Benutze mal den EVR Custom Renderer und aktiviere DXVA im Cyberlink Video Decoder.

Link to post

Keine Ahnung was da nicht passt... In der Nvidia Systemsteuerung ist die Graka zu sehen, GPU-Z zeigt sie an, im Geräteamanager wird sie angezeigt... CPU Auslastung bei ORF1 HD ist 6%. Somit geh ich davon aus, dass DXVA funzt. Ist auch aktiviert. Dass die GT430 nicht in dem File steht find ich schon merkwürdig. Evtl ein Problem mit Windows 64Bit?

 

Aufnahmen ruckeln auf meinem anderen PC nicht. Auf dem mit dem Ruckelproblem schon.

Edited by feuse8
Link to post

In diesem Bezug ist das Support.zip nicht ausschlaggebend! Wenn sie im Gerätemanager ohne Fehler drinn steht passt das schon! Zur Not einfach mit GPU-Z gegentesten, dort sieht man dann auch ob sich die GPU-Taktraten bezüglich DXVA Verwendung ändern.

Link to post

versuch mal den latency checker http://www.thesycon.de/deu/latency_check.shtml Hast du da peaks (rote balken/ausschläge)?

 

Hatte mal ein ganz merkwürdiges Problem damals und am ende lags bei mir z. B. wohl am Netzteil(!!!!)

 

Ruckeln die aufnahmen auch, wenn du sie z.B. mit dem WIndows Media player oder VLC abspielst?

Edited by desweil
Link to post

Danke für den Tipp!

 

Ich habe in mehr oder minder regelmäßigen Abständen zumindest Gelbe Ausschläge in der Kurve. Hast du noch einen Tipp, wie ich dem Verursacher auf die Spur komme? Gibt es eigentlich eine Log-Option bei dem Tool?

Link to post
Most Wanted

Hallo Leute

 

Was ich hier so raus lese ist also ne Onboardgrafik lösung mit z.b HD 4250 zuwenig wenn man HD schauen und aufnehmen will.

Also sollte man sich von hausaus gleich nee Grafikkarte mitbestellen.

Stimmt das so will mir nähmlich demnächst ein System zusammenstellen.

 

mfg Most Wanted

Link to post

Nein kann ich nicht bestätigen, hab schon div. HTPCs für mich und Freunde gebaut.

Füher mit 4200HD onboard jetzt mit i3, und es lief immer alles Problemlos.

Xp overlay mit Cyberlink Codec (9er codec, mit 10er hatte ich oft das Gefühl das es auch hackelt).

Win7 EVR custm. mit Cyberlink 9 aber auch der integrierte MS DTV codec läuft einwandfrei.

Edited by jasch
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...