Jump to content
notaclue

DVBViewer Video Editor Rückmeldungen

Recommended Posts

notaclue
Posted (edited)

Just installed the 64-bit version. Am running into a reproducable problem:

 

Open a recording. The first time, the file was indexed. That went ok.

Forward the slider.

Click on play.

I get a dialog "Ungültige Gleitkommaoperation".

After that, the program soon becomes unresponding to commands and then needs to be closed.

 

OS:           Windows 7 Ultimate Edition x64 Service Pack 1
OS Build:     7601
Aero enabled: True
DirectX:      10.0
d3dx9_33.dll:   True
Memory:       16381 MB
CPU:          AMD Athlon(tm) II X4 640 Processor
CPU Speed:    3013 Mhz
CPU Count:    4
Videocard:    AMD Radeon HD 5700 Series
Version:      15.200.1062.1004

 

Edited by notaclue

Share this post


Link to post
hackbart

What kind of recording did you opened? Can you also check the 32bit build? Please make sure that you also have 64bit codecs for the format you intend to play. There are not much decoders available. LAV should run fine.

 

Christian

PS: I better should check if codecs are available ;)

Share this post


Link to post
notaclue

An mpeg2 transport stream. The problem does not occur on a different PC with a newer Intel Skylake CPU. My main PC is the one with the AMD Athlon II X4.

 

4seven (eng) 31.05.2015

F:\Videos\Uncut\2015-05-31_18-50-00_4seven (eng)_Inside Jaguar  Making a Million....ts

Device: Digital Devices DVB-S/S2 Tuner 1 (1)

18:50:00 / 00:00:00 (~ 0,00 MB) Start
18:50:02 / 00:00:01 (~ 0,46 MB) PID 2316: MPEG2 Video, 16:9, 704x576, 25 fps
18:50:02 / 00:00:01 (~ 0,46 MB) PID 2317: MPEG Audio Stereo, 48 khz, 192 kbps
18:50:02 / 00:00:01 (~ 0,46 MB) PID 2319: MPEG Audio J. Stereo, 48 khz, 128 kbps
20:40:00 / 01:50:00 (~ 2741,65 MB) Stop

Average Data Rate: 0,415 MB/s
Total Size: 2741,6 MB (2874825688 Bytes)

 

 

Share this post


Link to post
hackbart

If you open the options, what codecs do you see listed for mpeg2 audio and video?

Share this post


Link to post
notaclue
Posted (edited)

Just reinstalled LAV Filters 0.71. No change. The options are all set to System Default.

 

Installed the 32-Bit version. Install ended with opening the old keytool, which I just closed.

The 32-Bit version will not give the error mentioned above.

Edited by notaclue

Share this post


Link to post
hackbart

Which sounds to be a codec related issue. I will check this at the moment, once my plain windows 10 finished its update orgy.

Share this post


Link to post
hackbart

Here it works without any error. I just had to install LAV in order to get a picture.

Share this post


Link to post
notaclue
Posted (edited)

Set all codecs in 64-Bit Version to LAV-Video/Audio Decoders. Still getting the same error.

 

Other observations:

  • Help-About does not display version number and bitness. That would be helpful, especially when one has both 32- and 64-Bit versions installed at the same time.
  • The shortcut in the start menu only points to one of the two installed versions.
  • When clicking on Tools-Enviroment Options, the options windows appears and then immediately disappears behind the editor window.
  • I now have two versions of the keytool. The 64-Bit version knows and allows ordering of the editor, the 32-Bit version does not.
  • When opening the TS-file mentioned above (with the 32-Bit version of the editor), it takes about 12 seconds before the timeline is being displayed. Perhaps some kind of message such as "please wait" or "opening file" would be helpful for the more impatient users among us.

 

PM me if you wish to move this discussion or need additional info or files.

 

Edited by notaclue

Share this post


Link to post
notaclue
Posted (edited)

Further observations:

 

  • after saving, when the status window has just disappeared, the program will not respond to commands for a few additional seconds (e.g. clicking on "File" yields no reaction). It's as if the program is still busy, but not telling you that it is.
  • when trying to cut the main feature from the TS-file mentioned above, even when using a frame that lays behind the main feature as end-marker, I'm still missing part of the end of the feature.
Edited by notaclue
spellcheck

Share this post


Link to post
waldi801

Tested here the 64-Bit Version on WIndows 10 and the Program works without any error. I can slide around and the App won´t stop working.

Share this post


Link to post
marni

Wieviel soll es denn kosten? Bietet es Vorteile gegenüber dem TS-Doctor?

Share this post


Link to post
notaclue
1 hour ago, notaclue said:

when trying to cut the main feature from the TS-file mentioned above, even when using a frame that lays behind the main feature as end-marker, I'm still missing part of the end of the feature.

Just restarted from scratch. Removed the index-file, opened the ts-file again, rebuilt the indexes, set the beginning and end markers just outside the main feature, selected "keep", saved again. This time it worked, I have the full main feature. Will play around a little more in the days to come.

Share this post


Link to post
notaclue
16 minutes ago, notaclue said:

This time it worked, I have the full main feature.

 

Checked the resulting file. I'm sorry to say that close to the end the audio is a bit out of sync. @Christian: Send me a PM if you want a link to the original recording (the source file).

Share this post


Link to post
Webturtle

Hallo,

 

ist es zutreffend, daß es zur Zeit nur die Demo-Version gibt? Ich meine, in einem anderen Thread gelesen zu haben, daß die reguläre Kaufversion erst mit der nächsten DVBViewer Pro Version zu bestellen ist. Mein Keytool (DVBViewer Version 6.0.4.0) kennt  noch keinen Videoeditor. Auch die "Bestellen-Seite" des DVBViewer sieht noch keinen Erwerb vor.

 

 

Viele Grüße

 

Webturtle

Share this post


Link to post
hackbart

Nein in der Demo ist das aktuelle Keytool drin. Das kann man einfach starten und kann die Lizenz darüber erwerben. In den nächsten Versionen kommt das aktuelle Keytool auch in den DVBViewer Installer.

Share this post


Link to post
Webturtle

Hallo,

 

nachdem ich auf "Registration Info" geklickt habe, ging beim ersten Mal das altbekannte Keytool ohne Videoeditor auf. Beim nochmaligen Programmstart ist dabei dann gar nichts mehr passiert.

 

 

Viele Grüße

 

Weburtle

Share this post


Link to post
iks-jott

@Webturtle

 

So ist es. Es werden 2 Erweiterungen angeboten, aber der Video-Editor ist nicht dabei.

Share this post


Link to post
Webturtle

Hallo,

 

Avira Antivir meint in VideoEditor.exe das Muster "TR\Crypt.ASPM.Gen" gefunden zu haben und hat die Datei in Quarantäne verschoben.

 

 

Viele Grüße

 

Webturtle

 

Share this post


Link to post
dgdg
vor 5 Stunden schrieb marni:

Bietet es Vorteile gegenüber dem TS-Doctor?

 

Wenn es nur halb so oft abstürzt wie der TS-Doctor ist das schon ein Vorteil. :whistle:

 

Aber im Ernst, ich verwende TS-Doctor und habe gerade den VideoEditor angetestet. Ist leider auch einmal abgestürzt.

Das Erstellen des Indexes dauert leider eine Ewigkeit (3 Minuten bei einem 90 Minuten TS-File in SD - HD habe ich mich noch gar nicht getraut).

Das Speichern des geschnittenen Files dauert leider auch ewig. TS-Doctor ist hier um Größenordnungen schneller - selbst bei HD.

 

Trotzdem hoffe ich auf eine Alternative zum TS-Doctor. Mein Maßstab ist hier aber ProjectX und Mpeg2Schnitt (leider nicht HD-fähig) - vor allem die Vorschau-Funktionen von Mpeg2Schnitt..

 

Solange quäle ich mich weiter mit TS-Doctor und beobachte, wie sich der VideoEditor entwickelt.

 

Share this post


Link to post
Webturtle

Hallo,

 

@dgdg: TS-Doctor ist nicht schlecht, aber jeder Editor unterscheidet sich etwas von den anderen, insbesondere in der Bedienung. Mein absoluter Favorit ist bisher immer noch Easy Movie von BHV (aka Womble MPEG Wizard). Dieser ist einmalig schnell. Man kann so schnell durch das Video browsen, wie man den Slider über die Zeitleiste ziehen kann. So kann man Werbeunterbrechungen praktisch so schnell manuell finden wie mit einer automatischen Werbeerkennung. Leider funktioniert meine Version nur mit MPEG. Mal sehen, ob der DVBViewer-Editior mein Favorit für HD oder auch für MPEG-Aufnahmen wird (wenn das Keytool funktioniert). 

 

 

Viele Grüße

 

Webturtle

Share this post


Link to post
mannix

Auch ich hatte auf ein großes Programm gehofft,  aber das Finden der Schnittpunkte und das ganze Handling ist doch um Einiges umständlicher als beim "Smart Cutter". Der kann zwar keine Werbeerkennung, aber ich kenne auch kein Programm, dass eine Werbeerkennung zuverlässig kann.

Mein Wunsch wäre eine Bedienbarkeit mit unterschiedlichen Slidern (große Entfernungen/bis zum nächsten Bild). Auch hier siehe Smart Cutter, der offensichtlich nicht weiterentwickelt wird.

Share this post


Link to post
Webturtle
Posted (edited)

Hallo,

 

also die Installation  ist sehr zickig. Bein ersten mal  gab es keine Fehlermeldung, aber beim Klicken auf Registration Info fehlte der Video-Editor. Nachdem ich DVBViewer, DVBViewer GE und EPGPlus beendet hatte, wurde eine Fehlermeldung angezeigt, daß Keytool.exe nicht ersetzt werden könne. Erst nach einem Neustart des Rechners lief die Installerton durch. Danach hat Avira Antivir aber sogleich die Datei Keytool.exe mehrfach wegen des Musters "TR\Crypt.ASPM.Gen" in Quarantäne geschickt. Ich mußte sie  mehrfach wieder zurückholen und dann dauerhaft eine Ausnahme einrichten. Jetzt war unter Registration Info auch  der Video-Editor zu finden. Aber nicht im DVBViewer, bei dem finde ich den Menüpunkt "Bestellen" nicht mehr und auch nicht beim Keytool über das Startmenü.

 

Was bedeutet die Fehlermeldung "Error opening http://ffmpeg.zeranoe.com/builds/win64/static/ffmpeg-20170330-ad7aff0-win64-static.zip

The server returned status code 404" ? Im Mitgliederbereich ist außer der Setupdatei für den Video-Editor anscheinend nichts weiter zu finden.

 

 

Viele Grüße

 

Webturtle

 

Edited by Webturtle

Share this post


Link to post
Griga
1 hour ago, Webturtle said:

Was bedeutet die Fehlermeldung "Error opening http://ffmpeg.zeranoe.com/builds/win64/static/ffmpeg-20170330-ad7aff0-win64-static.zip

The server returned status code 404" ?

 

Dass versucht wurde, ein veraltetes FFmpeg-Build zu laden, das es bei Zeranoe nicht mehr gibt. Guckst du hier

 

https://ffmpeg.zeranoe.com/builds/win64/static/

 

und besorgst es dir selbst, falls erforderlich. Ich würde die 3.4.2 nehmen. Der wesentliche Teil ist die enthaltene ffmpeg.exe. Mehr kann ich dazu nicht sagen, da ich den Editor und seinen Installer nicht kenne o:)

 

  • Like 1

Share this post


Link to post
hackbart

Oh der nutzt die gleiche Version wie der DMS. Das ging doch bis letztens. Ich passe das mal an.

Share this post


Link to post
Webturtle

Hallo,

 

@Griga: Vielen Dank für den Link! Aber die Version 3.4.2 findet sich eher hier: https://ffmpeg.zeranoe.com/builds/

 

Was mache ich dann mit der Zip-Datei? Sie enthält drei Unterverzeichnisse. Einfach in ein Verzeichnis "Ffmpeg" im Programmverzeichnis entpacken? Ein Setup-Programm gibt es anscheinend nicht.

 

 

Viele Grüße

 

Webturtle

 

P.S. @hackbart: Vielleicht kannst Du mal die Dateien bei Avira zur Überprüfung hochladen, damit die für sie eine Ausnahme machen.

 

 

 

Share this post


Link to post
hackbart

Avira ist der letzte ***, der meckert bei jeder Version die mit ASPack komprimiert wurde. Dabei ist es egal, ob du die Datei zertifiziert hast oder nicht. Ich denke ich komprimiere die Binaries einfach nicht mehr. 

Das hatte ich schon letzte Woche gemacht. Eiei, ich denke ich lade die gleich mal wieder hoch. Aktuell habe ich ein kleines Update am Wickel. Der Installer nutzt nun die -latest- build. 

 

 

Christian

PS: Ich bin mir ziemlich sicher das die obige ffmpeg build bis Freitag noch existent war.

Share this post


Link to post
hackbart

Ich habe eine neue Build (1.0.1) auf den Server gepackt. FFMpeg ist im Installer aktualisiert, die Versionsnummer wird angezeigt und eine leere Datei für ffmpeg bzw. comskip wird ignoriert. Außerdem ist im About-Fenster jetzt die Versionsinformation zu finden und die 32bit Build ist nicht mehr komprimiert.

Share this post


Link to post
dgdg
Posted (edited)
vor 16 Stunden schrieb dgdg:

Solange quäle ich mich weiter mit TS-Doctor und beobachte, wie sich der VideoEditor entwickelt.

 

Achso, geht ja gar nicht, weil der Testzeitraum des Video Editor zeitlich bschränkt ist. Ich kann also gar nicht testen, ob eine spätere Version meinen Ansprüchen genügt.

Ok, ich bin dann leider raus.

 

Edited by dgdg

Share this post


Link to post
norman.stoer

Hallo,

 

konnte auch schon etwas Testen. Hier mein Beobachtungen:

1. Der Zoom in die Thumbnails scheint noch nicht korrekt zu funktionieren: Reinzoomen mit F8 geht, wieder raus mit F7 nicht. Auch der Reset oder eine andere Auswahl funktioniert noch nicht.

2. ComSkip scheint sehr gut zu funktionieren.

3. Gelegentlich stürzt der Editor ab, beim Versuch das Fenster zu maximieren (noch nicht bei Version 1.0.1 geprüft)

4. Kann den Editor nicht über das KeyTool kaufen. Wird dort einfach (noch) nicht angezeigt.

Share this post


Link to post
Webturtle
Posted (edited)

 

 

@hackbart: Ich hatte bisher bei keinem der  Programme aus de DVBVViewer Umgebung Probleme mit Antivir.. Wird Ffmpeg dann automatisch soweit installiet wie es für den DVBViewer-Editor erforderlich ist?

Jetzt läuft die Installation ohne Fehlermeldung. Vielen Dank für Dein schnelles Tätigwerden.

 

@norman.stoer: Wenn Du alle DVBViewer Programme beendest und eventuell den Rechner neu startest und dann den Video-Editor neu installierst, wird das neue Keytool  installiert. Dann im Fenster, das beim Programmstart aufpoppt, auf Registration Info klicken. Dann ist auch der Video-Editor zu finden und zu bestellen.

 

Viele Grüße

 

Webturtle

Edited by Webturtle

Share this post


Link to post
hackbart

Naja der DVBViewer steht wohl auf einer Whitelist. Erstelle ich hier ein neues Projekt, benutze ASPack, dann hat mir laut virustotal Avira sofort einen Fehlalarm raus. Selbst wenn ich das Projekt signiere bringt das nichts.

Share this post


Link to post
HaraldL

Ich hab mal testweise versucht bei einer DMS-Aufnahme von einem ÖR-Sender (also 720p) Vor- und Nachspann wegzuschneiden. Beim Abspielen des Ergebnisses war der Anfang OK, aber die letzten paar Sekunden (vielleicht ab dem letzten I-Frame?) sahen so aus daß das Bild einfror und der Ton mit dem "Standbild" statt des Abspanns weiterlief bis zum Dateiende. Werde am Wochenende nochmal ein paar Tests machen.

Share this post


Link to post
hackbart
vor 5 Stunden schrieb dgdg:

 

Achso, geht ja gar nicht, weil der Testzeitraum des Video Editor zeitlich bschränkt ist. Ich kann also gar nicht testen, ob eine spätere Version meinen Ansprüchen genügt.

Ok, ich bin dann leider raus.

 

Einfach komplett deinstallieren und die Einstellungen löschen. Dann kann man den jederzeit erneut installieren.

vor 2 Stunden schrieb Webturtle:

@hackbart: Ich hatte bisher bei keinem der  Programme aus de DVBVViewer Umgebung Probleme mit Antivir.. Wird Ffmpeg dann automatisch soweit installiet wie es für den DVBViewer-Editor erforderlich ist?

Jetzt läuft die Installation ohne Fehlermeldung. Vielen Dank für Dein schnelles Tätigwerden.

FFMpeg ist nur für etwaiges reencoding nötig. Eigentlich ist das nur ein Feature, welches Majstang als Nice To Have erfragt hat. Du kannst mit ffmpeg am Ende oder wenn man als Zielformat etwas anderes als das Ausgabeformat angibt die Datei reenkodieren. Das dauert dann jedoch mitunter ziemlich lange, je nach Zielformat. Die Parameter dafür kann man in den Optionen definieren.

 

vor 30 Minuten schrieb HaraldL:

Ich hab mal testweise versucht bei einer DMS-Aufnahme von einem ÖR-Sender (also 720p) Vor- und Nachspann wegzuschneiden. Beim Abspielen des Ergebnisses war der Anfang OK, aber die letzten paar Sekunden (vielleicht ab dem letzten I-Frame?) sahen so aus daß das Bild einfror und der Ton mit dem "Standbild" statt des Abspanns weiterlief bis zum Dateiende. Werde am Wochenende nochmal ein paar Tests machen.

 

Wurde denn am Ende etwas weggenommen? I-Frames sollten bei DVB recht häufig kommen, zwischen den I-Frames liegen da meist keine 2 Sekunden. Wurde denn das Indexing verwendet?

Share this post


Link to post
dgdg
Posted (edited)
vor 16 Minuten schrieb hackbart:

Einfach komplett deinstallieren und die Einstellungen löschen. Dann kann man den jederzeit erneut installieren.

Das ist erfreulich. Dann werde ich das mal weiter beobachten.

 

Noch eine Sache die mir aufgefallen ist: Manche Fenster sind nach dem Öffnen im Hintergrund (z.B.  Options). Die muss man dann erst mal suchen und in den Vordergrund holen. Auch der Splash-Screen landet bei mir knapp ausserhalb des Bildschirms (man sieht noch einen kleinen Rand). Vermutlich weil ich zwei Monitore habe. Der zweite war aber ausgeschaltet.

 

Edited by dgdg

Share this post


Link to post
hackbart

Ja das habe ich in der Version 1.0.1 behoben. Der Nag-Screen ist in der Desktopmitte. Ich denke mal es macht Sinn den eher auf dem aktiven Monitor zu zentrieren. Das fixe ich beim nächsten Release.

Share this post


Link to post
HaraldL
vor 57 Minuten schrieb hackbart:

Wurde denn am Ende etwas weggenommen? I-Frames sollten bei DVB recht häufig kommen, zwischen den I-Frames liegen da meist keine 2 Sekunden. Wurde denn das Indexing verwendet?

ja ich hab am Ende den Nachlauf ca. 10 Minuten und am Anfang den Vorlauf ca. 5 Minuten weggeschnitten. In der Mitte nichts, war ja eine ÖR-Sendung ohne Werbung.

Und ich vermute ;) daß ich Indexing verwendet habe weil er beim Öffnen der TS-Datei recht lange indiziert hat. Hab in den Einstellungen außer den Codecs nichts verstellt. War einfach ein erster Versuch. Ich probiere es am Wochenende nochmal, dann mit der neueren Version.

Share this post


Link to post
marni
vor 6 Stunden schrieb dgdg:

 

Achso, geht ja gar nicht, weil der Testzeitraum des Video Editor zeitlich bschränkt ist. Ich kann also gar nicht testen, ob eine spätere Version meinen Ansprüchen genügt.

Ok, ich bin dann leider raus.

 

Ich habe in einer VM getestet...

 

Bin leider nicht so begeistert. Ein HD Aufnahme vom ZDF sollte vorn und hinten was weg. Die Punkte wurden leider nicht selbst erkannt, wie andere Tools es können. Also selbst gesucht und weggeschnitten. Beim Speichern blieb das Programm bei "1 Sekunde" verbleibend leider hängen.

In ein paar Wochen vielleicht wieder :)

Share this post


Link to post
hanschke

hab einfach mal dir Geld gesendet :)

Share this post


Link to post
semko

Ich habe comskip und ffmpeg bereits an anderer Stelle auf dem Rechner. Kann ich irgendwie auf die Pfade verweisen oder muss ich die beiden etwa noch einmal extra installieren?

Share this post


Link to post
hackbart
vor 9 Stunden schrieb semko:

Ich habe comskip und ffmpeg bereits an anderer Stelle auf dem Rechner. Kann ich irgendwie auf die Pfade verweisen oder muss ich die beiden etwa noch einmal extra installieren?

 

Leider nein, man kann die beiden Dateien nur  in den Editorpfad kopieren. Ich selber nutze auch die Donators Edition dafür.

 

vor 11 Stunden schrieb marni:

Bin leider nicht so begeistert. Ein HD Aufnahme vom ZDF sollte vorn und hinten was weg. Die Punkte wurden leider nicht selbst erkannt, wie andere Tools es können. Also selbst gesucht und weggeschnitten. Beim Speichern blieb das Programm bei "1 Sekunde" verbleibend leider hängen.

 

Für die Erkennung wird Comskip benutzt. Das funktioniert recht gut, allerdings kann man für diverse Sender einige Optimierungen vornehmen. Comskip ist mit den Standardeinstellungen ziemlich universell auf alle möglichen TV Sender geeicht. Eigenheiten von Sendern kann man in der Comskip.ini anpassen. Die Zeitanzeige ist ein gewichteter Wert der in etwa wie folgt bestimmt wird: 

FAssumedTimePerTick := SMOOTHING_FACTOR * FAssumedTimePerTick +   (1 - SMOOTHING_FACTOR) * (Now - FTimeOfLastProgress)

Das bedeutet im Prinzip nur, dass der Vorgängerwert etwas wichtiger angenommen wird, als der aktuelle Wert. Springt also dT mal schneller oder langsamer verfälscht sich die geschätzte Zeit nicht so übermäßig. Insbesondere die letzte Sekunde kann aber etwas länger dauern, da im abschließenden Vorgang noch diverse Sachen und Dinge getestet werden und die Datei beendet wird, vor allem wenn es gegen Ende noch Schnittmarker gibt. Das kostet dann mitunter ein wenig mehr Zeit als eine Sekunde. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×