Jump to content
notaclue

DVBViewer Video Editor Rückmeldungen

Recommended Posts

TommyB
On 16.4.2018 at 10:32 AM, hackbart said:

Die Idee dahinter diese zu lizensieren war, dass wir uns nicht um die Bugs kümmern müssen, sondern der Lizenzgeber (Solveig).

 

Das erklärt einiges ;)

Hatte versucht eine Datei zu schneiden (VideoReDo), der verweigerte das Öffnen. Habe das Tool mal ausprobiert, klappte auch. Ok, die Wiedergabe nur im externen Fenster, bissl unschön, kann in meinem Fall aber auch dran liegen dass es über Remote Desktop lief. Aber hat geklappt.

 

Aber: Bild und Ton komplett aus der Synchronisation raus. Kenn ich von dem Verein schon... Kaum ist ein Mini-Fehler im Stream drin passt es Vorne und Hinten nicht mehr, im wahrsten Sinne des Wortes.

Lösung für mich in diesem Fall: Mit TSPacketViewer ein PAT suchen, Hex Offset merken, Hexeditor auf, bis dahin löschen und dann frisst es ReDo. Ist danach übrigens fehlerfrei durchgelaufen, also scheint nur der Anfang der Datei beschädigt zu sein. Da hat der Media Server wohl etwas zu früh versucht aufzunehmen... (Klappt normalerweise)

 

Schade.

Share this post


Link to post
hackbart

Also generell sollten Fehler gefixt werden, wenn unter Optionen "Obey Sample Times" aktiviert wird. Alternativ kann man auch einen Haken bei ffmpeg setzen, dann wird als Fallback ffmpeg zum Schneiden verwendet. 

Share this post


Link to post
THSGT3

Hallo,

ich verwende den aktuellen Video Editor, 64 Bit.

 

comskip funktioniert bei mir bspw. bei Pro7 (Germanys next top Modell war der letzte Test) überhaupt nicht. Es wird keinerlei Werbung gefunden.

Bei RTL klappt es hingegen gut.

 

Was kann ich ändern?

 

Vielen Dank,

 

Thomas

Share this post


Link to post
majstang
1 hour ago, THSGT3 said:

What can I change?

Tuning a comskip.ini is kind of complex and not many at this forum knows how to. You could try this one and if it's still doesn't detect any commercials you could upload the recording here (max upload limit 5 Gb) I can take a crack at it. 

Share this post


Link to post
Webturtle

Hallo,

 

ich habe festgestellt, daß der Video-Editior bei mir bei manchen DVB-T2 HD Sendern (!) nicht funktioniert. Es handelt sich um das DVB-T2 HD Sendegebiet Frankfurt am Main/Rhein-Main.

 

Aufnahmen mit meinem standalone DVB-S2 Satreceiver (z.B. NDR HD) werden geladen. Ebenso DVB-S Aufnahmen mit dem DVBViewer (für den Computer habe ich keinen DVB-S2 Empfänger).

DVB-T2 HD Aufnahmen mit dem DVBViewer werden von ZDF Sendern (z.B. ZDF, 3sat zdf_neo) korrekt geladen.

Bei Aufnahmen von Sendern der ARD (z.B. Das Erste, one, hr, Bayern der Norden, NDR, rbb, arte) passiert überhaupt nichts, wenn man sie öffnet.

Selbst bei parallelen Aufnahmen vom Morgenmagazin vom Ersten und vom ZDF funktionieren nur die vom ZDF.

Beim Video-Editor habe ich für alles LAV Filter ausgewählt und die Sender bzw. die Aufnahmen werden auch vom DVBViewer bzw. MPC-HC angezeigt.

Die Aufnahmen von ARD Sendern lassen sich übrigens mit dem TS-Doctor schneiden und auch mit XMedia Recode im MPEG Dateien (für unseren Flachbild TV oder das Notebook, die kein HEVC H.265 beherrschen) umwandeln.

 

 

Viele Grüße

 

Webturtle

Share this post


Link to post
hackbart

Kannst du mir da eine Aufnahme zur Verfügung stellen? Es reichen ein paar MB dafür. Ich hab das gerade hier mit ARD getestet und das geht ohne Probleme.

Share this post


Link to post
Webturtle

Hallo Christian,

 

Gerne, aber als Gesamtgröße wird unten 0.15MB angezeigt. Ist es auch möglich, sie als Anhang an eine PN oder EMail zu schicken. Ich habe an zwei, drei Sender gedacht mit je ca. 30 Sekunden (?) Länge in einem Zip-Archiv. Teile mir mit, was Du benötigst.

 

 

Viele Grüße

 

Webturtle

Share this post


Link to post
hackbart

Du kannst mir die Zip auch per Mail schicken. 150kb für ein Video ist aber arg wenig.

Share this post


Link to post
Webturtle

Hallo,

 

@hackbart: Hallo, ich habe Dir an bhackbart@cmuv.de zwei Testaufnahmen von arte und Bayern - Der Norden von zwei verschiedenen DVB-T2 HD Kanälen der ARD geschickt. Die Aufnahme vom Ersten war mit 22 MB zu lang und ließ sich auch nicht mit 7zip mit Einstellung Ultra unter 20 MB drücken. Bei Web.de sind die Grenzen für Anhänge pro Anhang 20 MB und insgesamt 100 MB. Die 150kb bezogen sich auf die verbleibende Speichergröße von Anhängen im Forum. Da ich gerade in der Bibliothek sitze, war auf die Schnelle auch keine kürzere Neuaufnahme möglich. Falls Du mehr benötigst, lasse es mich bitte wissen.

 

Die Aufnahmen wurden mit dem DVBViewer Pro mit einem Pearl DVB-T2 HD Stick gemacht. Aber auch mit Astrometa Sticks lassen sich die Aufnahmen nicht öffen. Dies gilt nicht nur für die ARD im Bereich des Hessischen Rundfunks, sondern auch für das DVB-T2 HD in Bayern - Der Norden (Franken), getestet mit BR-Alpha (alias ARD- Alpha) und MDR Thüringen.

 

Ich habe mir die neu Version heruntergeladen und werde sie zuhause gleich mal ausprobierten. Ich nehme an, bei der Installation benötigt man nicht erneut eine Internetverbindung für den Download zusätzlicher Komponenten wie ffmpeg, die bei einer früheren Installation schon heruntergeladen worden sind.

 

 

Viele Grüße

 

Webturtle

 

Edited by Webturtle

Share this post


Link to post
BigBull

Hallo,

ich habe jetzt auch die Version 1.0.3 ausprobiert. Die .ts-Aufnahmen sind beim Speichern immer noch alle 0 Byte groß, es wird also gar nichts gespeichert. Ich habe DVBT-2, nur die freien Sender, und die gehen alle nicht.

Share this post


Link to post
hackbart

Ist ffmpeg installiert? Das sollte bei der Installation ausgewählt werden.

Share this post


Link to post
BigBull

Ja, ffmpeg ist mit der neusten Version installiert.

 

Edit: Ich habe jetzt das Programm nochmal inkl. der angebotenen ffmpeg installiert - und jetzt geht es! :-)

Edited by BigBull

Share this post


Link to post
hackbart

Ich habe hier mehrere DVB-T2 Streams getestet und die gingen alle. Was passiert denn, wenn du in ein anderes Format speicherst?

Share this post


Link to post
BigBull

Jetzt geht es.

 

Eine andere Frage: Kann man auch mehrere Audo-Streams in einem geschnittenen Video integrieren? Ich habe einen Poirot-Film auf One aufgenommen, der auf der zweiten Tonspur die origonale englische Sprache hat. Beim Speichern kann ich aber nur eine Audio-Spur auswählen. Übersehe ich etwas?

 

Danke.

Share this post


Link to post
kazmce

Kann man mit dem Video-Editor die Untertitel als Datei ausgeben?

Share this post


Link to post
hackbart
vor 13 Stunden schrieb BigBull:

Jetzt geht es.

 

Eine andere Frage: Kann man auch mehrere Audo-Streams in einem geschnittenen Video integrieren? Ich habe einen Poirot-Film auf One aufgenommen, der auf der zweiten Tonspur die origonale englische Sprache hat. Beim Speichern kann ich aber nur eine Audio-Spur auswählen. Übersehe ich etwas?

Nun Prinzipiell werden alle Tonspuren übernommen. Das Problem mit deinen Aufnahmen (ich gehe mal davon aus, da mir das hier auch aufgefallen ist), ist dass die Tonspur AAC LATM nutzt. Das kann der Editor aktuell nicht, die Anpassung dazu ist aber in Arbeit und kommt im (über)nächsten Update. Als Fallback habe ich in so einem Fall ffmpeg eingebunden und der Befehl zum Bearbeiten berücksichtigt scheinbar nicht alle Tonspuren. Ich bin gerade am lesen und passe das an.

 

vor 10 Stunden schrieb kazmce:

Kann man mit dem Video-Editor die Untertitel als Datei ausgeben

 

Du meinst bei der Wiedergabe? Nein das fehlt noch, eventuell binde ich das noch ein.

Share this post


Link to post
hackbart

Nachtrag: Er kopiert jetzt immer alle Ton, Bild und Untertitelspuren. Ich teste das ganze noch und lade heute Abend einen Fix auf den Server. 

Share this post


Link to post
Webturtle

Hallo,

 

ich habe gestern eine Aufnahme von Bayern 3 (ARD -> AAC Ton) versucht, die immer noch nicht geladen wird. Nachdem das Herunterladen von Ffmpeg in der ersten Version nicht funktioniert hatte, habe ich die zweite Version mit der gefixten Downloadadresse auf meinem W10 64-Bit Notebook installiert. Das Herunterladen hat anscheinend funktioniert. Beim Installieren der Version 1.0.3 hatte ich keine Internetverbindung, weshalb Ffmpeg nicht erneut heruntergeladen wurden.  Der Fallback hat aber anscheinend nicht funktionert. Wie kann ich feststellen, ob Ffmpeg für den Video-Editor korrekt installiert ist und muß ich irgendwelche Einstellungen wählen?

 

@Christian: Du bist übrigens nicht das einzige Opfer der ARD. Als ich in der Testphase einen Free-TV DVB-T2 HD Receiver von Pearl bestellt habe, funktionierten Aufnahmen mit dem Aufnahme-Upgrade zunächst nur bei ARD-Sendern mit AAC aber nicht bei ZDF-Sender mit AC3. Später zur Einführung des Regelbetriebes gab es ein Update, womit ZDF-Sender mit AC3 aufgenommen und wiedergegeben werden konnten. Mittlerweile hat die ARD anscheinend etwas geändert, so daß es bei ARD-Sender mit AAC nicht mehr funktioniert hat. Erst ein weiteres Update hat dies behoben.

 

 

Viele Grüße

 

Webturtle

Share this post


Link to post
HaraldL

Ich habe mir gedacht ich lade die aktuelle Demoversion nochmal runter und schaue ob meine Versuche damit besser klappen. Nach dem Start heißt es dann "Ihre Testphase ist abgelaufen" und das war es dann ... :-(

 

Auch wenn der Editor nicht viel kostet, so werde ich garantiert keine Bestellung tätigen. Ein Tipp wäre, wenn sich das Programm jetzt nach der Anfangsphase etwas "stabilisiert" hat eine neue Testphase ermöglichen. Ansonsten bin ich gezwungenermaßen erst mal raus.

Edited by HaraldL

Share this post


Link to post
hackbart

Alle alten Einstellungen löschen und dann geht die Demo auch wieder.

Share this post


Link to post
BigBull

Hallo,

danke für die neue Version 1.0.4. Damit werden jetzt alle Tonspuren gespeichert!

Share this post


Link to post
Ulli_T.
On ‎16‎.‎04‎.‎2018 at 7:26 PM, hackbart said:

Das ist wieder so ein Typischer Fall von Unwissen gepaart mit Dreistigkeit. Man kann für jedes Zielformat Profile in den Optionen eintragen. 

 

Unwissen - mag sein. Dreistigkeit kann ich allerdings bestenfalls in Deiner Antwort finden :-)

Aber vielleicht warst Du ja auch beleidigt, weil ich Deine Aussage, dass das Programm (ansich) ausgereift ist, angezweifelt habe.

 

Dummerweise war diese Version meiner Ansicht nach noch weit von "ausgereift" entfernt. Vor allem deshalb, weil ich überhaupt nicht (ohne umzuwandeln) speichern konnte. 

Ich habe mir aber jetzt die neue (noch ausgereiftere :-) Testversion installiert - jetzt kann ich tatsächlich einen geschnittenen Film speichern - und die Geschwindigkeit dafür ist auch ok. Abspeichern im MP4 Format (ohne die Vorgaben in den Optionen zu ändern) dauert immer noch unerträglich lange. Erschwerend kommt immer noch hinzu, dass Status und Fortschrittsbalken dabei völligen Blödsinn anzeigen, wie z.B. 7 Min Elapsed / 2 Min Remaining und 10 Minuten später 17 Min Elapsed und 11 Remaining ...

 

Ich will mich keinesfalls streiten - im Gegenteil: 

Bei meinem ersten Post habe ich geschrieben, dass ich mich sogar als der typische Anwender für dieses Programm sehe. Deshalb würde ich mich freuen, wenn es bald auch aus meiner Sicht ausgereift ist...

 

Ulli

Share this post


Link to post
hackbart

Ich hab doch schon geschrieben, wenn MP4 umgewandelt werden soll, ohne dass ein Neucodieren benötigt wird, reicht es wenn in den Optionen bei den Transkodierungseinstellungen unter mp4 der Eintrag auf "-vcodec copy -acodec copy -scodec copy -map 0:v -map 0:a" geändert wird.

 

Share this post


Link to post
TommyB
On 19.4.2018 at 6:48 PM, hackbart said:

Also generell sollten Fehler gefixt werden, wenn unter Optionen "Obey Sample Times" aktiviert wird. Alternativ kann man auch einen Haken bei ffmpeg setzen, dann wird als Fallback ffmpeg zum Schneiden verwendet. 

 

Mit der Option hat es geklappt, danke :)

Share this post


Link to post
aet

Bei der Version 1.0.4 ist die Funktion vorheriger Frame mit nächster Frame identisch.

Share this post


Link to post
Ulli_T.

Hallo,

 

auf meinem "TV-Server" läuft der Videoeditor sehr schleppend. Allerdings ist die CPU/RAM Ausstattung auch recht mager.

Mir geht es dabei um die Funktionen Werbung schneiden/speichern und in MP4 Umwandeln.

 

Mein alter Prozessor kann hardwareseitig keinerlei Codecs de-/encodieren.

Würde die Hardware Codierung einer moderneren CPU genutzt und eine deutliche Beschleunigung bringen und wenn ja, welcher Codec müsste dann de- und/oder encodierbar sein?

 

Ulli

Share this post


Link to post
hackbart

Das kommt auf das Videoformat an. Die Anwendung ist in Punkto Performance kaum noch zu verbessern. Die Darstellung erfolgt komplett in Direct3D und nutzt die Hardwarebeschleunigung. Zugegebenermaßen ist das Indizieren recht nervig, deswegen kann man das im Hintergrund durchführen, oder zur gänze Abstellen.

Ein Umwandeln oder auch Reenkodieren genannt dauert seine Zeit, zumindest wenn man die voreingestellten Werte verwendet. 

Share this post


Link to post
Christian Schwarzer
Am 4.5.2018 um 23:20 schrieb aet:

Bei der Version 1.0.4 ist die Funktion vorheriger Frame mit nächster Frame identisch.

Ja springt auch vorwärts wenn man vorheriger Frame drückt. Der Bug macht diese Version eigentlich unbrauchbar und sollte schnell gefixt werden.

 

Share this post


Link to post
hackbart

Naja, jein - das passiert nur, wenn man die Indizierung nicht nutzt. Ich werde heute Abend ein Update veröffentlichen mit einer aktuellen Version der Trim-Engine. 

Share this post


Link to post
hackbart

Ich sitze derzeit noch am Feintuning, da ich vorgestern ein neues Build des SDK's von Solveig bekommen habe. AAC LATM geht jetzt ohne Umwege über ffmpeg nativ. Aktuell probiere ich die ganzen Streams, welche in den letzten Wochen zur Verfügung gestellt wurden. Oh und defekte Indexdateien werden jetzt korrekt erkannt und ignoriert. Dadurch kann ich zumindest sicherstellen dass die Indizierung erfolgreich war. Es gab den ein oder anderen Nutzer der über mehr als 10 Stunden Aufnahmen schneiden wollte und bei dem die Indexdatei wohl nicht korrekt erstellt wurde. 

Share this post


Link to post
satorber

Hallo Bernd,

wie sieht es mit "mp4 - Schneiden" aus. Ist das in Planung ?

Das Meiste was aus den Mediatheken kommt, ist mp4.

Danke und lG Dieter

Share this post


Link to post
hackbart

Prinzipiell kann man die MP4 Dateien mit dem Konsolentool schneiden, wobei die MP4 Aufnahmen eigentlich ja schon seitens der Anbieter geschnitten sind. Ich habe zwar geplant später auch den Editor zu erweitern, dass man andere Formate bearbeiten kann, aber aktuell beschränkt es sich auf das was der DVBViewer aufzeichnet. Ehrlich gesagt ist das auch eher das war 98% der Nutzer brauchen.

Share this post


Link to post
Steffen Kreutz

Hallo Christian,

mit Version 1.0.5.0 des Videoeditors sehe ich schon mal den Zeitindex, den du wie geschrieben wegen der Tests ausgeknipst hast.
Auch wenn es vielleicht hier nicht reingehört, aber vielleicht kann mir trotzdem jemand helfen?
Der DVBViewer V6.1.0 und Mediaserver V2.1.0 ignorieren bei mir die Einstellung nur ac3/mp2 für TV und die Aufnahmen werden immer als ts gespeichert. Hab ich irgendwas übersehen?

Schon mal danke für eure Hilfe.

Steffen

Share this post


Link to post
Griga
13 minutes ago, Steffen Kreutz said:

Der DVBViewer V6.1.0 und Mediaserver V2.1.0 ignorieren bei mir die Einstellung nur ac3/mp2 für TV und die Aufnahmen werden immer als ts gespeichert. Hab ich irgendwas übersehen?

 

Media Server auf das heute erschienene Bugfix Release 2.1.1 aktualisieren.

Share this post


Link to post
Steffen Kreutz

Ah! Herzlichen Dank Griga. So einfach kann die Lösung sein. :-)

Share this post


Link to post
Webturtle

Hallo,

 

ich habe die Version 1.0.5. installiert und dabei alle Kästchen aktiviert gelassen. Da keine Internetverbindung bestand mußte ich das Herunterladen natürlich übergehen. Ich habe aber bereits eine Vorversion mit Herunterladen der zusätzlichen Module (z.B. ffmpeg) installiert. Ich denke diese bleiben bei einem Update erhalten. Falls nicht wäre ich für einen entsprechenden Hinweis dankbar.

 

Also auch mit der neuen Version 1.0.5. war es mir nicht möglich Aufnahmen von ARD DVB-T2 HD Sendern zu öffnen. Es geschah schlichtweg nichts. Ich habe es mit SWR HD und NDR HD probiert. Beim ZDF wurde zwar gleich ein Bild bzw. ein grünes Fenster angezeigt, aber unten fehlte der "Filmstreifen" mit den Szenenbildern, und kurz darauf ist der Rechner (W10 64 mit 64-bit Version des Video-Editors) mit einem Bluescreen abgestürzt. Dies ist bisher bei den Versuchen mit den Vorversionen noch nicht passiert.

 

 

Viele Grüße

 

Webturtle

 

Share this post


Link to post
hackbart

Was für Dekoder sind denn auf dem System installiert? Hier funktionieren alle meine T2 Aufnahmen im Editor. Nutzt du die 32, oder 64bit Version?

Share this post


Link to post
Webturtle

Hallo,

 

es ist ein Lenovo W10 64-bit Rechner mit LAV Filtern. Die betroffenen Aufnahmen - und natürlich alle anderen - lassen sich problemlos mit dem DVBViewer Pro bzw. GE anzeigen, sowohl live als auch die Aufnahmen. Diese lassen sich auch mit dem TS Doctor schneiden oder mit XMedia Recode recodieren.

 

Ich habe bisher die 64bit Version probiert, da es sich um ein 64bit System handelt, kann es aber auch mal mit der 32bit Version versuchen. Dafür würde ich aber gerne wissen, ob ich zur Installation wieder eine Internetverbindung benötige. Die 64bit Version (1.0.3 ?) hatte ich mit Internetverbindung und Download der zusätlichen Softwareelemente (FFMPEG und Comskip) vorgenommen. Bleiben diese bei späteren Installationen nutzbar (hier für die 32bit Version)?

 

Gibt es eigenlich irgendwo eine kurze Benutzungsanleitung? Im Wiki habe ich bei "Alle Seiten" unter Video-Editor nichts gefunden. Jeder Editor ist ja anders zu bedienen. Mal muß man das markieren, was behalten werden soll, also in der geschnittenen Aufnahme zu sehen ist mal ist es umgekehrt. Was bedeutet eigenlich der ovale rote Button unter der Zeitleiste mit der Aufschrift (Cut bzw. ?) ?

 

 

Viele Grüße

 

Webturtle

 

P.S. Vielleicht kann ja einer der mittelweile eingearbeiteten Nutzer zur Entlastung von Christian eine kurz Anleitung (es muß ja keine kurze Geschichte der Zeit werden;))  ins Wiki stellen. Es gibt ja schließlich viele Autoren, die dort schon zum Nutzen aller User tätig geworden sind.

 

Share this post


Link to post
hackbart

Die Dateien kann man aus dem 64Bit Installationspfad kopieren und müssen nicht erneut geladen werden. 

 

Eine Benutzeranleitung habe ich noch nicht erstellt. Die ist noch in Arbeit. 

 

Christian

Share this post


Link to post
Webturtle

Hallo,

 

ich habe gestern die 32bit Version über (?) die 64bit Version installiert, d.h. ich habe wie bei der 64bit Version die Installationsvorgaben verwendet. Mit der 32bit Version werden jetzt auch Aufnahmen von ARD-Sendern geöffnet, auch die Test-Aufnahme von arte, die ich Dir gemailt hatte.

 

Allerdings kann ich mit dem Video-Editor keine geschnittene Aufnahme speichern. Ich habe eine Aufnahme vom ZDF DVB-T2 HD geschnitten, der der Vor- und Nachlauf war abgedunkelt (die Marker sind etwas ungewohnt, denn hier muß man wohl den zu entfernenden Teil markieren, bei andreren Programmen z.T. den zu speichernden). Dann habe ich auf den Speichern-Button (? - ich sitze nicht am DVBViewer-Rechner) geklickt. Der Cut-Button war aktiv (bei der Gelegenheit: was bedeutet die Alternative keep ?). Im gewählten Ausgebeverzeichnis wurde eine Datei Name_cut.ts erstellt. Diese hat aber die Länge Null. Ich wollte als anderes Ausgabeformat mpg wählen, habe aber keine Möglichkeit dafür gefunden. Unter Dateiformat unter dem Namensfeld gibt es als Alternative zu ts nur Alle Dateien.

 

Auch ein zweiter Test mit einer Aufnahme vom DVB-S (wohl MPG in TS-Datei, Standardeinstellung des DVBViewer Pro) führte nur zu einer Datei mit Null-Länge.

 

Kann es sein, daß der Editor beim nächsten Versuch eine Aufnahme-Datei zu öffnen statt des zuletzt verwendeten Aufnahme-Verzeichnisses, das Verzeichnis angezeigt wird, das als Verzeichnis für die Ausgabe-Datei gewählt worden ist? Praktischer wäre es, wenn er sich beide Verzeichnisse merken könnte.

 

Viele Grüße

 

Webturtle

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...