Jump to content

Plötzlich "Fehler beim Tunen" mit Streaming-Device (Enigma2-Box)


buster19

Recommended Posts

Hi @ll,

 

Ich betreibe die Kombi aus DVBViewer, Media-Server, ext. Streaming-Device (Enigma-Box/VU+) sowie ein paar zusätzliche DVBViewer Streaming-Clients.

Das lief wirklich super in den letzten Jahren und ohne nennenswerte Probleme.

 

Seit ein paar Tagen bekomme ich aber sofort die Meldung "Fehler beim Tunen" im DVBViewer, wenn ich auf einen Kanal umschalte das auf mein externes Streaming-Device zeigt.

Das Bild bleibt dunkel. Ich habe auch keine Möglichkeit für mich gefunden, den Kanal dann doch noch ans laufen zu bekommen (z.B. mittels Wiedergabe neu aufbauen)

 

Kopiere ich die Stream-URL aus dem DVBViewer Sender-Editor nach VLC läuft der Stream dort ohne Probleme (selber Rechner).

Eine Stream-URL sieht bei mir z.B. so aus "http://vuuno4kse:8001/1:0:19:87:B:85:FFFF0000:0:0:0:" - vuuno4kse wird auch sauber aufgelöst (hat ja auch immer so funktioniert)

 

Auch wenn ich die Option "Als Datei wiedergeben" im DVBViewer Sender-Editor aktiviere läuft es erstmal wieder - aber das kann ja nicht die finale Lösung sein (Ich habe mich an diesem Thread hier orientiert: https://www.DVBViewer.tv/forum/topic/65212-frage-zu-m3u8/?tab=comments#comment-495724).

 

Ich bin echt ratlos warum mein Setup mit dem ext. Streaming-Device plötzlich nicht mehr funktioniert und hab auch keine Ideen mehr wie ich das wieder "geheilt" bekomme.

Über jeden Tipp wie ich das weiter analysieren oder fixen könnte, wäre ich echt dankbar.

 

 

 

 

support.zip

Link to comment

Die Ursache ist ein Fehler im DVBViewer Media Server 3.1.1. Der DVBViewer delegiert ab Version 7.0.0. den Empfang des VU+-Streams an den DMS auf dem selben PC:

 

On 12/13/2020 at 4:48 PM, hackbart said:

Geändert: Media Server Client: Wenn der DVBViewer als Client eines Media Servers auf dem selben PC konfiguriert ist, delegiert er den Empfang aller TS Stream-Sender (außer denen mit localhost als Quelle) an den Webserver des Media Servers, der den Stream an den DVBViewer weiterleitet. Dies vermeidet eine doppelte Bandbreiten-Belegung, z.B. wenn der selbe Internet TV/Radio-Sender im DVBViewer wiedergegeben und gleichzeitig im Media Server aufgenommen wird. Bitte beachten: Dieses Feature erfordert den DVBViewer Media Server 3.0.0. oder eine spätere Version.

 

Das funktioniert seit dem DMS 3.1.1 nicht mehr (eine nicht erkannte Nebenwirkung der Möglichkeit, im Webinterface bei TV-Wiedergabe Teletext anzuzeigen). Der DMS meldet in dem Fall einen Fehler 404 Not Found, was zu der Anzeige "Fehler beim Tunen" im DVBViewer führt. Ein Work-Around ist, den DVBViewer-Tweak "TS Stream über den lokalen Media Server empfangen" auszuschalten (-> Tweaker.exe starten).

 

Eine Korrektur ist leicht möglich. Ich habe dir per PM eine DMS-Testversion geschickt, mit der der Fehler nicht mehr auftreten sollte. Eventuell gibt es bald ein Hotfix-Release. Aber erst mal abwarten, ob noch mehr Bugs gemeldet werden...

 

Link to comment

Vielen Dank für das schnelle Feedback und das Bereitstellen des Hotfixes.

 

Ergebnis ist leider eher durchwachsen ... ich habe den Hotfix eingespielt und auch auf dem ersten DVBViewer-Client auch wieder ein Bild bekommen. So weit so gut.

Auf dem HTPC (wo der Media-Server und der DVBViewer zusammen laufen) sehe ich leider noch immer das selbe Problem -> "Fehler beim Tunen"

 

Auch in Kombination mit dem Tweak leider keine Verbesserung.

 

Gib es noch irgendwelche weitere Infos/Daten die ich zur Analyse liefern könnte?

 

Nachtrag: In der Kombination Hotfix plus Tweak plus "Wiedergabe neu aufbauen" scheint es nun auch auf dem HTPC zu gehen - Ich teste mal weiter

Edited by buster19
Nachtrag:
Link to comment

 

Nachtrag 2: Am Streaming-Client (DVBViewer) sehe ich nach dem Umschalten (Enigma2-Box) auch erstmal "Fehler beim Tunen", aber auch hier bekomme ich jetzt ein Bild nach "Wiedergabe neu aufbauen", war vor dem Hotfix noch nicht so und ist definitiv schon Mal eine Verbesserung.

Link to comment

Da komme ich nicht mehr mit. Was spielt sich jetzt auf welchem PC ab? Von welchem stammt die letzte support.zip? Hast du in deinem Netzwerk mehr als einen Media Server in Betrieb? Folgendes sollte klar sein:

  • Der Fix und auch der Tweak betreffen nur DVBViewer-Zugriffe auf einen Media Server, der sich auf dem selben PC befindet und als dessen Client der DVBViewer konfiguriert ist (siehe Optionen -> DVBViewer Media Server). In der letzten support.zip ist beides gegeben.
  • Wenn der Tweak "TS Stream über den lokalen Media Server empfangen" ausgeschaltet ist, spielt der Fix im DMS keine Rolle mehr, weil der DVBViewer den VU+-Stream selbst empfängt, d.h. nicht mehr über den DMS bezieht.

Falls es auf einem anderen PC als dem, von dem die letzte support.zip stammt, Probleme gibt,  brauche ich von diesem PC ebenfalls eine support.zip.

 

Link to comment

Ja, sorry - hast Recht. Hab hier einfach mal alles reingeworfen.

 

Ich bleib jetzt einfach mal beim Hauptrechner (HTPC), auf dem laufen der DVBViewer sowie der Media-Server. 

Von diesem PC stammt auch die Support.zip.

 

Folgendes habe ich auf diesem PC (HTPC) gemacht:

1. Hotfix eingespielt - Test -> Kein Bild nach umschalten (Stream von der Enigma2-Box) und Meldung "Fehler beim Tunen"

2. Zusätzlich den Tweak aktiviert - Test -> Kein Bild nach umschalten (Stream von der Enigma2-Box) und Meldung "Fehler beim Tunen"

3. "Wiedergabe neu aufbauen" aufgerufen und ich bekomme ein Bild

 

Nur Hotfix oder nur Tweak haben erstmal nichts gebracht (reproduzierbar) - Nur die Kombi aus den Schritten 1-3 funktionieren für mich.

 

Darüber hinaus habe ich auf einem anderen PC mit DVBViewer beim schnellen Test festgestellt (hängt am selben Media-Server der auf dem HTPC läuft), dass auch hier der Hotfix in Kombination mit "Wiedergabe neu aufbauen" funktioniert.

Link to comment

Hier funktioniert es nach dem Fix problemlos. Ich habe allerdings keine VU+, sondern greife für Tests auf Internet-TV-Streams zu. Bild und Ton sind sofort da, auch nach einer Senderumschaltung. Von daher weiß ich im Moment nicht weiter. Es gibt inzwischen einen weiteren Fall der Art. Mal sehen, wie das ausgeht...

 

Eine neue support.zip nach Reproduktion des Fehlers zeigt vielleicht, woran es nun liegt.

 

Du könntest als Gegentest auch probieren, ob es mit dem DVBViewer 7.1.0 / DMS 3.1.0 geht. Die Installer müssten bei dir noch im DVBViewer-Programmordner\setup liegen. Ansonsten sind sie auch im Mitglieder-(Download-)Bereich unter Older Versions erhältlich.

 

Link to comment

So, habe heute morgen ein paar mehr Test gemacht ..

 

Wie vorgeschlagen habe ich auf dem HTPC nochmal DVBViewer 7.1.0 und den DMS 3.1.0 installiert. Interessanterweise mit dem selben Ergebnis "Fehler beim Tunen".

Bild bekomme ich nachdem ich den Tweak aktiviert habe und "Wiedergabe neu aufbauen" aufrufe. - Ich habe für dieses Setup nochmal eine neue Support.zip erstellt und angehängt.

 

Im Anschluss habe ich wieder DVBViewer 7.1.1 und den DMS 3.1.1 installiert - ohne den Hotfix von gestern.

Es reicht dann tatsächlich aus den Tweak zu aktivieren und "Wiedergabe neu aufbauen" aufzurufen um ein Bild zu bekommen. Meine Aussage von gestern dazu, muss ich deshalb korrigieren (Hotfix wird nicht zusätzlich benötigt).

 

Ich glaube fast mittlerweile es gibt andere, externe Gründe für mein Problem (z.B. MS Update?) - Aber was? Was könnte ich noch testen um das Problem weiter einzukreisen?

Fakt ist das dass Problem erst vor ein paar Tagen begonnen hat und davor hat die Kombi aus DVBViewer 7.1.1 und DMS 3.1.1 funktionierte.

support.zip

Link to comment
Am 3.8.2021 um 18:34 schrieb Griga:

Hier funktioniert es nach dem Fix problemlos. Ich habe allerdings keine VU+, sondern greife für Tests auf Internet-TV-Streams zu. Bild und Ton sind sofort da, auch nach einer Senderumschaltung. Von daher weiß ich im Moment nicht weiter. Es gibt inzwischen einen weiteren Fall der Art. Mal sehen, wie das ausgeht...

 

Jetzt hat es mich auch erwischt. Nach Update des DMS auf 3.1.1.0 und des DVBViewers auf 7.1.1.0 bekomme ich auch "Fehler beim Tunen" bei TS-Streams.

Der Tweak hat das Problem erst mal behoben, aber laut Beschreibung bedeutet das doppelte Übertragung bei Aufnahme und gleichzeitiger Wiedergabe.

 

Wird der DMS Patch 3.1.1.1 allgemein verfügbar?

Link to comment
51 minutes ago, botti 56 said:

Wird der DMS Patch 3.1.1.1 allgemein verfügbar?

 

Vor einem offiziellen Bugfix-Release möchte ich noch etwas warten, was sonst alles gemeldet wird. Ich habe dich aber in eine PM-Konversation aufgenommen, in der du eine Testvesrion mit dem Fix herunterladen kannst.

 

Link to comment
On 8/4/2021 at 8:14 AM, buster19 said:

Ich glaube fast mittlerweile es gibt andere, externe Gründe für mein Problem (z.B. MS Update?)

 

Sorry, deinen letzten Post vor 6 Tagen habe ich glatt übersehen. Besteht das Problem noch in der beschriebenen Form? Ein Blick in das DVBViewer.log aus deiner support.zip zeigt, dass schlicht keine Antwort vom DMS kommt:

 

Quote

THTTPStream          Getting the response header failed. Bytes read 0

 

Warum, ist dem Log aber nicht zu entnehmen. Mein Verdacht wäre erst mal, dass es an der Portnummer 8000 liegt. Warum hast du den Webserver-Port des DMS (Standard 8089) geändert?

 

Ich habe dich ebenfalls in die aktuelle PM-Konversation für den Media Server-Fix aufgenommen.

 

Link to comment
vor 43 Minuten schrieb Griga:

Vor einem offiziellen Bugfix-Release möchte ich noch etwas warten, was sonst alles gemeldet wird. Ich habe dich aber in eine PM-Konversation aufgenommen, in der du eine Testvesrion mit dem Fix herunterladen kannst.

Danke. Ich habe den Patch jetzt aktiviert und den Tweak wieder rückgängig gemacht.

Funktioniert soweit - ohne negativen Effekte.

Link to comment
vor 12 Stunden schrieb Griga:

 

Sorry, deinen letzten Post vor 6 Tagen habe ich glatt übersehen. Besteht das Problem noch in der beschriebenen Form? Ein Blick in das DVBViewer.log aus deiner support.zip zeigt, dass schlicht keine Antwort vom DMS kommt:

 

 

Warum, ist dem Log aber nicht zu entnehmen. Mein Verdacht wäre erst mal, dass es an der Portnummer 8000 liegt. Warum hast du den Webserver-Port des DMS (Standard 8089) geändert?

 

Ich habe dich ebenfalls in die aktuelle PM-Konversation für den Media Server-Fix aufgenommen.

 

 

Ja, leider ist die Situation unverändert - aktuell lebe ich mit dem Workaround "Wiedergabe neu aufbauen"

Dieser Workaround funktioniert allerdings nur wenn auch der Tweak aktiviert ist (bzw. ausgeschaltet ist) - Den Hotfix verwende ich aktuell nicht.

 

"Gefühlt" scheint es so zu sein das beim Umschalten auf einen Streaming-Kanal (via http-Connect zur VU+ Box) der DVBViewer erstmal in ein Timeout läuft. Nach dem wiederaufbauen der Wiedergabe geht's dann aber. 

 

Als Ursache würde ich mittlerweile den DMS/DVBViewer fast ausschließen und vermute andere, externe Gründe. 

 

Port 8000 verwende ich seit Jahren ohne Probleme, warum genau weiß ich auch nicht mehr ? Ich werde das aber gleich mal auf 8089 zurück ändern und testen.

Link to comment
1 hour ago, buster19 said:

"Gefühlt" scheint es so zu sein das beim Umschalten auf einen Streaming-Kanal (via http-Connect zur VU+ Box) der DVBViewer erstmal in ein Timeout läuft.

 

Du kannst das Timeout verändern, indem du unter Optionen -> Hardware ein TS Stream-Device hinzufügst und dann in dessen Einstellungen das Verbindungs-Timeout hochsetzt (gleiches gilt für den Media Server). Wenn du zwei oder mehr Streams gleichzeitig empfängst, braucht es eine entsprechende Anzahl entsprechend konfigurierter TS Stream-Geräte.

 

Allerdings ist es sonderbar, dass eine Verbindung über localhost ein derart hohes Timeout benötigt. Wenn es daran liegt, musst du mit der Einstellung wahrscheinlich beim Media Server ansetzen.

 

Link to comment
vor 2 Stunden schrieb Griga:

 

Du kannst das Timeout verändern, indem du unter Optionen -> Hardware ein TS Stream-Device hinzufügst und dann in dessen Einstellungen das Verbindungs-Timeout hochsetzt

 

 

Im DMS habe ich bereits ein TS Stream-Device konfiguriert (mit 5 sek. Timeout) - Du räts mir aber jetzt auch im DVBViewer ein TS Stream-Device einzurichten, richtig?

Werde ich testen. Bei der Gelegenheit ... was bedeutet das Feld "In URL ersetzen", was trägt man hier ein (hab nix dazu gefunden)?

 

vor 2 Stunden schrieb Griga:

Allerdings ist es sonderbar, dass eine Verbindung über localhost ein derart hohes Timeout benötigt. Wenn es daran liegt, musst du mit der Einstellung wahrscheinlich beim Media Server ansetzen.

 

Zum Verständnis: Wenn ich den DVBViewer-Tweak "TS Stream über den lokalen Media Server empfangen" ausschalte, verbindet sicher der Viewer ja nicht über localhost (DMS), sondern direkt mit dem Streaming-Device - also z.B. direkt hierhin "http://vuuno4kse:8001/1:0:19:87:B:85:FFFF0000:0:0:0:"

Link to comment
4 hours ago, buster19 said:

Du räts mir aber jetzt auch im DVBViewer ein TS Stream-Device einzurichten, richtig?

 

Würde ich probieren. Wenn der DMS mehr als 5 Sekunden auf den VU+ wartet, muss der DVBViewerauch mehr als 5 Sekunden auf den DMS warten. Grundsätzlich würde ich mir aber Gedanken darum machen, warum das überhaupt so lange dauert.

 

4 hours ago, buster19 said:

was bedeutet das Feld "In URL ersetzen"

 

Im DVBViewer -> Hilfe -> Versionshinweise -> Mit der Browser-Suchfunktion (Strg+F) danach suchen. Für "TS Stream über den lokalen Media Server empfangen" ebenso.

 

 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...