Jump to content

DVBViewer schliesst sich einfach, ohne Fehlermeldung


Jackie78

Recommended Posts

Die Vermutung geht in die richtige Richtung.

Nach dutzenden von versch. Konfig-Tests bin ich inzw. bei Problemen im Timing der Graka gelandet.

 

Ich konnte allerdings noch nicht genau einkreisen wo das Problem genau liegt. Entweder sinds die Speichertimings oder Port/Bios Probleme.

 

Was ich inzw. zumindest für meine Seite ausschließe ist der DVBV-Core und die Codecs. Hier kann durch die Bank und alle Versionen das Verhalten reproduziert werden.

 

Ich bin inzw. soweit die Kiste auf ´nen Meßplatz zu schaffen und mal die Hardwareseite durch zuchecken.

 

Gruß

Pinbot

Link to post
  • Replies 130
  • Created
  • Last Reply

Top Posters In This Topic

  • Tüftler

    29

  • Jackie78

    24

  • okmikel

    14

  • morphus

    14

Könnte mal jemand mit diesen Problemen testen ob es bei 1024x768er Auflösung auch passiert?

Ich kann ja durch meinen verwendeten VGA-Converter nicht höher gehen.

Im Bios hab ich der Graka übrigens 512MB zugewiesen. CCC ist 8.6 und VectorAdaptives Deinterlacing ist auch auswählbar.

Habe aber die Einstellung auf >Automatisches Deinterlacing< stehen, machte aber bei einem Test auch keinen Unterschied.

Ansonsten definitiv keinerlei Abstürze mehr. o:)

Link to post

Ich hab inzw. 3 Testrechner hier laufen und einer steht auf dem Messplatz in der Firma...

Leider bisher ohne konkretes Ergebniss...

 

Ich werd mal einen auf 1024 umstellen mal sehen was passiert...

 

Der Gag an der Geschichte ist, dass weder XP noch der Viewer ungewöhnliche Zustände melden. Es sieht fast so aus als sei alles komplett normal.

 

Weitere Beobachtung: selbst ohne jegliche Beeinflussung von aussen (Netzwerk, Mon, Tastatur/FB eingaben) schmiert der Viewer ab.

 

Es gibt fast nichts mehr was ich noch testen könnte....

 

Gruß

Pinbot

Link to post
Der Gag an der Geschichte ist, dass weder XP noch der Viewer ungewöhnliche Zustände melden. Es sieht fast so aus als sei alles komplett normal.

 

Weitere Beobachtung: selbst ohne jegliche Beeinflussung von aussen (Netzwerk, Mon, Tastatur/FB eingaben) schmiert der Viewer ab.

 

Genau das macht mich schier wahnsinnig: XP läuft weiter, das System verhält sich als könne es kein Wässerchen trüben, alles scheint okay. Und man hat als Benutzer keinen Anhaltspunkt, kein Logfile zum Auswerten, es ist wie verhext. Könnte eine Debug-Version des DDVBViewers mehr Informationen liefern?

 

Was bewirkt eigentlich das Hochsetzen des Debuglevels vom OD (Standardwert 50)?

Link to post

Bei mir war es so, das nach dem Abschmieren ins Windows der Viewer nicht mehr gestartet werden konnte.

Ich musste dann entweder auf Abmelden oder Neustart, beides jeweils 2x (also Abmelden--> nichts passierte -->Abmelden dann wurde Abgemeldet!)

Das waren die einzigen Beobachtungen die ich hatte. o:)

Link to post

Hi,

 

Die Beobachtung von @Tüftler kann ich nicht bestätigen.

 

Bei mir ist es so wie bei @Jackie78 und @pinbot, alles läuft normal weiter, Viewer kann wieder ganz normal gestartet werden, nirgends irgendeine Fehlermeldung zu finden.

 

Macht einen wirklich fast wahnsinnig so was, wenn man überhaut keinen Punkt hat, wo man den Hebel ansetzen könnte ...

 

Gruß

Mikel

Edited by okmikel
Link to post
Bei mir war es so, das nach dem Abschmieren ins Windows der Viewer nicht mehr gestartet werden konnte.

Ich musste dann entweder auf Abmelden oder Neustart, beides jeweils 2x (also Abmelden--> nichts passierte -->Abmelden dann wurde Abgemeldet!)

Das waren die einzigen Beobachtungen die ich hatte. o:)

jep, dieses Problem habe ich auch gelegentlich beobachtet, allerdings dem Umstand zugeschrieben, dass ich die Tests teilweise auf virtuellen Maschinen laufen habe.

Allerdings hat mich auch da stuzig gemacht, dass das eigentliche Event "Abmelden/Runterfahren" nicht im Eventlog auftaucht..... hmmm eine mögliche Fehlerquelle mehr:Wo bleiben die fehlenden Eingaben bzw. wo kommen die Geisterbefehle her?

 

Gruß

Pinbot

Edited by pinbot
Link to post

Dass der DVBViewer kommentarlos beendet wird, habe ich auch schon erlebt - in einem Fall reproduzierbar und mit bekannter Ursache. Es handelte sich um einen selbstgemachten Bug, der zu einem Stack-Overflow führte. Der Stack ist ein Speicherbereiich, in dem Rückprungadressen, lokale Variablen und ähnliches "gestapelt" werden. Konkret war es eine Prozedur, die sich in einer Endlosschleife immer wieder selbst aufrief, und so den Stack in Windeseile mit Rücksprungadressen zu sich selbst füllte.

 

Offenbar zieht Windows in Fällen, in denen sich ein Prozess arg danebenbenimmt und die Systemstabilität gefährdet, eine Art Notbremse, d.h. schießt das Programm einfach ab. Warum in diesem Fall keine Meldung wie "DVBViewer hat ein Problem festgestellt und muss beendet werden" erfolgt, weiß ich auch nicht.

 

Zu berücksichtigen ist dabei, dass Windows alle Komponenten (DirectShow-Filter, Plugins, System-DLLs usw.), die innerhalb des Prozesses laufen, dem DVBViewer zurechnet. Das Problem entsteht also nicht zwangsläufig im DVBViewer-Code.

 

Dass sich der DVBViewer nach einem solch gewaltsamen Abbruch nicht mehr starten lässt, liegt an der Instanzen-Verwaltung. Jede laufende DVBViewer-Instanz trägt sich in einem "globalen" Shared Memory-Bereich als aktiv ein, mitsamt ein paar Informationen darüber, welche DVB-Hardware zur Zeit belegt ist und welcher Konfigurationsordner benutzt wird. Dieser Speicherbereich ist allen DVBViewer-Prozessen zugänglich - unter XP sogar über Benutzerkontogrenzen hinweg, Vista erlaubt das jedoch nicht mehr.

 

Beim Start überprüft der DVBViewer, ob bereits eine Instanz läuft, die auf den selben Konfigurationsordner zugreift. Falls ja, übergibt sie eventuelle Kommandoparameter an die bereits laufende Instanz und beendet sich sofort wieder, um Konflikten beim Zugriff auf die Setup.xml, channels.dat, epg.dat usw. vorzubeugen. Mehr dazu hier.

 

Bei einem kommentarlosen gewaltsamen Abbruch bleibt dieser Eintrag im Shared Memory-Bereich offenbar bestehen, worauf der DVBViewer bei einem nachfolgenden Neustart zu der Überzeugung gelangt, er liefe bereits mit identischer Konfiguration, und sich deshalb umgehend beendet. Erst ein Neustart des PC räumt das ab.

Link to post

In die Richtung habe ich ansatzweise auch schon gedacht.

Allerdings treten die Abbrüche auch auf einem völlig nacktem System auf.

Eine meiner VM ist so konfiguriert, dass nur XP Coreprozesse und die wesentlichen Elemente wie Graka und Soundtreiber laufen alles andere inkl. Treibershells und Codecs ist draußen.(codecs nur minmalst notwendige).

 

Selbst das Teil bockt. somit kommt der Fehler entweder aus dem Viewer selbst oder über XP.

 

Was die Hardware betrifft weiß ich morgen mehr. Z.Zt. steht ´ne zu meinem HHTPC identische Maschine auf einem Hardwaremessplatz im 24 Std. Stresstest.

 

Gruß

Pinbot

Link to post

Hi,

 

habt ihr inzwischen Neuigkeiten? Für mich ist dr DVBViewer unter XP gerade ideal eingerichtet,e s tut alles wie ich will,w enn nur diese ständigen meldungslosen Abstürze nicht wären. Ich habe das Gefühl, dass es frisch aus dem Standby öfter auftritt als nach komplettem Neustart.

 

Was ich definitiv sagen kann, es tritt immer unmittelbar nach einer eingabe mit der Fernbedienung (ich verwende nur die FB zum Steuern des Viewers) auf, meistens natürlich beim Klick auf "OK", Plopp weg ist er. Ich frage mich daher, ob man nicht eine Version des Viewers erstellen könnte zum Testen, der wirklich alles, was er macht, jede Methode die aufgerufen wird, protokolliert, so dass man wenigstens mal weiss, welcher Aufruf das Problem verursacht. Wie gesagt, ich schliesse diverse Codecs aus, habe ebenfalls ein nacktes XP System aufgesetzt, es kann also nur noch an irgendeinem Treiber, an Windows oder am DVBViewer selbst liegen.

 

Gäbe es Alternativen zum DVBViewer, wäre ich längst umgestiegen, leider funktionieren die anderen am Markt erhältlichen Lösungen generell nicht gut, oder bieten keine vergleichbaren Features. ;)

Link to post

Hast du mal meine 1024x768er Auflösung getestet?

Habe null Abstürze, und wenn dies bei dir auch funktionieren sollte dann ist es entweder das CCC oder die Graka (Onboard) die dass auslöst.

Link to post

Weitere Erkenntnisse:

Wenn die Einstellung >Ansicht >Immer im Vordergrund< abgehakt wird, kommt es bei DVD Wiedergabe zum Sofortabsturz und bei Video Wiedergabe, über OSD angewählt, wenn Datei gestartet wird ebenfalls.

 

Ist >Immer im Vordergrund< nicht abgehakt, dann läuft alles Problemlos bei mir.

 

Könnt ihr dieses Verhalten bestätigen? Evtl auch nur bei 1024x768er Auflösung?

Link to post

Da ich heute viel zu tun hatte nur ein kurzer Zwischenbericht.

Tiefere Hardwareprobleme (Timing,Ports) kann ich weitgehends ausschließen. Wir haben div. Test gemacht, keine Auffälligkeiten.

 

Es gibt allerdings eine Spur: ImonPad

 

Drauf gebracht hat mich Griga. Wie es aussieht, neigt die FB zum Prellen. D.h. es werden bei einem Tastendruck unkontrolliert mehrer Ereignisse ausgelöst.

 

Ich hab jetz das Teil im Testplatz und maltretiere es. Was ich vermute ist das durch die unkontrollierte Impulsfolge irgendwie auch mal der "close" Befehl ausgelöst wird oder das schlicht die Imonsoft ´n Überlauf provoziert indem sie die Eingabeverarbeitung des DVBV überflutet.

 

Mal gucken ob´s die Richtige Spur war...

 

Gruß

Pinbot

Link to post
user456732

Hallo @all,

 

wollte hier nur mal kurz anzeigen, das es bei mir das gleiche ist.... denke auch nach dem standby tritt es häufiger, will sogar sagen nur auf. nach einem neustart habe ich dieses problem noch nicht gehabt. bei mir power sconi empfänger mit harmony 885, was es was nützt dies zu wissen.

wünsche allen hier ein schönes wochenende.

 

gruß der user

Link to post

Hi,

 

also zur Fernbedienung: ich verwende die FB meiner Hauppauge Nova HD S2 Karte, mit irremote.ini im Windows-Verzeichnis. Ich hatte auch schon in diese Richtung gedacht, aber was mich davon wegkommen ließ ist die Tatsache, dass der DVBViewer beim regulären Beenden seinen letzten Status (eingestellter Sender, etc.) noch weiss, nach einem unkontrollierten Beenden jedoch komplett vergessen hat. Es müsste also einen "geheimen" Befehl auslösen zum Sofort-Beenden ohne irgendwas zu speichern.

 

Und ich hatte das Problem auch schon nach einem kompletten Neustart, es tritt zwar gefühlt nach dem Standby häufiger auf, aber definitiv auch nach komplettem Neustart, zumindest bei mir.

 

Gestern Abend habe ich mal ein paar Stunden lang den Filemon im Hintergrund mitlaufen lassen, komischerweise trat da gar kein Absturz auf. Ich vermute immer mehr, dass es eben doch irgendeine Art von Timingproblem ist, denn warum sonst sollte ein und dieselbe Aktion mal klappen, und mal zum Absturz führen?

 

Außerdem habe ich über Nacht nochmal den memtest86 durchlaufen lassen, bisher keine Auffälligkeiten, ich lasse ihn mal noch ein paar Stunden weiterlaufen. Aber mit defektem Speicher rechne ich auch nicht, da alles andere PRoblemlos läuft.

Link to post

So, habe gestern noch weiter getestet und kann nur vollgendes sagen:

 

Die PDVD7.3 Version läuft vollkommen zuverlässig.

Die PDVD8 Version kann man mit der Einstellung >Immer im Vordergrund< zum Absturz bringen.

Am meisten trat das bei kurzen Wechseln zwischen Bspw TV und DVD auf oder auch DVD starten und gleich wieder Beenden.

Hier würde evtl. eine Verzögerung für den erneuten Graph Aufbau was bringen.

 

Auffällig war, das bei Deinstallation der 7.3er Version danach die 8ter fast garnicht mehr zuverlässig läuft.

Ich hatte auch eine Fehlermeldung beim Neustart von Windows (irgendeine Verknüpfung fehle> konnte aber Aufgrund des langen Dateizweiges nicht nachvollziehen welche).

Werden solche Fehlermeldungen Irgendwo eingetragen (Windows XP) und wenn ja wo?

 

Hab dann die 7er wieder installiert, dann sind Abstürze in der 8ter seltener, warum auch immer. (Nirgendwo is dabei die 7er als Renderer ausgewählt!)

Um die ImonSoftware auszuschließen werde ich alle Befehle mal nur über die Tastatur schicken (wobei dabei ja nur der IR-Empfänger ausgeschlossen werden kann).

Evtl. lässt sich dann was über die Tastaturverzögerung im ImonManager machen.

Link to post

Den IR-Empfänger kann ich ausschließen, da es bei reinen Tastatureingaben auch passiert.

Auch eine Annahmeverzögerung im Imon Manager bringt da keine Abhilfe.

 

Ein Absturz ins Windows habe ich immer nach 3maliger DVD-Wiedergabe oder Video-Wiedergabe (DVD starten > Stop, DVD starten > Stop, DVD starten ->Absturz; selbes Prozedere mit Video über OSD angewählt!)

 

PS: Nach einem Absturz muss man unbedingt Neu Starten, ein Ab- und Anmelden reicht nicht, da offensichtlich Irgendwas im Windows abgeschossen und nach Neuanmeldung nicht mit Initialisiert wird.

Dies hat bei DVD Starten einen Sofort-Absturz zur Folge.

 

Jetzt werde ich wohl den 7.3er auf Systemstabilität testen.

Link to post

Der 7.3er funktioniert bei DVD-Wiedergabe garnicht ->System friert ein und kann auch über den Taskmanager nicht reaktiviert werden. Allerdings hab ich noch nicht gepatcht. Werde ich heute abend mal machen.

 

Zum 8ter mit letztem Patch kann ich folgende Tipps geben:

 

Optionen >DirectX >Audioformat Automatisch erkennen und Videoformat Automatisch erkennen (beides nicht aktiviert) hat zur folge, das bei DVD Stop im TV kein Bild angezeigt wird. Muss erst neu aufgebaut werden.

 

Optionen >DirectX >Audioformat Automatisch erkennen und Videoformat Automatisch erkennen (einzeln Audio oder Video aktiviert) hat zur folge, das bei DVD Wiedergabe das System ins Windows abstürzt.

 

Optionen >DirectX >Audioformat Automatisch erkennen und Videoformat Automatisch erkennen (beides aktiviert) hat zur folge, das erst nach mehrmaligen Stop (wie oben Beschrieben) das System ins Windows abstürzt. (zur Zeit für mich die beste Auswahlmöglichkeit) ;)

Edited by Tüftler
Link to post

So, da bin ich mal wieder.

Einige werden wohl bald denken das ich gerne Threads für mich selber poste, scheint keiner außer mir mehr was beitragen zu können/wollen.

Aber so ist das nun manchmal und mich kotzt dieser Fehler echt an.

Seit Wochen versuche ich meiner Frau den HTPC schmackhaft zu machen und bei jedem Absturz kommen schnippische Bemerkungen.

 

Langsam aber sicher bin ich dem Fehler aber auf der Spur.

Meine weiteren Erkenntnisse:

 

Das OSD ist nicht ganz Unschuldig an den Abstürzen. Das hat aber damit zutun wie, sagen wir mal, Hardwarehungrig in Sachen Graka-Ram dieses ist. (auch die Auflösung wird hier eine Rolle Spielen)

 

Wenn man Bspw den default-Skin von Rago benutzt, stürzt der Viewer nach nur 2 Video-Wiedergaben ab.

Das dieser recht Hardwarehungrig ist, kann man an nicht so schnellen Menüwechseln sehr gut beobachten.

Mit dem concinnity 3d schafft man immerhin 3 bis 5 Video-Wiedergaben.

Auch hat beim 780G die shared-Ram größe einen Einfluss darauf.

128MB führen zum Sofort-Absturz bei der Wiedergabe, 256MB gehen am zuverlässigsten und 512MB machen nahezu keinen Unterschied zu 256MB, wobei Rago's Skin mit 512 nicht so recht will. (Auch Sofortabsturz)

Mit der Autoeinstellung im BIOS werden 256MB zugewiesen, machte bei mir dann aber mit dem Ruhezustand teilweise Probleme (Ram-Inhalt wird ja auf Festplatte geschrieben).

 

Meine Schlussfolgerung -->Speicherüberlauf durch Overlay bzw. der Ram wird nicht schnellgenug geleert.

Wenn jemand ein Programm kennt womit man das Prüfen könnte wären wir wieder einen Schritt weiter.

 

Also meine Empfehlung zur Zeit (mit den anderen Tipps von weiter oben): BIOS shared Ram auf 256MB (fest) und den concinnity 3d oder einen ähnlich weniger Hardwarelastigen OSD-Skin.

 

So und nun Gute Nacht. :wacko:

Link to post

Hi Tüftler.

 

also ich bin auf jeden Fall auch noch an der Sache dran, habe nur leider gestern nichts neues mehr rausgefunden. So langsam glaube ich, wir sollten den Entwicklern ein 780G Board zum Testen besorgen, mein HTPC wäre quasi perfekt, wenn dieses ******** Problem nicht wäre.

 

Nicht verzagen, ich teste auf jeden Fall weiter, wenn sich neue Erkenntnisse ergeben, melde ich mich natürlich.

Link to post
Optionen >DirectX >Audioformat Automatisch erkennen und Videoformat Automatisch erkennen (beides nicht aktiviert) hat zur folge, das bei DVD Stop im TV kein Bild angezeigt wird. Muss erst neu aufgebaut werden.

 

Also das kann ich bestätigen. Es tritt bei mir immer auf, wenn von der DVD-Wiedergabe zur TV-Wiedergabe gewechselt wird. Egal ob mit Stop oder letzten Kanal, oder direkter Anwahl, egal welcher Sender. Und es tritt bei allen Decoder-kombinationen und Renderern für TV und DVD, die ich getestet habe, auf. Die DVB-Hardware wird korrekt initialisiert (man kann trotz schwarzen Bild normal aufnehmen), der Wiedergabegraph ist aufgebaut (soweit ich das beurteilen kann), nur DVBSource befindet sich im Stopzustand. Sieht man auf der Eigenschaftsseite von DVBSource.

Das gleiche Bild wie nach dem Eingabebefehl: Stop Renderer 8256 .

Den gestoppten Wiedergabegraph bekommt man beim DVBViewer Pro bei der TV-Wiedergabe indirekt wieder zum laufen (Play funktioniert nicht) : Timeshift an, Play drücken, Timeshift aus. Und die Wiedergabe läuft. (nur als Test)

 

Aktiviere ich Audioformat... und/oder Videoformat automatisch erkennen, tritt das Problem nicht mehr auf.

Abstürzen tut der DVBViewer dann aber nicht bei mir. Das ist eventuell ein anderes Problem (ATI-typisch? ,hab ne Nvidia)

 

Kann das noch jemand bestätigen?

 

Schönen Sonntag noch, gwr.

Edited by gwr
Link to post
Kann das noch jemand bestätigen?

Ja, für den DVBViewer Pro 3.9.4.

 

Sieht so aus, als ob eine Stop-Message aus dem DVD-Graph verspätet eintrudelt, nämlich kurz nachdem die TV-Wiedergabe gestartet wurde, und die Sache wieder anhält, ohne dass der DVBViewer dies richtig zuordnet. "Videoformat automatisch erkennen" sorgt dann für die nötige Verzögerung, um das Ereignis vor dem Start der TV-Wiedergabe stattfinden zu lassen.

 

Den gestoppten Wiedergabegraph bekommt man beim DVBViewer Pro bei der TV-Wiedergabe indirekt wieder zum laufen (Play funktioniert nicht)

Damit rächt sich in gewisser Weise, dass es einen Stop des Live-TV-Wiedergabe-Graphen nach Willen des Programmierers eigentlich gar nicht geben darf. :wacko:

Link to post

@ pinbot

 

also das problem, dass die fb auf einmal spinnt und hin und her befehle gedrückt eingibt passiert mir auch in einigen abständen, ich muß kompl. den pc neustarten, weil DVBViewer neustart nützt nicht, also ist es vista problem, oder hat da schon eine lösung??

 

benutze von origen s16t die philips fb (halt mce fb) und als plugin mcr2005!

Link to post

Ich habe übrigens seit gestern eine Radeon HD 4850 in meinem PC, seitdem kein einziges Beenden mehr. Nur zur Info, es liegt also wohl irgendwie an der Kombination 780G onboard-Grafik + DVBViewer.

Link to post
user456732

hallo @all,

 

meine austattund siehe sig. bei mir das gleiche problem. viewer beendet sich einfach selbst. kann ihn dann auch nicht mehr starten. muß den rechner neu starten. ich sehe beim beenden dann den desktop. der tasksheduler sagt mir aber das der viewer noch läuft. glube daher das es nicht unbedingt am board liegt.

gruß der user

Link to post

Moin,

 

ich hatte diese Woche jetzt noch mal etwas Zeit zu probieren, da sind mir noch ein paar Kleinigkeiten aufgefallen, die evtl. bei der Fehlersuche helfen:

 

1. Ich hatte mir diese Woche 2 Grafikkarten zum Rumprobieren ausgeliehen, eine HD3450 und eine HD3650 mit jeweils 512MB. Mit diesen Karten tritt der hier beschriebene Fehler genauso auf. Ich habe das ganze mit Catalyst 8.4, 8.6 und 8.7 probiert. Also scheint es nicht am Onboard HD3200 zu liegen.

 

2. Ich habe festgestellt, dass wenn man das

-c

schaltet den DVBViewer beim Start oder im laufenden Betrieb in seinen Standby-Modus, in dem kein Sender empfangen und praktisch keine Prozessorleistung ver­braucht wird. Trotzdem kann der DVBViewer anliegende Timeraufnahmen starten und schaltet dafür automatisch den betreffenden Sender ein. Deshalb ist dieser Modus bestens geeignet, um das Programm im Hintergrund auf den Beginn einer Sendung warten zu lassen. Beispiel:

 

C:\Programme\DVBViewer Pro\DVBViewer.exe -c

macht, der Viewer auch bei ca. einem von 10 Versuchen sich einfach beendet (gleiches Verhalten wie weiter oben von vielen beschrieben für Dateiwiedergabe, beendet sich einfach ohne Fehlermeldung). Vielleicht kann man dadurch die Funktion im Quellcode eingrenzen, die dafür verantwortlich ist (IMHO müsste man evtl. nur mal schauen, welche Funtionsaufrufe beim "-c" und der Dateiwiedergabestart die gleichen sind und man hat das ganze weiter eingegrenzt, welche Funktion verantwortlich ist).

 

Gruß

Mikel

Link to post

Dies mit "-c" kann ich so bestätigen. Bringt keine Verbesserung.

Das OSD kann man auch ausschließen, da ich es gestern abgeschaltet hatte und trotzdem die Abstürze bei Dateiwiedergabe auftreten.

Werde heute Abend mal die TV-Karte deaktivieren, damit sich nach der DVD/Dateiwiedergabe kein Graph aufbaut, und dann das Verhalten prüfen. ;)

Link to post

Hallo miteinander!

 

Ich habe bei mir eine MSI Nvidia 8600GT drin.

Scheint wohl ein ATI problem zu sein. Habe alles versucht nachzuvollziehen.

Ein Absturz gab es bei mir nie.

Versucht doch mal die Umschaltverzögerung etwas hoch zu nehmen.

Die Standartwerte verursachten bei mir am Anfang Abstürze.

Optionen-->TV+Radio

Hilft vielleicht?

 

Wüsch euch viel Erfolg!!!

Link to post

Hi,

 

mit

C:\Programme\DVBViewer Pro\DVBViewer.exe -c

meinte ich, dass der Viewer schon dann sporadisch abschmiert, wenn man den Befehl ausführt, man braucht gar nix weiter zu machen. Allein der Befehl reicht aus, wenn man den ausführt, wenn der Viewer schon läuft. Kam vielleicht nicht ganz deutlich rüber.

 

Es scheint also mehr ein Problem zu sein, wenn die Grafikausgabe abgeschaltet wird, das wollte ich damit sagen.

 

Gruß

Mikel

Link to post
Hallo miteinander!

 

Ich habe bei mir eine MSI Nvidia 8600GT drin.

Scheint wohl ein ATI problem zu sein. Habe alles versucht nachzuvollziehen.

Ein Absturz gab es bei mir nie.

Versucht doch mal die Umschaltverzögerung etwas hoch zu nehmen.

Die Standartwerte verursachten bei mir am Anfang Abstürze.

Optionen-->TV+Radio

Hilft vielleicht?

 

Wüsch euch viel Erfolg!!!

Ich denke das sollte eigentlich auf die DVD/Dateiwiedergabe keinen Einfluss haben.

Siehe Optionen>TV+Radio >ganz oben

"Hier wird das Verhalten des DVBViewers bei einem Senderwechsel eingestellt. Die Schaltverzögerung ermöglicht es, mehrere Sender weiterzuschalten, bevor der DVBViewer reagiert."

Werde das trotzdem testen, danke.

 

Auf dem Arbeitsrechner XP/SP2, mit einer ATI X300/X550 (128 MB RAM), Catalyst 8.4 und logischerweise ohne TV-Karte, gibt es jedenfalls keine Abstürze.

Edited by Tüftler
Link to post
Hi,

 

mit

C:\Programme\DVBViewer Pro\DVBViewer.exe -c

 

meinte ich, dass der Viewer schon dann sporadisch abschmiert, wenn man den Befehl ausführt, man braucht gar nix weiter zu machen. Allein der Befehl reicht aus, wenn man den ausführt, wenn der Viewer schon läuft. Kam vielleicht nicht ganz deutlich rüber.

 

Es scheint also mehr ein Problem zu sein, wenn die Grafikausgabe abgeschaltet wird, das wollte ich damit sagen.

 

Gruß

Mikel

Habe den DVBViewer mit dem Befehl gestartet, läuft. Bringt aber wie gesagt keine Verbesserung.

Edited by Tüftler
Link to post

Hi,

 

Scheint wohl ein ATI problem zu sein. Habe alles versucht nachzuvollziehen.

 

Kann schon sein (oder ist sogar höchstwahrscheinlich so), dass es irgendwie damit zusammen hängt (es tritt wirklich, so wie es aussieht, nur mit ATI Karten auf, aber mit allen wahrscheinlich).

 

Allerdings muss man auch dazu sagen, dass es nicht nur an ATI liegen kann, da mit anderen Programmen, außer dem DVBViewer, so etwas ja nicht passiert.

 

Treffen wohl zwei "halbe" Bugs aufeinander (halb ATI und halb DVBViewer) die dazu führen. Ist wahrscheinlich nur eine Kleinigkeit, die man auf einer der beiden Seiten ändern müsste, dass es geht. Man müsste halt raus finden, woran es liegt, und das wird das Problem sein ...

 

Allerdings habe ich wenig Hoffnung, dass da ATI was ändert und ich setzte eben größere Hoffnungen auf die Macher das DVB-Viewers.

 

Versucht doch mal die Umschaltverzögerung etwas hoch zu nehmen.

Die Standartwerte verursachten bei mir am Anfang Abstürze.

 

Was hast du da drin stehen? Da sind bei mir momentan 800ms drin, ist das zu kurz? Sonst werden ja die Umschaltzeiten unheimlich lang und beim Umschalten habe ich eigentlich noch kein Problem gehabt.

 

Habe den DVBViewer mit dem Befehl gestartet, läuft. Bringt aber wie gesagt keine Verbesserung.

 

Ich hab das immer noch anders gemeint. Du startest den DVBViewer normal, schaltest auf einen Kanal (z.B. ARD, ist eigentlich egal) und führst dann in der Eingabeaufforderung den Befehl aus. Der Befehl schaltet dann die Ausgabe vom schon laufenden DVBViewer aus und dabei schmiert er sporadisch ab (hab's bisher 2 mal reproduzieren können). Geht aber wie gesagt nur dann, wenn der DVBViewer schon läuft und was ausgibt (d.h. schon auf einen Kanal geschaltet ist).

 

Bemerkt habe ich das, weil ich diesen Befehl nutze, um den Viewer "ruhig" zu stellen, wenn ich mit einen selber gebauten Menüeintrag über eine cmd-Datei z.B. den Firefox oder MAME Plus starte.

 

Gruß

Mikel

 

 

 

Gruß

Mikel

Edited by okmikel
Link to post
Was hast du da drin stehen? Da sind bei mir momentan 800ms drin, ist das zu kurz? Sonst werden ja die Umschaltzeiten unheimlich lang und beim Umschalten habe ich eigentlich noch kein Problem gehabt.

 

bei mir stehen 1200 drin.

Link to post
Ich hab das immer noch anders gemeint. Du startest den DVBViewer normal, schaltest auf einen Kanal (z.B. ARD, ist eigentlich egal) und führst dann in der Eingabeaufforderung den Befehl aus. Der Befehl schaltet dann die Ausgabe vom schon laufenden DVBViewer aus und dabei schmiert er sporadisch ab (hab's bisher 2 mal reproduzieren können). Geht aber wie gesagt nur dann, wenn der DVBViewer schon läuft und was ausgibt (d.h. schon auf einen Kanal geschaltet ist).

Dann habe ich wohl den Befehl falsch angewendet.

Link to post

Bei mir beendet sich der DVBViewer auch sporadisch beim Abspielen von Aufnahmen/Videos. Was natürlich sehr ärgerlich ist. Vielleicht hilft ja meine Support.zip. Falls ich euch irgendwie beim Testen helfen kann, gebt bitte bescheid.

 

Lesen die Entwickler hier eigentlich noch mit? Denn nach allem was ich hier gelesen habe, sieht es nicht danach aus, dass man das selbst beheben kann.

 

Tritt das Problem auch in Vista auf? Hatte kurzzeitig Vista installiert, hatte da aber Probleme mit dem Timeshift unter EVR.

Link to post

Ich lese mit, habe mehrfach versucht es zu reproduzieren, gemäß

 

Du startest den DVBViewer normal, schaltest auf einen Kanal (z.B. ARD, ist eigentlich egal) und führst dann in der Eingabeaufforderung den Befehl aus. Der Befehl schaltet dann die Ausgabe vom schon laufenden DVBViewer aus und dabei schmiert er sporadisch ab

aber ohne Erfolg. Auch bei der Dateiwiedergabe mit dem DVBViewer Pro ist es mir noch nie begegnet, tritt also offenbar nur unter bestimmten Bedingungen auf.

Link to post

So, habe einfach die TV-Karte deaktiviert (auf nicht benutzen gestellt).

Jetzt kann sich natürlich kein TV-Bild mehr aufbauen und siehe da, kein Absturz mehr ins Windows.

DVD/Dateiwiedergabe laufen völlig stabil!

 

Kann mir jetzt jemand evtl Tipps geben was an meiner Einstellung falsch sein könnte?

Offensichtlich wird der TV-Graph nicht korrekt auf- bzw. abgebaut.

 

PS: Das raufsetzen der Zeit hat, wie vermutet, keinen Einfluss darauf.

Edited by Tüftler
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...