Jump to content
amontillado

MyMovies - Movie info OSD Plugin

Recommended Posts

byngo
I am going to try out the my movies plugin and filminfopics.exe tonight on top of my concinnity 3D skin.

I have mostly Bluray back-ups on a 1 TB drive, recently I started playing these back via DVBViewer 4.1 so I leave them in "File Mode" in a folder for each but I also have some back-ups that are an iso file.

Will filminfopics.exe get the data from the iso's without mounting them (virtual drive I mean) as long as I put the iso file in a folder of the movie title?? Or will these need to be re-backed up in "File Mode"??

 

If the above does work, did i read correctly that I get a prompt to "put the disc in the drive" (or in my case mount it)???

 

 

Update, Ok, Great, What a fantastic plugin and film info program. works brilliantly and very fast for me, no switching delay even with 1920 x 1080 backdrops.

Now I've used it I've answeed my own question. The program recognised the title of the folder that an iso file was in (or the title of the iso) and added the backdrop and thumbnail folder jpegs, but of course, the movie does not play without being mounted.

 

 

I have another question though that I wondered how those more experienced handle,

When I use the movie info exe program it will often place several backdrops into the corrsponding movie folder, I then edit my movies plugin entry to point to a particular backdrop i like, then I delete the ones I don't want to save accumulating space on the HDD.

Now then, If after adding a new movie folder, I re-run the info program on the HDD contents, I assume it will replace all the backdrops I deleted from the current movies and of course add the new one if recognised. Should I just be running the program on the newly added folder??? this seemed to throw up errors when I tried it last night.

P.S @ Flowy, Good luck with the GUI and stuff, I will be looking out for updates. Running your prog got my movie thumbnails working in the Concinnity 3D skin aswell which was the problem I was originally looking to solve.

P.P.S @ Amontillado, well done with a fantastic plugin. An even better solution to the problem I had with thumbnails in the first place.

These two tools are great for anyone like me who has a Gaming PC, but often uses it like a media centre for certain things.

Edited by byngo

Share this post


Link to post
Flowy

Thanks, byngo

 

I have another question though that I wondered how those more experienced handle,

When I use the movie info exe program it will often place several backdrops into the corrsponding movie folder, I then edit my movies plugin entry to point to a particular backdrop i like, then I delete the ones I don't want to save accumulating space on the HDD.

Now then, If after adding a new movie folder, I re-run the info program on the HDD contents, I assume it will replace all the backdrops I deleted from the current movies and of course add the new one if recognised. Should I just be running the program on the newly added folder??? this seemed to throw up errors when I tried it last night.

 

This could be solved with an option. Perhaps later with gui. I will write it in my todo list

 

Thanks for testing and your report

Edited by Flowy

Share this post


Link to post
byngo

Amontillado,

 

I think I have found a bug but you might correct me...

I have set up mymovies plugin and have several movies listed wich seemd to work well, having all the backdrops and thumbs looked great. Not only that but the filminfopics got my thumbnails working in the concinnity 3D skin too. My DVBViewer is at Version 4.1.

 

Now, I use my hauppage remote to control DVBViewer and PowerDVD. I also use it to switch displays between monitor and HD TV. To bring all these functions together I use a program called EventGhost which has plugins for DVBViewer and PDVD so is pretty easy to configure.

 

The snag I have found is that if I open DVBViewer with my mouse (shortcut on desktop) and then use my remote to open the OSD menu and navigate to My Movies it all works great. But.. if I start DVBV with the remote and do the same navigation I have no movies listed, no backdrops no thumbs.

Also, a related issue im sure, if I have started DVBV with the remote and navigate the DVBV options with my mouse, like I would to add or edit movie info etc, when i get to Mymovies the window that opens is blank with just ok cancel and apply buttons at the bottom but if i do the same naigation, having started the program from the desktop shortcut by mouse, the options are there and so is the list of my movies, (although admitedly, I do sometimes just get the blank window and have to close the program and start again).

 

Overall, this is not a major problem, but for the true media centre experiance and to watch a movie, I can leave the keyboard and mouse at the PC workstation, grab my remote, switch displays to the TV in the lounge, open DVBViewer (or PDVD), navigate & press ok (play).

To get Mymovies to work I have to make sure I start DVBViewer with the mouse.

 

Why is the options\Mymovies window content intermittent??? (the mymovies settings tab below it always opens ok)

And something's going on with starting DVBV in HTPC mode.

 

Also for further info, no matter what method I use to start DVBV I can always navigate, by remote, to my movies and thumbnails via the concinnity OSD menu by navigating to "Videos".

 

I hope I have explained myself well, sorry for the long post.

Edited by byngo

Share this post


Link to post
uglyned

Do you have 2 copies of DVBViewer installed on your system? Maybe one beta and one 'live'? Maybe your shortcut is running one version and the RC launcher is running a different one? It sounds like the one you run from EventGhost doesn't have the plugin file present in its system. I'd check the path for both and make sure it's the same.

Share this post


Link to post
byngo
Do you have 2 copies of DVBViewer installed on your system? Maybe one beta and one 'live'? Maybe your shortcut is running one version and the RC launcher is running a different one? It sounds like the one you run from EventGhost doesn't have the plugin file present in its system. I'd check the path for both and make sure it's the same.

 

Ahhh, that sounds worth looking into,

A while ago I installed DVBViewer-GE version, can't remember why. Mind you, in either scenario the "mymovies" tabs are in the list under options.

I would think that I would see them in one program, but not in the version that's missing the plugin.

I wish I could check now but im at work.

Thanks for that advice. :)

Share this post


Link to post
uglyned

Think it's got to be something like that - they're both just slightly different ways of running the same executable file. You could check the 'Start in' folder on the shortcuts too, just to make sure that it's starting in your DVBViewer folder.

Share this post


Link to post
byngo
Think it's got to be something like that - they're both just slightly different ways of running the same executable file. You could check the 'Start in' folder on the shortcuts too, just to make sure that it's starting in your DVBViewer folder.

 

Thanks for starting me off in the right direction. I found the problem and it's not a plugin bug. (Appologies to plugin author)

I do not have two versions of DVBViewer, but what I found was that EventGhost seemed to be calling on the same command line but one with a load of "~" in it.

Did'nt mean much to me but,,,,,

Using a system services program i noted that when i used the desktop shortcut, the program opened under windows exploer, but if i used the remote to start DVBViewer the command line came under system services \ svchost.exe.

 

I changed the Event Ghost action for the command to point the target to the application path and now of course both methods open the same thing and in the same way.

 

Trouble is, Eventghost serves me very well, but you set it up and leave it alone. Then later, you forget how it works and how to make changes.

 

Cheers. :)

Share this post


Link to post
Kommakul

Hi

 

First: This a really useful plugin.

 

I have a couple of suggestions/feature requests and questions:

 

1:

I would really like to see support for DVD's backed up as ISO's. I can get them to play by manually writting the filename, but they are not recognized by DVBV as DVDs (No posssibility for accessing the DVD menu and such) Further it does not allow resuming playback at last position). I have a lot of DVDs in this format, so I would really appreciate this feature, and I would be happy to participate in any testing.

 

2:

In the current implementation only the first part of a long description is displayed. Would it be possible to include f.ex. in the options menu a window with the full (scrollable description). Similar to the one that is brought up by a OK press on a program in the timeline. (If I should be really wishfull, the window could be brought up directly by one of the colored keys...)

 

3:

Maybe a bug: First time I enter MyMovies navigation is correct. But if i exit and reenter, the highlighted control is the "Large Icons" button, and not the last selected movie...

 

4:

Just a question:

Is it possible to let DVBV record in the folder structure required by the FilmInfo application?

Or are you all doing it manually?

If it's not possible I will probably write a script for the purpose.

 

Once again it's a really nice plugin and I'm looking very much forward to seeing the automated solution you and Flowy are building.

 

Keep up the good work!

Christian

Share this post


Link to post
amontillado
2:

In the current implementation only the first part of a long description is displayed. Would it be possible to include f.ex. in the options menu a window with the full (scrollable description). Similar to the one that is brought up by a OK press on a program in the timeline. (If I should be really wishfull, the window could be brought up directly by one of the colored keys...)

 

3:

Maybe a bug: First time I enter MyMovies navigation is correct. But if i exit and reenter, the highlighted control is the "Large Icons" button, and not the last selected movie...

2. Allready on the 'next version list' B)

3. Indeed.. a bug ;)

 

Dont know when the new version will come, the MySeries plugin is taking up most of the available time (and its fathersday now :))

Edited by amontillado

Share this post


Link to post
amontillado
2:

In the current implementation only the first part of a long description is displayed. Would it be possible to include f.ex. in the options menu a window with the full (scrollable description). Similar to the one that is brought up by a OK press on a program in the timeline. (If I should be really wishfull, the window could be brought up directly by one of the colored keys...)

 

3:

Maybe a bug: First time I enter MyMovies navigation is correct. But if i exit and reenter, the highlighted control is the "Large Icons" button, and not the last selected movie...

Some free time so uploaded a new version (b26) that has (2.) implemented. Just pres OSD-Yellow.

 

3. Is a weird one, seem skin related.. only does it in my system with cocinnity and thumbnails. Havent figured out why yet B)

Share this post


Link to post
amontillado
3. Is a weird one, seem skin related.. only does it in my system with cocinnity and thumbnails. Havent figured out why yet B)

Fixed (b27)

Share this post


Link to post
Kommakul

2 & 3: Wow, fast work. Thanks.

 

1. Have you tried Options > Daemon Tools > Automount?

 

4. If you use the Recording Service it should be possible

http://en.DVBViewer.tv/wiki/Timer_concept_...rding_file_name

 

4: Unfortunately I use Task scheduler.

 

1: I use this (with autoplay DVDs disabled). The DVD image mounts and starts playing, but not correctly as a dvd.

 

Hope to see support for ISOs, sometime in the future.

 

Regards

Christian

Share this post


Link to post
byngo
Fixed (b27)

 

Thanks for the update.

 

I'm new to this plugin but really liking it so far.

 

Question:- How do I update to B27, I don't want to loose my mymovies set-up so far. Sorry if that's a noob question?? :)

Share this post


Link to post
amontillado
Thanks for the update.

 

I'm new to this plugin but really liking it so far.

 

Question:- How do I update to B27, I don't want to loose my mymovies set-up so far. Sorry if that's a noob question?? :)

Just copy all the files to their respective directories.

The data and settings are stored in the .ini and .db files, and those are not included in the .rar file anyway (they are created on first use).

Share this post


Link to post
sw4y

Hey, don't know why, but the plugin does not work for me anymore...

 

Used version 01.27, and it did work after I used it for the first time. But then I changed my media-folders, so I cleared the db and tried to search for the movies again.

You can see that the plugin does something, but after that, I don't see any movies, whether in the settings-tab or the mymovies-menu.

 

I also tried to delete everything related to the plugin (means the dll from the plugins dir as well as the images and databases) and reinstall the plugin, but it does not work.

 

Maybe you can help with that, maybe I forgot something?

 

Anyway, the work you do with mymovies and myseries is awesome. I really appreciate it!

 

Thx so far,

 

sw4y

Share this post


Link to post
amontillado
Hey, don't know why, but the plugin does not work for me anymore...

 

Used version 01.27, and it did work after I used it for the first time. But then I changed my media-folders, so I cleared the db and tried to search for the movies again.

You can see that the plugin does something, but after that, I don't see any movies, whether in the settings-tab or the mymovies-menu.

 

I also tried to delete everything related to the plugin (means the dll from the plugins dir as well as the images and databases) and reinstall the plugin, but it does not work.

 

Maybe you can help with that, maybe I forgot something?

 

Anyway, the work you do with mymovies and myseries is awesome. I really appreciate it!

 

Thx so far,

 

sw4y

1. Can you enable the debug log, try to search again and afterwards post the osd.log & osderror.log.

2. If you manually add a movie.. does that work ?

3. Can you mail me the database and .ini file ?

4. What skin do you use?

5. Does one of the older versions work e.g. build 25 ??

Share this post


Link to post
rdg

You ve done a great job for this plugin, i like it very much. it's a great alternative and very efficient.

 

i just would like to ask you an improvment, would it be possible to search video file name instead of the folder name

the actual way oblige me to create folders for each video. that not very conveniant and esay to use when we have a lot of videos

 

Reguard's

Share this post


Link to post
byngo
You ve done a great job for this plugin, i like it very much. it's a great alternative and very efficient.

 

i just would like to ask you an improvment, would it be possible to search video file name instead of the folder name

the actual way oblige me to create folders for each video. that not very conveniant and esay to use when we have a lot of videos

 

Reguard's

 

I think its set-up that way to suit the majority and those that like to use the film info pics program. This requires a folder to put the respective cover art in such as backdrops and thumbnails and the info text file.

I guess if you are building an archive its easy to start with orgainising into folders but if you did'nt start that way & have lots of movies now its a pain.

Share this post


Link to post
rdg

FilmInfosPics is very good

but not possible to choose the language as with MySeries Manager

 

Is it possible to scap Allocine.fr www.allocine.fr (for the french user) as with XBMC ?

 

(sorry for my bad english)

Share this post


Link to post
Kommakul
You ve done a great job for this plugin, i like it very much. it's a great alternative and very efficient.

 

i just would like to ask you an improvment, would it be possible to search video file name instead of the folder name

the actual way oblige me to create folders for each video. that not very conveniant and esay to use when we have a lot of videos

 

Reguard's

 

I'm also interested in a more flexible handling of the folder structure.

 

As I see the database fields, there is no problems for the MyMovies plugin in having all the video files in one folder and store the additional files (info and pictures) in subfolders.

 

The challenge is in the FilmInfosPics application, that expects the videofiles to be in the subfolders.

 

As I understand, work is done in regards to automating (and integrating?) the two steps. A suggestion for this work would be to allow for both folder structures in the two search procedures (FilmInfosPics must then search by the filename).

 

Is there anything, that makes this impossible? Apart from the additional work we are eagerly imposing on you... :)

 

Looking very much forward to the automated solution.

Christian

Share this post


Link to post
sw4y
1. Can you enable the debug log, try to search again and afterwards post the osd.log & osderror.log.

2. If you manually add a movie.. does that work ?

3. Can you mail me the database and .ini file ?

4. What skin do you use?

5. Does one of the older versions work e.g. build 25 ??

 

Hey, thx for your fast support. I will try this asap (little busy at the moment) and give you an answer or rather send you the files you mentioned.

I'm very optimistic to find a solution.

Share this post


Link to post
sw4y

Sent you the mentioned files!

Share this post


Link to post
rdg

Why, do some research no results?

 

Example:

- Into the Blue

- 21

- Wrong Turn

- The Island

 

and many others...

Share this post


Link to post
Flowy
Why, do some research no results?

 

Example:

- Into the Blue

- 21

- Wrong Turn

- The Island

 

and many others...

 

Okay I tested it!

 

Internal Server Errors :/ from the API

Now the filminfospics.exe will recognize this errors and try to parse html

 

New Version => http://www.DVBViewer.info/forum/index.php?...st&id=19216

 

Try it, I hope your movies will now be recognized

Share this post


Link to post
rdg
Okay I tested it!

 

Internal Server Errors :/ from the API

Now the filminfospics.exe will recognize this errors and try to parse html

 

New Version => http://www.DVBViewer.info/forum/index.php?...st&id=19216

 

Try it, I hope your movies will now be recognized

 

Very good work!

The program works perfectly

Thank you for your rapid response

Share this post


Link to post
rdg

Sorry, a little problem with "Aliens vs Predator"

FilmInfosPics downloads the info, cover and backdrops from "Aliens vs Predator Requiem"

 

How to choose "The Hills Have Eyes" (2006) because the program downloads the info on the version of 1977?

 

thx

Share this post


Link to post
Flowy

"Alien vs Predator" => Rename the folder to "AVP Alien vs Predator"

 

and with "The Hills Have Eyes" (2006) i got the same problem, but i dont know how to solve

exact names :/

Share this post


Link to post
rdg
"Alien vs Predator" => Rename the folder to "AVP Alien vs Predator"

 

and with "The Hills Have Eyes" (2006) i got the same problem, but i dont know how to solve

exact names :/

 

 

"The Hills Have Eyes" and "The Girl Next Door" for me

 

ok, it works for AVP

thank you for the tip

Share this post


Link to post
rdg

It is possible to have a version of the plugin in 4:3 ?

Share this post


Link to post
mils

Hello everybody!

I've a question, you could not so the plugin use the film via OSD information can only be yellow, and so the screen for the poster freibleibt.

If not possible, how could I change itself.

Thanks in advance

Share this post


Link to post
amontillado
It is possible to have a version of the plugin in 4:3 ?

Sure, just make a skin file for the 4:3 skin you are using.

(Skineditor is available on the download section, and you can use one of the supplied skin as an example)

 

I've a question, you could not so the plugin use the film via OSD information can only be yellow, and so the screen for the poster freibleibt.

If not possible, how could I change itself.

I'm sorry, but could you please clarify this a bit more.. i dont really understand the question.

Share this post


Link to post
mils

I want to when I go to a movie only the background picture and the cover is to be seen.

The movie information on the OSD should then be called yellow.

Is it somehow possible and if how?

Greeting Mils

Share this post


Link to post
Nick-Night

when i go with remotecontrol to button an select list view then i can not go up to scrolllist to select a film. by smal and large icons it will be works. the bug is online in listview

Edited by Nick-Night

Share this post


Link to post
mils

Hallo

Ist es möglich das wenn ich auf My Movies gehe und einen Film auswähle, das dann nur das Backgroundbild und das Cover angezeigt wird.

Ich möchte auf die Filminformationen hier verzichten und diese nur über OSD Gelb für den jeweiligen Film abrufen.

Kann ich das eventuel selber irgendwo einstellen z.b. in der mymovies xml.

Gruß Mils

Share this post


Link to post
amontillado
Hallo

Ist es möglich das wenn ich auf My Movies gehe und einen Film auswähle, das dann nur das Backgroundbild und das Cover angezeigt wird.

Ich möchte auf die Filminformationen hier verzichten und diese nur über OSD Gelb für den jeweiligen Film abrufen.

Kann ich das eventuel selber irgendwo einstellen z.b. in der mymovies xml.

Gruß Mils

Yes that is possible, all you need to do is change the xml file (remove the description labels/buttons).

 

when i go with remotecontrol to button an select list view then i can not go up to scrolllist to select a film. by smal and large icons it will be works. the bug is online in listview

Found and fixed, I'll post a new release this weekend.

Share this post


Link to post
Nick-Night
Found and fixed, I'll post a new release this weekend.

 

thx and sorry for my bad english

Share this post


Link to post
amontillado
thx and sorry for my bad english

Uploaded new version (.28), please test if it works.

 

Also added new function: Random backdrops. If enabled it will randomly select a backdrop form the movies backdrop list.

THis does require that you eiter re-import the movies (first remove them), or change the backdrops manually (in the edit movie screen).

Share this post


Link to post
Nick-Night

danke es geht jetzt. random backdrops geht auch.

 

da ich mittlerweile mehrere Festplatten mit Filmen habe, diese aber nicht ständig am Rechner sind. Ist es möglich nur die Filme anzeigen zu lassen die auf der angeschlossenen Festplatte sind und auf die zugegriffen werden kann?

Share this post


Link to post
amontillado
danke es geht jetzt. random backdrops geht auch.

 

da ich mittlerweile mehrere Festplatten mit Filmen habe, diese aber nicht ständig am Rechner sind. Ist es möglich nur die Filme anzeigen zu lassen die auf der angeschlossenen Festplatte sind und auf die zugegriffen werden kann?

Not at the moment. You might have noticed that there is allready an option "is Removable medium" .. which will be used for that later on.

So, someday in a new version it will be added.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...