Jump to content

MyMovies - Movie info OSD Plugin


amontillado

Recommended Posts

ist mir garnicht aufgefallen das dass geplant ist, hab aber nach deiner info danach gesucht und hab es gefunden. :D ich sehe das tool ist gut durchdacht und wenn das geplant ist reicht mir das.

Link to comment
  • Replies 562
  • Created
  • Last Reply

Top Posters In This Topic

  • amontillado

    171

  • Flowy

    36

  • CiNcH

    29

  • sw4y

    17

Top Posters In This Topic

Posted Images

Added an option for hiding unavailable movies.

 

For it to work you need to define paths first (in MyMovies, change view to Paths and add one or more paths)

Secondly you need to enable the setting "Hide Offline Paths" (in MyMovies-Settings).

 

MyMovies will check if the paths are available, if a movie is in an unavailable path then it wont be shown.

 

(Example)

- Path 1: "C:\Film", local path and available

- Path 2: "Z:\Film" , Networkpath that is offline

 

- Movie 1: "C:\Film\Batman Begins\Batman Begins.mkv" , will be shown

- Movie 2: "Z:\Film\Top gun\Top gun.avi" , won't be shown.

Link to comment

Sry, but this is an english thread. There is exactly the same thread in german langugage, so please post your problems there to keep the threads divided and clean.

Link to comment

I agree/understand... allthough I would prefer it that Nick-Night just translates his post to english since my german writing is not that great (reading no problem, but writing .... al those "der/den/dem/die/das/ uzw"... ;) )

Link to comment

Thats my problem too english reading no problem, but writing..... so i want to try it.

 

sorry for my mistake writing german here. so i want to explain.

 

if more than one externel drive have different path it will works. but i have a quickdeck so i change only the harddisk and each harddisk have the same path. my questchen was, is it possibal to scan the hdd name too. so i can give my hdd a name like movie 1, movie 2..... the names must then define in settings with path and the plugin can scan which hdd is online.

Link to comment
Thats my problem too english reading no problem, but writing..... so i want to try it.

 

sorry for my mistake writing german here. so i want to explain.

 

if more than one externel drive have different path it will works. but i have a quickdeck so i change only the harddisk and each harddisk have the same path. my questchen was, is it possibal to scan the hdd name too. so i can give my hdd a name like movie 1, movie 2..... the names must then define in settings with path and the plugin can scan which hdd is online.

Haha..I just answered in the german forum ;) .. anyway: it was a small bug, .30 should work.

Link to comment

it looks like it will be work fine ;) , but when no harddisk ist online he shows me some picture from the cache. better is then no or a black picture.

 

a smal idea i have also. i have some movies which have two or more files in one folder is it possibal when i select one of these films that has more than one movie files then a second menu comes where i can select wich part of these movie i would to play

Edited by Nick-Night
Link to comment
it looks like it will be work fine ;) , but when no harddisk ist online he shows me some picture from the cache. better is then no or a black picture.

 

a smal idea i have also. i have some movies which have two or more files in one folder is it possibal when i select one of these films that has more than one movie files then a second menu comes where i can select wich part of these movie i would to play

1. I'll look into that later

2. CUrrently if you import movies (after using flowy's filminfopics) it will find all videofiles (I you manually add movies you can also select mulitple videofiles.). If you then select a movie it will add all files to the playlist so you can simply skip to the next file using the standard functionality.

Link to comment

I put all my DVD's onto a network storage (path: \\nslu\nas\DVD). The MyMovies plugin seems to have problems retreiving the images from there:

 

mymovies.jpg

(this is no backdrop BTW, but live TV ;) )

 

The thumbs are displayed within the DVBViewer HTPC videos however. They are also displayed in the MyMovies plugin settings in the edit movie tab.

 

If I connect the USB HDD directly to the PC and re-import the DVD's everything also works with the MyMovies plugin.

Edited by CiNcH
Link to comment
I put all my DVD's onto a network storage (path: \\nslu\nas\DVD). The MyMovies plugin seems to have problems retreiving the images from there:

 

The thumbs are displayed within the DVBViewer HTPC videos however. They are also displayed in the MyMovies plugin settings in the edit movie tab.

 

If I connect the USB HDD directly to the PC and re-import the DVD's everything also works with the MyMovies plugin.

Do you use the "use local thumbs" option, if yes: are the the thumbs created (and can you open them), if no: could you try that.

 

Do you have the possibilty to upload the .db ( and osd.log & osderror.log) somewhere ?

 

btw.. I'm currently installing my first NAS, so possibly I'll run into the same probs.

Edited by amontillado
Link to comment
2. CUrrently if you import movies (after using flowy's filminfopics) it will find all videofiles (I you manually add movies you can also select mulitple videofiles.). If you then select a movie it will add all files to the playlist so you can simply skip to the next file using the standard functionality.

 

thx, it will be work

Link to comment

I started from scratch again, so removed all movies, paths, Thumbs.db and mymovies.ini. After re-importing, almost everything is there, but some movies do not have a backdrop, but if you look into the folders, there are some available for those movies. Nothing is mentioned in the logs about this...

 

Every movie has its own Thumbs.db now. Previously I had a Thumbs.db in the movie root folder.

 

osderror.log

Edited by CiNcH
Link to comment

Hallo

Wie kann ich die mymovies xml anpassen das die Filminformationen nicht mehr sichtbar sind.

Ich möchte die Filminformationen nur über OSD Gelb aufrufen.

Ich weiß nicht was ich aus der mymovies xml löschen muss um das hinzukriegen.

Vieleicht hat ja einer eine angepaste mymovies xml.

Vielen Dank im vorraus

Gruß Mils

Link to comment

Some backdrops seem to be broken.

 

backdrop_folder.jpg

 

What I don't like is that the plugin generates all those Thumbs.db but can't remove them automatically.

Edited by CiNcH
Link to comment

There is exactly the same thread in german language, please post your problems there.

 

Den gleichen Thread gibts auch auf deutsch, bitte dort posten, wenn man kein Englisch kann.

Ich meine mich auch erinnern zu können, das genau die Frage dort schonmal gestellt wurde.

 

*edit*

 

sry mils, hatte nicht gesehen, dass du die frage hier schonmal auf englisch gestellt hattest.

hatte gedacht, die wäre im deutschen thread gestellt worden.

nichts für ungut, denke trotzdem die frage ist im deutschen thread besser aufgehoben.

 

amontillado hatte die frage ja auch schon beantwortet, einfach mal ein wenig mit dem skineditor herumspielen.

Edited by sw4y
Link to comment
Some backdrops seem to be broken.

 

..

What I don't like is that the plugin generates all those Thumbs.db but can't remove them automatically.

The plugin doesn't create any thumbs.db.. those are created by windows explorer when you open a folder in thumbnail view.

It creates resized copies of the backdrops and folders, but that can be turned of ("Use local thumbs").

 

I also noticed broken resized copies on rare occasions, some bug in delphi's image32 component I guess.. still looking for a solution for it.

Link to comment
They are not exactly broken, but 0 Bytes, so not written.

I uploaded a new version (.31) which hopefully fixes the problem.

One problem was that from files in the backdrop folder a thumb was made, so in some cases also non picture files (like the thumb.db).

Best thing is to delete the backdrops thumb directory , remove the movies and reimport.

 

I just finished installing my new NAS and there it works.

Link to comment

Now no backdrops are shown at all in the OSD even though they were created within the backdrop folder. I again started from scratch, so deleted everything and used MyMovies default settings. I can't see anything special within the logs.

 

Where does the plugin save information like paths?

Edited by CiNcH
Link to comment
Now no backdrops are shown at all in the OSD even though they were created within the backdrop folder. I again started from scratch, so deleted everything and used MyMovies default settings. I can't see anything special within the logs.

 

Where does the plugin save information like paths?

Weird.

General settings (from mymovies-settings) are stored in the .ini, everything else is stored in the .db

 

if you disable "use local thumbs" what happens then ?

 

Could you possibly upload the .db, .ini, osd.log and osderror.log to my ftp

Ftp details:

adres: amontillado.nl

username: DVBViewer@amontillado.nl

pasword: DVBViewer

Link to comment
if you disable "use local thumbs" what happens then ?

Didn't help. Now neither the thumbs nor the backdrops are shown. Only the text.

 

http://bleedingme.dyndns.org/osderror.log

http://bleedingme.dyndns.org/osd.log

http://bleedingme.dyndns.org/mymovies.db

http://bleedingme.dyndns.org/mymovies.ini

 

Which sqlite version do you use?

Edited by CiNcH
Link to comment
Didn't help. Now neither the thumbs nor the backdrops are shown. Only the text.

 

http://bleedingme.dyndns.org/osderror.log

http://bleedingme.dyndns.org/osd.log

http://bleedingme.dyndns.org/mymovies.db

http://bleedingme.dyndns.org/mymovies.ini

 

Which sqlite version do you use?

2.8, It uses the sqlite.dll that comes with DVBViewer.

 

Thanks for uploading. I'll take a look at it this evening

Link to comment

CiNcH and I kept the rest of the troubleshooting out of this topic so I'll post the solution for his problem here, in case anybody has the same problem.

 

It turned out that it was actually not a bug in MyMovies but the setting "Display background graphics" in the osd-general section of the DVBViewer settings was disabled (which we both totally overlooked :blink: ).

A fine case of looking for the most complex reasons first and looking at the most obvious one last :P

Link to comment

Has anybody worked with ISO's yet? Even though it is not in the extensions list I added an ISO manually to 'Filename' of a movie ('\\nslu\nas\BD\CRANK\CRANK.ISO'). DVBViewer HTPC Videos would mount the image with Deamon Tools or Virtual Clone Drive and try to find a DVD or BD structure and play it back. MyMovies doesn't do that. Can this somehow be delegated to the DVBViewer? This would fully replace the DVBViewer's HTPC Video for me.

Edited by CiNcH
Link to comment
Has anybody worked with ISO's yet? Even though it is not in the extensions list I added an ISO manually to 'Filename' of a movie ('\\nslu\nas\BD\CRANK\CRANK.ISO'). DVBViewer HTPC Videos would mount the image with Deamon Tools or Virtual Clone Drive and try to find a DVD or BD structure and play it back. MyMovies doesn't do that. Can this somehow be delegated to the DVBViewer? This would fully replace the DVBViewer's HTPC Video for me.

 

As mentioned before. I would appreciate support for ISO´s too!

 

Christian

Link to comment

@ amontillado,

 

how do you currently open a video file? Via command line? Or via COM PlayFile?

 

Maybe it would be cool if the DVBViewer API could also:

 

-> mount ISO's and detect/play DVD/BD structures

-> provide the possibility to pass a path/folder instead of an ISO (DVBViewer will detect BD and DVD structures)

Edited by CiNcH
Link to comment
@ amontillado,

 

how do you currently open a video file? Via command line? Or via COM PlayFile?

 

Maybe it would be cool if the DVBViewer API could also:

 

-> mount ISO's and detect/play DVD/BD structures

-> provide the possibility to pass a path/folder instead of an ISO (DVBViewer will detect BD and DVD structures)

I use the PlayFile command (that actually also works as long as there's a splitter that can split the iso.. like the nero splitter), but its not realy the best way..

 

Havent really tried to implement it properly, mainly because I dont use/have daemon tools.

I'll look into it soon.

 

Maybe Lars / Christian / Griga can tell how this can be achieved ???

Edited by amontillado
Link to comment
I use the PlayFile command (that actually also works as long as there's a splitter that can split the iso.. like the nero splitter), but its not realy the best way..

 

Havent really tried to implement it properly, mainly because I dont use/have daemon tools.

I'll look into it soon.

 

Maybe Lars / Christian / Griga can tell how this can be achieved ???

 

If a solution through COM is not possible, it should be possible to do it through a commandline solution.

I have used something similar for a quick-play list of my childrens ISO´s.

 

Example:

call "C:\Program Files\DAEMON Tools Lite\daemon.exe" -unmount 0

call "C:\Program Files\DAEMON Tools Lite\daemon.exe" -mount 0, N:\Videos\rasmusklump1.iso

call "C:\Program Files\DVBViewer\DVBViewer.exe" I:

 

Remember to wait for completion between each command

 

The daemon.exe path, drivenumber (0), and drive letter (I:) can be found in setup.xml.

But I agree that if you could let DVBV handle it, it would be preferable.

Link to comment

Same for Virtual CloneDrive:

vcdmount.exe image name, e. g. vcdmount.exe "m:\image name.iso"

 

For unmounting:

 

vcdmount.exe /u

 

vcdmount /d=X imagefile

 

where x is your "virtual drive number-1", e. g. you want to mount the image into virtual drive 1 you have to use 0 for x, for drive 8 you have to use 7.

 

when you want to unmount image in drive 8 you have to use "vcdmount.exe /d=7 /u"

Link to comment

Doesn't work here. Even though I prefer Virtual CloneDrive, I installed Daemon for a test. Screen just turns black and the ISO is not loaded into the virtual drive. The plugin does not even try to access the network drive to load the image (I of course set the movie ISO file within the 'Filename' field.. '\\nslu\nas\DVD\LOVE VEGAS\WHAT HAPPENS IN VEGAS SE.iso').

 

The following commands work for me:

C:\Programme\DAEMON Tools Lite>daemon.exe -unmount 0
C:\Programme\DAEMON Tools Lite>daemon.exe -mount 0, "\\nslu\nas\DVD\LOVE VEGAS\WHAT HAPPENS IN VEGAS SE.iso"

Edited by CiNcH
Link to comment

DVBViewer seems to not work correctly with the latest version of Daemon Tools. I updated a few days ago and since then it doesn´t mount images from DVBViewer. I didn´t test it but maybe this is not a MyMovies problem.

Link to comment
I didn´t test it but maybe this is not a MyMovies problem.

MyMovies handles the mounting all by itself via CLI, and not via DVBViewer. CLI works as I mentioned but not as executed by the plugin. There is no interaction with the DVBViewer, DVBViewer just recognizes the "inserted disc", just as if you put a DVD into the physical drive.

Link to comment
Doesn't work here. Even though I prefer Virtual CloneDrive, I installed Daemon for a test. Screen just turns black and the ISO is not loaded into the virtual drive. The plugin does not even try to access the network drive to load the image (I of course set the movie ISO file within the 'Filename' field.. '\\nslu\nas\DVD\LOVE VEGAS\WHAT HAPPENS IN VEGAS SE.iso').

 

The following commands work for me:

C:\Programme\DAEMON Tools Lite>daemon.exe -unmount 0
C:\Programme\DAEMON Tools Lite>daemon.exe -mount 0, "\\nslu\nas\DVD\LOVE VEGAS\WHAT HAPPENS IN VEGAS SE.iso"

Quick question.. did you manually type in the filename.. if so then dont use the ' before and after but "

 

I'll add some proper logging this evening... and virtual clone drive support.

 

Thanks anyway for testing :)

Link to comment
Quick question.. did you manually type in the filename.. if so then dont use the ' before and after but "

You mean on the command line? Yes, I entered it manually and I already used the ". It doesn't work with '.

 

But I also tried a BD ISO with no blanks in path and filename. Didn't work either within MyMovies, nothing is being mounted. It doesn't even seem to try, because there is no error thrown by Daemon. I think it doesn't even find the daemon.exe. Maybe because of the blank within the program's path?

 

EDIT:

Ah you meant setting the path within the plugin. I set it via file browser and did not write it myself. It uses the " automatically.. Everything should be fine there.

Edited by CiNcH
Link to comment
A button to show the trailer from the movie would be nice^^

Those are all links to YouTube movies... and they can at this moment not be played by DVBViewer

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...