Jump to content

Neue ÖR HD Sender (und einige alte) ruckeln.


ccdmas

Recommended Posts

Pete1976

Das ZDF bis zum 30.04. und das ZDF danach sind nicht das Selbe, da der Sender ins High Profile gewechselt ist.

ZU welchem Zweck? Klar liegts NICHT am Codec, sondern am Zusammenspiel von Stream und Codec (sowohl bei DVBViewer-Nutzung als auch bei Standalone Receivern), aber ist mir das als brav GEZ zahlendem Seher egal? Klar! Denn ich erwarte, dass das ZDF diese Änderungen umfassend prüft, bekannt macht und bei Problemen nicht alles auf den Nutzer/die Hersteller abwälzt.

 

Aber das ist ja die neue Masche: erst ändern und dann die anderen im Regen stehen lassen. War bei der Einführung von E10 genauso: was kümmert die Mineralölfirmen (und den Staat), ob die Motoren das Zeug vertragen? Hauptsache Aktionismus!

 

Sorry für OT

Link to post
  • Replies 235
  • Created
  • Last Reply

Top Posters In This Topic

  • dbraner

    21

  • Craig77

    14

  • kater

    12

  • damy

    11

Top Posters In This Topic

Posted Images

HaraldL

Cyberlink hat ihren Codec anscheinend so "hingebastelt" daß er die bisher(!) verwendeten Formate beherrscht. Nun haben die Sender einen besseren Encoder verwendet, der etwas liefert was ganz offensichtlich immer noch der auch vorher schon vorhandenen Norm entspricht (ansonsten hätten die Receiver-Hersteller ganz groß mit dem Finger auf die Norm gezeigt und sich geweigert Updates zu bringen). Nur daß das Signal jetzt etwas anspruchsvoller ist als vorher. Dadurch fallen alle Codecs auf die Nase die aus Faulheit/Unwissen/Kostenersparnis nicht die komplette Norm umgesetzt haben und wohl gehofft haben daß die nie jemand komplett ausreizt. Das ist jetzt halt schief gegangen, etlichen Herstellern von Set-Top-Boxen und Fernsehern mit integrierten Decodern ist es genauso ergangen, darum brauchen etliche ein Update.

Link to post

Ich hatte auch Probleme mit den neuen HD Sendern und PDVD 12. Durch probieren habe ich jetzt aber herausgefunden,dass, wenn ich von einem SD Sender auf z.B. ZDF HD wechsle, keine Artefakte und Sync-Probleme mehr habe. Wenn ich von einem HD-Sender auf die neuen ZDF HD- Kanäle wechsle muss ich einen Neuaufbau machen, dann sind die Fehler wieder weg. Mit dem neuen LAV funktionierten die ZDF HD Sender ohne Probleme nur ServusTV HD hatte dann immer Sync-Probleme.

 

Fast genau sieht es bei mir auch aus. Und mit PowerDVD hat damit gar nichts zu tun. Egal welchen Decoder ich nutze, und das sind reichlich, und auch egal welchern renderer,...ZDF HD ruckelt beim Umschalten von einem HD-Sender zu ZDF- Von einem SD-Sender nicht. Und sage mir niemand es läge nicht an DVBViewer. keiner meiner Satreceiver hat das problem. Und bei mir ist es auschließlich ZDF HD. Alle anderen ZDF-HD-Sender sind davon nicht betroffen. Auch andere HD-Sender nicht. Nur und ausschließlich ZDF-HD.

 

Gibt es denn kein Update seitens DVBViewer?

Link to post

um Cyberlink nochmal in Schutz zu nehmen, die Firma PowerDVD ist bekannt geworden durch Software zum abspielen von DVDs.

Das die beinhaldeten Decoder auch lange Zeit das Nonplusultra zum realisieren der Wiedergabe in DVB Wiedergabeprogammen war

ist für diese Firma bestenfalls ein Nebenschauplatz.

Jetzt diesbezüglich von "Faulheit/Unwissen/Kostenersparnis" zu sprechen halte ich doch für ein dickes Ding.

 

Ich möchte nooh anfügen, auch DVBViewer ist hier, meiner Meinung nach, bestenfalls Opfer. Das Problem beim Viewer ist nur,

das es hier im Gegensatz zu einem Receiver in den Settings viel mehr Möglichkeiten gibt etwas nicht 100% einzustellen. Er stellt weitgehend

den Rahmen zur Verfügung. Was die Nutzer damit machen liegt zum großen Teil auserhalb seines Einflusses

Also, Rufe nach einem Update erübrigen sich.

Edited by kater
Link to post

Fast genau sieht es bei mir auch aus. Und mit PowerDVD hat damit gar nichts zu tun. Egal welchen Decoder ich nutze, und das sind reichlich, und auch egal welchern renderer,...ZDF HD ruckelt beim Umschalten von einem HD-Sender zu ZDF- Von einem SD-Sender nicht. Und sage mir niemand es läge nicht an DVBViewer. keiner meiner Satreceiver hat das problem. Und bei mir ist es auschließlich ZDF HD. Alle anderen ZDF-HD-Sender sind davon nicht betroffen. Auch andere HD-Sender nicht. Nur und ausschließlich ZDF-HD.

 

Gibt es denn kein Update seitens DVBViewer?

 

Ich kämpfe seit Anfang dieses Post und kann den Fehler nicht nachvollziehen. Bei mir rückelt nichts, also kann der DVBViewer nicht schuldig sein. Warum sollen die Enwickler an was rumflicken, was sie nicht kaputtgemacht haben?

 

Hast du LAV probiert wie viele andere?

Edited by blasgl
Link to post

um Cyberlink nochmal in Schutz zu nehmen, die Firma PowerDVD ist bekannt geworden durch Software zum abspielen von DVDs.

Das die beinhaldeten Decoder auch lange Zeit das Nonplusultra zum realisieren der Wiedergabe in DVB Wiedergabeprogammen war

ist für diese Firma bestenfalls ein Nebenschauplatz.

Jetzt diesbezüglich von "Faulheit/Unwissen/Kostenersparnis" zu sprechen halte ich doch für ein dickes Ding.

 

Ich möchte nooh anfügen, auch DVBViewer ist hier, meiner Meinung nach, bestenfalls Opfer. Das Problem beim Viewer ist nur,

das es hier im Gegensatz zu einem Receiver in den Settings viel mehr Möglichkeiten gibt etwas nicht 100% einzustellen. Er stellt weitgehend

den Rahmen zur Verfügung. Was die Nutzer damit machen liegt zum großen Teil auserhalb seines Einfulsses

Also, Rufe nach einem Update erübrigen sich.

 

ob es hilft, den bug an cyberlink zu melden? :rolleyes:

Link to post
Craig77

Habe mir jetzt mal die Cyberlink Codecs installiert aus PowerDVD 11, manuell registriert via Filter Manager.

Folgendes ist zu beobachten und tritt definitiv nur in Zusammenhang mit diesem Codec auf:

- Umschalten von ProSieben SD auf ZDF HD --> Fehlerfreies Bild,

anschließendes Umschalten auf zdf_neo HD ebenfalls fehlerfrei. Für SD ist ebenfalls CL im Einsatz, aber auch mit LAV kein Unterschied.

- Umschalten von ARD HD auf ZDF HD ---> Fehlerhaftes Bild!

anschließendes Umschalten auf zdf_neo HD ist fehlerfrei.

Der Neuaufbau des Graphen behebt jegliche Fehler, die Voraberkennung nützt nichts.

Ich denke, dass sind ca. die Probleme, die andere User hier schon beschrieben haben.

Aber das ändert absolut nichts daran, dass weder der DVBViewer noch das ZDF hier unschuldig sind, denn die LAVFilter funktionieren, wie von mehreren hier bestätigt, sauber. Ebenso wie oben schon geschrieben die uralten MainConcept Decoder aus dem Jahre 2008.

Der PowerDVD Codec scheint hier nicht standardkonform ausgelegt zu sein und genau diese Lücke scheint das ZDF durch die Umstellung zu treffen.

Soviel von meiner Seite nochmal dazu.

@Franny, dass sämtliche Decoder und Renderer bei dir versagen, sollte das überhaupt der Fall sein, dürfte dann aber eher andere Ursachen haben.

 

Stimme kater hier zu, die sind schließlich nie dafür gemacht worden, DVB-S2 wiederzugeben, sondern BluRays und DVDs.

Edited by Craig77
Link to post

Kann man eigentlich eine "Auto Video B" Bedingung einfügen, die nur bei ZDF auf "Video B" umschaltet.

Dann würde ich nur für ZDF den LAV nutzen.

Link to post

ob es hilft, den bug an cyberlink zu melden?

nö, das ist nicht deren Problem. In letzter Zeit versuchen die ja zu verhindern, daß aus ihrer Software der entsprechende Decoder herausextrahiert wird.

Bei mir läuft:

Auf XP und Gforce 9500; LAV auf CUVID eingestellt mit dem VMR9 (unten VMR Fix NVIDI und ATI angeklickt). Hatte erst EVR, aber so ists ein Tick besser, glaub ich.

Link to post
Craig77

@ML1982 warum nicht durchgängig den LAV? Meiner Meinung nach liefert der ein sehr gutes Bild und ist dazu noch opensource und damit frei verfügbar. Die CL Codecs sind ja im Prinzip nur missbraucht und wahrscheinlich verstößt man auch noch gegen die Lizenz.

Link to post
kai0815

Die Sache hier ist auch für mich sehr ärgerlich. Ich benutze seit längerem den Cyberlink PowerDVD 8 für HD. Das war bei mir (NVIDIA u. XP SP3 u. Nova HD S2) der einzige Decoder der auch mit den BBC HDs, ITV HD, Dubai Sport HD, TRT HD, ORF HD .... usw. vernünftig lief. Nun wird in einer Nacht-und-Nebelaktion mal eben bei den ÖR was umgestellt und alles is essig :( Sicher bekomme ich es durch rumgebastel hin, das die ÖR funktionieren, dann laufen die HD-Programme der anderen Satelliten aber nicht :(

Link to post
Craig77

@kai0815 unterstützt deine nVidia-Karte CUDA? Selbst wenn nicht, LAVFilter ausprobieren.

Und das Ganze war keine Nacht- und Nebelaktion, sondern schon Ewigkeiten genau so geplant.

Im Allgemeinen verstehe ich nicht, warum die Leute mit Problemen nicht mal ein wenig im Thread lesen und gewisse Tipps ausprobieren, die Lösung ist fast immer die Gleiche.

Link to post

Im Allgemeinen verstehe ich nicht, warum die Leute mit Problemen nicht mal ein wenig im Thread lesen und gewisse Tipps ausprobieren, die Lösung ist fast immer die Gleiche.

Warum liest du nicht mal im Thead um festzustellen, dass der LAV halt nicht überall rund läuft, auch wenn man schon einiges an Tipps probiert hat?

Link to post
Craig77

Ich habe den Thread sehr wohl gelesen und aus den vorherigen Posts geht eindeutig hervor, dass etliche Poster eben nicht gelesen und eben nicht probiert haben. Und Probleme mit den LAVFiltern beziehen sich hauptsächlich auf Synchronität, wo es auch mehrere Lösungsoptionen für gibt. Außerdem sind die LAVFilter auch nicht die einzige Option... Auch wenn es mittlerweile 9 Seiten sind, in anderen Foren wird vorausgesetzt, dass man sich in ein Thema einliest, bevor man seinen Senf dazu gibt.

Link to post
Pitty_2

Ich bin der Ansicht es hat irgendwie mit dem Videopuffer und der synchronisierung zu tun. Habe auf Video B seid ein paar Tagen den Arcsoft 2.25 von 2008 laufen. Schaltet langsmer um,aber läuft Sauber und DXVA geht auch.

Der Decoder läuft bei mir mit Overlay und DVB Splitter und Hali Splitter für MKV gut. Mir ist aufgefallen das Paketfehler jetzt öfters auftreten und der Cyber dann aus dem tritt kommt. Ich vermute mal das Satelitensignal kann auch Fehlerhaft sein.

Ich benutze noch den Viewer 4.5 weil alles danach mit xp nicht immer in den Ruhemodus geht. Daher liegts mit sicherheit nicht am Viewer, sondern an den Codec bzw. Streams.

Link to post
ThulsaDoom

Ich möchte an dieser Stelle NOCHMAL betonen, daß bei mir der ARCSOFT Codec aus TMT5 das Problem gelöst hat. Davon gibt es auch eine Trial und wie man den Codec zum laufen bekommt, sollte über Google wohl zu lösen sein!

 

Gruß

ThulsaDoom

Link to post
dbraner

Die Diskussion wird jetzt schon etwas emotional. Immer locker bleiben B)

 

Es wurde schon mehrfach hier gepostet, dass die Probleme mit ZDF HD Sendern eigentlich nur mit den Cyberlink Codecs auftreten. Es ist verständlich, dass viele Leute, die bisher diese Codecs genutzt haben (so wie ich auch), diese gerne weiter nutzen würden. Sie laufen a) stabil und B) ist das Bild besser als bei den anderen (meine subjektive Einschätzung).

 

Die Sache ist doch ganz einfach: Wir hoffen darauf, dass Cyberlink mit dem nächsten Release-Wechsel von PowerDVD das Problem behebt. In der Zwischenzeit nutzen wir eine der vielen, meist problemlos funktionierenden Alternativen wie LAV, CoreAVC oder Arcsoft oder ...

Link to post
Kann man eigentlich eine "Auto Video B" Bedingung einfügen, die nur bei ZDF auf "Video B" umschaltet.

Dann würde ich nur für ZDF den LAV nutzen.

 

Leider (noch :-) ) nicht.

Link to post

Es wurde schon mehrfach hier gepostet, dass die Probleme mit ZDF HD Sendern eigentlich nur mit den Cyberlink Codecs auftreten.

ist ja OK aber mit anderen Decodern laufen des öfteren andere HDTV Sender nicht.

 

Schön wäre übrigens, wemm man sich mal bemühen würde eine aktuelle Signatur zu erstellen.

Zumindest über die Komponenten, die füt DVB wichtig sind.

Link to post
dbraner

ist ja OK aber mit anderen Decodern laufen des öfteren andere HDTV Sender nicht.

 

Kann ich nicht bestätigen. Mit CoreAVC läuft alles und inzwischen habe ich auch keine Audio/Video-Sync Probleme mehr mit LAV (hab den Codec nochmal neu installiert).

 

Schön wäre übrigens, wemm man sich mal bemühen würde eine aktuelle Signatur zu erstellen.

Zumindest über die Komponenten, die füt DVB wichtig sind.

 

Alles zu meiner Config findest Du hier.

Link to post

Alles zu meiner Config findest Du hier.

so gründlich hab ichs nun auch wieder nicht gemeint :rolleyes: ist ja ein Meisterwerk.

 

ich meinte eher die Kurzversion, unten im Beitrag.

Core läuft bei mir auch ordentlich, aber ich hab noch die Version 1.6. und die hat

meines Wissens noch kein DXVA. Zumindest wüsste ich nicht wo ich da ein Häkchen setzten sollte.

OK, ist ja bei den CPUs heute auch nicht mehr unbedingt nötig.

Edited by kater
Link to post

Hallo,

 

ich muss mich hier mal einklinken:

Habe das Problem, dass auf sämtliche HD-Kanälen grüne Klötzchen flimmern, sobald ich von einem HD-Kanal zum nächsten zappe.

Nun habe ich nach dem Durchforsten der 10 Seiten dieses Threads 'mal eben' vom PowerDVD 8 Codec auf den aktuellen Arcsoft Codec gewechselt.

Leider tritt das Problem trotzdem noch ab und zu auf, obwohl eindeutig der ArSoft Codec im DVBViewer läuft.

Graph neu aufbauen, oder einmal den Codec ändern (Video-Ausgabe B ) führt sofort zu Abhilfe.

Also liegt scheinbar nicht nur am Cyberlink-Codec...

 

BTW, mit dem Arcsoft-Codec funzt kein Overlay (nur schwarzes Bild)- woran kann das liegen?

Edited by Exciter
Link to post

Da wird was an den einstellungen was nicht stimmen. Habe das gleiche Board. geht einwandfrei.

 

Geht denn das dxva oder mkv dateien? welcher Splitter oder filter ?

Edited by Pitty_2
Link to post

Da must du mal was über deine Hardware und was für ein Windows äusern.

 

steht doch recht eindeutig in der Signatur...

Link to post

Da wird was an den einstellungen was nicht stimmen. Habe das gleiche Board. geht einwandfrei.

 

Geht denn das dxva oder mkv dateien? welcher Splitter oder filter ?

 

Mkv, ts usw. funzen alle einwandfrei.

Die HD-Sender haben bis zur glorreichen Umstellung auch alle einwandfrei gearbeitet.

Es reicht ja schon, wenn ich von einem SD auf einen HD Kanal umschalte, dann ist alles gut.

Edited by Exciter
Link to post

zu Overlay:

 

MKV -> Haali Splitter -> Cyberlink H264 -> Overlay -> i.O.

MKV -> Haali Splitter -> ArcSoft -> Overlay -> kein Bild / kein Ton

MKV -> Haali Splitter -> ArcSoft -> System Default Renderer -> i.O.

 

Livestream -> DVBSource -> Cyberlink H264 -> Overlay -> i.O. (außer grüne Klötzchen beim ZDF-HD-Umschalten)

Livestream -> DVBSource -> Arcsoft -> Overlay -> kein Bild / aber Ton vorhanden

 

zum ZDF-HD Problem:

 

Livestream -> DVBSource -> Cyberlink H264 -> Overlay -> grüne Klötzchen beim ZDF-HD-Umschalten -> Umschalten auf SD-Sender und zurück, oder Graph neu aufbauen löst das Problem einmalig

Livestream -> DVBSource -> Arcsoft -> System Default Renderer -> grüne Klötzchen beim ZDF-HD-Umschalten -> Umschalten auf SD-Sender und zurück, oder Graph neu aufbauen löst das Problem einmalig

 

Ich kann also widerlegen, dass das ZDF-HD-Problem beim Arcsoft-Decoder nicht auftritt (siehe Screenshot im Anhang).

Kann man die DVBViewer Optionen so einstellen, dass nach dem Umschalten auf explizite Sender der Graph neu aufgebaut wird?

post-66097-0-12001900-1336811841_thumb.jpg

Link to post

Auf der Seite www.digital-room.de ist ein neuer Artikel über die ZDF ARD Probleme:

 

....im digitalen MPEG4-Videosignal sei nun der Abstand zwischen jeweils zwei komplett übertragenen Bildern (i-Frames) größer geworden als bisher. Je länger eine solche "Group of Pictures" zwischen zwei i-Frames im Digitalsignal ist und je höher die Datenrate des DVB-Datenstromes sein kann, desto mehr Bildinformationen muss der Receiver am Eingang zwischenspeichern, um eine flüssige Bildwiedergabe zu gewährleisten. Diese Begründung bestätigt auch die Aussage von Kathrein-Mann Auer, der bereits vor gut einer Woche angab, man habe das Problem in den beiden betroffenen Geräten mit einem vergrößerten Eingangspuffer gelöst.....

Link to post

Bei mir haben die Arcsoftcodecs die Probleme mit den ZDF Sender gelöst.

Es gibt wohl keine pauschal gültige Lösung.

Link to post

..... man habe das Problem in den beiden betroffenen Geräten mit einem vergrößerten Eingangspuffer gelöst.....

 

Wo liegt denn dieser Puffer in der Signalkette beim DVBViewer?

Edited by Exciter
Link to post

Dieser "Buffer" muß doch Teil des AVC decoders sein. Könnte man etwa im DVBViewer über :

 

Ansicht -> Filter -> "Decoder" -> Settings an den Parametern für den Decoder etwas ändern?

 

Etwas anders machen die Receiver Hersteller doch sicher auch nicht. Am AVC decoder selber ändern die nichts. Der ist doch bei Satreceiver "in Hardware gegossen".

 

 

---> Mal gerade probiert : Beim "Mainconcept decoder" kann man einige Parameter ändern. Bei PowerDVD9 nicht "

Edited by noberto
Link to post

Der Arcsoftdecoder macht das gut. Beim umschalten verzögert er dadurch manchmal, oder mein Zeitsprung kommt er kurz aus dem triit, aber kommt dann wieder Syncron. Wenn der Decoder nicht im Overlay geht ist die Version nicht richtig installiert. Ich verwende eine alte von 2008 2.25 Mal suchen Codecpack.

Link to post
Wo liegt denn dieser Puffer in der Signalkette beim DVBViewer?

Der "Eingangspuffer" liegt im DVBViewer Filter, der maximal ca. 8 MB an Videodaten vorhält - siehe dazu auch Queued Video Buffers. Jeder einzelne Puffer ist 8 KB groß. Dort befinden sich Daten, die darauf warten, vom Videodecoder abgeholt zu werden. Das gilt allerdings nicht für den Cyberlink, der es dem DVBViewer Filter aus der Hand nimmt, indem er selbst puffert und vorhandene Daten i.a. sofort übernimmt.

 

Falls die Warteschlange des DVBViewer Filters überläuft, meldet er Buffer Overflow-Fehler an die Anwendung, die daraufhin die gesamte Wiedergabe zurücksetzt (stoppt) und neu startet, um die Sache zu bereinigen. Solche Fehler zeigt der DVBViewer Filter auf seiner Eigenschaftsseite an. Ich möchte jedoch bezweifeln, dass ein Pufferüberlauf an dieser Stelle das Ruckel-Problem auslöst. Eher ein Unterlauf.

 

Dazu muss man betrachten, was sich auf der anderen Seite des Decoders tut. Dort wird nämlich ebenfalls gepuffert. Hauptgrund ist das sogenannte Frame-Reordering. Um eine möglichst effiziente Kompression zu erreichen, entspricht die gesendete Reihenfolge der Bilder innerhalb einer GOP nicht unbedingt der Reihenfolge der Darstellung. Jedes Bild hat einen Zeitstempel (PTS, Presentation Time Stamp), der den Darstellungszeitpunkt bestimmt. Der Videorenderer muss eine bestimmte Anzahl dekodierter (!) Bilder vorab speichern und sie gemäß den Zeitstempeln sortieren, bevor er sie ausgibt.

 

Damit dazu genug Zeit bleibt, wird Video i.a. mit einem gewissen Vorsprung vor Audio gesendet, was man auf der Eigenschaftsseite des DVBViewer Filters schön sehen kann, wenn man die laufend angezeigten DVB-PTS vergleicht (PTS -> DVB anklicken, und ein Geheimtip: Ein Klick auf das DVBViewer-Icon der Eigenschaftsseite hält die Anzeige an, so dass man die Werte in Ruhe betrachten kann). Die Video-PTS liegen also weiter in der Zukunft als die Audio-PTS. Sie müssen weit genug in der Zukunft liegen, damit das Frame-Reordering vor der Ausgabe vollständig stattfinden kann. Beim ZDF ist der Video-Zeitvorsprung etwas geringer als bei der ARD, soweit ich das feststellen konnte.

 

Da der DVBViewer Filter ohnehin die gesendeten DVB-Zeitstempel auf die DirectShow-Zeitbasis umsetzen muss, bietet er die Möglichkeit, die PTS beliebig in die Zukunft zu verschieben, was dazu führt, dass mehr gepuffert wird - die Zeit bis zur Darstellung wird länger. Die zuständige Einstellung heißt Latency. I.a. muss man auch den Wert für Max Queued Audio (TV/Radio) entsprechend erhöhen, weil sonst die Überpufferungskontrolle im DVBViewer Filter Alarm schlägt, oder man schaltet diese Kontrollfunktion für Versuchszwecke ganz ab, indem man Max. Queued Audio (TV/Radio) = 0 setzt. Zu beachten ist generell, dass geänderte Einstellungen erst nach "Übernehmen" und einem Stop/Start der Wiedergabe (z.B. Senderwechsel) wirksam werden. Mehr dazu hier.

 

Letztlich hatte ich gepostet, dass auf meinem Uralt-System ARD- und ZDF-HD mit einem älteren Cyberlink kaum Probleme machen. Inzwischen musste ich feststellen, dass das nur für Overlay gilt. Mit dem VMR 9 ruckeltn die ZDF-Ableger auch gerne mal heftig, die ARD-Sender nicht.

 

Daraufhin habe ich probeweise durch Ändern der Latency von 200 auf 2000 und max. Queued Audio (TV/Radio) = 0 die gesamte Wiedergabe drastisch in die Zukunft verschoben - mit dem sichtbaren Erfolg, dass der Eingangspuffer des Cyberlink nicht mehr ausreichte, um die gestauten Daten aufzunehmen, so dass zusätzlich die Eingangspuffer im DVBViewer Filter mit ca. 4 MB zum Zuge kamen. Und damit war das Ruckeln weg! Reproduzierbar.

 

Es wäre von Interesse, ob das auf anderen Systemen auch so ist, und falls ja, wo die Latency-Grenze liegt, ab der es rund läuft - mein System ist sicherlich nicht mit aktuellen PCs vergleichbar (bei H.264 kein DXVA, Single Core-CPU durchweg am Anschlag - eigentlich müsste es nur ruckeln ;)). Man kann davon ausgehen, dass hierbei komplexe Timingverhältnisse über mehrere Komponenten hinweg eine Rolle spielen (bis hin zum Treiber der DVB-Karte), die sich so oder anders ergeben können. Womöglich sind deshalb die Meldungen zu diesem Thema so uneinheitlich - mal geht es unter diesen Bedingungen, mal unter jenen. Es sollten sich alle von der Vorstellung verabschieden, dass sich das Problem an einfachen Kausalzusammenhängen festmachen lässt und es einen eindeutig Schuldigen geben muss. Das ist zu simpel gedacht.

Link to post

Grad mal getestet: Latency auf 200, 400 und 2000ms esetzt -> keine Auswirkung auf die grünen Artefakte.

 

Was mich nur wundert ist, warum ist die Wiedergabe nach dem erneuten Aufbauen des Graphs in Ordnung?

Link to post
Latency auf 200, 400 und 2000ms esetzt -> keine Auswirkung auf die grünen Artefakte.

Das ist auch nicht zu erwarten. Latency betrifft das Ruckel-Problem, da es auf das Timing wirkt, nicht auf das Dekodieren an sich. Artefakte entstehen durch Diskontinuitäten (= fehlende Daten im empfangenen Stream) oder Probleme des Decoders, sich mit der Struktur der Daten zu synchronisieren, d.h. das Erkennen eines geeigneten Einstiegspunktes funktioniert nicht wie vorgesehen. Wenn die Hardware mitdecodiert, kann sie auch daran beteiligt sein. Man muss sich darüber im klaren sein, dass Live-Wiedergabe Random-Access-Fähigkeiten des Decoders erfordert. Der Punkt, an dem der Stream einsetzt, ist absolut beliebig.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...