Jump to content

Erster Eindruck HbbTV-Engine DVBViewer 5.2


Cool_Spot

Recommended Posts

Cool_Spot

Hallo,

habe mir gestern das HbbTV-Feature von DVBViewer Pro 5.2 gekauft, installiert und freigeschaltet.

Leider ist mein erster Eindruck nicht sehr positiv.

 

Z.B.:

ZDF HD:

Die Mediathek (z.B. Rubrik "Sendung verpasst") funktioniert nur sporadisch.

In den meisten Fällen passiert bei Auswahl eines Videos rein gar nichts.

Nach Betätigen des "Roten Buttons" wird dann kurz der Bildschwirm schwarz

und das Live-TV wird wieder eingeblendet.

Auch habe ich den Effekt, dass nach Einblenden von HbbTV und anschließendem

Ausblenden die Channel-Up und Channel-Down Tasten der Fernbedienung

nicht mehr für Live-TV funktionieren. Hier hilft ein kurzes Schalten der Info-Taste.

Anschließend funktionieren sie wieder.

 

RTL HD:

Habe mal "Clipfish Music" angetestet. Hierbei stellte ich fest, dass teilweise enorme Antwortzeiten

bei Betätigen der Navigationstasten entstehen, so dass zunächst der Eindruck entsteht, dass System hat sich

aufgehängt, was aber nicht der Fall ist.

Dann kam nach einem Clipfish-Music Werbeblock eine DVBViewer Pro Exception-Fehlermeldung, dass das

Video nicht gerendert werden kann?!

 

Gelegentlich werden Videos, die eigentlich im 16:9 Format aufgenommen worden sind unter HbbTV im 4:3-Format

angezeigt, was natürlich nicht sonderlich gut aussieht. Von den Eierköpfen ganz zu schweigen ;-)

 

 

Also für mich ist das Feature für den normalen Einsatz noch nicht zu gebrauchen.

Es wirkt instabil und unfertig. Woran das nun liegen mag (Sender oder DVBViewer)

kann ich nicht beurteilen.

 

Vielleicht wird es in einer nächsten Version ja verbessert.

 

Ansonsten funktioniert DVBViewer im normalen Live-TV absolut stabil und ohne Probleme!

 

Gruß

Cool_Spot

 

 

Link to post
  • Replies 180
  • Created
  • Last Reply

Top Posters In This Topic

  • hackbart

    28

  • BALOU

    17

  • nordstern70

    14

  • Cool_Spot

    11

Top Posters In This Topic

Popular Posts

Einfach mal Notepad öffnen, folgenden Code eingeben: Dim DVBViewer Set DVBViewer = GetObject(, "DVBViewerServer.DVBViewer") DVBViewer.HbbTV.LoadInBrowser "http://www.spiegel.de", 0 DVBViewer.H

Hi, habe mir jetzt auch das HBB-TV Plugin gekauft. Gibt es denn irgendwo ne richtige Anleitung dafür?   1. Habe nach einigem Suchen gefunden dass man die Channel+- Tasten brauch, um nach links und

Habt ihr das MP4Stream Preset aktiviert und den LAV-Filter installiert? http://de.DVBViewer.tv/wiki/GraphPresets

Posted Images

@Cool_Spot

Passende Beschreibung,sieht noch sehr nach Beta aus.

Hoffen wir mal das da noch entscheidend nachgebessert werden kann.

Zufällig hatte ich nach einem Beitrag von Tjod erst festgestellt das meine lavstream.fgb nicht im richtigen Ordner installiert wurde,

Das brachte anfangs natürlich schon etwas Frust da eigentlich nichts vernüftig ging.

Link to post
nordstern70

Naja, der erste Eindruck ist schon positiv.

Ganz so negativ würde ich das nämlich nicht beschreiben.

 

1. Es ist ein deutlicher Mehrwert da, den man nicht von der Hand weisen kann.

2. Zu großen Teilen liegen die Probleme bei den Sendern selbst.

3. Alles zu diesem Thema ist ja sozusagen im "Kindergartenalter", also ca. 3-4 jahre nach der Geburt - wenn man so will.

 

Kann also grade mal 2 Jahre laufen, noch nicht perfekt sprechen und das Gehirn ist in der fortwärenden Entwicklung und im Wachstum und ständiger Verbesserung.....

 

Aber: Recht hast du natürlich, das nicht alles super perfekt läuft.

manchmal hat man den Eindruck, das sich der DVBViewer aufgehängt hat, was aber nicht der Fall ist und auch die Tastenbelegung ist von Sender zu Sender anders zu benutzen.

 

Nunja, in der Zukunft wird sich sicher das eine und andere von selbst ( nämlich den Sendern) beheben und von den Entwicklern beheben lassen.

Soviel Vertrauen bringe ich da schon auf ohne zu zweifeln.

 

Deshalb ist es ja nur von Vorteil für alle, wenn Fehler gepostet werden und dabei das Ziel im Auge behalten wird dieses Plugin zu verbessern.

Edited by nordstern70
Link to post

Schön wäre es auch wenn man das Plugin de-und aktivieren könnte(die Zoomerei bei manchen Senderwechseln ist etwas nervig).

Wurde ja von einigen schon angedacht einen eigenen HbbTV Bereich zu eröffnen,momentan stolpert man in vielen Bereichen eher zufällig auf Interessantes.

Natürlich sehe ich die Implementierung von HbbTV auch als Bereicherung an ;)

Link to post
SupaChris

Schön wäre es auch wenn man das Plugin de-und aktivieren könnte(die Zoomerei bei manchen Senderwechseln ist etwas nervig).

 

Da wäre ich auch dafür. Zumal bei einer Deinstallation des PlugIns gleich mal der ganze DVBViewer weggeschmissen wird. Durch das Zoom-Problem kann ich leider das PlugIn derzeit nicht am HTPC nutzen, meine Frau würde mir schon erklären, dass da was nicht stimmt ;)

Link to post

Welches Zoom-Problem bei der Verwendung von HbbTV? Meinst du das mache HbbTV viedeos mit den Falschen Seitenverhältnissen dargestellt werden?

Link to post
Constantin

Ich habe gerade das Plugin aktiviert und es bereitet bei mir massive Probleme, um nicht zu sagen es macht den DVBViewer unbenutzbar.

Es hatte kurzzeitig funktioniert, habe das HbbTV-Portal des Ersten gesehen. Dann ist der DVBViewer leider eingefroren. Seitdem passiert folgendes:

Schon direkt nach dem Start reagiert das Fenster kurzzeitig nicht. Dann öffne ich die Senderliste, auch hier wieder kurzzeitiges Einfrieren. Beim Ein-/Ausklappen der Senderliste und Anklicken eines Senders ebenfalls Einfrieren.

Bekomme auch weder Bild noch Ton, wenn ich einen Sender auswähle.

 

Fände ich auch praktisch, wenn ich das Plugin einfach kurzerhand deaktivieren könnte...

 

\\edit: Ok, auf wundersame Weise (habe nichts verändert) lief's jetzt gerade ohne Einfrieren. Nach kurzer Zeit kam allerdings die Meldung "User data error 1279: Please user KeyTool.exe to enter the correct data" und der DVBViewer hat sich beendet. Meine Daten im KeyTool stimmen aber?!

Edited by Constantin
Link to post
Constantin

Ok, das mit den Userdaten lag daran, dass ich mir auch eine komplett neue DVBViewer-Lizenz geholt hatte und nicht bedacht habe, dass ja auch die Setup-Datei schon auf eine Lizenz gemünzt ist. Also mit einer neuen nochmal installiert, läuft jetzt ohne Fehlermeldung, auch das Freezen scheint erst mal behoben zu sein. Habe das Gefühl, dass es hier und da noch etwas hakt, aber ich teste erst mal weiter, bevor ich berichte...

Link to post
hackbart

Naja es gibt ein Problem beim ZDF das gab es seit Beginn an. Mal wird die Seite richtig geladen und mal nicht. Der Inhalt ist der selbe, nur wird die Description nicht angezeigt bzw. die Suche. Im Debugger sieht man das die Div Elemente außerhalb der Anzeige zu finden sind. Ob das nun ein Fehler vom Webkit ist, oder vom ZDF vermag ich nicht sagen. Letzteres ist allerdings unwahrscheinlich. Je nachdem ob der Mimetyp application/vnd.hbbtv.xhtml+xml ist oder nicht, verändert sich das verhalten. Abspielen kann man die Videos dennoch, indem man "blind" 2x rechts drückt.

Das andere größere Problem was einige Nutzer haben ist mindestens genauso nervig, Tjod und ich hatten da die letzte Woche schon etliche Stunden mit verbracht. Irgendwann hat die Engine die Zustandsinformationen nicht mehr an die HbbTV Anwendung geliefert. Das trifft aber nicht auf jedes System zu und ich konnte es heute zufällig in einer Windows 7 VM reproduzieren und hoffentlich beheben. Die nächsten Tage verbringe ich wohl damit das zu testen bzw. die COM Schnittstelle zu erweitern, damit man auch in Plugins auf Webseiten zugreifen kann. Ich denke mal im Laufe der nächsten Woche gibt es dann eine 5.2.1 als Update. Da ist dann auch die Ansteuerung von MHEG5 ähnlich wie bei HbbTV.

Link to post
nordstern70

Bei Gelegenheit könntet Ihr mal auf die Sendergruppe der Bayerischen Lokalprogramme schalten. Auch dort bietet man bei den meisten Hbb Infos an nur, das zwar die "Red-Butten" Logos kurz erscheinen, sich jedoch nichts weiter tut.

Link to post

Ich weiß jetzt nicht welche du meinst. Aber wahrscheinlich bekomme ich die hier nicht per Kabel.

Du könntest aber mal selber in der Debug Console gucken ob an den Daten die die schicken was auffälliges zu sehen ist. Sofern du etwas Ahnung von HTML hast.

Dazu musst du in der hbbtv.ini im Konfigurationsverzeichnis einen Eintrag hinzufügen.



[Browser]
....
11=Debug Konsole|debug

Und dann kannst du über das OSD--Menü > HbbTV (auf einem Sender ohne HbbTV) die Debug Konsole aufrufen und denn auf den Sender wechseln den du untersuchen möchtest.

Link to post
  • 2 weeks later...
GBWebmaster

Bin seit heute auch stolzer Besitzer von HbbTV.

 

Was mir auffiel ist der Umstand, dass ich aus der ARD-Mediathek heraus keinen Film starten kann. Auswählen ja, aber nach kurzer Zeit und schwarzem Bildschirm flieg ich komplett aus HbbTV heraus und bin wieder beim laufenden Fernsehbild - das Ganze am MediaPC und meiner TV-Ausgabe.

 

Auf dem Arbeitsrechner ein etwas anderes Verhalten: Hier wähle ich einen Film aus, anschließend kommt gleich die Einblendung "Was wollen Sie tun" d.h. es wird getan, als ob ich den Film schon angeschaut hätte ...

 

 

Kann dieses Verhalten von anderen bestätigt werden?

Ansonsten kann ich dann auch eine support.zip nachreichen.

 

 

Gruß GBWebmaster

Link to post

Das HbbTV Plugin habe ich wieder deinstalliert.

Leider war dann auch eine Neuinstallation des DVBViewer nötig.

Zum Plugin(nur meine persönliche Meinung)

zum jetzigen Zeitpunkt in meiner Umgebung nicht praxistauglich.

Ist eigentlich zuviel um alles aufzuzählen

-ständige gezoome(auch bei Zoomeinstellung alles 0)

-aufruf aus den ZDF Mediatheken nicht 1 Beitrag abspielbar

-teilweise falsche SV

-DVBViewer über einen gewissen Zeitraum lahmgelegt bis wieder bedienbar

-aufwachen aus dem Standby fehlerhaft

Die Vielzahl an Fehlern schreckt ein ab aktiv zu testen.

Finde ich schon sehr optimistisch so etwas unausgegorenes kostenpflichtig anzubieten.

Aber die Hoffnung stirbt zuletzt in den nächsten Versionen werde ich es natürlich wieder testen.

Link to post

...ZDF Mediathek: Chose in options "Transparency - TV window in Background" and everything will be selectable and play.

Link to post

Inzwischen hab ich mir auch mal ein paar Mediatheken mit dem HbbTV Plugin angeschaut. Mich interessieren haüptsächlich die Mediatheken der ARD Gruppe. Problemlos funktioniert die "Das Este Mediathek", die Filme werden sowohl im "Vorschaufester" der Mediathek als auch im Vollbildmodus abgespielt. Bei allen andern ARD Mediatheken (ARD Mediathek, alle 3. Programme Mediatheken) werden die Filme nur im Vorschaufenster abgespielt. Beim Umschalten auf Vollbild läuft der Film zwar weiter - Ton wird ausgegeben - aber das Bild bleibt schwarz. Haben die Mediatheken der 3. Programme ein anderes Videoformat, muss dafür ein ein spezieller Flashplayer o.ä. installiert sein? Das Abspielen der Filme aus den Mediatheken der 3.Programme über den Firefox geht problemlos. WinXPSP3, DVBV 5.2, RS 1.26, PDVD10/12 Decoder.

wade77

Link to post

...das Problem mit dem Nicht-Abspielen lässt sich meistens durch 2mal drücken der Pausetaste auf der FB beheben.

 

Grüsse

 

hoto44

Link to post
hackbart

Das Problem mit der ZDF Mediathek ist auch "behoben". Im Prinzip werden nur diverse divs nicht richtig gerendert. Das wird wohl, so wie ich dank Hilfe vom MITxperts erfahren habe, durch den Webkit verursacht wurden sein. Zumindest unterscheidet man beim ZDF lediglich bei der Übertragung des Inhalts zwischen den Useragenten. Setzt man einen nicht HbbTV tauglichen Agenten gehts in 99% der Fälle, ansonsten muss man 2x die Pausetaste auf der Fernbedienung drücken. Ist halt etwas ärgerlich, aber mit dem neuen Update wird es besser. Und was auch prima geht ist über die Com Schnittstelle den Browser anzuweisen eigene Seiten anzusteuern. Im übernächsten Release werde ich die Html5 und WebGL Unterstützung freischalten.

Link to post
GBWebmaster

Ich bin es nochmals. Also wie gesagt, bei mir geht die Wiedergabe der Mediathekenvideos nicht - getestet auf 2 Rechnern.

Die Support.zip hab ich mal angehängt.

 

Was müsste ich in meinem System ändern, damit dies funktionieren würde?

 

 

 

Gruß GBWebmaster

support.zip

Link to post
hackbart

Hi, das System ist recht übersichtlich. Da fehlt lediglich ein MP4 Splitterfilter. Der Einfachheithalber sollte der Lav Splitter ausreichen: http://1f0.de/lav-splitter/.

Alles andere ist in deinem System vorhanden (sprich die Codecs).

Link to post
GBWebmaster

Hallo Christian,

 

Danke schon mal. Damit geht nun zumindest die ARD-Mediathek.

 

Nicht funktionieren tut jedoch die ZDF-Mediathek.

Und bei den anderen Dritten (SWR, BR) hab ich bei den Videos zwar Ton, aber kein Bild. Auch mit Pause drücken und weitermachen nicht ... :(

 

 

Gruß GBWebmaster

Link to post
hackbart

@Wade77: Das ist kein Fehler, da muss in der Hbbtv.ini nur angegeben werden das die einen Colorkey nutzen. Die aktuelle Version schaut dann so aus:

 

[blacklist]
0=http://hbbtv-videos.daserste.de/*
1=http://smarttv.nexxcdn.com/310/*
2=http://cpix.daserste.de/*
3=http://www.rtl2.de/hbbtvp*
4=http://arte.*
5=http://hbbtv.zdf.de/zdfhjplus*
6=http://hbbtv.prosieben.de/voting/*
7=http://hbbtv.br.gl-systemhaus.de/*

​Christian

 

Link to post

Ich muss zugeben, dass ich die 5.2 inkl. HBBTV noch gar nicht installiert habe. Warte auf das erste Update wg. der COM Erweiterung.

 

Anyway: Wäre es sinnvoll, die hbbtv.ini separat im Member-Bereich zum Download anzubieten? Ich gehe mal davon aus, dass es in der nächsten Zeit öfters Updates geben wird, zumindest öfter als neue DVBViewer Versionen.

Link to post
hackbart

Naja im Prinzip schon, allerdings überlege ich noch das Format komplett umzuwandeln und die jeweiligen Javascripte auch direkt einzubinden. Das könnte man ähnlich wie in Opera direkt online anbieten und quasi regelmäßig aktualisieren. Außerdem werden derzeit die Skripte und auch die hbbtv.ini im Einstellungsverzeichnis gespeichert und das ist zugegebenermaßen nur sinnvoll wenn Nutzer die auch ändern oder wir die Datei regelmäßig über unseren Server aktualisieren.

Geplant ist vorerst ein Service-Update vom DVBViewer zu veröffentlichen mit diversen Bugfixes die in den letzten 2 Wochen notwendig wurden und danach sehen wir in Ruhe wie wir das am besten umsetzen.

Link to post

@hoto44:...ZDF Mediathek: Chose in options "Transparency - TV window in Background" and everything will be selectable and play. ...
funktioniert gut, die Einstellungen sind aber nach dem Beenden des DVBViewers wieder weg.

@Christian [blacklist]....
hab mir für die 3.Programme entsprechende Einträge in der Hbbtv.ini gemacht. Funktioniert noch nicht für alle Sender, aber schon für einige, schöne Sache.
z.B.
7=http://hbbtv-media.wdr.de/*
8=http://hbbtv-ondemand.swr.de/swr-fernsehen/*
9=http://multistream.rbb-online.de/*

den Eintrag
0=http://hbbtv-videos.daserste.de/* habe ich ändern müssen in
0=http://hbbtv-videos-ard.daserste.de/*

Bayerisches FS
7=http://hbbtv.br.gl-systemhaus.de/* hat bei mir nichts gebracht (auch nicht mit 7=http://hbbtv.b7.br.gl-systemhaus.de/*)
Die ausgewählten Videos werden aber im Hintergrund abgespielt (kein schwarzes Bild wie bei den anderen 3. Programmen, sondern weißer Hintergrund mit einem "Start-Stopp-Pause Menü). Nach dem Drücken der ESC-Taste werden die Videos im Vollbildmodus dargestellt. Zurück zur Videoauswahl gehts dann mit F5 (Red-Butten). Die Dateiauswahl ist in der BR-Mediathek bei mir nur mit der Maus möglich, nicht mit den Pfeil-Tasten.

Bedanke mich für die bisherigen Informationen, werde bei Gelegenheit noch ein wenig weitertesten.
wade77

Link to post
hackbart

Die Pfeiltasten gehen komischerweise bei einigen Seiten nicht, ich habe zwar schon eine Vermutung - die IWebkit bzw. Chromium betrifft, allerdings muss ich das noch testen. In der nächsten Version kann man via den Tasten Kanal +/- die einzelnen Elemente auswählen (adäquat zu Tab bzw. Shift+Tab). Das ist zwar nicht schön, aber es funktioniert denke ich recht gut. Zumindest kann man dann halbwegs mit einer Fernbedienung die Elemente ansteuern, die sich mit Cursortasten verweigern,

Ansonsten danke für die 3 zusätzlichen URLs.

Link to post

Hallo, ich habe gerade die neue Version des Plugins installiert. Dabei ist mir folgendes aufgefallen:

In der hbbtv.ini steht:

2=launchpad/index.html|http://astramediencenter.sport1.de/

Ich musste noch

http://

vorsetzten, damit die Weiterleitung funktioniert.

 

Rausgekommen ist dabei siehe Bild.

uvwdov8d.png

 

Anbei die

MfG Christian

 

Link to post
GBWebmaster
Nicht funktionieren tut jedoch die ZDF-Mediathek.

Und bei den anderen Dritten (SWR, BR) hab ich bei den Videos zwar Ton, aber kein Bild. Auch mit Pause drücken und weitermachen nicht ... :(

 

Dies ist auch mit dem neuen Update immer noch so ...

Link to post
hackbart

@janee: Ja das liegt daran dass Webkit ein http davor setzt, dass ist in der AIT nicht drin (das ist die Tabelle in der die jeweiligen Links gespeichert sind und da steht beim aktiven Link im Fall von Sport1 HD: launchpad/index.html - der eigentliche Link ist im optionalen Boundary Descripter, warum auch immer). Im Prinzip muss das bevor die Seite geladen wird schon angepasst werden. Das geht im nächsten Update. Auch kommt keine Fehlermeldung mehr wenn die Seite nicht existiert, außer man hat grade den Browser offen. Ist im aktuellen Release behoben - ich werde das die Woche noch veröffentlichen.

 

@GBWebmaster: Logisch, da das im DVBViewer angepasst werden musste. Die aktualisierten Daten im Plugin betreffen nur das was im Changelog steht. Der Rest wurde im Hauptprogramm angepasst.

Link to post

noch zur Ergänzung zu 34:

im Bay. Fernsehen funktioniert das Abspielen der Panoramabilder recht gut.

Beim Versuch in Mediatheken abzuspielen (z.B. ZDF) kommt die Meldung: bitte warten, Daten werden geladen und danach (Pfeil rechts):Bitte warten, lade Video. Dann ist Ruhe.

 

Thori

Link to post
nordstern70

Bei Gelegenheit könntet Ihr mal auf die Sendergruppe der Bayerischen Lokalprogramme schalten. Auch dort bietet man bei den meisten Hbb Infos an nur, das zwar die "Red-Butten" Logos kurz erscheinen, sich jedoch nichts weiter tut.

 

Hi,

bin grad aus dem Urlaub zurück.

 

Bei den Lokalprogrammen aus Bayern ( über Sat) erscheint nun länger die Butten-Einblendung, es tut sich jedoch nichts weiter.

 

Beim ZDF laufen die Vids nicht.

Link to post
nordstern70

noch zur Ergänzung zu 34:

im Bay. Fernsehen funktioniert das Abspielen der Panoramabilder recht gut.

Beim Versuch in Mediatheken abzuspielen (z.B. ZDF) kommt die Meldung: bitte warten, Daten werden geladen und danach (Pfeil rechts):Bitte warten, lade Video. Dann ist Ruhe.

 

Thori

 

ja, so ist's bei mir auch

Link to post
hackbart

Bei BR fehlte der Colorkey, das ist in der letzten Version des Plugins drin und geht auch so wie es soll:

brmediathek.jpg

 

ZDF funktioniert auch in der aktuellen Version, wie gesagt die kommt vorrausichtlich morgen raus.

 

zdf.jpg

 

Das gleiche gilt für Sport1 HD:

 

sport1hd.jpg

 

Link to post
nordstern70

Will morgen aufs Dach und meine Mulifeedanlage justieren und abändern, den 28° Sat in den Fokus nehmen. 19 und 13 ° sollen schielend mit 1,20m gehen und möchte den 23° gegen den 26° wechseln.

Damit kann ich das Parlamentsfernsehen nicht mehr empfangen, eigentlich nicht tragisch.

Aber, könnte man die Website auch in der HbbTv Engine einbinden?????

Edited by nordstern70
Link to post
hackbart

Klar, mit der Comschnittstelle kann man sich u.a. ein Script erstellen das die Seite jederzeit lädt.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...