Jump to content

HD läuft flüssig mit Single Core und AGP Grafik !


craig_s

Recommended Posts

@schlucki Deine beschriebene Konstellation sollte auf jeden Fall funktionieren.

 

 

Ich hatte ein System bestehend aus Radeon HD 2400 Pro AGP und Athlon 64 3000+ getestet. Da lief es problemlos. Also wird es auch mit der 3650 ordnungsgemäß laufen.

 

 

@gwr Was meinst du mit AGP Hotfix Treiber? Ist das die Geschichte das die Subsys ID der AGP Modelle nicht in den Original AMD/ATI Catalyst Treiber Inf-Dateien steht und deshalb die automatische Installation nicht funktioniert?

 

Ich hab da immer manuell installiert und einfach das entsprechende PCI-e Modell meiner AGP-Karte in der Deviceliste ausgewählt und die Installation praktisch "erzwungen". So konnte ich auch immer den neuesten Catalyst Treiber von der AMD Seite nehmen und war nicht auf Sapphire und Co. angewiesen.

Edited by toro1978
Link to comment
  • Replies 202
  • Created
  • Last Reply

Top Posters In This Topic

  • craig_s

    75

  • Tüftler

    27

  • HVR4000er

    20

  • harno

    10

Top Posters In This Topic

Posted Images

.. bezüglich ATI-Grafikkarten umgesehen und hab jetzt 2 zur Auswahl. Nämlich die ASUS AH3650 und die Sapphire Radeon HD3850. Mir persönlich wär die ASUS lieber weil diese hat einen Passivkühler. Nun zu meiner Frage. Ist diese ausreichend um HDTV über DVBViewer bzw. BlueRay files in 1080p flüssig abzuspielen oder micht die 3850ér mehr Sinn. Mein Rechner ist ein Athlon64 3000+ bei 2400Mhz betrieben und 1Gb Ram.

Hi schlucki,

ja, bequem wär es jetzt wenn man sagen konnte schau her, der und der mit genau der Hardware hatte Erfolg - deshalb mein Aufruf funktionierende Konstellationen hier mal zu dokumentieren (s.o.).

 

So kann ich nur sagen es MÜSSTE gehen. Mehr nicht, leider! Deswegen auch mein Tip viel weiter oben, so kaufen, daß man die Karte wieder zurückgeben/schicken kann wenn es nicht tut wie es soll. Oder wie toro1978 für 10 Eurole ;) Pardon, bei AGP dürfte das schwierig werden..

Grad hab ich gelesen:

Modelle in der HD 3000 Serie sind weiterhin mit der neuesten ATI Avivo HD Technologie für bessere Video-Wiedergabe ausgestattet und bieten einen bereits eingebauten UVD (Unified Video Decoder) für die Hardware beschleunigte Dekodierung von Blu-ray und HD DVD Inhalten sowohl für VC-1 als auch H.264 Codecs.

..sollen wir ihnen glauben?

Was der DVBViewer von der Hardware verlangt ist, wie man bei toro1978 sehen kann, unglaublich gering, gemessen an dem Theater das hier im Forum veranstaltet wird. Bei meiner Hardware hab ich jetzt gerade BluRay aktiviert, läuft schon beim ersten Versuch flüssig mit ~28% Tendenz sinkend.

 

Bis du die Karte bekommst bereite schon einiges vor:

daß du den letzten (Catalyst)Treiber vom Hersteller hast, weil Ati AGP nicht offiziell unterstützt. (Nur inoffiziell über die Hersteller).

Den Cyberlink h.264 auch schon installiert,

die blauen HD-Sender sollten im DVBViewer auch schon anwählbar sein (und mit deiner jetzigen Karte evl. komplett schwarz bleiben).

Weil die aber rel. unzuverlässig sind wegen DVBViewer's Senderlisten-Problemen bereite schon vorab einen sichereren Test vor:

 

Lade diese Media Player Classic (MPC) Version runter und

dieses (117MB) HD-Video

Starte MPC und vergewissere dich, daß in view - options - "Interne Filter" rechts alle H264 und AC3 aktiviert sind.

 

Wenn die Karte eingebaut ist starte den Taskmanager mit strg-alt-del und dort auf "Systemleistung".

Dann ziehe das HD-Video auf die mplayerc.exe

das Video wird abgespielt, derweil sollte die CPU-Auslastung bei ~10% oder weniger sein.

 

Wenn das der Fall ist wird DVBViewer bei 1080i-Sendern auch flüssig laufen falls er jetzt mit HD noch Zicken macht..

 

so, mal wieder locker 3 Stunden erklärt, gut Nacht...

Edited by craig_s
Link to comment

>>Da werden sich die Dual- und Quad Core Nutzer verwundert die Augen reiben, was alles selbst mit einem 1 GHz Single Core im Zusammenhang mit Hardwarebeschleunigung der Grafikkarte möglich ist ;)

 

Genau diese Information ist schon hier im Forum verfügbar, seitdem es Grafikkarten gibt, die H.264 in Hardware unterstützten (und das müssten jetzt auch schon bald 2 Jahre sein :)). Das einzig neue hier ist, dass es auch mit AGP Karten funktioniert. Daher könnt ihr ruhig auf dem Teppich bleiben ;)

Wo verfügbar?

Edited by craig_s
Link to comment

@ Moses - P.S.

Wenn das so ist, warum steht diese Botschaft "HD flüssig möglich mit 1GHz" nicht schon seit 2 Jahren

so breit

über dem HDTV Forum um die verirrten Schäflein auf den rechten Pfad zu bringen?

Warum gibt es hier nicht schon seit 2 Jahren ein Wiki o. Pinned: "HD flüssig Erfolge mit folgenden Hardware/Treiber/Codec Kombos" oder so ähnlich? Das wäre doch extrem beruhugend und hilfreich für alle, vom Anfänger bis zum Spezialisten.

 

Verehrter Herr Forums-Mitbegründer, du hast das doch damals auch super hinbekommen mit den 10 Geboten vom Berg Sinai...

Kannste das jetzt nicht nochmal bringen? ;)

Edited by craig_s
Link to comment
Ich hab da immer manuell installiert und einfach das entsprechende PCI-e Modell meiner AGP-Karte in der Deviceliste ausgewählt und die Installation praktisch "erzwungen". So konnte ich auch immer den neuesten Catalyst Treiber von der AMD Seite nehmen und war nicht auf Sapphire und Co. angewiesen.

Hammerhart !!! Das klappt? Keine Probs mit Spielen oder so? Aber auch in der Zukunft?

 

Wenn ja, wäre ja damit das aktuelle-AGP-Treiber-Nachschub-von-trägen-Herstellerseiten Ärgernis gelöst!

Edited by craig_s
Link to comment

Update @ schlucki

nimm lieber dieses (leider grössere, 117MB) Video zum Testen mit MPC. Weil das andere hat noch Karaoke-Laufschrift dabei und die verleitet MPC u.u. dazu DXVA nicht zu benutzen.

Diese Links kommen von watching h.264 videos using DXVA wo die Einstellungen für MPC nochmal genau beschrieben sind.

 

Kannst die Videos ja auch schon mal mit deiner jetzigen Hardw. testen.

Ob MPC DXVA benutzt teilt er einem auch mit -> in Play - Filters - "MPC Video Decoder" bei "DXVA Mode".

"Not using" oder was anderes.

Link to comment

Hallo craig_s

 

Habe das von dir angesprochene Video getestet. Mit dem MPC-Videodekoder geht das ganze nicht so flüssig wie mit dem PowerDVD(Version 7.2). Beim MPC-Dekoder steht dass DXVA nicht verwendet wird beim Cyberlink ist ein Hacken vor DXVA. Die Prozessorlast ist meistens so bei 85%, manchmal auch bei 100%. Das sieht man dann auch in der Anzahl der übersprungenen Bilder. Bin schon gespannt wie das ganze dann mit neuer Graka aussieht. Werde diese in den nächsten Tagen zusammen mit einer neuen TV-Karte für Kabel(Übersiedlung) bestellen. Danach werde ich meine Erfahrungen berichten.

 

sg

Schlucki

Link to comment
Beim MPC-Dekoder steht dass DXVA nicht verwendet wird beim Cyberlink ist ein Hacken vor DXVA. Die Prozessorlast ist meistens so bei 85%, manchmal auch bei 100%.

Wenn man es erstmal eingeschaltet hat bleibt das DXVA Häkchen beim Cyberlink immer, egal ob er Hardw.Beschleunigung gerade verwenden kann oder nicht.

Der MPC-Dekoder zeigt dir seinen tatsächlichen momentanen DXVA Zustand.

"Not using DXVA" kann ausgelöst werden durch die kodierung des Videos bzw. fehlende Codecs/Splitter usw. oder nicht vorhandene Hardware Unterstützung.

Die .ts Dateien die DVBViewer bei HD-Aufnahme erzeugt spielt er schon mit den eingebauten Filtern flüssig wenn die Graka DXVA unterstützt und ts bei "Interne Filter" angehakt ist.

Link to comment

Wichtiges Update für Radeon HD AGP Treiber:

 

Ati stellt doch auf seinen Seiten neueste AGP-Treiber für die HD2000/HD3000 Serie zur Verfügung:

http://support.amd.com/us/kbarticles/Pages...tAGPHotfix.aspx

 

Ich habe den "Catalyst 8.12 Hotfix" jetzt ausgiebig getestet mit super Ergebnis.

- nochmal niedrigere CPU-Auslastung mit DVBViewer

- wichtig für ungestörte Blu-ray / HD-DVD Wiedergabe !

(mein Laufw: LG GGC-H20L über SATA Controller Karte)

 

Installation:

- erst den neuesten (Catalyst)Treiber vom Karten-Hersteller mit allem drum und dran (AVIVO, HDAudio, CCC usw.) installieren.

- dann den Hotfix einfach drüber.

 

Sollte der Link oben mal nicht mehr gehen:

http://support.amd.com/

suchen nach:

Catalyst AGP Hotfix Radeon HD 3000

 

Dank an gwr für den Hotfix-Tip!

Edited by craig_s
Link to comment

p.s.

der im Topic beschriebene Fehler

- Pixelsalat wenn man im DVBViewer direkt zwischen 1080i-Sendern zappt (Astra+Anixe) und beim Vor- und Zurückspringen im MPC

 

ist mit "Catalyst 8.12 Hotfix" auch weg. :)

Link to comment

Jemand ahnung ob dies auch mit onboard HD Lösung funzt?

 

Hab damals extra diesen ASrock Müll gekauft um später festzustellen, das die versprochene HDCP nicht funktioniert bzw. eine superstarke CPU benötigt.

 

Gruß

G

Link to comment

Hallo!

Habe ja versprochen meinen Erfahrungsbericht zu liefern.

Mein System: WinXP SP3, Athlon64 bei 2,4 GHz(Single Core), ATI HD3600 AGP(ATI 9.1 Treiber), Mystique Cabix DVB-C (mit KNC-BDA-Treiber), PowerDVD8 H.264-Decoder

post-34330-1234172032_thumb.jpg

Die über meinen Kabelbetreiber angebotenen Sender(AstraHD+, AnixeHD und ORF1 HD) laufen alle super. Die im Bild erkennbare CPU-Last liegt so um die 15-30% im VMR9-Video Renderer. Mit dem Overlay Mixer sinkt diese sogar auf 5-10% ;)

Zur Wiedergabe von MP4/MKV-Files:

Das weiter oben im Thread angebotene Testviedeo (https://dl.getdropbox.com/u/132004/Q-R_Utaw...1080_VFR%29.mp4) läuft mit dem MPC-HC bei Verwendung des MPC-Video-Decoders auch einwandfrei(CPU-Last 5-10%).

Was mir weiters aufgefallen ist: Ist ein HD-Video-File in 1080p vorhanden und wird dieses nicht beschleunigt stößt man mit dieser CPU schnell an die Grenzen des flüssig ablaufenden Bildes. Die CPU Last geht schnell gegen 100%. Guter Videodecoder ist hier der von DIVX, dabei sinkt die CPU-Last im Vergleich zum PowerDVD8 Decoder um 25%.

Im großen und ganzen bin ich vollkommen zufrieden, dass ich mich dazu entschieden habe mein altes System mit einer neuen Graka aufzurüsten. Brauche es ja nur zum Fernschauen als HTPC und nicht zum Gamen. Wie sich das ganze bei Blueray-Titeln schlägt werde ich auch bald testen, sobald ich ein entsprechendes Laufwerk gekauft habe. Also ich hoffe ich konnte einen guten Einblick in die Welt des HD-Fernseherlebnisses mit Singel Core CPU und entsprechender Grafikkarte geben.

 

Also dann viel Spaß noch

Link to comment

Siehste schlucki, alles wird gut! Und massenweise Zeit, Nerven und Euros gespart mit Einrichten von nem neuen PC!

 

Ist ein HD-Video-File in 1080p vorhanden und wird dieses nicht beschleunigt stößt man mit dieser CPU schnell an die Grenzen des flüssig ablaufenden Bildes. Die CPU Last geht schnell gegen 100%. Guter Videodecoder ist hier der von DIVX, dabei sinkt die CPU-Last im Vergleich zum PowerDVD8 Decoder um 25%.

..z.B. beim "Elfen Lied" Video lädt der MPC den "DirectVobSub (auto-loading version)"-Filter (falls installiert) mit dazu um die Karaoke Laufschrift darstellen zu können. Mit DirectVobSub weigert sich der "MPC Video Dekoder" aber DXVA zu können und schon steigt die CPU-Last. Zur Abhilfe den Merrit vom DirectVobSub auf 0x400000 runter (mit geeignetem Tool zB. GSpot) und schon läufts flüssig ohne Karaoke.

Auch sonst muß man sich durch die trickreichen "Interne Filter"-Settings vom MPC (und überhaupt einige Codec-Splitter ect. Jongliererei) erst mal durchbeissen, einfach alle Häkchen setzen ist nämlich überhaupt nicht optimal. Dazu unten mehr..

 

Im großen und ganzen bin ich vollkommen zufrieden, dass ich mich dazu entschieden habe mein altes System mit einer neuen Graka aufzurüsten. Brauche es ja nur zum Fernschauen als HTPC und nicht zum Gamen.

Wirste erstaut sein wieviel Spiele gut rennen! Ja, natürlich nicht die allerneuesten allerhärtesten in riesen Auflösung.. Die interessieren mich eh net.

 

Wie sich das ganze bei Blueray-Titeln schlägt werde ich auch bald testen, sobald ich ein entsprechendes Laufwerk gekauft habe.

Solltest du mit Blu-ray gelegentlich Bildaussetzer haben empfehle ich dringend den "Catalyst AGP Hotfix" Link von 5 Posts weiter oben. Er ist inzwischen bei 9.1 und hat bei mir vieles verbessert. Auch ohne DXVA laufen bei mir damit einige HD-Videos flüssig.

Grundsätzlich alle Treiber immer irgendwo aufheben! Man weiß nie was der nächste bringt...

 

 

@ alle

im MPC "Interne Filter" den Haken bei "MPEG PS/TS/PVA" doch nicht setzen! Dieser be/verhindert die Ausgabe von einigen Sorten Videos, u.a. evo. DVBViewer's ts Dateien brauchen ihn auch nicht. evo und einige andere brauchen ausserdem den Haali Matroska Splitter (den echten, nicht den internen von MPC). "MPEG-2 Video" darf MPC-intern manchmal auch nicht gesetzt sein.

 

Ausnahme: ts Dateien von manchen Receivern brauchen den Haken bei "MPEG PS/TS/PVA".

 

;)

Edited by craig_s
Link to comment

P.S.

 

um gleich dem nächsten "Schock" vorzubeugen -

jeder eben neu installierte Catalyst macht beim ersten Start einen Grafik-Test um sich selbst einzustellen. Wenn man direkt danach DVBViewer startet bleibt alles Pechschwarz!

 

Einfach PC nochmal neu starten und alles Läuft wie gewohnt.

Edited by craig_s
Link to comment

Also ich habe das

 

- Windows XP inkl. SP3

- aktuellstes DirectX (nov 2008)

- als auch aktuellste ATI Catalyst 9.1 Treiber

- sowie PowerDVD8 installiert,

- in DVBViewer ist für den PowerDVD Codec auch DXVA aktivert.

 

Aber die CPU Last bei AnixeHD ist dennoch zwischen 50-95 Prozent schwankend.

Im Catalyst Control Center wird die Auslastung der GPU wenn AnixeHD läuft mit 16 Prozent angezeigt.

 

CPU: Pentium 4 D631 mit 3GHz und 2MB Cache

GPU: GeCube Radeon HD2400 Pro 256MB PCIe, Auflösung 1920x1080, 32bit

 

Nachdem andere hier durchwegs schnellere Grafikkarten von ATI eingesetzt haben, 2600er bzw. 3600er Modelle, frage ich mich ob ich an der Konfiguration noch was verbessern kann, oder ob die GPU schon ausgereizt ist bei der Beschleunigung von H.264 Video.

 

Denn von den hier berichteten CPU Auslastungen bei HDTV von um die 10% ist mein Rechner ja noch weit entfernt.

 

Grüße,

Christian

Link to comment

Wie ich mittlerweile feststellen musste fehlt mir im DXVA Checker auf der Seite Decoder Device der Eintrag für den PowerDVD H.264 Codec. Nur wieso kann ich nicht nachvollziehen.

 

Das tritt auf zwei PCs, sowohl mit Radeon HD2400 Pro als auch HD4350 auf

post-75474-1234275195_thumb.png

post-75474-1234275216_thumb.png

post-75474-1234275380_thumb.png

post-75474-1234275386_thumb.png

Edited by Tedric
Link to comment

Hallo Leute!

Habe ja in meinem vorigen beitrag geschrieben dass alles einwandfrei läuft. Das tut es aber auf einmal nicht mehr. Wenn ich ORF1-HD schaue friert nach kurzer Zeit das Bild ein und der Ton läuft weiter. Das passiert im Overlay und VMR9 renderer. Bei ANIXE-HD und ASTRA-HD+ tritt das nicht auf. Habe schon alles ausprobiert. ATI hotfix 8.12 installiert, habe jetzt ATI hotfix 9.1 aber es ändert nichts. Habe zwischendurch mal PowerDVD 8 neu installiert hilft aber auch nichts. Das eigenartige an der Sache ist wenn ich bei eingefrorenen Bild das Catalyst Control Center öffne beginnt das Bild wieder normal weiterzulaufen. Habe darauf hin schon alle möglichen Einstellungen im CCC vorgenommen. Hilft aber alles nichts.

Hat jemand eine Idee was ich da probieren könnte.

Was mir noch aufgefallen ist, wenn ich auf Filter -> VMR 9 Renderer klicke öffnet sich kein Fenster, gleiches beim Overlay Renderer. Hat da jemand Erfahrung wie man dass wieder aufrufen kann?

 

Für jede Hilfe dankbar

 

Schlucki

Link to comment
Wie ich mittlerweile feststellen musste fehlt mir im DXVA Checker auf der Seite Decoder Device der Eintrag für den PowerDVD H.264 Codec. Nur wieso kann ich nicht nachvollziehen.

 

Das tritt auf zwei PCs, sowohl mit Radeon HD2400 Pro als auch HD4350 auf

- der Eintrag für den PowerDVD H.264 Codec wird nur angezeigt, wenn du ein geeignetes HD-Video in das "Decoder Device"-Fenster vom DXVA Checker ziehst.

 

- die HD4350 hat jedenfalls alles laut DXVA-Checker

 

- hab grad woanders gelesen, daß der allerneueste PowerDVD8 Ultra v.25xx Zicken macht und man wieder auf 22xx zurückgehen soll falls das auf dich zutrifft.

 

- mach mal diesen Test:

Lade diese Media Player Classic (MPC) Version runter und

dieses HD-Video (117MB)

Starte MPC und vergewissere dich, daß in view - options - "Interne Filter" rechts alle H264 und AC3 aktiviert sind. MPC beenden.

 

Dann ziehe das HD-Video auf die mplayerc.exe

das Video wird abgespielt, derweil gehe ins Menü:

-> in Play - Filters - "MPC Video Decoder" bei "DXVA Mode", was steht da?.

1) not using DXVA

Treiber oder Karte defekt oder falsch eingestellt oder können's nicht

 

2) was anderes als "not using DXVA"

Hardw. Beschleunigung wird verwendet (CPU-Last müßte jetzt auch niedrig sein)

d.h. falsche DirectX-Settings im DVBViewer und/oder (PDVD) Codec funzt net.

u.v.a.m...

Link to comment

@ schlucki, Orf HD hab ich net..

 

welche TV-Karte?

 

in DVBViewers DirectX-Optionen beide Haken vor Audioformat/Videoformat automatisch..?

 

bein VMR9 auch das vorm VMR-Fix..?

 

sieht aber nach nem Codec-Problem aus, versuch mal ältere/andere

versuch die 3 sec aufzunehmen ind schau was der MPC mit dem TS anfangen kann..

Edited by craig_s
Link to comment

Hatt längere Zeit auf ORF1-HD fern geschaut und alles lief einwandfrei. Doch auf einmal blieb das bild stehen. Nach einem Bildaufbau gings dann wieder eine weile aber die zeiträume in denen das bild wieder einfror wurden immer kürzer. Ich denke das muß was mit dem VMR9 bzw Overlay mixer zu tun haben. Kann diese auch nicht mehr über Filter -> VMR 9 Renderer bzw Oberlay Renderer aufrufen. Kann man diese irgendwied händisch registrierern? Was mich stutzig macht ist, dass die beiden anderen Sender einwandfrei laufen.

Zu deinen Fragen: die automatische Audio/Viedeoerkennung hilft nichts

VMR fix ist aktiv, sonst hab ich kein formatfüllendes Bild.

Als Tv-Karte verwende ich die Mystique Cabic DVB-C Karte mit den BDA-Treibern von KNC.

Habe zu testzwecken eine Aufnahme gemacht. Die Wiedergabe mit MPC-HC und dem internen MPC dekoder läuft gut bei VMR9 ausgabe.

Link to comment
Ich denke das muß was mit dem VMR9 bzw Overlay mixer zu tun haben.

nicht unbedingt. Die beiden Renderer sind Bestandteil von DirectX bzw. Windows (system32\quartz.dll bzw. qdvd.dll).

händisch registrierern.. Kannst das gleiche DirectX nochmal drüber installieren, das geht.

Kannst DirectX checken - Zubehör-Systemprog.-Systeminformationen starten Extras-DirectX Diagnoseprog.

Beim Start läuft ein Scan aller relev. Dateien durch und wenn eine kaputt wäre bekämste ne Meldung.

 

>>Was mir noch aufgefallen ist, wenn ich (in DVBViewer) auf Filter -> VMR 9 Renderer klicke öffnet sich kein Fenster, gleiches beim Overlay Renderer.

Kann man diese Fenster im MPC öffnen? Du kannst dort die Renderer in Optionen-Ausgabe wechseln. Danach MPC erst komplett beenden damit die neuen Renderer geladen werden.

 

>>Habe zu testzwecken eine Aufnahme gemacht. Die Wiedergabe mit MPC-HC und dem internen MPC dekoder läuft gut bei VMR9 ausgabe.

was heißt gut? Mit DXVA?

 

Wie ist die CPU Last bei ORF HD wenns im DVBViewer dunkel wird?

Ist ORF HD 1080i oder 720?

Was tut sich beim System default Renderer?

 

>>Zu deinen Fragen: die automatische Audio/Viedeoerkennung hilft nichts

..ist aber bei mir immer eingeschaltet, manche Sender-Renderer-Kombos brauchen es.

Edited by craig_s
Link to comment

Hallo!

Habe jetzt herausgefunden, dass ich irgendwie den Overlay Mixer aus der Registrierung mit Radlight filter manger entfernt hatte und dieser war auch dafür verantwortlich dass ich das VMR 9 bzw Overlay Fenster unter den Filtern nicht öffnen konnte. Das funktioniert jetzt wieder.

Nach einen Neustart war das Einfrierproblem bedeutend besser, aber noch nicht ganz weg. Was ich weiters festgestellt habe ist, dass die GPU auslastung jetzt auf ~10% gesunken(vorher 50%) ist. Das find ich schon mal gut.

Das DirectX Diagnoseprogramm liefert keine Fehler.

Das aufgenommene Video wird durch den MPC-HC mit DXVA unterstützt.

Wie sich die CPU-last verhält muß ich erst beobachten. Die GPU-last bleibt gleich sobald das video einfriert.

 

Ich werde das ganze weiter beobachten und meine Erfahrungen mitteilen.

Vielen Dank für die Hilfe. Soweit läuft DVBViewer wieder einigermaßen.

 

CU

Link to comment
Habe jetzt herausgefunden, dass ich irgendwie den Overlay Mixer aus der Registrierung mit Radlight filter manger entfernt hatte und dieser war auch dafür verantwortlich dass ich das VMR 9 bzw Overlay Fenster unter den Filtern nicht öffnen konnte. Das funktioniert jetzt wieder.

Hilf Himmel!! :(

Wenn du dabei bist dir dein Windows mit Gewalt zu zerstören, nur weiter so.. ;)

Ich hoffe du hast nen Wiederherstellungspunkt o.ä. oder fang doch nochmal ganz von vorne an...

Oder lach dir ne andere Festplatte oder Bootpartition an für solche Experimente - oder für ne Clean-Installation aller Komponenten zum Fehlersuchen.

Link to comment
- mach mal diesen Test:

Lade diese Media Player Classic (MPC) Version runter und

dieses HD-Video (117MB)

Starte MPC und vergewissere dich, daß in view - options - "Interne Filter" rechts alle H264 und AC3 aktiviert sind. MPC beenden.

 

...

 

Hallo,

 

ich habe es ausprobiert, mit der Raden HD4350 kein Problem. Bei der Radeon HD2400 bringt der MPC eine Fehlermeldung und beginnt nicht mit der Wiedergabe.

 

Dann habe ich die Karten zwischen den beiden PCs ausgetauscht.

 

Ergebnis:

Auf dem Scenic W620 der zuvor mit der HD4350 DXVA nutzen konnte geht mit der HD2400 kein DXVA und es erscheint dieselbe Fehlermeldung bei MPC wie bei der Celsius W340. Damit hat sich die HD2400 trotz ansonsten korrekt installierter Software als nicht tauglich für DXVA erwiesen.

 

Anders herum hat DXVA mit der HD4350 im Celsius W340 ebenfalls nicht funktioniert. Bei Decoder Device fehlten dort sämtliche Einträge... sehr merkwürdig... aber da die Karte im Scenic W620 DXVA konnte wird es wohl bei der Celsius W340 ein Problem mit der Softwareinstallation geben. - Irgendwelche konkreten Ideen was da falsch läuft oder komm ich um eine Neuinstallation des Rechners nicht rum?

 

Grüße,

Christian

 

PS: Kann es sein, dass der MPC nur auf dem primären Bildschirm wiedergibt?

 

PPS: Bei DXVA Nutzung fiel mir auf dass die GPU Load sowohl im Catalyst Control Center als auch bei GPU-Z mit 0% angezeigt wird... ich hatte erwartet hier die Nutzung der GPU angezeigt zu bekommen, ist aber nicht so. CPU Last ist aber dank DXVA unter 10%

post-75474-1234339807_thumb.png

post-75474-1234339829_thumb.png

post-75474-1234339852_thumb.png

post-75474-1234339864_thumb.png

Edited by Tedric
Link to comment
Dann habe ich die Karten zwischen den beiden PCs ausgetauscht.

Ergebnis: ...

Abermals Hilf Himmel ! ;) wenn du beim Tausch die jew. Ati-Treiber nicht komplett deinstalliert und für die neuen Karten neu installiert hast!

So einfach geht's halt net.. :)

 

Die HD 2400 würde ich noch lange nicht aufgeben. Wie du u.a. (SuchFu.) hier

http://www.DVBViewer.info/forum/index.php?...st&p=230935

sehen kannst wurde sie schon HD-Positiv eingesetzt. Jedenfalls als AGP Vers., da sollte doch PCIe erst recht..?

 

..nicht aufgeben bevor ich sie nicht auf nem Test-Windows mit sauberer Installation getestet hätte.

Tja, Arbeit über Arbeit.. manchmal würd ich den ganzen Kasten auch am liebsten zum Fenster rausschmeissen. :(

 

>>PS: Kann es sein, dass der MPC nur auf dem primären Bildschirm wiedergibt?

weiß ich net, hab nur einen.

Link to comment

Um dir mit der HD 2400 weiter Mut zu machen - da bin ich eben drübergestolpert:

http://www.DVBViewer.info/forum/index.php?...st&p=226295

ff.

 

eins tiefer:

"bei mir läuft die 2400 pro mit CAT 8.12, bei 1080i bis einschließlich der Deinterlacing Einstellung "MotionAdaptiveDevice: DXVA1/2, 720x480 / 1280x720 / 1920x1080" stabil und ohne Probleme. Mit höheren Deinterlacing-Einstellungen ist meine Hardware jedoch überfordert."

 

also VA-Deinterlacing ist mit der HD 2400 evl. nicht, aber bitte, die bekommt man jetzt schon für'n Zehner.. :(

Link to comment
Abermals Hilf Himmel ! :( wenn du beim Tausch die jew. Ati-Treiber nicht komplett deinstalliert und für die neuen Karten neu installiert hast!

So einfach geht's halt net.. ;)

 

Ok, ich gebs zu... ich war ein wenig naiv und wollte mir Arbeit sparen... zur kurz gedacht setzte ich voraus dass selber Treiberpaket bedeutet, dass die Karte automatisch erkannt wird und sauber eingebunden. Ist wohl nicht so...

 

... und weil ich es mir heute Vormittag zu einfach gemacht habe mit dem Tausch der Grafikkarten, werde ich jetzt eine zweite Festplatte nehmen und da das Betriebsystem gaaanz frisch aufspielen. Und dann werd ich ja sehen was mit der HD2400 in Sachen DXVA geht oder nicht.

Link to comment

..in den riesen Thread vom Link 2 weiter oben ist öfter irgendwas von "(Reg.- Tweaks 0.14)" o.ä. die Rede die oder den man irgendwie brauchen könnte/müsste.. Evl. könnte mal einer der Kartenkenner hier was zu sagen oder du findest es raus, würd mich interessieren und dich sollte es warscheinlich.

 

Grüße craig

Edited by craig_s
Link to comment

Ok, Rechner ist jetzt neu installiert. XP inkl SP2 + SP3 + directx nov2008 + .net 2.0 + chipsatztreiber + lan-treiber + audiotreiber + grafiktreiber ati catalyst 9.1 auflösung 1920x1080, 32bit+ Media player classic homecinema + DXVA Checker, PowerDVD 8

 

 

So, damit ist alles was ich brauche vorhanden um zu testen ob DXVA geht... DXVA Checker gestartet... mp4 datei (Q-R_Utawarerumono_OP_-_Musouka_(BD_x264_1920x1080_VFR).mp4) reingezogen... failed. wiedergabe im media player classic, geht nicht. es kommt fehlermeldung wenn die datei geöffnet werden soll, dazu erzeugt der media player classic einen dump, den ich gerne jemanden den es interessiert zusenden kann.

 

 

Damit ist für mich die GeCube RADEON HD2400PRO PCIe gestroben was die Nutzung für HDTV mit DXVA Beschleunigung angeht. Auch wenn jemand hier im Forum mit einer HD2400 AGP das ganze ans laufen bekommen hat. Das PCIe Exemplar das mir vorliegt tut es nicht.

Link to comment

Diesen Beitrag schon gelesen? Link

ich hab mal unter post # 148

 

die HD 2400 registry hacks für XP hochgeladen und ein kleines Programm um die

korrekten strings in der Registry zu finden

 

1080 i MPEG 2 DXVA 20 Mbit jetzt mit 9 %

mit vector und motion adaptive deinterlacing

 

directshow apps funktionieren jetzt mit H.264 und MPEG2 DXVA (WMP -MPC-DVBViewer)

 

http://www.avsforum.com/avs-vb/showthread....p;#post11019368

 

 

Grüsse

 

vm (aka mine)

 

Der Beitrag wurde von vonMengen bearbeitet: Jul 18 2007, 05:49

Edited by awaschko
Link to comment
Damit ist für mich die GeCube RADEON HD2400PRO PCIe gestroben was die Nutzung für HDTV mit DXVA Beschleunigung angeht. Auch wenn jemand hier im Forum mit einer HD2400 AGP das ganze ans laufen bekommen hat. Das PCIe Exemplar das mir vorliegt tut es nicht.

...gibst ja schnell auf, dabei würd es jetzt erst richtig losgehen...

awaschko's Link zeigt auf einen riesigen Thread, bei dem es nur um HD 2400/2600 geht

da wird auch oft noch auf diese Seite verwiesen:

http://exdeus.home.comcast.net/~exdeus/ati-hd2x00/

 

nur so als Anregung, ob du noch Bock hast ist natürlich dir überlassen.. :(

Link to comment
...gibst ja schnell auf, dabei würd es jetzt erst richtig losgehen...

awaschko's Link zeigt auf einen riesigen Thread, bei dem es nur um HD 2400/2600 geht

da wird auch oft noch auf diese Seite verwiesen:

http://exdeus.home.comcast.net/~exdeus/ati-hd2x00/

 

nur so als Anregung, ob du noch Bock hast ist natürlich dir überlassen.. :(

 

 

ES LÄUFT !!! *freu* *rumhüpf*

 

 

Tweaks sind nach einem zuvor gemachten Vollbackup drauf.

Hier die neuen Screenshots vom DXVA Checker im Vergleich zum Zustand vorher. --- wie kann ich denn alte Attachments löschen um neue hochladen zu können?

Allerdings kommt wenn man eine Datei auf den DXVA Checker zieht immer noch ein Fehler

MPC dagegen spielt die HD Videos in H.264 format bei deutlich unter 10% CPU Last. Interessanterweise habe ich eine Auslastung im Catalyst Control Center von bis zu 19% angezeigt bekommen --- mit der HD4350 auf dem anderen PC verharrte die Anzeige bei 0%.

 

Der PowerDVD 8 H.264 Codec nutzt aber immer noch kein DXVA ;)

Link to comment
ES LÄUFT !!! *freu* *rumhüpf*

...

Der PowerDVD 8 H.264 Codec nutzt aber immer noch kein DXVA :(

Heeee, es geht was!

Evl. mal eine Catalyst Vers. von vor paar Monaten probieren für die die Tweaks geschrieben wurden.

Scheints in dem chaotischen *HD 2400/2600* Thread hat fast jeder nen anderen heissen Tip, versch. Treibervers., Codecvers., Arcsoft...

Wird evl. nicht leicht werden da causale Zusammenhänge rauszufiltern.. ;)

Edited by craig_s
Link to comment

Im DVBViewer konnte ich durch die Einstellung "Video Mode: Force Weave" für den PowerDVD Codec erreichen dass die CPU Last auf unter 10% sinkt. Scheinbar kann das Deinterlacing vom PowerDVD Codec nicht auf die GPU abgewälzt werden. In der PowerDVD Anwendung selbst jedoch bleibt die Auslastung sehr hoch. Was dort auffaellt ist, dass die Einstellung die AVIVO Hardwarebeschleunigung zu aktivieren zwar gesetzt werden kann aber immer wieder zurückgesetzt ist wenn man wieder in die Einstellungen schaut. Der Tweak hat in den AVIVO Einstellungen im Catalyst Control Center weitere Deinterlacing Verfahren neben Bob und Weave hinzugefügt... die vermutlich von der Grafikkarte berechnet werden, aber von PowerDVD8 wohl leider nicht genutzt werden.

Link to comment
...aber von PowerDVD8 wohl leider nicht genutzt werden.

siehe Beitrag #75

evl. auf ältere Versionen aller beteiligten Verdächtigen zurückgreifen und vorher bisschen lesen

Mist, schon wieder Arbeit..

Link to comment

Auf'm Teppich bleiben..

Das einzig entscheidende Kriterium ist doch: läuft's flüssig oder nicht?

 

Im DVBViewer konnte ich durch die Einstellung "Video Mode: Force Weave" für den PowerDVD Codec erreichen dass die CPU Last auf unter 10% sinkt. Scheinbar kann das Deinterlacing vom PowerDVD Codec nicht auf die GPU abgewälzt werden.

- sobald Astra oder Annixe ruckelfrei laufen läuft DXVA bei der HD 2400, egal was irgendwo angezeigt wird.

- Deinterlacing ist nur Kosmetik um das Bild etwas glatter und ruhiger zu machen, die Hauptarbeit ist das Dekodieren, zu Beobachten bei den H264 bzw. VC1 usw. Einträgen in "Decoder Device" vom DXVA Checker. Wenn die bis 1920x1080 gehen hast du "gute Karten".

 

In der PowerDVD Anwendung selbst jedoch bleibt die Auslastung sehr hoch ...

Wie jetzt, hast du schon Blu-ray am laufen? Bei 1080p ist die Auslastung immer höher als bei 1080i (Astra/Annixe), bei mir je nach BD 30-50%. Kommt auch auf die CPU an, wie schnell die ist.

 

Aber es läuft schön flüssig und das ist erstmal das einzige was mich interessiert.

Link to comment
- Deinterlacing st nur Kosmetik um das Bild etwas glatter und ruhiger zu machen, die Hauptarbeit ist das Dekodieren, zu Beobachten bei den H264 bzw. VC1 usw.

Das stimmt in dieser Form überhaupt nicht, adaptive Deinterlacing-Algorithmen sind komplexer und rechenintensiver als h264/VC1-Dekoder, insbesondere bei 1080i-Content.

Schalt mal das Ganze Post-Processing bei 1080i-Quellen ab und sag mir dann nochmal ob es nur Kosmetik ist.

Link to comment
Das stimmt in dieser Form überhaupt nicht, adaptive Deinterlacing-Algorithmen sind komplexer und rechenintensiver als h264/VC1-Dekoder, insbesondere bei 1080i-Content.

Schalt mal das Ganze Post-Processing bei 1080i-Quellen ab und sag mir dann nochmal ob es nur Kosmetik ist.

Juhuuu, endlich sagt hier einer mal was, mir geht nämlich langsam die Puste aus, die ganze Zeit den Alleinunterhalter zu spielen, kein Wunder daß ich irgendwann Blödsinn rede!

Bitte bitte, liebe Spezialisten, helft den Hifesuchenden! Besonders auch den Anfängern, und so das die's verstehen...

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...