Jump to content
SnoopyDog

OSD Skin "BluFuzz" mit optionaler Scrobbler Funktion

Recommended Posts

SnoopyDog

Anbei eine neue Version des Plugins:

  • Bei Blu-Ray-Wiedergabe wird nicht mehr zum Filmstart zurückgesprungen, wenn das Abspielen der zuletzt gemerkten Wiedergabeposition aktiv ist.
  • In den Einstellungen des Plugins gibt es unter "Eingabeoptionen" den neuen Punkt "Fenster mit Musikinformationen automatisch bei Musikwiedergabe öffnen".

 

 

Edited by SnoopyDog

Share this post


Link to post
SnoopyDog

Kurze Info: Die Seite htbackdrops.org wurde komplett umstrukturiert. Es gibt keine vernünftige Suchfunktion mehr, kein API und auch kaum noch Bilder. Mal abwarten, ob das so bleiben soll.

Es werden ja noch immer Bilder bei fanart.tv und theAudioDB.org gefunden, wobei ja fanart.tv auch mit Problemen zu kämpfen hat:

 

 

We were recently contacted by Cloudflare and told we were on the wrong package for the amount of bandwidth we were using (and the type of content we were caching, mainly images from the API assets) and that we should move to the enterprise plan for $2000/mo.

Ich hatte die letzten Wochen kaum Zeit weil ich umziehen mußte, aber so langsam lichtet sich das Chaos und ich habe bald wieder mehr Zeit hier aktiv zu sein...

Share this post


Link to post
Odie13690

Hallo,

 

ich benutze BluFuzz schon seit ein paar Jahren. Nun habe ich mal die aktuellen Dateien eingebunden. Leider ist seitdem der Hintergrund der Mini-EPG-Anzeige beim TV transparent. Die Informationen sind daher kaum lesbar. Habe noch keine Einstellung gefunden, wo man die Transparenz einstellen kann.

 

odie13690

Share this post


Link to post
SnoopyDog

Huch, transparent sollte das nicht sein. In den OSD-Einstellungen des DVBViewers gibt es eine Einstellung für Transparenz, überprüfe die mal. Ich schau allerdings nachher selbst auch einmal, ob ich da etwas übersehen habe, was Probleme bereiten könnte. Du hast alles aktualisiert, d.h. die Skin-Dateien und das Plugin (?)

Share this post


Link to post
Fruchtzwerg

Ich mag den Skin sehr, habe ihn bisher gerne genutzt, vielen Dank dafür. Leider gibt es mit meiner aktuellen Konfiguration ein Problem damit. Ich habe jetzt Windows 10 installiert und auch meinen HTPC aufgerüstet zum Schauen von 3D Blurays. Wenn man die stereoskopische 3D Funktion in der nVidia Systemsteuerung aktiviert, dann stürzt der DVBViewer ab wenn man 2D oder 3D Blurays sehen möchte. Wenn ich den Originalskin von DVBViewer nehme, dann kann ich trotz aktiviertem 3D noch 2D Blurays ohne Absturz anschauen. Schön wäre es natürlich wenn ich mit dem Skin 2D und 3D Bluray sehen könnte.

 

Mein Setup: madVR und LAV Filter

Share this post


Link to post
SnoopyDog

Hallo, das ist merkwürdig. Schaltest Du nur den Skin um oder hast Du auch mein Plugin deaktiviert, wenn Du den Originalskin verwendest?

An welcher Stelle stürzt der DVBViewer genau ab?

Ein Unterschied von meinem Skin zu dem vom DVBViewer ist, daß ich das TV-Bild unten links verkleinert weiterlaufen lasse (VideoInfo), wenn Du in den Skin reingehst. Falls es daran liegt, kann ich nichts ändern, dann hätte entweder der madVR oder der nVidia-Treiber ein Problem.

Share this post


Link to post
SnoopyDog

Vorne habe ich ein Update hochgeladen:

  • Anpassungen an neuere DVBViewer Versionen
  • Zugriff auf htbackdrops.org entfernt, da es diese Seite leider nicht mehr gibt. Alternativ werden Bilder von theAudioDB und fanart.tv heruntergeladen, aber htbackdrops hatte hier wesentlich mehr auf Lager. Trotzdem wird auch bei diesen Anbietern so einiges gefunden.
  • Verbesserte Erkennung von Musikartisten bei Musikwiedergabe. Voraussetzung ist, daß ihr Eure Musikdateien korrekt getaggt habt. Es wird immer zuerst versucht, über die Kombination Titel und Artist zu suchen, weil es hier bei verschiedenen Künstlern mit demselben Namen wesentlich eindeutigere Ergebnisse gibt. Erst wenn dieses Suchergebnis trotz allem leer sein sollte, wird versucht, nur über den Künstlernamen zu suchen. Danke an diese Stelle noch mal an musicbrainz für diesen tollen Dienst.
  • Poster und Backdrops werden wieder von theMovieDB heruntergeladen. Es hatte sich eine Kleinigkeit bei denen geändert.
  • Im Musik-Info-Fenster sowie im Schauspieler-Info-Fenster kann nun mit OSD-Grün (oder über das Kontextmenü) ausgewählt werden, von welcher Datenquelle Informationen zur Person angezeigt werden sollen (soweit verfügbar). Musik: Wikipedia (standard) / theAudioDB / last.fm. Schauspieler: Wikipedia (standard) / theMovieDB. Oft haben "die anderen" jedoch mehr oder weniger bei Wikipedia abgeschrieben...
  • Konfigurationsdialog des Plugins in den Options-Dialog des DVBViewer verlagert. Punkte sind: "OSD-Skin Einstellungen" / "DVD/Blu-Ray Wiedergabe" / "Medieninformationen"
  • Unterstützung für das neue SmartHome Plugin
  • Diverse andere Verbesserungen, die mir momentan nicht einfallen :)

 

Ein paar offene Punkte habe ich noch am Plugin, z.B. wenn man bei Wikipedia bei Doppeldeutigkeiten manuell den korrekten Künstlernamen auswählen muß, werden manchmal viel zu viele Alternativen angezeigt.

Oder ich hatte begonnen, den Audio-Renderer über das OSD auswählbar zu machen, aber leider wird derzeit die Änderung nur bei einem Neustart des DVBViewer übernommen.

Begonnen (aber noch nicht fertig) hatte ich auch eine Anzeige der aktuellen Musik Playlist direkt im Musik-Info-Fenster. Liefere ich bei Gelegenheit nach...

 

Und sobald ich einen UHD-TV habe, wird es bestimmt auch noch ein paar Änderungen geben (müssen?)

Edited by SnoopyDog
  • Thanks 1

Share this post


Link to post
SnoopyDog

Sorry, ich mußte das ZIP-Archiv noch einmal neu hochladen, da ich im Plugin noch einen kleinen Fehler entdeckt hatte. Sorry.

  • Thanks 1

Share this post


Link to post
hoto44

Many Thanks. Works perfect so far.

Share this post


Link to post
PetBel

Nachdem ich über die Festtage meine Media-PCs erneuert habe bin ich von der Standard Skin auf die BluFuzz umgestiegen. Ist soweit eine super Sache bis auf ein Problem:

Der automatische Download von Medieninfos für meine als mp3 auf dem Server liegenden CDs funktioniert problemlos. Bei meiner Filmsamlung im mkv Fomat tut sich hingegen überhaupt nichts bezüglich Infodownload.Hab keine Ahnung woran das liegen könnte. Bin der Meinung wenns bei den Audiodateien geht müsste es doch auch bei den Videodateien funktionieren.

 

Share this post


Link to post
Josef Jochum
  • Ich bin neu bei DVBViewer, würde geren BluFuzz ausprobieren, finde aber den zip File zum Download nicht. Kann mir da jemand helfen. Danke! 

Share this post


Link to post
Humppakäräjät

Hallo, ich habe ein Problem mit dem Skin. Ich habe eine mkv mit deutscher und englischer Tonspur.

Wenn ich von der Deutschen auf die Englische wechsle, dann wechselt der DVBViewer nach ca. 0.5-1 Sekunden wieder automatisch auf die vorherige Tonspur zurück. Wenn ich aber im DVBViewer den default Skin wieder einschalte, dann geht es einwandfrei. Hab den DVBViewer Pro V6.1.4.0 und die aktuellste BluFuzz Version (inkl. MRSkin Helper Plugin). Ansonsten wirklich ein toller Skin, verwende ich schon seit Jahren. Harmoniert gut mit der Fernbedienung.

 

Share this post


Link to post
SnoopyDog

Es tut mir leid, ich war leider länger nicht hier. Besteht das Problem noch? Bei mir ist so etwas bisher nie passiert.

Ich habe in letzter Zeit noch einige Verbesserungen an der Plugin-DLL vorgenommen (vor allem bei Wiedergabe von 4k Blu-Rays und der Suche nach Musik-Artisten).

 

TheMovieDB hat momentan einen Teil seines API deaktiviert, weil seit ein paar Tagen eine ungewöhnlich hohe Last beobachtet wurde, also nicht wundern, wenn derzeit keine Informationen zu Filmtiteln gefunden werden.

 

https://mobile.twitter.com/themoviedb/status/1161718247097454592

 

  • Thanks 1

Share this post


Link to post
SnoopyDog

Ich kann es leider überhaupt nicht reproduzieren. Welche Codecs verwendest Du? Falls LAV: hast Du da in der Splitter-Konfiguration die bevorzugte Sprache vorgegeben?

  • Thanks 1

Share this post


Link to post
Humppakäräjät

Hi Snoopy,

 

Danke für Deine Antwort. Hatte hier schon länger nicht mehr reingeschaut, deshalb die späte Antwort.

Das Problem besteht leider immer noch. Ich habe kürzlich den kompletten DVBViewer gelöscht (inkl. Konfiguration) und komplett neu installiert.

Was jetzt nicht mehr ist, ist dass das Problem verschwindet, wenn ich auf den Standard Skin zurück wechsle. Jedoch verschwindet es, wenn ich die SkinHelperMR.dll und SkinHelperMR.lng Dateien aus dem Plugins Verzeichnis lösche.

 

Quote

Welche Codecs verwendest Du? Falls LAV: hast Du da in der Splitter-Konfiguration die bevorzugte Sprache vorgegeben?

 

Was Codecs angeht bin ich wirklich Laie. In den DVBViewer Einstellungen steht ausschließlich LAV drin. In den Einstellungen vom LAV habe ich aber kein Feld ausmachen können über das man die Sprache einstellen kann (siehe Bild Untitled-2.png). 😐

Was mir aufgefallen ist, ist dass ich im DVBViewer keinen Menüpunkt 'Plugins' mehr habe. Der war früher immer da und da konnte man dann die Plugins konfigurieren.

Ich habe Dir mal die support.zip angehängt. Hoffe die kann Dir helfen...

 

Jedenfalls Danke für Deine Mühe!

Untitled-2.png

support.zip

Share this post


Link to post
SnoopyDog

Danke für Deine Antwort! Was leider aus der support.zip nicht hervorgeht ist, welche Filter bei Dir beim Abspielen einer mkv Datei aktiv sind. Kannst Du bitte mal eine mkv bei Dir starten und dann während der Wiedergabe im Menü unter "Einstellungen" den Punkt "Filter   >" aufrufen. Was wird da bei Dir aufgelistet?

 

Unbenannt.png.80ac4389b1a81fddea571299b2d36d5b.png

  • Thanks 1

Share this post


Link to post
Humppakäräjät

Hier bitteschön...

Untitled-1.png.d3d01cc8a9dd73ede2eeceea65ccc357.png

Edited by Humppakäräjät

Share this post


Link to post
SnoopyDog

Leider sehe ich noch immer nicht, welcher Splitter bei Dir verwendet wird. Hast Du für mkv etwas Spezielles wie den Haali Splitter installiert?

  • Thanks 1

Share this post


Link to post
Humppakäräjät

Der Haali Splitter war tatsächlich installiert. Das deinstallieren hat aber auch nichts gebracht. 😖

Was mir noch eingefallen ist... In einer früheren Version, als es in der Menüleiste noch den Menüpunkt "Plugins" gab, konnte ich dort eine Konfigurationsseite von Deinem Plugin aufrufen. Sobald ich dort irgendeinen haken geändert hatte (egal welchen) und auf "Übernehmen" geklickt habe, dann ging das wechseln der Audiospur wieder einwandfrei. Gibt es diese Konfigurationsseite noch?

 

Share this post


Link to post
SnoopyDog

Die Konfiguration befindet sich jetzt im normalen DVBViewer-Menü "Optionen" => "Einstellungen" (siehe angehängtes Bild).

 

Ich habe vorne ein Update hochgeladen, damit wir auf demselben Stand sind. Bitte lade die Datei "BluFuzz_16_9_19-09-11.zip" herunter und kopiere die darin enthaltenen Ordner in die entsprechenden Verzeichnisse des DVBViewer.

 

Folgendes habe ich geändert:

  • 4k Blu-Rays ließen sich nicht abspielen.
  • Icons für 4k-Wiedergabe hinzugefügt.
  • Suche nach Artisten von gerade laufenden Musiktiteln verbessert.
  • Der Fallback auf englische Sprache bei der Wikipedia-Suche zu Personen, falls in der bevorzugten Sprache nichts gefunden wurde, hat nicht funktioniert.
  • Verbesserte Filmtitelerkennung beim Einlegen von neuen DVDs oder Blu-Rays.
  • Viele Kleinigkeiten, die mir nicht alle einfallen.

 

 

Unbenannt.png

Edited by SnoopyDog
  • Thanks 1

Share this post


Link to post
Humppakäräjät

Hab die neue Version installiert, ist aber genau das selbe Verhalten wie zuvor. Ich ändere die Tonspur von Deutsch auf Englisch, dann höre ich für ca 1 Sekunde Englisch, dann springt er wieder zurück auf Deutsch.

Danke für den Hinweis mit den Menüs. Hab da ein bisschen drin rumgeklickt, ist aber leider nicht wie früher, als ich einfach irgendeinen Haken ändern musste und es danach funktioniert hat.

Aber mir ist folgendes aufgefallen: sobald ich im DVD/Blu-Ray Wiedergabe Menü die Standardsprache bei Wiedergabe auf Englisch ändere, sich das mit den Tonspuren genau andersherum verhält. Nachdem ich die Tonspur auf Deutsch ändere, springt er dann nämlich nach ca. 1 Sekunde wieder zurück auf die Englische.

 

Die Filterliste hat sich geändert, der LAV Splitter taucht jetzt in der Liste auf. Weiß aber nicht ob es an Deiner neuen Version liegt, oder ob ich nachdem ich den Haali deinstalliert habe einen Neustart hätte machen müssen.

 

Jedenfalls vielen Dank für Deine Mühe!

 

Untitled-2.png.658cef67d28949c219fe97c48947e5e8.png

 

Untitled-1.png.8adfa06db0b378e4f5595c50138bc291.png

Share this post


Link to post
SnoopyDog

Danke für Deine Geduld. Wie genau änderst Du die Tonspur? Mit der Fernbedienung?

Share this post


Link to post
Humppakäräjät

Rechte Maustaste ins Bild und dann über das Kontext-Menü Audiospur. Wenn ich die Tonspur über die Fernbedienung ändere ist das Problem das gleiche.

Untitled-1.png

Share this post


Link to post
SnoopyDog

Ach so. Ja, wenn ich es mit dem Menü umschalte, dann passiert es bei mir auch. Das benutze ich nie, weil ich alles für die Benutzung mit der Fernbedienung ausgelegt habe - wie auf der ersten Seite geschrieben: " Ausgelegt ausschließlich auf Bedienung mit der Fernbedienung (Wohnzimmer) "

Wechsle ich dagegen mit der Fernbedienung die Tonspur, dann erscheint zuerst das OSD-Menü mit der Auswahl der verfügbaren Sprachen und bestätige ich dann mit "Ok", dann wird die Tonspur gewechselt und bleibt auch dauerhaft selektiert. Man muß den Befehl der Fernbedienung in der Konfiguration für "Eingaben" dem Befehl "OSD-Audiospur" zuweisen.

 

Aber jetzt weiß ich wenigstens, wonach ich suchen muß 😉

  • Thanks 1

Share this post


Link to post
SnoopyDog

Versuche es bitte einmal mit der angehängten DLL. SkinHelperMR_19_09_12.zip

  • Thanks 1

Share this post


Link to post
Humppakäräjät

Super, dass Du das Problem hast nachvollziehen können. Sehr guter Hinweis mit der OSD-Audiospur, da funktioniert es jetzt bei mir auch, vielen Dank!

Die SkinHelperMR_19_09_12 dll hat leider keine Veränderung gebracht.

Share this post


Link to post
SnoopyDog

Komisch. Der Fehler war nachvollziehbar und ich habe ihn beseitigt. Du hast beim Einspielen der neuen DLL hoffentlich keine umbenannte Kopie der alten DLL im Plugins-Verzeichnis beibehalten (?)

  • Thanks 1

Share this post


Link to post
Humppakäräjät

Oh wie peinlich. Ich hab es jetzt nochmals probiert und siehe da... funktioniert einwandfrei.

Kann mir jetzt aber nicht wirklich erklären warum es heute Früh nicht hin gehauen hat.

Super Job, vielen Dank! 🤗 👍

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...