Jump to content

New installation, service starts but then stops, and a couple of other


Recommended Posts

Hi everyone,

I purchased DVBViewer around 10 days ago, and because of my slightly unusual setup (I am wheelchair bound, and my computer also acts as the server for the network, as well as my TV, and runs 24/7, it has two monitors connected, one of which is predominately set to the television (DVBViewer Application), I decided to install the recording service, to allow me to schedule the recording of new programs from my iPad via the web interface. However three things keep on happening.

1. The recording service keeps on stopping with Event ID 0 (from the event viewer, although it states that Event ID 0 doesn't have a description associated with it, which is generally something added when the application or service is built, so maybe this can be added in a future release, so that people like me can have a bit more of a hint as to what is going on?)

2. The web interface once accessed via the iPad, and say one recording added to the timer section, then I'll go and have a cup of tea, or my carer will tell me that I need to do something, then come back and the web interface will not load again. The service is still running when this happens, there have been occasions when restarting the service is not sufficient to bring the web server back online, and a full server restart is required to do it.

3. When I use the recording service to power DVBViewer Pro, it will run for around 20 minutes with no problem, watching any of the FTA channels, and then the screen will freeze, and changing channels will sometimes solve the problem, other times you have to restart DVBViewer Pro entirely to get things working again.

I need to get all three items fixed. I've tried all of the usual items to fix the problems, but nothing seems to have worked. The EPG updates with no problems, the channel lists all update, and the favourites list updates, again without any issues. It's just the three problems above which are plaguing me.

My problem is that I am bed-bound, and my PC (the server running both the recording service and DVBViewer are around 8 foot away from me, and whilst I don't mind using a wireless keyboard and mouse, as I do for everything else when I need to use the server. I have the iPad deliberately to allow me to do things like setup the recordings, and I am under the impression that the recording service web interface does this, well I know it does as I have managed to setup one or two in this way, and they recorded if the service stayed alive long enough.

I am an IT consultant, but this is my first foray into the world of computer/television setups, and so I am at a but of a loss as to what to do to get things working.

The server has 4 IPv4 addresses, and none of them are listed in the not to listen to section of the service configuration.

The operating system is server 2008 r2, the BDA drivers work perfectly on the viewer without the service, and on the service when it runs, but it doesn't seem to want to stay alive.

Any ideas or suggestions, have I missed something in the configuration, or have I done something silly which is causing these problems? I assume that they are all linked, and are symptoms of a larger problem, but I have no ideas as to what that larger problem may be.

I've done the support.zip process, and that is attached for you all to scrutinise, hopefully it'll help someone provide me with a solution to the problems.


Link to comment

Hi guys,


I've been playing around a little bit, and wanted to update you all on what I've discovered so far. Any help you could provide would really be very grateful.


I've setup a Windows XP Professional (x86) virtual machine, and it doesn't automatically find the recording server, despite being able to connect to the recordings share which is on the same machine. I managed to enter all of the settings manually, and got a connection which worked, and all seemed okay. However when I tried to select a channel, from the newly loaded channel list, the screen remained blank, and no sound came out of the speakers. I checked by playing a recording from the recording service, and it worked perfectly fine, sound and picture, both worked within DVBViewer Pro.


The virtual machine then experienced a weird problem where it refused to boot up, but I think that is unrelated. The only thing installed on the machine is Windows XP Professional (x86), Oracle VirtualBox VM's tools, the drivers for the various virtual hardware components, and DVBViewer Pro. I went through the initial setup wizard, but obviously as I didn't have any devices physically connected to the machine, I couldn't do a scan, so when I got the channel list to load from the recording server, I had gotten quite excited, but nothing loaded in terms of both picture and sound. I've temporarily turned off the firewall on the server, to see if that helps, and hopefully once I've sorted out the virtual machine's refusal to boot problem, then I'll see if that makes a difference.


I'll submit the support.zip for it once I'm able to get back into the virtual machine. Can someone please give me some advice, help, or support as to what on earth is going on here, as I am rather concerned about the lack of response from anyone so far.


Thanks guys and girls, hopefully someone will say something soon, and I'll be able to sort out this problem(s).


Christopher East MBCS.

Link to comment

I'm not an expert in reading those support.zip's. So maybe I get some things wrong... Your issues are quite strange... there must be something broken badly.


A few hints:


1. You should try to run RS without plugins, if you have plugins installed for RS.


2. If you are using RS and DVBViewer at the same time, you should switch the real hardware device in DVBViewer to "Do not use". If I read the hardware.xml in your support.zip correctly, they are active, as are the RTSP devices..


3. Especially for your third issue you might try to enable TCP/IP in RTSP devices in DVBViewer or try to replace them with Unicast devices. But issue 3 might also just go away if you solve the first ones.


4. I experienced your second issue sometimes. One thing that can cause this, is when the RS is tuning. I have this issue that sometimes one of my cable tuners fails to tune anything and is set to retune every 5 seconds. A tuning request in this situation takes 2-3 seconds in which the RS webinterface does not react... this gives me like 2 seconds to find out which timer is causing the issue on the status page (it usually recevies 0MB/s and is at signal strength 0%) and stop it from the timers page.


4a. Another thing that caused issue 2 for me was automatic updates of my videos directory. If I understand your setup correctly, you have that activated, too. Right? That crashed my RS sometimes into some undefined state where the web interface was not reacting (this actually is the most fragile part of the RS), and sometimes even recordings won't start or stop. The only thing that helped there was to kill the service using windows task manager. (If you can't restart the service, you always should have a look in task manager, if the service is still running and kill it).


5. One other hing, because in the svcdebug.log it looks like the RS always did shutdown nicely: You know that the service stops on purpose, if you open the service configuration tool? Maybe that is one or two of the "just shutdown" events? From the debug log it does not look like the service is crashing.

Link to comment

From the number of downloads, it seems a few people have tried to help but did not spot anything obviously wrong. The only thing I noticed is that "device 6" is still enabled in the client. Even though it's disabled in the server config., this might cause some confusion. I recall reading other posts where this practice was deprecated, maybe due to changes in recent versions.


RTSP is a relatively recent introduction. Most users, like myself, may have stuck with Unicast and so can't help with this. I would agree with Moses that Unicast would be worth trying if problems persist.


When the web server stops responding on the iPad, can you still access from a browser on the Windows machine? I wondered if it was just the web client.


Screen freezes are most commonly blamed on codec issues. Recent LAV versions have a good reputation, but It's always worth trying an alternative. You could try the Microsoft one as your "B". Also check the LAV settings, such as hardware acceleration.

Link to comment
  • Create New...