Jump to content

ffmpeg - Failed loading nvcuvid


cosmoshin

Recommended Posts

Posted (edited)

Hallo.

 

Ich möchte mit ffmpeg und der Hardware Beschleunigung der Grafikkarte aus einer h264 Videodatei alle n-te Sekunde Frames extrahieren.
Ohne Hardware Beschleunigung kann ich zwar Frames extrahieren, aber es dauert leider zu lange.

 

Mein System:
win10
ffmpeg build gyan.dev v5.0.1 full
grafikkarte: gtx 560 se, fermi
gtx 560 Treiber: v391.35

 

Ich gebe folgenden Befehl ein:
ffmpeg -y -hwaccel cuda -hwaccel_output_format cuda -c:v h264_cuvid -i input.mp4 -vf fps=1/60 img%03d.jpg

 

Fehlermeldung:
Cannot load cuvidGetDecodeStatus
und
Failed loading nvcuvid.

 

Ich gehe davon aus, dass zuerst die Inputdatei dekodiert werden muss, um einzelne Frames zu extrahieren.
Die gtx560 Grafikkarte unterstützt Hardware Dekodierung (aber keine Enkodierung).

 

Die nvidia developer Seite beschreibt zwar wie man ffmpeg neu kompiliert, aber da ich keine Ahnung von Kompilieren habe, bin ich schon bei der Schritt für Schritt Anleitung gescheitert.

 

Dann bin ich auf gyan.dev gestossen. Nach meinem Verständnis muss ich hier nichts kompilieren und kann die Hardware Beschleunigung nutzen. Leider bekomme ich jetzt die oben genannte Fehlermeldung.

 

Wie kann ich Hardware Beschleunigung nutzen?

 

Über Hilfe der Community würde ich mich sehr freuen. Dankeschön.

Edited by cosmoshin
falscher Tag
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...