Jump to content
Guest Lars_MQ

DVBViewer, Der Webserver

Recommended Posts

SpecialK
vermnisse den Log Eintrag einfach nur

Der hatte nur eine echte bedeutung beim programmieren. Im laufenden betrieb hat er einfach nur den server gebremst. Daher hab ich das entfernt.

 

Zu den IPs: ich verstehe nicht so ganz was du meinst. werden keine angezeigt, oder wo liegt dort genau das problem?

 

Genau, es werden in dem Auswahlfeld schlichtweg keine angezeigt. In der Ini steht aber die, welche ich im Webinterface gesetzt habe.

Wie gesagt: Den Betrieb hintert es nicht.

Nur muss ich leider noch mal kurz zum Streamen kommen: Außer ein schwarzes Bild kommt bei mir nicht :blink:

Ich habe schon diverse Stream Einstellungen getestet.

 

SpecialK

Share this post


Link to post
hackbart

teste mal im Windows Mediaplayer (mplayer2 z.B.) folgendes:

http://ipadresse:3335 (letzteres ist der Standard Port für die Videoausgabe).

 

Ich kann bei mir im Feuerfuchs auch kein Video anzeigen lassen - das scheint aber nur nen Fehler in der stream.html zu sein.

 

Christian

Share this post


Link to post
SpecialK
teste mal im Windows Mediaplayer (mplayer2 z.B.) folgendes:

http://ipadresse:3335 (letzteres ist der Standard Port für die Videoausgabe).

 

Ich kann bei mir im Feuerfuchs auch kein Video anzeigen lassen - das scheint aber nur nen Fehler in der stream.html zu sein.

 

Christian

 

Habe ich probiert, jedoch ohne Erfolg. Ich werde das ganze morgen nochmal auf meinem Client installieren und testen. Heute habe ich es auf einem Win2003 Server getestet.

Das wird zwar damit wohl nichts zu tun haben, aber es kann ja nichts schaden, das ganze mal auf einem zweiten System zu testen.

Nun erstmal danke an euch und gute Nacht.

 

SpecialK

Share this post


Link to post
prefrontallobotomy

Erst mal großes Lob, dass mit dem Webserver auch noch Streaming kommt, das habe ich mir ja nicht im Traum auszumalen gedacht. Hier im Forum zu stöbern, das ist ja fast schon wie ein Weihnachtsfest mit immer neuen Überraschungen, das gar nicht mehr zu Ende gehen will. Erst Multi-Tuner-Unterstützung im DVBViewer, dann der Webserver mit Remote-Programmierung, vor ein paar Tagen kam dann Rayman mit seinem EPG-Search-Plugin, und schließlich als Krönung auch noch Streaming übers Web. Sehr schön. o:)

 

So, nach dem Lob hoffe ich hier jetzt aber auch noch mit einem Fehlerbericht Unterstützung geben zu können:

 

* Wurde glaube ich woanders schon angemerkt: die horizontale Menüleiste zeigt auf XGA-Bildschirmen die Streaming-Config nicht mehr an. Zum Glück gibt es Opera mit der praktischen Zoom-Funktion, sonst hätte ich gar nicht testen können. :bye: Die Leiste ist jetzt so breit, dass ich nicht glaube, dass man so viele Menüpunkte da noch gescheit für eine 1024er-Bildschirmbreite unterbringen kann. Warum nicht den Menüpunkt zur Streamingkonfiguration in die allgemeine Konfiguration packen? Es wäre außerdem schön, dass wenn man das Streaming dann ausschaltet auch der Menüpunkt "Streaming" in der Menüleiste nicht mehr aufgeführt wird. Also mein Vorschlag für eine konsistentere, übersichtlichere Bedienung: Streaming-Config unter allgemeine Config packen und Ausblendung des Menüpunktes Streaming bei Deaktivierung der Streaming-Funktion.

 

* Wird die Checkbox hinter "Don't compress" aktiviert und die Seite aktualisiert, ist das Häkchen verschwunden und neben dem leeren Kästchen steht "checked". Die Option wurde wohl erfolgreich gesetzt, nur wird das aufgrund eines Tippfehlers, wie ich vermute, hier etwas "unkonventionell" angezeigt. :huh: Die Folge ist u.a., dass man jedesmal beim Speichern der Einstellungen die Checkbox selbst noch mal setzen muss, damit die Einstellung nicht wieder verlorengeht.

 

* Die Porteinstellung scheint nicht zu funktionieren. Egal, welchen Port ich wähle, wenn ich anschließend auf die Streaming-Seite gehe und mir mit einem Rechtsklick auf das Videofenster genauere Infos ausgeben lasse, sehe ich immer, dass das System auf Port 3335 zugreifen will.

 

* Zu guter Letzt gibt es bei mir ebenfalls noch das ganz grundlegende Problem, dass ich einfach keinen Stream geliefert bekomme. Das Windows Media Player-Plugin im Browser sucht, aber findet nichts. Auch der Versuch, einen Stream von einem anderen Rechner im lokalen Netz mit dem VLC abzugreifen, bringt keinen Erfolg. Die konstante CPU-Auslastung des ältlichen Rechners, auf dem DVBViewer läuft und der die Transkodierung wegen mangelnder Reserven sowieso nicht packen würde, zeigt mir, dass er noch nicht mal ansatzweise den Versuch unternimmt, Videodaten zu transkodieren. Ist der Fehler hier vielleicht bei mir zu suchen, fehlt noch irgendetwas an Grundausstattung, muss man zur Nutzung dieser Funktionalität etwa vielleicht vorher erst einmal den Windows Media Encoder installiert haben, weil eventuell irgendwelche Komponenten aus dieser Installation benötigt werden?

 

* Nur für den Fall, dass es in Vergessenheit geraten ist: Ich habe hier --->hier<--- schon mal einen Bug gepostet, dass die letzten Einträge in der Übersicht manchmal etwas komisch platziert werden und in diesen Fällen dann auch die Kommando-Buttons unten beim letzten Beitrag fehlen (siehe Screenshots). Das Problem besteht nach wie vor.

 

Wünsche:

 

* Ich würde mir ferner wünschen, dass noch einige Elemente von Gibmans Änderung am Benson-Design ("Benson-Design", der Name hat was, den würde ich mir schützen lassen... ach nein, gibt es ja ->schon<-! So'n Mist aber auch! :) ) in das Web-Template einfließen würden. Die IMDb-Links fand ich ganz nett, und es schien mir wirklich sinnvoll, dass in der großen Übersicht "was-läuft-jetzt" der Eintrag unter dem Mauspointer hervorgehoben wurde. Farblich gab es so eine Einheit mit der Knopfleiste unten, und damit war auf den ersten Blick ersichtlich, zu welchem Eintrag die Knöpfe denn jetzt gehören. Ohne diese Hervorhebung sieht die Übersicht für mich ziemlich unstrukturiert und ein wenig wie Kraut und Rüben aus. Obwohl ich den Webserver schon länger im Betrieb habe und mit dem Design eigentlich vertraut sein sollte, merke ich, wie ich immer unwillkürlich kurz stocke, ob ich denn jetzt auch wirklich auf die richtigen Elemente klicke. Mist, fühle ich mich plötzlich soooo alt und tattrig... :blink:

 

* Der Kollege von SolveigMM hatte doch hier im Forum mal seine On-the-fly-Requantisierer-Demo mit DirectShow-Komponente gepostet, die angeblich keine Beschränkung haben soll. Wäre es sinnvoll/möglich, zusätzlich zu den Optionen "Transkodierung ins Windows Media-Format" und "unkomprimiert" auch noch eine Schnittstelle zu diesem Requantisierer einzubauen, der für seine Arbeit wahrscheinlich weniger CPU-Power braucht als eine komplette Neuencodierung im WM-Format? Ich habe da als Anwendungsfall die Übertragung von TV über ein schlechtes WLAN im Sinn, für das der unmodifizierte Strom zu groß dimensioniert ist und es deshalb zu Aussetzern kommt.

Edited by prefrontallobotomy

Share this post


Link to post
Guest Lars_MQ
Also mein Vorschlag für eine konsistentere, übersichtlichere Bedienung: Streaming-Config unter allgemeine Config packen und Ausblendung des Menüpunktes Streaming bei Deaktivierung der Streaming-Funktion.

Ich bin mehr für die jetzige Lösung. Auf die weise lässt sich sehr einfach abfangen, wenn das Streaming plugin nicht installiert ist. Und es erspart in diesem Fall lästige fragen: warum geht das nicht, ich hab das doch in der config aktiviert.

Aber wie Benson schon sagte er wird sich was dazu ausdenken, wie man die Leiste besser aufbaut :blink:.

 

Wird die Checkbox hinter "Don't compress" aktiviert und die Seite aktualisiert, ist das Häkchen verschwunden und neben dem leeren Kästchen steht "checked".

Bestätigt, dort ist in der hmtl datei das ">" um ein wort nach links gerutscht. Behoben.

 

Die Porteinstellung scheint nicht zu funktionieren.

Bestätigt und behoben, lag am Streaming plugin.

 

das ganz grundlegende Problem, dass ich einfach keinen Stream geliefert bekomme.

Also 1. stell mal alles zurück auf anfang (in der HTTPServer.ini die [WebStreaming] abteilung löschen).

Das ganze ist nicht zu vergleichen mit dem Streaming des DVBViewers selber.

Dieses Webstreaming braucht EINIGES an CPU leistung, da der Stream komplett recodiert wird.

 

Das Streaming wird komplett von Microsoft komponenten übernommen. Es benötigt den Mediaplayer. Benson sagte, bei ihm geht es nicht mit der 8 nur mit Version 9. Leider können wir nicht alle möglichen kombinationen selber durchtesten. Also müssen wir uns rantasten, was die Grundvoraussetzungen sind.

Gestern hat christian auf jedenfall schon testweise einen Stream nach Houston, USA geschickt (Starwars).

 

Es wäre also gut, wenn wir rückmeldungen kriegen in der Form:

- Streaming läuft/läuft nicht,

- MS Mediaplayerversion

- Windowsversion (inkl. SP)

- benutzter Browser

- (und weil MS alles mögliche irgendwo hinpackt) welche Version des IE im system installiert ist (auch wenn sie nicht benutzt wird).

 

Also bestätigt ist bis jetzt:

- Win XP SP2, MS Mediaplayer 10, IE 6 mit allen patches

- Win 2k SP4, MS Mediaplayer 9, IE 6

 

Achja eines noch: Wer ein Problem damit hat, dass wir die M$ Komponenten dafür nutzen, der sollte das Streaming Plugin nicht installieren, der Betrieb des Webserver ist nicht von dem Streaming plugin abhängig.

Share this post


Link to post
SpecialK

Wie schon besprochen:

Als Hostsystem des Viewers:

Win2003 Server Sp1, alle Patches

Als Testsystem:

Win Xp SP2, alle Patches, IE 6.0 und Opera 8.1, Mediaplayer 10 => geht nicht

 

SpecialK

Share this post


Link to post
pilz

Super Teil, der neue Webserver.

Ein kleines Problem habe ich noch. Möchte ich den DVBViewer über den Webserver mit dem Power Button schliesen, erscheint am DVBViewer die Frage "wirklich schliesen?". Erst nach bestätigen "OK" schließt dieser sich. Am Webserver bekomme ich allerdings von alle dem nichts mit.

Oder kann man diese Frage abschalten. Habe aber nichts davon entdecken können.

Beim Schließen, direkt am DVBViewer erscheint diese Frage nicht.

Share this post


Link to post
SpecialK

Kann man abschalten. Hatte nämlich das gleiche "Problem" :blink:

Im DVBViewer bei den Optionen unter, hmm, ich glaube "Allgemein - Beenden"

Sitze gerade nicht davor, ist aber zumindest ziemlich einfach zu finden.

Da gibt es den Punkt, den du suchst.

 

SpecialK

Share this post


Link to post
prefrontallobotomy

Hostsystem des Viewers:

Win XP Pro SP2, alle Patches, Media Player 10

 

Client über Webinterface:

Win XP Pro SP2, alle Patches, IE 6.0 (letzter Stand) und Opera 8.5, Mediaplayer 9 und 10 (auf verschiedenen Systemen) sowie Versuche, einen Stream über VLC abzurufen (verschiedene Versionen).

 

Bekomme einfach kein Streaming hin, auch nicht, wenn "don't compress" aktiviert ist.

 

Wie sieht's denn mit meinem unkommentiert gebliebenen Vorschlag aus, Web-Server-Streaming und/oder vielleicht sogar den DVBServer mit einer -->Requantisierungsfunktion<-- auszustatten? Ist diese Idee einfach nicht diskussionswürdig (weil technisch schlecht realisierbar/rechtliche Situation nicht eindeutig/anhaltende freie Verfügbarkeit der externen Komponente zu unsicher?) und deshalb schon verworfen, oder wird das von euch als legitime Anfrage mit einer gewissen Aussicht auf Realisierung angesehen?

Share this post


Link to post
Benson

Wenn ihr den DVBViewer direkt über das Webinterface gestartet habt, dürft ihr beim Testen der Streaming-Funktionalität nicht vergessen, auch einen Kanal zu tunen. Das ist mir nämlich am Anfang mal passiert.

 

Zum weiteren Debugging: Schaut, ob die temporäre lokale asf-Datei überhaupt erzeugt wird. Wenn das nicht der Fall ist, ist es schon mal kein Browserproblem, sondern ein Problem mit dem WMP / MPEG-Decodern.

 

Bei mir läuft das Streaming jedenfalls jetzt auf beiden Systemen absolut problemlos, auch das Umschalten geht. Die Systemlast durch das zusätzliche Encoden ist allerding schon recht hoch, sie liegt bei beiden System um die 80%.

Share this post


Link to post
Guest Lars_MQ
auch nicht, wenn "don't compress" aktiviert ist.

Lasse die grundeinstellungen. don't compress verschlimmert alles nur.

 

Vorgehen (mit grundeinstellungen) -> lokal.

- DVBViewer mit dem Plugin läuft.

- Firewall ist entsprechend konfiguriert, das der Webserver UND das Plugin nicht geblockt werden.- Ein FTA Channel ist getuned.

- In den Streamoptionen des Webservers ist nur active entsprechend angekreuzt worden und mit speichern gespeichert, alles anderes (besonders die Profile und die rechte seite) bleibt wie es ist.

- Stream aufrufen.

 

Über requantisierer machen wir uns gedanken, wenn das system erstmal läuft. Das eine hat mit dem anderen nichts zu tun und würde (abgesehen von der rechtlich zweifelhaften seite) ein umstellen der gesamten architektur erfordern.

Share this post


Link to post
SpecialK

Wo soll die asf Datei liegen?

Einen Channel hatte ich eingestellt. Ich bekomme beim Stream-Fenster im Mediaplayer auch die Meldung, dass keine Verbindung zum Server hergestellt werden kann. Genau diese Meldung kommt auch, wenn ich das ganze im Mediaplayer manuell aufrufe.

 

SpecialK

Share this post


Link to post
Guest Lars_MQ
Die Systemlast durch das zusätzliche Encoden ist allerding schon recht hoch, sie liegt bei beiden System um die 80%.

Ich habe schon überlegt, ob man nicht ein disableAV zum streamen sendet, um die last etwas niedriger zu halten.

Share this post


Link to post
prefrontallobotomy
Lasse die grundeinstellungen. don't compress verschlimmert alles nur.

Schon klar, ich habe es hauptsächlich mit den Grundeinstellungen versucht, alles ohne Erfolg bis jetzt.

 

Vorgehen (mit grundeinstellungen) -> lokal.

- DVBViewer mit dem Plugin läuft.

Ja. Habe das Plugin ins Verzeichnis "Plugins" des DVBViewers kopiert, das ist doch richtig, oder?

 

EDIT: Nur um Missverständnissen vorzubeugen, registriert habe ich das Plugin in dem Ordner nach dem Reinkopieren mit dem beiliegenden Batchfile natürlich auch.

 

- Firewall ist entsprechend konfiguriert, das der Webserver UND das Plugin nicht geblockt werden.- Ein FTA Channel ist getuned.

Keine Firewall. Und auch auf localhost (Host gleichzeitig als Gast) tut sich nix.

 

- In den Streamoptionen des Webservers ist nur active entsprechend angekreuzt worden und mit speichern gespeichert, alles anderes (besonders die Profile und die rechte seite) bleibt wie es ist.

Ja, nicht angerührt.

 

- Stream aufrufen.

Und es tut sich nix.

 

Zum weiteren Debugging: Schaut, ob die temporäre lokale asf-Datei überhaupt erzeugt wird. Wenn das nicht der Fall ist, ist es schon mal kein Browserproblem, sondern ein Problem mit dem WMP / MPEG-Decodern.

Da bin ich mir ganz sicher, dass dem so ist. Auf einem Pentium 3 mit 600 MHz sollte man doch in der CPU-Auslastung deutlich sehen, wenigstens in Form einer kurzen Spitze, wenn sich das System an einer Transcodierung versucht. Ist aber nichts, nicht das kleinste Zucken.

 

Wo würde ich die lokale asf-Datei denn finden?

 

Da es ja bei so vielen anderen offenbar läuft, befürchte ich fast schon, dass meine Konfiguration vielleicht irgendwie verhunzt ist. :mellow: Dass das Transcoding bei mir mit dieser Hardwareausstattung nicht auch nur ansatzweise sinnvoll funktionieren kann, ist mir schon klar, aber wenigstens den MPEG-Strom irgendwann mal über das Webinterface gestreamt zu bekommen, wäre schon eine feine Sache. DVBServer ist schön, aber bei meinem Setup (nur eine Karte, und der DVBViewer soll nach Möglichkeit als Dienst auf einem Headless Server ständig laufen und nicht für den DVBServer beendet werden müssen) leider keine befriedigende Lösung.

Edited by prefrontallobotomy

Share this post


Link to post
Benson
Wo würde ich die lokale asf-Datei denn finden?

 

Standardmäßig liegt sie im Windows Temp-Verzeichnis des angemeldeten Users (also C:\Dokumente und ...\Users\Lokale Einstellungen\Temp\..).

 

Aber auf einem Pentium 3 mit 600 MHz wirst du mit dem Encoding wahrscheinlich eh wenig Erfolg haben. Wie erwähnt sind meine System mit dem Encoding schon fast am Limit. Also ein P4 sollte es da wohl mindestens sein.

Share this post


Link to post
prefrontallobotomy
Standardmäßig liegt sie im Windows Temp-Verzeichnis des angemeldeten Users (also C:\Dokumente und ...\Users\Lokale Einstellungen\Temp\..).
...bzw. dann wahrscheinlich des Accounts, unter dem mein Service läuft. Ich finde aber nichts. (Auch wenn ich den DVBViewer nicht als Service, sondern ganz normal von Hand starte, finde ich nichts, meine Service-Installation wird also wohl nicht der Grund sein.)

 

Aber auf einem Pentium 3 mit 600 MHz wirst du mit dem Encoding wahrscheinlich eh wenig Erfolg haben. Wie erwähnt sind meine System mit dem Encoding schon fast am Limit. Also ein P4 sollte es da wohl mindestens sein.

Schon klar. :mellow: Aber er sollte doch wenigstens versuchen, was zu liefern, und dass er das bei mir nicht tut, macht mich stutzig. Nebenbei hoffe ich ja darauf, dass mir die Streaming-Erweiterung (irgendwann einmal) auch den MPEG-Strom durchreichen kann, und das klappt zumindest mit dem DVBServer schon wirklich gut ohne nennenswerte Auslastung (aus oben bereits genannten Gründen ist der DVBServer bei mir aber leider ziemlich unpraktisch).

Edited by prefrontallobotomy

Share this post


Link to post
Guest Lars_MQ
und das klappt zumindest mit dem DVBServer schon wirklich gut ohne nennenswerte Auslastung

Ja das ist ein durchreichen, das wird auch niemals als webstream laufen (es sei denn du hast eine leitung die bis zu 20 Mbit (Netto!) datenrate verträgt.

 

Wir reden hier über:

1. Demuxing und MPEG2 dekompression.

2. Skalierung, aufbereitung und neucodierung im ASF format.

 

Ich weiss nicht ob er es überhaupt versucht bei Dir, kann durchaus sein, das MS dort sicherungen drinne hat.

 

Ich kann sagen mit einem Athlon XP 2000+ kommt er bei einem 256 kbit stream an den absoluten Rand seiner leistungsfähigkeit (AV des DVBViewer ist disabled).

 

Selbst bei dem einfachen Defaultformat liegt er bei 60 - 70% das nur nach milchmädchrechnung runtergerechnet auf Deine 600 Mhz wären so um die 200% cpu auslastung :mellow:.

Share this post


Link to post
prefrontallobotomy
Ja das ist ein durchreichen, das wird auch niemals als webstream laufen (es sei denn du hast eine leitung die bis zu 20 Mbit (Netto!) datenrate verträgt.

Schon klar. Will ich ja auch nicht als Webstream haben, sondern im lokalen Netz. Das Problem ist dieses (wenn ich alles richtig verstanden habe): DVBViewer und DVBServer teilen sich keine Hardware. Also entweder weise ich eine TV-Karte dem einen oder dem anderen Programm zu. Wenn ich eine zweite Karte einbaue, kann ich wohl zusätzlich zum DVBViewer-Betrieb mit dem DVBServer ins Netz streamen, aber muss ihn vorher beenden, wenn ich im DVBViewer bei eben diesen zwei installierten Karten auch mal von zwei Transpondern gleichzeitig aufnehmen will. Das finde ich unpraktisch. Volle DVBServer-Funktionalität auch im DVBViewer bzw. auch Recorderfähigkeiten mit Remotesteuerung im DVBServer wäre besser. Oder eben DVBViewer-Fernsteuerung plus Streaming ohne Neucodierung einfach im Webinterface, das wär optimal.

 

Wir reden hier über:

1. Demuxing und MPEG2 dekompression.

2. Skalierung, aufbereitung und neucodierung im ASF format.

 

Ich weiss nicht ob er es überhaupt versucht bei Dir, kann durchaus sein, das MS dort sicherungen drinne hat.

Hab gerade nochmal den anderen Thread verfolgt, dort schreibt Gibman, dass bei ihm ebenfalls nichts streamt. Aber ich weiß ja nicht, ob er das auch auf so einer antiken Schachtel laufen hat. :mellow:

 

http://www.DVBViewer.com/forum/index.php?s...indpost&p=89243

 

Selbst bei dem einfachen Defaultformat liegt er bei 60 - 70% das nur nach milchmädchrechnung runtergerechnet auf Deine 600 Mhz wären so um die 200% cpu auslastung :D.

Du kennst dich da natürlich weitaus besser aus, aber ich bin von der Aussage sogar positiv überrascht. Ich hätte damit gerechnet, dass mindestens die sechsfache Leistung nötig wär.

 

Noch 'ne Verständnisfrage: Ist "don't compress" überhaupt das, was ich mir vorstelle, oder reden wir hier aneinander vorbei? Heißt "don't compress" Streaming ähnlich wie beim DVBServer, ohne Neucodierung, also dass das vermutlich auch noch auf meinem System läuft, oder ist mit der Bezeichnung etwas ganz anderes gemeint, und ich verstehe das nur falsch?

Share this post


Link to post
Guest Lars_MQ

Genau weiss ich es nicht, aber Don't compress bedeutet wohl schicke das als unkomprimierten strom, sprich ein kräftige folge von einzelbildern mit einer Bandbreite jenseits von gut und böse :mellow: Ich habs bei mir nur durch ein harten reset beenden können, da der rechner so mit sich selber beschäftigt war, das nix mehr ging :D

Share this post


Link to post
prefrontallobotomy
Genau weiss ich es nicht, aber Don't compress bedeutet wohl schicke das als unkomprimierten strom, sprich ein kräftige folge von einzelbildern mit einer Bandbreite jenseits von gut und böse :mellow: Ich habs bei mir nur durch ein harten reset beenden können, da der rechner so mit sich selber beschäftigt war, das nix mehr ging :D

Aha, gut zu wissen, also hab ich's doch nicht richtig kapiert gehabt, worum es sich dabei handelt.

 

Besteht denn die Möglichkeit, sowas wie von mir skizziert noch einzubauen? Also anstatt neu zu kodieren einfach den MPEG2-Stream zu schicken und im Browserfenster dann anzeigen zu lassen?

Share this post


Link to post
Benson

So ich habe mich wie versprochen nochmal um das Template gekümmert, hier die neue Version:

 

web_blue_v11.zip

 

Changelog:

- gibmans nette JavaScript Spielereien aufgenommen (siehe dieses Topic)

- Menü Punkte verkleinert, so dass bei XGA-Auflösung noch alles zu sehen ist

- Fernbedienung: neue Hintergrund-Grafik

- bei Stream-Konfiguration den "checked" Bug behoben

 

Edit 30.3.03:

- FB Hintergrundgrafik um ein paar Pixel gekürzt

- Action-ID bei "Untune" geändert, jetzt "Disable A/V" vorher "Shutdown card"

Edited by Benson

Share this post


Link to post
prefrontallobotomy
Changelog:

- gibmans nette JavaScript Spielereien aufgenommen (siehe dieses Topic)

- Menü Punkte verkleinert, so dass bei XGA-Auflösung noch alles zu sehen ist

Sehr schön, danke! :)

 

- Fernbedienung: neue Hintergrund-Grafik

Wenn ich ehrlich sein soll, bin ich davon im Moment weniger überzeugt, auch wenn ich den feinen Farbverlauf sehr mag. Dein Design ist ja ansonsten sehr "eckig" :D, also auch die Fernbedienung ist "eckig" eingefasst, und diese Rundungen empfinde ich ein wenig als Stilbruch. Das liegt wahrscheinlich daran, dass die Fernbedienung bei meinen beengten Bildverhältnissen unten scharf begrenzt ist und vor allem aber der Scrollbalken von der Seite links daneben direkt anliegt. Der Abstand von oben, den du für die Fernbedienungsbegrenzung gewählt hast, sollte meinem ästhetischen Empfinden nach auch an der linken Seite und unten anliegen.

 

Das ist aber sicher nur eine Geschmacksfrage. Was für den ein oder anderen (in diesem Fall eben leider auch mich :)) vielleicht ungleich störender wirkt, ist die Tatsache, dass durch diese Neugestaltung die Fernbedienung größer geworden ist und zumindest bei meinem XGA-Setup nicht mehr komplett auf den Bildschirm passt, die ist immer unten ein wenig abgeschnitten, das schaut dann nicht so überzeugend aus.

 

Bilder:

 

Firefox: remoteff5lc.th.jpg Opera: remoteopera1rc.th.jpg

 

 

EDIT:

 

Das ist wohl wirklich hauptsächlich eine Gewöhnungssache. Je länger ich mir die neue Fernbedienung angucke, desto besser gefällt sie mir. Nach fünf Minuten finde ich sie jetzt schon richtig schick. :D

 

Hätte nicht so schnell antworten (ist sonst eigentlich gar nicht meine Art), sondern das erst mal auf mich wirken lassen sollen... :D:mellow::blush:

 

Dass sie unten abgeschnitten ist, ist gar nicht so tragisch, und schlimmstenfalls fehlt bei mir das Autohide-Feld, was auch noch verschmerzbar ist. Also: Lass das überarbeitete Design mit dem neuen Hintergrund und den runden Ecken um Himmelswillen auf jeden Fall so, wie es jetzt ist! Gute Arbeit! :D Ich hab' oben vor ein paar Minuten wohl wirklich nur Quatsch geredet, da war ich einen Moment lang offenbar nicht ganz zurechnungsfähig. :blink:

 

Trotzdem möchte ich aber nach wie vor vorschlagen, den gleichen Abstand, den die FB von oben hat, auch zum Frame links hin einzubauen, dann wirkt das ganze Design aus meiner Sicht noch ausgereifter.

Edited by prefrontallobotomy

Share this post


Link to post
Benson

Sorry, habs nur im Standard IE Fenster getestet. Da passte es gerade so. Muß dazu sagen, dass ich schon seit ewigen Zeiten einen 19" Monitor mit 1280x1024 Auflösung habe, deswegen schiebe ich das Fenster dann immer nur auf ungefähr 1024x768, was eventuell nicht ganz der Realität entspricht.

Share this post


Link to post
prefrontallobotomy
Sorry, habs nur im Standard IE Fenster getestet. Da passte es gerade so. Muß dazu sagen, dass ich schon seit ewigen Zeiten einen 19" Monitor mit 1280x1024 Auflösung habe, deswegen schiebe ich das Fenster dann immer nur auf ungefähr 1024x768, was eventuell nicht ganz der Realität entspricht.

Ja, hab's nochmal weiter probiert. Im IE mit Luna-Oberfläche passt's bei mir in XGA nur dann 100%ig, wenn lediglich die Navigationsleiste angezeigt wird, also ohne darunter angeordnete Addressleiste oder Toolbar. In Classic passt's so grade eben noch auch mit zusätzlicher Addressleiste. In Firefox ist alles erreichbar, aber damit die schöne Umrandung der FB unten auch noch angezeigt wird und somit alles optisch stimmig ist, darf nur die Navigationsleiste eingeblendet sein.

 

Aber wie gesagt, nach etwas Gewöhnung finde ich es halb so schlimm, und die meisten Leute arbeiten heute ja wahrscheinlich sowieso schon in höheren Auflösungen(*). Um etwas mehr Platz zu schaffen und den Beschränkungen der XGA-Auflösung somit ein wenig entgegenzukommen, müsstest du wohl das Layout der Tasten nochmal etwas umkrempeln. Diese Tastenordnung ist dir aber sehr gut gelungen, du hast ja z.B. die Droplist durch einen größeren Zwischenraum von der Lautstärkeregelung abgesetzt, was ich sehr gut und notwendig finde, weil das jetzt aufgeräumter wirkt. An dem grundlegenden Layout würde ich wirklich nicht mehr viel ändern, vielleicht kannst du hier und da bei den vertikalen Zwischenräumen ein paar Pixel abknapsen, das könnte vielleicht in der Summe schon etwas helfen.

 

[(*) Dafür habe ich persönlich zwar absolut keine Verwendung, aber hier kommt mir gerade die entgegengesetzte Idee, dass sich jemand, der zuviel Zeit zur Verfügung hat :mellow:, doch vielleicht mal an einem verkleinerten PDA-tauglichen Webinterface versuchen könnte, sowas wie es beim Slimserver optional gibt (das ist bei einer SlimServer-Installation dann gesondert erreichbar über http://adresse.des.slimservers:port/handheld )...]

Edited by prefrontallobotomy

Share this post


Link to post
Lars_k

Könnte mir bitte jmand nen link zu dem prog geben weil der auf seite eins bringt mich nur in die mitte dieses Threads

Share this post


Link to post
hdv

Hallo,

 

Könnte mir bitte jmand nen link zu dem prog geben weil der auf seite eins bringt mich nur in die mitte dieses Threads

in dem Beitrag auf den du verwiesen wirst steht am Ende:

 

[Edit]Verlegt in die Membersarea[/edit]

 

soll heißen, das du es jetzt im Mitglieder-Bereich finden kannst.

 

 

:mellow:

Share this post


Link to post
prefrontallobotomy
Könnte mir bitte jmand nen link zu dem prog geben weil der auf seite eins bringt mich nur in die mitte dieses Threads

Ist im Members-Bereich für registrierte Kunden zu finden ("Customer Area"), dort in der Beta-Section unten:

 

http://www.DVBViewer.com/members

 

Steht dort aber auch im Thread:

 

[Edit]Verlegt in die Membersarea[/edit]

http://www.DVBViewer.com/forum/index.php?s...indpost&p=88903

Share this post


Link to post
Lars_k

Danke und bitte um verzeihung das ich nicht alles gelesen hab

Share this post


Link to post
Lars_k

So ich bekomme immer mehr graue harre bei mir streamt nichts nicht mal ein bischen.

Also ich hab auf meinem Rechner Xamp laufen und komme auch von überall dort drauf wenn ich nur die HTTPServer.exe dort hin kopiere mit allen was da so bei dem Dowload bei ist und dann nen Doppel klick mache und das fenster aufgeht steht dort port 80 dann meine localhoost ip ( 127.0.0.1 ) dann ein feld wo Activate steht wo ich aber keinen hacken reinmachen kann der geht immer gleich wieder raus.

Dann ein feld wo steht connect on start dort kann ich einen hacken rein machen

Und dann kommt da noch eine ordner angabe wo drin steht D:\Programme\xamp\htdocs\\Web

Im DVBViewer hab ich bei optionen Netzwerkn Unicast Übertragung.

und nirgends nen butten Streaming oder ich finde ihn nicht.

Die .bat hab ich ausgeführt aber es streamt immer noch nichts.

Ich hänge unten mal ein oder 2 screens an.

Share this post


Link to post
hdv

Hallo,

 

kopiere deinen bisherigen DVBViewer Pro Ordner (um die funktionierende Installation nicht kaputt zu machen)

 

jetzt fügst du der kopierten Installation allen in der Zip-Datei enthaltenen Dateien hinzu und ersetzt bereits vorhandene Dateien.

 

Doppelklick auf HTTPServer.exe und minimieren (verschwindet neben die Uhr ins Tray)

Starte deinen Internetbrowser und gebe diese Adresse ein: http://127.0.0.1

Benutzername und Kennwort eingeben: Default Benutzer und Kennwort: admin

 

siehe hier: Webinterface für den DVBViewer

 

so habe ich es jedenfalls vorhin zum laufen gebracht, stremen braucht wahrscheinlich viel Rechenleistung, ich bekomme das streamen bei mir nicht hin.

 

siehe auch nochmal hier: das Streamen per HTTP (und internet) ermöglicht

 

 

:mellow:

Share this post


Link to post
Guest Lars_MQ

Das streaming plugin MUSS registriert werden mit der register bat im DVBViewer Plugins ordner.

Share this post


Link to post
prefrontallobotomy
So ich bekomme immer mehr graue harre bei mir streamt nichts nicht mal ein bischen.

Also ich hab auf meinem Rechner Xamp laufen und komme auch von überall dort drauf wenn ich nur die HTTPServer.exe dort hin kopiere mit allen was da so bei dem Dowload bei ist und dann nen Doppel klick mache und das fenster aufgeht steht dort port 80 dann meine localhoost ip ( 127.0.0.1 ) dann ein feld wo Activate steht wo ich aber keinen hacken reinmachen kann der geht immer gleich wieder raus.

Dann ein feld wo steht connect on start dort kann ich einen hacken rein machen

Und dann kommt da noch eine ordner angabe wo drin steht D:\Programme\xamp\htdocs\\Web

Ich glaube, ich kann dir nicht ganz folgen. Wovon sprichst du? Hast du aus dem xampp-Paket Apache auf Port 80 laufen, und willst zusätzlich dazu auch noch den DVBViewer Webserver auf Port 80 installieren? Das geht nicht, der Port 80 kann nur einmal in Beschlag genommen werden. Der Standardport für den DVB-Webserver ist 1111.

 

 

Im DVBViewer hab ich bei optionen Netzwerkn Unicast Übertragung.

und nirgends nen butten Streaming oder ich finde ihn nicht.

Das hat dann wiederum nix mit dem Webstreaming zu tun, was du suchst ist vielleicht der DVBServer für's Streaming im lokalen Netzwerk?

 

 

@Lars_MQ:

 

Meine Probleme mit den Streamingversuchen werden wohl wirklich auf irgendwelche ominösen fehlenden DirectShow-Komponenten zurückzuführen sein. Ich hab da gestern eine andere Multimedia-Anwendung installiert und jetzt plötzlich scheint auch das DVBViewer-Web-Streaming zu funktionieren. Ich seh zwar immer noch nix (bei der Hardware kein Wunder ;-), aber das Buffering beginnt wenigstens und die Infos über die im Stream verwandten Codecs und Bitraten, die ich schon auslesen kann, sehen soweit ganz plausibel aus. Die von mir berichtete Problematik scheint also wirklich nur ein singuläres Konfigurationsproblem auf meiner Seite zu sein ohne irgendwelche weitere Relevanz.

Share this post


Link to post
Guest Lars_MQ

@prefrontallobotomy

Ich hab mich in der zwischenzeit auch etwas schlau gemacht. In der nächsten version (kommt bald) werden noch andere profile mit drinnen sein, die angeblich (laut MS) auch mit schwächeren Rechnern ein streaming ermöglichen.

Share this post


Link to post
Lars_k

Ok nun bekomme ich das interface richtig angezeit und kann nun beinen DVBViewer übers internet Steuern aber leider hab ich kein bild ich sehe zawar den media player aber alle knöpfe sind grau und ich kann nichts anklicken uns sehne tuht ich nur ein schwarzes bild den Xamp hab ich wider runtergeschmissen. Wie bekomme ich ein bild?

Mein system ist ein AMD 2400+ mit 1,5 gb ram und dsl 6000 hab ich auch noch ich denke das es nicht am zu schwachen system liegt.

Ich habe port 80 und port 1111 an dem Server rechner frei geben muß ich noch welche frei geben?

Share this post


Link to post
Lars_k

Ach ja Videotext und alles andere geht nur das streaming nicht

Share this post


Link to post
Lars_k

ok nun kommt was an doch sobald er anfangt zu streamen hängt sich der dvbviever auf und nichts geht mehr dann muß ich den srver und den DVBViewer neu starten welche einstellungen muß ich denn vorbehmen?

Ich hab keinen plan was ich noch machen soll wenn wer lust hat kann er ja mal auf http://latax.dyndns.org gehen passwort ist das standart vileicht sind meine einstellungen ja falsch. Und die pw bitte so lassen wie sie sind.

Edited by Lars_k

Share this post


Link to post
hackbart

Ich hab das mal auf deinem Rechner getestet und es läuft problemlos. Wichtig ist, dass einige Systeme irgendwie das Activemovie Objekt auf der Streaming seite nicht mögen. Wähl die Seite einfach aus, dann öffne den windows mediaplayer und tippe bei url:

http://ip:port ein. Port ist das was in den Streamingoptionen für die ASF angegeben wurde. Ip ist deine dyndns Adresse.

 

Christian

Share this post


Link to post
Lars_k

Mit welchem Browser hast du das den getestet?

Wenn ich men dyndns andresse eingebe dann kommt die pw abfrage und dann das web interface.

Wenn ich im WMP über datei url öfnen gehe kommt nur ne Fehler meldung das WMP die datei nicht Wiedergeben kann weil ein netzwerk fehler aufgetreten ist naja ich soll überprüfen ob eine netzwerk verbindung besteht und ob der Proxy richtig eingestellt ist Proxy hab ich nicht und die netzwerk einstellungen sind ok.

So und aufeinmal geht es wiso auch immer.

Immer noch folgendes Problem wenn ich übers wep den Player auf dem rechner anmache stürzt der Server ab sobald das streamen beginnt mache ich allerdings den player per hand an also direkt auf dem rechner geht es hat da jemand ne idee woran das noch liegen könnte?

Edited by Lars_k

Share this post


Link to post
maju

Bei mir funktioniert das Streaming ganz gut.

2 Dinge habe ich aber auf dem Herzen:

 

1) Obwohl am "Server" die CPU Auslastung nicht auf 100% geht (70-80%), ruckelt das Bild an den Clients doch sehr stark und ist eigentlich nicht für die Dauerbenutzung geeignet. Woran könnte das liegen? BTW: Es ruckelt auch wenn der Client am Server selbst gestartet wird. Netzwerkprobleme können also ausgeschlossen werden.

 

2) MMS beschränkt sich ja nicht auf WMV als Container/Format. Wäre es auch möglich andere Profile zu nutzen, die z.B. das Encodieren nach H.263 und AAC in einen .MP4 Container ermöglichen? Das Echtzeitcodieren mit den 3ivx Filtern ist weit weniger CPU-lasting als WMV. Auch Nero scheint sehr schnelle DirectShow Encodier Filter mitzubringen (hab' ich aber noch nicht getestet).

 

3) Hab' auch das Streamen auf einen Standalone-Player getestet (http://www.digitalrise.biz/products/dvb_player/xstream/). Es geht! Aber leider nur der Ton, da der Xstream Player WMV8 nicht dekodiert sondern nur WMV9 ...

Besteht Hoffnung, dass es auch ein WMV9 Encodierprofil geben wird?

 

Verdammt, jetzt sind's doch 3 Punkte geworden! :bye:

Share this post


Link to post
Guest Lars_MQ

3. wm9 hat keine systemprofile mehr und ein selber zusammenbauen ist sehr aufwendig, also zähle nicht auf eine funktion in nächster zukunft ;)

 

1. Das ist abhängig vom system. selbst wenn der taskmanager (der eine genauigkeit hat wie eine sanduhr im vergleich zu einer atomuhr) anzeigt es ist alles schön, sind spitzen vorhanden, die das system auslasten.

 

2. hängt mit 3. zusammen und zusätzlich damit, das es leider nicht möglich ist, das zu testen da die komponenten ständig crashen, insofern wirds da auch nix weiter geben, bis absolut sichergestellt ist, das alle komponenten (insbesondere mpegdecoder und die diversen encoder) miteinander harmonieren (also wahrscheinlich am jüngstens tag :bye: ). Aus dem gleichen grund wird es für die nächste version zwar ein streaming von TS und Mpeg dateien geben (sprich Aufnahmen), aber keine AVI da divx und auch xvid ständig crashen....

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...