Jump to content

Imon VFD/LCD Plugin


markymark

Recommended Posts

Hallo, kein Problem...

 

lade dir die letzte neuste Version von Imon runter Link, danach einfach und normal installieren.

Das Plugin hier runterladen(z.B die 0.98 oder 1.00) und in einen Odnr oder Verzeichnis deiner Wahl entpacken.

 

Dann such dir die orginale SG_VDF.dll aus dem Imon Verzeichnis bsp "C:/Programme/SOUNDGRAPH/Imon/SG_VDF.dll" , diese Datei kopieren und in das Pluginverzeichnis einfügen. Danach die vorher vorhandene VDF.dll aus dem Pluginverzeichnis löschen und die vom Imonverzeichnis eingefügte so umbenennen wie die gelöschte. Im Imonmanager die Option Frontview auf "nie" stellen und das Plugin starten, fertig...

 

Danke dir ... das klappt soweit auch so gut aber ich habe das Problem das ich hier schon mal gelesen habe.

Jetzt sehe ich zwar die Kanals Infos im Display aber die Fernbedienung der Antec Elite funktioniert nicht mehr.

 

Jetzt habe ich folgendes getestet ... erst VFD Plugin dann Imon dann DVBViewer starten -> Ergebnis: ich kann umschalten und sehe die Infos auf dem Display.

Gibt es eine einfachere Lösung als einen Task-starter-planer?

Link to post
  • Replies 962
  • Created
  • Last Reply

Top Posters In This Topic

  • markymark

    173

  • Tüftler

    72

  • MogRuith

    44

  • disaster

    36

Top Posters In This Topic

Posted Images

Danke dir ... das klappt soweit auch so gut aber ich habe das Problem das ich hier schon mal gelesen habe.

Jetzt sehe ich zwar die Kanals Infos im Display aber die Fernbedienung der Antec Elite funktioniert nicht mehr.

 

Jetzt habe ich folgendes getestet ... erst VFD Plugin dann Imon dann DVBViewer starten -> Ergebnis: ich kann umschalten und sehe die Infos auf dem Display.

Gibt es eine einfachere Lösung als einen Task-starter-planer?

 

Moin,

 

kann das so nicht nachvollziehen.

Ich habe das gleiche Display wie du und muss keinen Autostartverzögerung aktivieren damit die FB funktioniert.

Windows startet normal mit Imon, sowie das Plugin, dann starte ich DVBViewer und alles funktioniert.

Ein paar Posts zuvor schrieb wer, das er Imon aus dem Autostart herrausgenommen hat, was bei mir dann zu einer nicht funktionierenden FB führt. Die orginale SG_VDF.dll muss in beiden Ordnern vorhanden sein, im Plugin sowie im Imon Ordner.

 

Gruß

Oliver

Link to post

Hallo

Ich hab IMON aus dem Autostart rausgenommen aber ich starte es mit dem Startup Delayer nach dem Plugin. somit geht alles, auch die Fernbedienung.

Wichtig ist die Startreienfolge. Eine dll habe ich nie kopiert oder umbenannt. Das ging bei XP und jetzt bei Windows7.

Ich hatte in den letzten 2 Jahren trotz Hardwareumbau damit nie Probleme.

Allerdings habe ich die Startzeiten jetzt verkürzt, da mein HTPC jetzt schneller ist. Vorher war das Startbild von Windows7 noch zu sehen und der Fernsehton lief schon im Hintergrund aber das Bild blieb schwarz. Erst nach Wiedergabe neu aufbauen gings dann wieder.

Link to post
Hallo

Ich hab IMON aus dem Autostart rausgenommen aber ich starte es mit dem Startup Delayer nach dem Plugin. somit geht alles, auch die Fernbedienung.

Wichtig ist die Startreienfolge. Eine dll habe ich nie kopiert oder umbenannt. Das ging bei XP und jetzt bei Windows7.

Ich hatte in den letzten 2 Jahren trotz Hardwareumbau damit nie Probleme.

Allerdings habe ich die Startzeiten jetzt verkürzt, da mein HTPC jetzt schneller ist. Vorher war das Startbild von Windows7 noch zu sehen und der Fernsehton lief schon im Hintergrund aber das Bild blieb schwarz. Erst nach Wiedergabe neu aufbauen gings dann wieder.

 

Wenn du den Viewer ebenso im Autostart drinn hast, macht es Sinn, wenn nicht verstehe ich es nicht ganz?!

Link to post

Also ich habe jetzt mal weiter getestet und muss fest stellen das ALLEs im Autostart ausreciht ... glücklicherweise startet das system in der richtigen Reihenfolge.

Und Standby aufwecken funktioniert auch.

 

Danke noch mal

Link to post
  • 2 weeks later...
Diablo_Vmax1200

Hi!

 

Da nun alles unter Windows 7 (32 Bit) läuft, wollte ich nun auch das Plugin V 0.98 verwenden. Das Plugin läuft auch, aber mit der Aktuellen Beta vom Viewer + RecordingService bekomme ich keine Anzeige des Senders und Programms etc.

Es kommt nur das Datum und HDD Platz. D.h. das Plugin bekommt nicht mit dass der Viewer läuft

 

Hat jemand das Plugin unter Windows 7 schon zum Laufen bekommen?

 

Grüsse

Michael

Link to post
  • 1 month later...
  • 2 weeks later...

Hallo,

ich bin neu hier und hab auch so meine Probleme mit dem Display:

 

Habe ein Antec Fusion Remote mit Lcd und Fernbedienung IMON Pad bzw. Harmony 555.

Win7 x64, IMON 7.78.1125, DVBViewer 4.2.1.0, und natürlich das plugin 100.

alles installiert und und läuft vernünftig, bis auf das lcd:

dieses läuft zwar im Programm des Plugin super, jedoch nicht am Display.

Das Programm schreibt lcd gefunden,... wenn ich dann das Plugin Programm schliesse und

neu öffne zeigt es plözlich auch am Display die Informationen an, jedoch nur bis zum nächsten erwachen aus dem Standby- dann kurz die zeitanzeige von (denke IMON), und wieder dunkel.

Habe schon alle möglichen Reihenfolgen beim Programmstart ausprobiert- keine Besserung

Im Imon- Manager hab ich auf "nie" gestellt, jedoch option " dritte" oder ähnliches hab ich nicht gefunden.

 

Kann mir vieleicht jemand helfen???

Danke

Link to post

Das Problem hatte ich auch, das hier hat geholfen, allerdings

starte ich das IMON-Plugin als letztes (10 Sekunden Verzögerung), IMON starte ich nach 5 Sekunden Verzögerung.

Den DVBV starte ich gar nicht, da bei mir mein HTPC (s. Sig) nur für Aufnahmen zuständig ist (RS läuft) sowie für manches zum Abspielen.

Zumeist wird nur gestreamt (per TV (Mediaserver)), der verbunden ist mit dem HTPC (100MBit-Crossover).

"Bestücken"/Aktualiseren, Schneiden, Kopieren/Löschen, etc. mach ich nur Remote per Notebook, ebenfalls verbunden per 1GBit-Crossover-Kabel mit dem HTPC.

Also habe ich sozusagen nur eine FB, und zwar die vom TV.

 

Gruss Inti31

Link to post

Die Sache mit dem verzögerten starten der Programme funktiioniert leider nicht , egal in welcher Reihenfolge!

wenn ich allerdings das Plugin Programm vor Standby beende, und nach erwachen wieder starte funktioniert alles,

ich bräuchte also ein Programm das bevor der pc in Standby geht das Plugin beendet.

Ich versetze den pc mit der Fernbedienung in standby, und normalerweise mit laufenden DVBViewer.

kennt jemand eine möglichkeit wie dies funktionieren könnte??

 

Danke für eure Hilfe

 

Buc

Link to post

Hallo

Danke für eure Hilfe- ich hab das Problem einstweilen so gelöst, indem ich den pc jedes mal ganz herunterfahre, und dann das plugin 10sec. verzögert starte- so funktionierts- jedoch hab ich nun das Problem wenn ich einen Timer programmiert habe das ich den pc mit der maus in standby setzen muss, geht leider nicht mit der FB (d.h. ich brauche jedesmal meine BT Logitech).

Aber der Vorschlag mit dem "Hibernate Trigger" hört sich interressant an, nur leider hab ich keine Ahnung wie mann diesen Anwendet bzw. wie man ein Batch programmiert, also falls du einen link oder eine genaue Anleitung hast wäre mir sehr geholfen.

Jedenfalls Danke

Buc

Link to post

Moin, ich bin neu hier! ;) Ich bin von dem Plugin echt begeistert! Super Arbeit! Allerdings hab ich jetzt ca90% dieses Threads durchgelesen, aber leider noch keinen passenden Beitrag gefunden... Ich nutze als Frontend IMedian HD, starte daraus den DVBViewer PRO und bin soweit auch zufrieden damit! Da aber wenn das Plugin im Hintergrund läuft, das LCD etwas rumspinnt wenn ich z.B. mit IMedian Musik höre wollt ich fragen ob es eine Möglichkeit gibt das Plugin nur dann zu starten wenn der DVBViewer startet und dann auch wieder beendet wird wenn man den DVBViewer schließt?

 

Falls das doch irgendwo steht, wäre ich dankbar über die Seite! ;)

 

Vielen Dank im Voraus!

Link to post
  • 2 weeks later...

Hallo,

 

gibt es den überhaupt noch einen Support für dieses Plugin? Hatte auch schon mal wünsche für das Plugin geschrieben aber es scheint so als wenn es hier keine neuen Versionen mehr gibt.

Ist echt schade.

Link to post

Hi,

 

normalerweise schalte ich den HTPC nie aus, ich habs immer im Standby.

 

Das Aufwachen vom Standby funktioniert tadellos, DVBViewer macht weiter.

 

Allerdings muss ich dieses LCD Plugin immer wieder neustarten wenn ich Standby mache.

 

Gibts dafür keine Lösung?

Link to post

Nein Leider :-( Genau das gleiche Problem habe ich auch. Ein "Workaround" ist es mit Eventghost vor dem Standby mit taskkill zu killen und nach dem Resume wieder zu starten.

Das Problem dabei ist, dass das Taskbar Symbol immer da bleibt und irgendwann der Window-Manager von Windows Schlapp macht.

 

MarkyMark kann den Source nicht hergeben da irgendwelche gekaufte Teile drinnen sind. Und wie es aussieht ist mit einem Fix auch nicht zu rechnen.

 

cu

pOpY

Edited by popy
Link to post

Bei dem Ereigniss "Standby" musst du folgenden Befehl hinzufügen

 

TASKKILL /F /IM imonplugin.exe

 

beim "Resume" Ereigniss musst du den Befehl "imonplugin.exe" hinzufügen.

 

So sollte es gehen.

 

cu

pOpY

Link to post
  • 3 weeks later...

Hallo Forum,

 

ich benutzer seit geraumer Zeit das Imon vfd Plugin.

Da ich Probleme mit meiner technotrend 3200 nach dem Ruhezustand (bluescreen) habe, würde ich gerne für jede anstehende Aufnahme ein neu gestartetes System haben. Dies ist auch problemlos möglich indem ich die anstehenden Aufnehmen des dvbviewers an den Imon Manager übergeben lasse und das System zur entsprechenden Zeit von Imon gestartet wird. Problematisch wird dies nur wenn das Imon Plugin als letztes läuft. Irgendwie verhindert dieses das der Computer gestartet wird.

Kann mir jemand bei diesem Problem weiterhelfen?

 

Ps: eine entsprechende bat Datei kann nicht helfen, da diese zwar das imon plugin beendet und den imon manager neu startet aber es zu konflikten beim Neustart kommt wobei oft das Plugin nicht richtig geladen wird...

Link to post
  • 2 weeks later...

Hallo zusammen!!

 

Erstmal danke für das super Plugin!!! -Es funktioniert bei mir auch sehr gut unter win7 ich hätte da nur eine Fragen zu der ich auch mit der Suchfunktion keine Lösungen gefunden habe:

..gibts eine Möglichkeit, dass bei Timeraufnahmen des RecordingServices die getimten Daten (wie sonst auch in der Anzeige: Sendung/Sender Record) auch im VFD angezeigt werden???

bei mir steht dann dort nur ganz normal der Kanal den ich vorm Runterfahren laufen hatte und die Sendung die gerade läuft aber keinerlei Info zur Aufnahme!?

 

Wollte auch mal fragen obs ein Plugin für Power DVD gibt??

 

Danke!!

Link to post
  • 4 weeks later...
So ! ... Habe das Problem gelöst ! Ich bin in meiner Verzweiflung alle Versionen des Plugins durch gegangen. Hatte nur die letzte Version probiert. Also die Version 0.98 läuft bei mir auf Anhieb. Version 1.00 und 0.99 wollen garnicht.

 

Hatte bei meinem Silverstone LC16S genau das gleiche Problem! Bin fast durchgedreht und habe 55 Seiten dieses Threads durchsucht... DANKE burn2 für den Tipp!!

 

@markymark: es wäre nett, wenn es im Post 1 einen Hinweis gäbe, dass Version 1.0 des Plugins nicht mit allen iMON VFD Displays läuft, insbesondere nicht mit den aktuell im Silverstone LC16x-MR verbauten. Die Version 0.98 läuft hingegen auf Anhieb. Abgesehen davon - DANKE für das Plugin, feine Sache, macht Freude!

 

EDIT: Folgender Hinweis könnte fürs Debuggen noch hilfreich sein: mit der Version 1.00 erhielt ich jeweils die Meldung "iMON LCD erkannt", was nicht stimmt. Wenn ich das Plugin auf VFD umschaltete, erhielt ich eine Meldung "kein iMON VFD oder LCD erkannt" (oder so ähnlich). Wenn ich wieder auf denLCD-Modus umschaltete, erschien irgend welcher Garbage auf dem Display, aber nur wenn ich gleichzeitig iMON Frontview auf "Automatisch" stellte. hth.

Edited by mrphlox
Link to post
  • 2 weeks later...

Hallo,

 

ich habe seit kurzem meinen HTPC in einem Chieftec Hi-Fi HM02 Gehäuse. Das Gehäuse hat ein iMon VFD integriert. Ein ganz normales mit zwei Zeilen à 16 Zeichen. Daher ist an dem Gerät prinzipiell nichts ungewöhnliches. Aber das iMon Plugin funktioniert einfach nicht.

Starte ich es im VFD Modus, sagt das Tool "Kein iMon LCD/VFD gefunden". Starte ich es im LCD Modus, sagt das Programm absurderweise "iMON LCD gefunden". Angezeigt wird aber trotzdem nichts. Die iMon Software läuft im Hintergrund, wie angegeben, FrontView ist auf "Nie" eingestellt". Was mache ich falsch? Oder was läuft im Plugin falsch? ;)

 

PS: Es handelt sich definitiv um ein iMon VFD und NICHT LCD!

Edited by 12die4
Link to post
  • 1 month later...
MogRuith

Hallo beisammen,

das plugin im Einsatz im OrigenAE M10:

 

FB ist eine IMon PAD mit Tüftlers config. Ich habe nur ein Problem mit deutschen Umlauten und Sonderzeichen...muss mal eine Version ungleich 0.98 testen.

Gruß

Link to post

Also bei mir läuft das iMon Plug-In nach wie vor nicht. Egal was ich versuche, es wird nichts auf dem Display angezeigt. Woran zum Teufel kann das liegen?? Ist echt zum Verzweifeln. ;)

Link to post

steht sicherlich schon irgendwo aber wie aktivier ich das plugin nach nem standby wieder? es läuft zwar aber zeigt nichts an dann

Link to post

Die neueste Vorabversion von iMon hat eine Funktion für XBMC und Co. Kann sich DVBViewer da nicht auch einklinken?

Der Plugin funktioniert bei mir definitiv nicht. Habe schon alle bekannten Tipps ausprobiert. An der iMon SW-Version kann es nicht liegen, weil hier ja auch viele die aktuelle verwenden (hatte auch schon andere drauf). Meine Vermutung ist eher, eine neue Firmware-Version des Displays die einfach vom Plugin nicht unterstützt wird. Also entweder das XBMC Feature irgendwie nutzen (Tunneln der Informationen analog zu XBMC, sodass iMon denkt es läuft tatsächlich XBMC und nicht DVBViewer) oder halt einen Bugfix für das existierende Plugin, please! o:)

Link to post
MogRuith

startupdelayer funktioniert nicht nach einem standby oder hibernate...hilft also nicht...

Ich habe es mit EventGhost gelöst: nach resume WOL an server, VFD-Neustart und DVBV-Start

Bei mir läuft immer noch IMon 6.2 mit VFD-plugin 0.98...geht alles bis auf Umlaute.

Welche firmware-Version hat dein display?

Edited by MogRuith
Link to post

Juhu, jetzt hab ich's auch zum Laufen gekriegt. Version 0.9.8 läuft, neuere Versionen partout nicht. Wäre schön, wenn mal jemand gucken könnte, warum das so ist. Denn die neuen Versionen haben ja mehr Features.

 

Muss gleich mal ausprobieren, ob das Display auch aus bleibt, wenn ich einen Standby mache. Oder ist das immer so?

Link to post
Tüftler

Schau mal nach in was du die VFD/LCD.dll umbenannt hast, denn das ist bei der 1...Version dann anders, was auch irgendwo in diesem Thread steht!

Suche mal nach meinen Beiträgen in diesem Thread, da muss es irgendwo stehen. :wacko:

Link to post

Also bisher geht das Display auch immer zuverlässig wieder an, wenn der HTPC aus dem S3 reaktiviert wird. Brauche also keine Spielereien à la EventGhost - jedenfalls vorerst nicht.

 

@Tüftler: Was genau meinst du? Ich habe für eine funktionierende 0.9.8 gar keine VFD.dll kopiert. Ich weiß, dass es bei manchen hilft, die SG_VFDU.dll aus dem Soundgraph Verzeichnis ins Plug-In Verzeichnis zu kopieren und damit die originale VFD.dll zu ersetzen. Das hat bei mir aber nie geholfen und bringt auch die 0.9.8 dazu, nichts mehr anzuzeigen. Verwende ich die originale DLL, läuft 0.9.8. Aber 0.9.9 und 1.0.0 eben nicht mehr (mit den jeweiligen Original-DLLs).

Link to post

Kannst du mir die DLL vielleicht uppen? Dann kann ich die Kombination bei mir mal ausprobieren. Habe bisher nur deutlich neuere iMon Versionen getestet.

Link to post

Okay, das Plugin funktioniert doch nicht so wie gewünscht. Da habe ich mich mal wieder zu früh gefreut. 2 Tage lief es wirklich anstandslos. Jetzt auf einmal vertragen sich iMon Plugin und iMon nicht mehr miteinander. Habe nichts an der Konfiguration geändert. Plötzlich nimmt iMon keine Befehle von der Fernbedienung mehr entgegen. Sobald ich das VFD Plugin aus dem Autostart schmeiße, funktioniert alles. Aber sobald das Plugin gleichzeitig mit iMon läuft, ist er IR-Empfänger "taub".

Ich nehme an, dass es daran liegt, dass die alte DLL aus der 0.9.8 Plugin Version nicht mit den neuen DLLs der iMon Software kompatibel ist und da beide DLLs gleichzeitig versuchen auf das Modul zuzugreifen, sich gegenseitig stören. Aber warum läuft es dann bei euch anderen? Das Plugin soll doch ausdrücklich die Weiterverwendung von iMon ermöglichen...

Könnten mir hier noch ein paar Leute sagen, ob sie ähnliche Probleme mit den neuen Version der iMon Software erlebt haben bzw welche iMon Version sie verwenden? Derzeit läuft bei mir abwechselnd 7.85.0222 final bzw. 7.87.0524 beta.

Link to post

Du wirst mich für bescheuert halten, aber das hatte ich schon ausprobiert in allen nur erdenklichen Kombinationen. Nutze ja xHTPC und da kann man das sehr bequem einstellen. Aber es half alles nix. Jetzt probier ich es nochmal mit der Startreihenfolge VFD Plugin -> DVBVSwitch -> DVBViewer (nach 2sek) -> iMon (nach 5sek) und plötzlich geht's. Hatte diese Reihenfolge schonmal, nur vielleicht mit minimal anderen Verzögerungen, und nun geht's auf einmal. :angry:

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...