Jump to content

Imon VFD/LCD Plugin


markymark

Recommended Posts

Hi Leute!

 

Für das Problem mit dem Standby und dem LCD das der nicht angeht habe ich eine kleine Anwendung für die TrayBar geschrieben, die beim Starten vom DVBViewer das Plugin beendet und neu startet.

...

Ich hoffe das ich ein paar Leuten helfen konnte.

 

Mir hast Du damit sehr geholfen. Dafür ein großes THANKS. Funzt wunderbar!

Link to post
  • Replies 962
  • Created
  • Last Reply

Top Posters In This Topic

  • markymark

    173

  • Tüftler

    72

  • MogRuith

    44

  • disaster

    36

Top Posters In This Topic

Posted Images

Diablo_Vmax1200

Hi!

 

Ich habe nun folgendes versucht:

* IMON Plugin mit Windows gestartet

* Im Plugin LCD eingestellt -> es wird LCD gefunden auch angezeigt

* IMON selbst mit dem Startup Delayer um 10sek verzögert

* Frontview im IMON Manager auf nie

 

* IMON Version 7.40.0806

* IMON Firmware Ver 0x360101

* VFD HID OEM

 

* DVBViewer V 4.0

* Windows Vista Home Pro x86

* IMON Plugin V 1.00

* Chieftec Gehäuse HM-02 (laut Hersteller HP ist ein I-MON VFD /VOL and Navigator Knob verbaut)

 

Wenn ich das Plugin auf VFD stelle kommt die Anzeige "kein VFD oder LCD gefunden" (auch nach Plugin Neustart)

Wenn es auf LCD steht und ich im IMON Manager Frontview auf Automatisch oder immer stelle wird sporadisch etwas angezeigt aber es kommt immer nur ein Zeichen wirrwarr welchs über die Ausgabe des IMON Managers drüber geschrieben wird.

 

Hat jemand eine Ahnung woran es liegen könnte?

Soll ich Screenshots von den Einstellungen posten?

 

Über jede Hilfe wäre ich dankbar!

 

 

Grüsse

Michael

Link to post

@Diablo_Vmax1200:

 

Ich habe zwar kein LCD sondern "nur" ein iMon-VFD, aber vielleicht hilft Dir meine Methode, die einzige, die ich überhaupt zum laufen bekommen habe nachdem iMon-Auto-Update auf 7.40.0806:

 

#219528

#219570

 

Gruß Cambies

Link to post
@Diablo_Vmax1200:

 

Ich habe zwar kein LCD sondern "nur" ein iMon-VFD, aber vielleicht hilft Dir meine Methode, die einzige, die ich überhaupt zum laufen bekommen habe nachdem iMon-Auto-Update auf 7.40.0806:

 

#219528

#219570

 

Gruß Cambies

 

Also die Sache mit dem Display vielleicht mal etwas aufzuhellen (schönes Wortspiel oder):

 

es spielt keine Rolle, ob man zuerst die iMON-Software oder das Plugin startet. Bei mir hat bisher auch jede iMon Software mit dem Plugin funktioniert. Einziges Problem ist, dass das Display nach dem Aufwachen aus dem Standby dunkel bleibt. Daher habe ich ein Script, das nach dem Aufwachen aus dem Standby das Display immer einschaltet. Fertig.

das Plugin muss auch nicht vor dem Standby gestoppt und beim Aufwachen gestartet werden. Einfach Display einschalten fertig.

Ich hatte hier mal ein kleines Tool gepostet, das einen entsprechenden code an das Display schickt.

Link to post
Diablo_Vmax1200

Hi!

 

Ich habe mal wie vorgeschlagen die Version 0.97 installiert und siehe da mein VFD wird erkannt und es kommt auch eine Anzeige :-)))))

 

Vielen Dank für die Tipps!

 

 

Grüsse

Michael

Link to post
yaRincewind

HEUREKA!

 

Mein Display funktioniert auch tatsächlich mit der Version 0.97 :)

Jetzt muss ich nur noch prüfen, ob die Fernbedienung noch geht. Bin sehr gespannt :D

 

 

Woran liegt das mit der 0.97? An der anderen dll Version?

 

 

 

EDIT:

Mift. Offenbar geht jetzt die Fernebedienung nicht mehr. ARGHHHHHHHHHH

 

Frontview nie: Anzeige wie sie sein soll :wacko: , Fernbedienung geht nicht :bye:

Frontview Auto: Uhrzeit :( , Fernbedienung geht :angry:

 

@Tüftler

Besteht die Möglichkeit einer :angry: :angry: Situation?

Du hattest doch da auch mal Probleme, oder?

Edited by yaRincewind
Link to post

Mir hat da nur das Neuaufsetzen des Rechners geholfen.

Ich mutmaße mal, Problem wurde verursacht durch:

1. alte iMonManagerSoftwarereste in der Registry (in der letzten gibt es ja keine Einstellung für "Benutzt für dritte", oder so)

2. alte HID-USB-Treiber des Displays (Treiberreste)

3. Startreihenfolge Beachten (unabhängig vom Neuaufsetzen) ->PlugIn->iMonManager->DVBViewer

Link to post
yaRincewind

Hm.

 

Wieso habe ich sowas befürchtet?

Eigentlich hält sich meine Lust alles neu aufzusetzen in sehr sehr sehr engen Grenzen, vor allem da langsam alles läuft :)

 

Ich habe da eine Idee:

1. Die neue iMon Software deinstallieren

2. Die neue iMon Software neu installieren, und einen Registry Cleaner mitlaufen lassen.

3. Den die Installation rückgängig machen lassen

 

4. Die alte Software neu installieren, Cleaner mitlaufen lassen

5. Cleaner die alte Software vom system entfernen lassen

 

6. Neue Software neu installieren.

 

Vielleicht reicht das ja aus. Und 2 De/Installationen sind nicht sooooo zeitaufwendig.

 

 

Kennt wer ein gutes Freeware Programm was Systemänderungne protokolliert und rückgängig machen kann?

Link to post

Hallo

Danke für das Plugin, läuft alles super!

 

Besteht vielleicht die Möglichkeit das man im Ruhemodus oder Standbymodus ausser

dem Text auch Informationen über den nächsten Timerstart oder die Uhrzeit mit anzeigen kann.

Link to post
yaRincewind

Komisch komisch.

Jetzt habe ich die neue iMon Software komplett entfernen lassen mit dem RevoUninstaller.

Jetzt gibt das 0.97 Plugin Text aus, auch wenn die iMon Software nicht gestartet ist. Wenn ich sie starte, kommt nur noch kurz die PlugIn Ausgabe, und wird dann schwarz (Frontview: nie) ider aber wird dann zur Datum/Uhrzeit (Frontview: auto).

 

Also bräuchte ich jetzt nur ne alternative Software, die mit dem iMon Empfänger kann für die Fernbedienung. Dann würde ich die iMon Soft einfach in die Tonne treten :bye:

Link to post
Komisch komisch.

Jetzt habe ich die neue iMon Software komplett entfernen lassen mit dem RevoUninstaller.

Jetzt gibt das 0.97 Plugin Text aus, auch wenn die iMon Software nicht gestartet ist. Wenn ich sie starte, kommt nur noch kurz die PlugIn Ausgabe, und wird dann schwarz (Frontview: nie) ider aber wird dann zur Datum/Uhrzeit (Frontview: auto).

 

Also bräuchte ich jetzt nur ne alternative Software, die mit dem iMon Empfänger kann für die Fernbedienung. Dann würde ich die iMon Soft einfach in die Tonne treten :bye:

 

 

dann probier doch mal zuerst die imon software zu starten frontview auf nie und danach das imonplugin. so funktioniert es bei mir. wenn die imonsoftware gestartet ist, ist zwar das lcd display aus aber die fb funktioniert. wenn dann das plugin gestartet wird, wird das display eingeschaltet und die fb funktioniert weiterhin. jeder hat hier andere erfahrungen mit der reihenfolge. bei meinem vfd muß ich das im gegensatz zum lcd genau andersrum machen.

Link to post
Komisch komisch.

Jetzt habe ich die neue iMon Software komplett entfernen lassen mit dem RevoUninstaller.

Jetzt gibt das 0.97 Plugin Text aus, auch wenn die iMon Software nicht gestartet ist. Wenn ich sie starte, kommt nur noch kurz die PlugIn Ausgabe, und wird dann schwarz (Frontview: nie) ider aber wird dann zur Datum/Uhrzeit (Frontview: auto).

 

Also bräuchte ich jetzt nur ne alternative Software, die mit dem iMon Empfänger kann für die Fernbedienung. Dann würde ich die iMon Soft einfach in die Tonne treten :)

Das ist ja klar, das dies geht. Das PlugIn benötigt ja auch nur den USB-Treiber für das Display, nicht aber die iMonSoftware.

Die Software brauchst du nur für die Fernbedienung.

Mit dem StartupDelayer kannst du ganz bequem die Startreihenfolgen Zeitverzögert austesten. In der Grafik siehst du auch welche Sachen wann gestartet werden.

Link to post
better_play

...habe das Silverstone LCD.

 

Funktionierendes Setup bei mir:

 

Imon 6.2 (Frontview nie)

LCD PLugin 99

 

Erfahrung mit anderen kombinationen (iMon 7.2, 7.4 Lcd-Plugin 99 und 100:

 

Nach einem Autoupdate (startet automatisch wenn man als Admin arbeitet), erst 7.2 dann 7.4, ging gar nichts mehr.

 

Die Imon Software spricht das LCD an und kurz darauf geht es komplett aus (Frontview nie)

Fehlerhafte Zeichen, unzuverlässige Funktion, springen der Laufschrift (Fronview auto)

 

Nach einem Neustart funktionierte es sowohl mit der Batch-Lösung als auch mit Startdelay. Beim Aufwachen aus dem Standby liess sich die Startreihenfolge jedoch nicht mehr beieinflussen und das Display blieb dunkel.

 

Wie gesagt mit o.g. Setup geht's...Dickes Danke an den Developer :)

Link to post
  • 2 weeks later...

Hallo markymark,

wäre es dir möglich, deinem Plugin die Anzeige von RDS-Daten bei Radiosendern anstelle von der aktuellen Sendung beizubringen?

Einige Radiosender zeigen mir über den RDS-Text den aktuellen Titel an, welchen ich allerdings bei abgeschalteten TV nicht sehen kann.

Daher würde mir so eine Anzeige im Display gefallen. :)

Link to post

hallo an alle!

 

bin neu hier im forum und denke wenn mir hier niemand helfen kann dann wohl nirgens mehr! :)

 

 

hab seit kurzem ein silverstone GD01 MX mit eingebautem LCD display.

 

habe das "kleine" problem das ich es nicht schaffe dem display zu sagen das es aus bleiben soll. sobald ich im imon-manager frontview auf "nie" stelle

gehts aus und zeigt sekunden später die uhrzeit an. nach dem runterfahren bleibt die auch an. dann beim neustart geht das display wieder aus weil ja imon erkennt "nie". dann gehts wieder an. hab jetzt schon sämtliche softwareversionen durch. leider hilft mir auch das plugin nicht wieter. es funktioniert zwar aber sobald ich es beende bleibt das display auch wieder hell. mich nervt die beleuchtung des displays beim filme schaun.

komischer weise bleibt die uhrzeit auch am display wenn ich imon deinstalliert habe!? selbst wenn ich den usb-stecker vom board ziehe ändert sich nix?

bekommt das teil die zeit übern stromstecker?

 

das einzige was mir wichtig ist wäre das es aus bleibt wenn ich automatisch sarten nie wähle.

 

kann mir jemand helfen bitte? ich google mich seit einer woche zú tode...

Link to post

Die Einstellung die dir hilft findest du im iMonManager unter iMonHilfsmittel>FrontView>Auto-Modus>Stand-by Anzeige.

Dort gibst du VFD/LCD abschalten an.

Link to post
Das ist ja klar, das dies geht. Das PlugIn benötigt ja auch nur den USB-Treiber für das Display, nicht aber die iMonSoftware.

Die Software brauchst du nur für die Fernbedienung.

Mit dem StartupDelayer kannst du ganz bequem die Startreihenfolgen Zeitverzögert austesten. In der Grafik siehst du auch welche Sachen wann gestartet werden.

 

Bei meinem HTPC benötigt das Display außer dem Plugin gar nichts. Ich habe die IMON-Software einmal installiert und danach die Festplatte bestimmt 6 mal formartiert. Die IMON-Software-Scheibe hat mein HTPC nie wieder gesehen. Und trotzdem funktioniert das Plugin tatellos.

 

Gruß

Link to post
Die Einstellung die dir hilft findest du im iMonManager unter iMonHilfsmittel>FrontView>Auto-Modus>Stand-by Anzeige.

Dort gibst du VFD/LCD abschalten an.

 

 

ich habe imon manager 7.40.0806 da gibts bei auto-modus keinen punkt stand-by anzeige. nur kategorieauswahl / uhrzeit und entzerrer-schalter (was das wohl sein soll?)

 

soll ich eine andere version installieren? habe vista 64bit.

Link to post

Ich wollte das Problem mit dem Ruhezustand (Display geht nicht an) mit Hibernate Trigger lösen. Doch alle Google-links sind down. Kann mir jemand das Programm zur Verfügung stellen?

Link to post

Wozu brauchst du dann das Display?

Lösungsvorschläge:

USB-Stecker abziehen, oder die iMonSoftware deinstallieren oder das Display von der Platine ziehen (ist nur gesteckt).

Link to post
Wozu brauchst du dann das Display?

Lösungsvorschläge:

USB-Stecker abziehen, oder die iMonSoftware deinstallieren oder das Display von der Platine ziehen (ist nur gesteckt).

 

 

ich finde halt das es beim filme schaun stört.beleuchtet ist die auch ohne software. dann zeigt es mir systemzeit an. usb alleine bringt auch nix... immer noch systemzeit.

wenn ich sie vom strom nehme (der kleine stecker der direkt vom netzteil den strom bekommt) kann ich auch die FB nicht mehr benutzen > auch keine lösung.

denn die benutze ich ja. somit weiss man einfach nicht warum das display bei der einstellung automatisch starten "nie" einfach trotzdem beleuchtet wird!?

nur eines ist seltsam >> sie geht ja kurz aus und dann nach kurzem wieder an. das dauert manchmal 1 minute manchmal auch sofort. ich weiss keinen rat.

kann ich das display evtl auch vom motherboard direkt mit strom versorgen> also ohne den adapter? oder eine bestímmte einstellung im bios vielleicht...

 

was mir heute auserdem noch aufgelfallen ist>> das display friert manchmal ein wenn der rechner auf vollast geht. zb bei games. dann startet es erst wieder bei neustart des pc´s. finde soundgraph liefert hier softwaretechnisch eine recht armselige vorstellung ab. vielleicht klappts ja mit einem zukünftigen update.

gibts keine andere software die man für diese lcd´s verwenden kann?

Link to post
Hallo ich habe es hier schon mal gepostet.

 

Ich verwende Hibernate Trigger dieses Progamm ruft vor dem Standby eine *.bat Datei auf die das Plugin beendet. In der Batchdatei benutze ich den Befehl Taskkill. Vielleicht gibt es ja noch bessere Befehle aber seit dem ich bei Windows die bunten Bilder anklicken kann habe ich mich nur selten mit CMD beschäftigt.

 

Der Nachteil an der Geschichte, das Symbol bleibt im Tray vorhanden bis man mit der Maus rüber fährt, dann verschwindet es.

 

Das Plugin starte ich über den Scheduler.

Seltsam ist nur das es funktioniert wenn ich den PC per Fernbedienung aus'm Standby hole. Wenn der PC über eine Timer-Programmierung hochfährt bleibt das LCD aus. Wenn der PC nach der Aufnahme wieder in Standby geht und ich den PC wieder mit Fernbedienung starte geht es auch nicht dann wird das Plugin nicht mit gestartet? Muss ich dann selber starten und dann gehts wieder.

Kannst du mir das Programm zur Verfügung stellen. Die Google links sind alle down.

Link to post
Hallo markymark,

wäre es dir möglich, deinem Plugin die Anzeige von RDS-Daten bei Radiosendern anstelle von der aktuellen Sendung beizubringen?

Einige Radiosender zeigen mir über den RDS-Text den aktuellen Titel an, welchen ich allerdings bei abgeschalteten TV nicht sehen kann.

Daher würde mir so eine Anzeige im Display gefallen. o:)

 

Prima Idee, mich würde es auch sehr freuen wenn das Plugin diese Anzeigemöglichkeit unterstützen würde.

 

Gruß

 

Markus

Link to post

Hallo allerseits,

 

ich habe das Plugin wunderbar zum laufen bekommen, das einzige was ich mir noch wünsche ist, dass der LCD im Standby eine Uhr anzeigt.

Gibt es da eine Möglichkeit.

 

Habe das Antec Micro mit blauem LCD.

 

Viele Grüße

baschek

Link to post

Ich habe das, mit der Uhrzeitanzeige, über die iMonSoftware gemacht.

Im iMonManager>iMonHilfsmittel>Frontview> Registrierkarte>Auto-Modus unter Standby-Anzeige kann man dort bei "Wann geschlossen" einstellen, ob man die Uhrzeit, eine Nachricht anzeigen will oder das VFD/LCD abgeschalten werden soll.

Ich glaube rein über das PlugIn geht das nicht.

Link to post
Ich habe das, mit der Uhrzeitanzeige, über die iMonSoftware gemacht.

Im iMonManager>iMonHilfsmittel>Frontview> Registrierkarte>Auto-Modus unter Standby-Anzeige kann man dort bei "Wann geschlossen" einstellen, ob man die Uhrzeit, eine Nachricht anzeigen will oder das VFD/LCD abgeschalten werden soll.

Ich glaube rein über das PlugIn geht das nicht.

 

Also ich hab jetz nochmal geschaut aber unter Auto Modus hab ich nur die Punkte "Kategorieauswahl" "Uhr" und "Entzerrer Schalter"

Welche IMon version hast du? Bei mir ist es die 7.40.0806 (ANTEC)

Link to post

Lade dir mal die Originale Soundgraphsoftware hier: http://soundgraph.com/Eng_/Supports/BoardV...p;searchString=

herunter und lasse diese dann automatisch Updaten. Dann sollte es funktionieren. Es kann sein, dass die Antecversion dies nicht beinhaltet.

 

Edit:

Möglicherweise wird beim Start die VFD/LCD-Version abgefragt und diese Funktion nicht freigeschaltet, sofern es sich um eine OEM-Version handelt (ANTEC, Thermaltake, etc).

Sollte dies so sein, dann melde dich nochmal, werde dann nach einer Lösung suchen.

Edited by Tüftler
Link to post

So ich habe nun die 7.2 von der Webseite installiert und das Update gefahren.

 

Vor dem Update gab es ein Menüpunkt Standby, in dem ich allerdings nur einen Text eingeben konnte.

Nach Update auf 7.40 ist dieser Menüpunkt wieder komplett verschwunden, also scheinbar doch aufgrund der Antec OEM.

Link to post
So ich habe nun die 7.2 von der Webseite installiert und das Update gefahren.

 

Vor dem Update gab es ein Menüpunkt Standby, in dem ich allerdings nur einen Text eingeben konnte.

Nach Update auf 7.40 ist dieser Menüpunkt wieder komplett verschwunden, also scheinbar doch aufgrund der Antec OEM.

Gehe mal in folgendes Verzeichnis: C:\Dokumente und Einstellungen\Administrator\Anwendungsdaten\SOUNDGRAPH\iMON

Dort öffnest du die iMon.ini mit dem Editor und suchst nach folgendem Eintrag: Closed Type=

Wenn er bei dir vorhanden ist, dann stelle dort den Wert auf 0, bei dir müsste er auf 2 stehen.

Ist er nicht vorhanden, versuche ihn unter [Auto Mode] in alphabetischer Reihenfolge (ist nur wegen der Übersichtlichkeit) neu hinzuzufügen.

Das sieht dann so aus: Closed Type=0

Viel Erfolg! :)

Link to post
Gehe mal in folgendes Verzeichnis: C:\Dokumente und Einstellungen\Administrator\Anwendungsdaten\SOUNDGRAPH\iMON

Dort öffnest du die iMon.ini mit dem Editor und suchst nach folgendem Eintrag: Closed Type=

Wenn er bei dir vorhanden ist, dann stelle dort den Wert auf 0, bei dir müsste er auf 2 stehen.

Ist er nicht vorhanden, versuche ihn unter [Auto Mode] in alphabetischer Reihenfolge (ist nur wegen der Übersichtlichkeit) neu hinzuzufügen.

Das sieht dann so aus: Closed Type=0

Viel Erfolg! :(

 

 

 

guter tip auch für mich! danke...

 

 

kannst du mir evtl auch sagen welcher eintrag für das anzeigen der uhrzeit veranwortlich ist wenn die imon-software beendet wird? bei mir erscheit hier auf alle fällr eine uhrzeit >> mit schlecht lesbarer schrift! 4 sieht aus wie 9 usw..

Link to post

Closed Type=2 bedeutet eigentlich VFD/LCD abschalten.

 

Closed Type=1 bedeutet Nachricht aus oberer- und unterer Zeile anzeigen

(zu finden im iMonManager>iMonHilfsmittel>FrontView> Auto-Modus "Standby Anzeige")

oder in der ini folgende Einträge vervollständigen/setzen:

Closing Upper=******

Closing Lower=******

-> statt der Sterne die Nachricht eintragen!

 

Closed Type=0 bedeutet Uhr anzeigen

Link to post
Daher habe ich ein Script, das nach dem Aufwachen aus dem Standby das Display immer einschaltet. Fertig.

das Plugin muss auch nicht vor dem Standby gestoppt und beim Aufwachen gestartet werden. Einfach Display einschalten fertig.

Ich hatte hier mal ein kleines Tool gepostet, das einen entsprechenden code an das Display schickt.

 

Könntest du bitte dein Script hier veröffentlichen? Ich habe das gleiche Problem.

Link to post

Hat hier jemand auch das Problem, dass sich die Schriftart ständig verstellt?

Benutze die Version 1.00 aber auch bei der 0.99 passiert is mit dem unschönen Nebeneffekt, dass ich es da ja nicht ändern kann...

Weiß jemand Rat?

Link to post
  • 2 weeks later...
xxSunny77xx

Hallo@all

 

Ich habe das Soundgraph 2 Zeilen Display (Gehäuse Silverstone LC-16M) und eigentlich geht hier garnichts. Entweder Fernbedienung oder Display gehen im Mediaportal.

 

In den anhängenden Bilder habe ich mal meine Systemdaten .

 

Ich habe auch schon probiert Frontview auszuschlaten und hier das Toll installiert. Doch leider kann ich es garnicht ansteuern. Interessant ist auch, dass ich ja eigentlich ein VFD habe, dieses aber eigentlich nur als LCD gefunden wird.

 

Folgende Probleme bei geposteter Einstellung:

1. FB klappt aber Display klappt nur im Vista selbst, sobald ich Mediapoprtal starte, bleibt das Display (die Uhr) stehen, also gefreezt. FB klappt aber einwandfrei. Stelle ich was an den Einstellungen um, klappt die FB nicht mehr, aber das Display, auch in MP.

 

Ich werde hier noch wahnsinnig. Hab schon ne Menge getestet, auch ältere Treiber u.s.w.

Ich wäre sehr sehr dankbar hierüber Hilfe zu finden.

post-77908-1235390426_thumb.jpg

post-77908-1235390436_thumb.jpg

post-77908-1235390444_thumb.jpg

Link to post
Hallo@all

 

Ich habe das Soundgraph 2 Zeilen Display (Gehäuse Silverstone LC-16M) und eigentlich geht hier garnichts. Entweder Fernbedienung oder Display gehen im Mediaportal.

 

In den anhängenden Bilder habe ich mal meine Systemdaten .

 

Ich habe auch schon probiert Frontview auszuschlaten und hier das Toll installiert. Doch leider kann ich es garnicht ansteuern. Interessant ist auch, dass ich ja eigentlich ein VFD habe, dieses aber eigentlich nur als LCD gefunden wird.

 

Folgende Probleme bei geposteter Einstellung:

1. FB klappt aber Display klappt nur im Vista selbst, sobald ich Mediapoprtal starte, bleibt das Display (die Uhr) stehen, also gefreezt. FB klappt aber einwandfrei. Stelle ich was an den Einstellungen um, klappt die FB nicht mehr, aber das Display, auch in MP.

 

Ich werde hier noch wahnsinnig. Hab schon ne Menge getestet, auch ältere Treiber u.s.w.

Ich wäre sehr sehr dankbar hierüber Hilfe zu finden.

 

Du weißt schon, dass das hier das DVBViewer Forum ist und nicht das Mediaportal Forum? Daher wirst Du auch nur wenig Erfolg mit dem IMON DVBViewer Plugin haben :blush:

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...