Jump to content

Premiere HD/ Discovery HD gleichmäßiges ruckeln nach wenigen Sekunden


searge

Recommended Posts

Das ist ein gutes Zeichen dafür, dass dein System entweder einfach zu langsam ist (also die Hardware) oder irgendwo anders etwas Hakt, ausserhalb des DVBViewers und der Live Wiedergabe... da wird dir die Latenz auch nicht helfen. Die hilft nur genau dann, wenn es nur bei Live-TV ruckelt und Aufnahmen ruckelfrei wiedergegeben werden können.

 

Allso das es an der Systemleistung liegt kann eigendlich nicht sein, da ich einen CoreDuo E6600 übertacktet auf 3GHz und eine ATI 1800XT habe und auch das DXVA des Cyberlink H.264 Dekoders eingeschaltet habe. Ausserdem hatte ich Pre...HD vor ca. 2Monaten schon mal absolut stabiel zum laufen gebracht. Weiterhin läuft ja auch Pro7HD, Sat1HD, AstraHD und AnixHD absolut stabiel.

 

Ich vermute das die Aufzeichnugen von Pre..HD deshalb ruckeln weil die Fehler schon vorm Aufzeichnen geschehen, allso im DVBSource Filter wenn dieser den Stream auf die Platte schreibt.

Link to comment
  • Replies 311
  • Created
  • Last Reply

Top Posters In This Topic

  • CiNcH

    32

  • Moses

    30

  • uglyrooster

    29

  • darky

    21

Top Posters In This Topic

Posted Images

Auf Basis der Softwareentschlüsselung werden wir hier wohl nicht weiter diskutieren, denn da haben wir eine weitere nicht unerhebliche Fehlerquelle, die nicht supported wird da illegal...

 

So, hab nun das Problem mit MainConcept gelöst. Der Installer bzw. Uninstaller versemmelt die Registration/Unregistration der Filter ein bisschen. Mit MainConcept habe ich besagtes Problem nicht mehr.

 

 

Wer's probieren will...

 

http://www.elecard.com/ftp/pub/AVC/EAVCStr...gPlugIn_WMP.zip

 

Achtung! Der Filter muss händisch registriert werden nach der Installation unter C:\Programme\Gemeinsame Dateien\Elecard (regsvr32 mcavcvd.ax)

Edited by CiNcH
Link to comment

Hallo!

 

Ich habe heute eine für mich nicht erklärbare Entdeckung gemacht. Wenn ich im BIOS die 'Graphics Aperture Size' auf 128MB einstelle, ist das Ruckeln bei den HD-Sendern weg. Mit der Standardeinstellung von 32MB beginnen alle HD-Sender nach einigen Sekunden zu ruckeln. Da ich es zuerst nicht glauben konnte, habe ich jetzt mehrmals die Einstellung geändert. Es ist immer das gleiche Ergebnis. Mit 32MB ruckelt es und mit 128MB nicht.

 

Meine Grafikkarte ist eine 6600GT mit 128MB RAM, die SAT-Karte ist eine Skystar HD.

 

Vielleicht kann das ja jemand auf seinem System nachvollziehen.

Link to comment

Diese Option ist ja AGP-Grafikkarten vorbehalten. PCIe dürfte beliebig viel Arbeitsspeicher abzweigen können, denke ich.

 

Hat schon jemand den MainConcept-Dekoder probiert? Wie gesagt löst dieser das Problem bei mir auch. Dürfte also ein Problem des CyberLink-Dekoders sein.

 

Dennoch halte ich die getrennte Behandlung für MPEG-2 und AVC im DVBSource-Filter für sinnvoll.

Edited by CiNcH
Link to comment

Ich setze auch eine AGP-Karte (MX440 von nVidia) ein und bei mir hat es tatsächlich auch gefunzt die Aperture Size hoch zu setzen. Die besten Ergebnisse habe ich mit 256MB. Seitdem läuft bei mir alles butterweich. :blink: Nun habe ich nur noch die Probleme der Discontinuities im DVBSource bei h264 zu lösen... Die treten hauptsächlich bei Premiere/Disc. HD auf. Bei den anderen HD-Sendern habe ich damit nur ganz ganz selten Probleme.

Edited by DarkSoul
Link to comment

Das ist interessant. Es weist darauf hin, dass die Grafikkarte mit ihrem eigenen Speicher nicht auskommt und etwas vom Hauptspeicher in Anspruch nimmt. Eine Erläuterung findet sich hier:

 

http://www.techpowerup.com/articles/overclocking/vidcard/43

 

Dazu eine Rechnung: Wenn, wie bei einem Premiere HD Sample beobachtet, Video 0.8 s eher ankommt als Audio, muss der Renderer bei 25 fps an die 20 Frames zwischenspeichern, damit es synchron wird. Das macht bei einer Farbtiefe von 24 Bit = 20 x 1920 x 1088 x 3 Bytes = 120 MB.

 

Was sich genau zwischen Decoder, Renderer und Graka abspielt, und inwiefern die Graka für Zwischenspeicherung verwendet wird, kann ich allerdings auch nicht sagen...

Link to comment

Bei mir tritt das Ruckelproblem bei Premiere HD seit kurzem ebenfalls auf. Dachte immer es liegt an PowerDvD 7.3, da ich dies erst kürzlich installiert hatte. Nachdem mit Coreavc das Ruckeln ebenfalls auftrat habe ich mich mal auf Fehlersuche gemacht. Hab bissel im DVBSource Filter gespielt und konnte durch hochsetzen des Max Queued Audio Buffers auf 9000 schon eine deutliche Besserung feststellen. Habe dann zusätzlich mal Reclock in den Wiedergabegraph gehängt, um zu schauen ob irgendwelche Merkwürdigkeiten im Videostream auftreten, sobald das Ruckeln beginnt. Zuerst ist mir dabei aufgefallen, dass das Ruckeln immer nach großen Sprüngen in der Bitrate auftritt. Reclock meint dann immer das der Videostream nur 16,67 FPS hat, DVBSource zeigt aber immer noch 25FPS an. Sobald sich die Bitrate stabilisiert hat verschwindet das Ruckeln wieder, wohlgemerkt mit Max Queued Audio Buffer auf 9000ms. Lass ich ihn auf dem Standardwert hab ich nach 10sec dauerhaftes Ruckeln mit 16,67 fps, laut Reclock. Da dieses Ruckelphänomen aber mit dem CoreAVC und dem Cyberlink Codec genau unter den selben Umständen auftritt und nur auf Premiere HD (Discovery HD?)beschränkt ist, denke ich Premiere hat wieder was an seiner H264 Codierung geändert womit die Softwaredecoder bei live Wiedergabe nicht klar kommen.

 

System:

 

X2 4400

7900gx2 mit 160.03

S3200

WinXP

Power DVD Ultra 7.3

50-60% CPU Last bei Premiere HD

Link to comment

Habe nun auch wieder mein System von Vista Home Premium auf XP (je 32 bit) geändert nachdem ich bei HDTV in allen Sendern Pro7 HD/ Sat.1 HD/ Anixe/ Prem HD / Discovery HD sehr starkes Ruckeln hatte welches ich auch nicht mit der Erhöhung der Latency o.ä. wegbekommen habe.

 

Nun, unter XP, laufen alle HDTV bis auf Discovery HD ruckelfrei. Und alles ohne Latency-Buffer-Änderung. Es kommt mir so vor, dass immer, wenn es bei der variablen Bitrate von Discovery HD zu seitlichen Kameraschwenks kommt, das Bild für eine unbestimmte Zeit anfängt zu ruckeln. Das ist aber nach einigen Sekunden wieder weg. Das Bild fängt sich wieder und läuft wieder normal. Denke, dass sich irgendwo dann Daten stauen. Mit dieser Datenmenge scheint irgendwas (Graka, Decoder....) nicht klar zu kommen.

 

System:

 

XP Home 32bit

Gigabyte 965P-DS4

C2D E6600

2 GB Corsair RAM 800

Asus Nvidia Geforce 8600 GT Silent m. HDCP mit Treiber 165.01

Cyberlink 7.3 Patch 2911

2x KNC1 DVB-2 (1x alt mit Video-in, 1x neue Version)

DVBViewer Pro 3.6.1.20

 

Prozessorlast: Anixe/Pro7/Sat1 HD ca. 6-15%

Prem HD/Discovery HD ca. 15-55% (schwankt sehr stark)

Link to comment
Es kommt mir so vor, dass immer, wenn es bei der variablen Bitrate von Discovery HD zu seitlichen Kameraschwenks kommt, das Bild für eine unbestimmte Zeit anfängt zu ruckeln. Das ist aber nach einigen Sekunden wieder weg. Das Bild fängt sich wieder und läuft wieder normal.

 

Stimmt, allerdings hat es nichts mit Vista zu tun. Ich habe von XP auf Vista umgerüstet (da ich das Problem unter XP hatte) und es ist weitgehend identisch.

 

Allerdings habe ich eine PCIe-Karte, so dass ich die AGP-Workarounds (sollten hier ohnehin sinnlos sein) nicht nutzen kann.

 

Leider ist damit auch meine einzige echte Lösung (volle H264 Hardwareunterstützung meiner 8600 GTS) nicht mehr möglich, da der Treiber VMR und/oder Overlay unter Vista nicht unterstützt.

 

Ich würde ja auch mit der neuen ATI testen, aber die hat wohl noch niemand mit voller Hardwarebeschleunigung im DVBViewer unter Vista laufen?

Link to comment
Dazu eine Rechnung: Wenn, wie bei einem Premiere HD Sample beobachtet, Video 0.8 s eher ankommt als Audio, muss der Renderer bei 25 fps an die 20 Frames zwischenspeichern, damit es synchron wird. Das macht bei einer Farbtiefe von 24 Bit = 20 x 1920 x 1088 x 3 Bytes = 120 MB.

 

Das würde zumindest meine Probleme erklären, da die MX440 von mir nur 64MB RAM hat und die 6600GT 128MB (mit der lief's einiges besser).

Link to comment

Den 'InterVideo Video Decoder' habe ich nun auch irgendwie mit der Pro ans Laufen bekommen. Im System registriert sind 'CyberLink H.264 Decoder' und 'InterVideo Video Decoder'. Obwohl der 'InterVideo Video Decoder' nicht in der Auswahl der H.264 Dekoder erscheint und der 'CyberLink H.264 Decoder' gewählt ist, wird der 'InterVideo Video Dekoder' verwendet, und ohne das Ruckelproblem...

Edited by CiNcH
Link to comment

Ich glaub ich weiß nun, warum das passiert. Ich switche zu Testzwecken oft zwischen PowerDVD und PowerDVD Ultra und da war wohl eine kleine Unsauberkeit, sodass der gewählte H.264 Dekoder zwar noch registriert, aber nicht mehr physikalisch vorhanden war und somit dann Default gerendert wurde. (PowerDVD und PowerDVD Ultra registrieren ja H.264 Dekoder mit unterschiedlicher CLSID)

Link to comment

... ist zwar schon alles gesagt .... :bye:

ich habe das ruckeln auch und meine Freudin reißt mir so langsam den Kopf vom Hals, der mitlerweile auch immer dicker wird.

 

nach vielen Testen bin ich zum Schluß gelangt, dass was man auch immer einstellt (z.B. im dvbfilter) oder konfiguriert, es nicht nützt oder sehr flüchtig ist.

 

zur Zeit ist es so, dass egal was ich auch im udH264latency einstelle, mal Ruhe ist mal nicht. Dann läuft das Bild mal wieder stabil, bis es wieder zu Ruckeln anfängt und dann fänggt es sich mal wieder usw... -> fix geht nicht wirklich

am PowerDVD oder sonstigen Codec liegt es auch nicht. Und eine Geforce 6600GT ist sehr wohl in der Lage, die Daten zu verarbeiten.

 

Das ist doch längst kein annehmbarer Zustand mehr. (gibt´s eigentlich irgendwo sein Geld zurück???)

 

Kann hier mal jemand für Abhilfe sorgen?

Edited by pappnase_01
Link to comment

Geld zurück gibt's höchstens von dem, der das Problem verursacht. So. Und den hat bis jetzt noch keiner so richtig gefunden. Oder weißt du genau, dass es am DVBViewer liegt, weil Anwendung XY das besser hinbekommt (mit Live TV wohl gemerkt, es seidenn DVBViewer zeigt bei dir auch die Probleme bei der Wiedergabe).

 

Bei Postings in der Form kann bestimmt keiner für Abhilfe sorgen. Wenn du willst, dass alles "einfach funktioniert", dann solltest du auf HDTV noch 2-3 Jahre verzichten... wer "early adopter" sein will, der muss auch Spaß am basteln haben und (zum Teil teure) Rückschläge verkraften können.

 

Du kannst schreiben, was du schon alles versucht hast bzw. welche Symptome du genau hast, ggf. hat einer noch ne Idee, was man probieren kann. Dann wird dir vielleicht geholfen.

Link to comment

also, ich meine, dass mitlerweile genug POsts zu diesem Thema gibt.

Das sollte eigentlich ausreichen, damit sich der Entwickler selber eine entsprechende Testumgebung erstellen kann.

 

Man nehme: Windows + Powerdvd + Grafikkarte + DVBViewer und sehe damit ProSieben HD oder einen anderen und schon hat man auch die Ruckler. Hier sind so viele mit unterschiedlichen Konfigurationen dabei und alle haben das gleiche Problem und die einzige Konstante die dabei gleich bleibt ist der DVBViewer. Ergo...

 

Oder fluppt das mit HD bei Dir richtig? (Würde mich jetzt wundern). Wenn ja, will ich nix gesagt haben.

 

Ich bin jetzt schon permanten drei Wochen am basteln und immer habe jetzt von den Rückschlägen genug. Mag auch nicht mehr testen. Am Anfang sah das noch alles sehr gut aus, aber jetzt :-( - Schade, 15 Euro in den Sand gesetzt. Einen für mich funktionierenden HTPC kann ich hiermit nicht aufbauen. Dann bleib ich lieber bei der XBOX, die alles macht außer TV und kauf mir dann eben im Herbst (weil ich ja nicht mehr warten wollte, habe ich mir den DVBViewer zugelegt) den Topfield mit HDD und Web-Server.

 

 

...Kann alles (nix) und läßt keine (viele) Wünsche offen... - man sollte die Homepage mal überarbeiten.

 

 

Sicherlich macht der schon eine ganze Menge, nur leider nicht, was ich mir davon erwartet/versprochen habe. Dann kaufe ich mir eben doch den Topfield und warte noch so ein paar Jahre, bis der DVBViewer hdtv auch mal richtig kann.

Link to comment
also, ich meine, dass mitlerweile genug POsts zu diesem Thema gibt.

Das sollte eigentlich ausreichen, damit sich der Entwickler selber eine entsprechende Testumgebung erstellen kann.

 

Man nehme: Windows + Powerdvd + Grafikkarte + DVBViewer und sehe damit ProSieben HD oder einen anderen und schon hat man auch die Ruckler. Hier sind so viele mit unterschiedlichen Konfigurationen dabei und alle haben das gleiche Problem und die einzige Konstante die dabei gleich bleibt ist der DVBViewer. Ergo...

 

Oder fluppt das mit HD bei Dir richtig? (Würde mich jetzt wundern). Wenn ja, will ich nix gesagt haben.

 

Das ist halt falsch. Bei mir ruckelt da überhaupt nix. Windows XP + PowerDVD 7.0 2211a + Nvidia Geforce 7950 (+ irgne komische Buchstabenkombination) + DVBViewer -> Pro 7 HD kein Ruckeln, Premiere HD kein Ruckeln, Discovery HD kein Ruckeln... und das hatte ich da auch noch nie (daher nichts an der Konfiguration geändert ausser neueren Versionen vom DVBViewer).

So, und nu? ^_^

 

Ich bin jetzt schon permanten drei Wochen am basteln und immer habe jetzt von den Rückschlägen genug. Mag auch nicht mehr testen. Am Anfang sah das noch alles sehr gut aus, aber jetzt :-( - Schade, 15 Euro in den Sand gesetzt. Einen für mich funktionierenden HTPC kann ich hiermit nicht aufbauen. Dann bleib ich lieber bei der XBOX, die alles macht außer TV und kauf mir dann eben im Herbst (weil ich ja nicht mehr warten wollte, habe ich mir den DVBViewer zugelegt) den Topfield mit HDD und Web-Server.

...Kann alles (nix) und läßt keine (viele) Wünsche offen... - man sollte die Homepage mal überarbeiten.

Sicherlich macht der schon eine ganze Menge, nur leider nicht, was ich mir davon erwartet/versprochen habe. Dann kaufe ich mir eben doch den Topfield und warte noch so ein paar Jahre, bis der DVBViewer hdtv auch mal richtig kann.

 

Tja, solang du auf deinem System nicht den gegen Test mit einer anderen Software machst, ist es leider überhaupt nicht klar, ob das Problem jetzt am DVBViewer liegt, oder nicht....

 

Ausserdem verstehe ich auch nicht, warum man so ein riesen Trara um HDTV macht... mich überrascht und freut es zwar, dass es bei mir so gut läuft (und eigentlich von Anfang an lief), aber nutzen tue ich es eigentlich eher selten... nämlich genau dann, wenn Pro 7 mal eine interessante Sendung in HD Ausstrahlt, oder ich nix zu tun hab und mal auf Discovery HD zappe... HD Inhalte sind doch noch recht selten und das meiste, was mich interessiert ist noch in SD produziert... Wenn bei mir HDTV nicht funktionieren würde oder ruckeln oder was auch immer, hätte ich wieder was zu basteln, aber ein Grund meinen HTPC aufzugeben wäre das noch lange nicht. ;)

Edited by Moses
Link to comment

ich & mein Plasma warten jetzt schon 2 Jahre auf HDTV, und meiner Meinung nach kommt die Industrie damit auch nicht in die Pötte.

So zum Beispiel Technotrend. Die bewerben auch nur die Produkte und Treibermäßig kommt da auch nichts mehr neues. (MCE Vista).

Das ist alles sehr traurig.

sag ich mal: Glück gehabt. Freue Dich.

 

Mir würde es schon reichen, wenn ich ProSieben HD ordentlich sehen könnte. Da kommen meine Serien und hin und wieder auch ein Filmchen (gestern z.B. Identity). Der sieht in HD einfach besser aus als in SD.

 

Dann würde ich mal für mich sagen, das die GF6600GT nicht genug Saft hat. Das andere passt sehr gut. So ein X2 4600 wird ja wohl ausreichen. Und am PowerDVD kann es auch nicht liegen 7.3.2911. Soviel dann dazu. Im Board wird zwar immer auf den H264-Codec rummgeritten, aber das ist es nicht. Da vertraue ich auf Cyberlink.

 

Wie soll man jetzt das Problem der Ruckler angehen? Mit einer GF8600GT ging es beim letzten Test. Damit ich das dann aber wieder überprüfen kann, muss ich diese wieder einbauen. Dann geht es wieder (vielleicht). Dann fliegen mir aber auch die Ohren wieder weg (Lüfter).

 

Aber warum dann nicht mit der GF6600. Die macht doch schließlich NvidiaPure. Und läuft ja auch, bis auf die Ruckler nach einiger Zeit. Alles sehr merkwürdig. Und mit 2*6600GT geht es auch nicht, trotz SLI und so.

 

Installieren doch einmal Deinen PC neu. Mit WinXP-SP2. und PowerDVD 7.3.2911. und NVidia 158.24. und DVBViewer 3.6.4.12. und dann sehen mir mal, ob der dann nicht ruckelt. Meiner macht das dann. mit GF6600GT. OK, ich hänge damit auch am Plasma, mit der HD Auflösung von 1920*1080. Vielleciht leigt auch hier das Problem, dass der dvbfilter da irgendwie nicht zurecht mit kommt.

(Ich kann keine Installations-CD´s/Treiber mehr sehen - werde/bin schon wahnsinnig).

Aber kann natürlich sein, dass die Grafikkarte das nicht mehr schafft. Habe aber auch hierzu noch keine eindeutige Aussage erhalten. HD-DVD Trailer kann die aber sehr wohl flüssig abspielen. Soviel dazu.

 

P.S.: die Technotrend Software funktioniert im übrigen. Da liegt die Vermutung schon nahe, dass es am DVBViewer liegt, oder? Warum, weiss ich aber auch nicht. Irgendwie kommt der mit dem durchschieben dass Daten zur Grafikkarte/Codec nicht klar. Und mit den Einstellugnen im dvbfilter, wird es auch sehr kurzzeitig besser.

 

Und jetzt habe ich schon wieder 30 Minuten meines Lebens damit verschwendet - weil, besser gehen tut´s ja auch immer noch nicht.

Link to comment
OK, ich hänge damit auch am Plasma, mit der HD Auflösung von 1920*1080.

 

Was hast Du denn für eine Diagonale mit einem Plasma(!!!) mit Full-HD? Einen LCD kann ich mir da schon eher vorstellen...

Link to comment

42", 1080i - nix full hd

Ruckelt, aber auch auf dem LCD 1280*1024 :-( - ziehe also Aussage mit der Auflösung wieder zurück. Das war es dann doch nicht.

Edited by pappnase_01
Link to comment

bei mir hängt auch ein 42" Plasma im 1080i dran...

Ich könnte mir schon vorstellen, dass es mit neueren Versionen des Cyberlink Decoders mehr Probleme geben kann. Wenn man die 7.3 nicht brauch wegen Hardware Decodierung gibt's für mich eigentlich keinen Grund die zu nutzen. Und es gab schon den ein oder anderen Bericht über Bugs.

(Ich würde anbieten die ältere Version zu verschicken, zu test Zwecken).

 

Andererseits hat Griga auch schon vermutet, dass der DVB Source Filter irgendwo Probleme mit dem muxing haben könnte.

Kann der DVBViewer bei dir denn Aufnahmen abspielen? Dann könnte Timeshift für dich erstmal ein Workarround sein. ^_^

 

Achja, da fällt mir ein mit der 6600GT oder 6800GT + nforce Chipsatz und AMD Dual Core CPU gab's mal nen lustigen Bug, das irgendwer ständig die CPU zu 100% belegt hat... guck mal nach, ob bei dir noch wer CPU Leistung beansprucht ausser dem DVBViewer.

 

Du könntest auch mal die DVBViewer GE Version versuchen. Jemand anders hatte mit der Problemloses HDTV gehabt, mit dem DVBViewer Pro aber zu hohe CPU Auslastung (die CPU war auch ein AMD X2, welche Zahl weiß ich gerad nich mehr genau, aber auch ne 4 vorne).

Link to comment
Ich glaub ich weiß nun, warum das passiert. Ich switche zu Testzwecken oft zwischen PowerDVD und PowerDVD Ultra und da war wohl eine kleine Unsauberkeit, sodass der gewählte H.264 Dekoder zwar noch registriert, aber nicht mehr physikalisch vorhanden war und somit dann Default gerendert wurde. (PowerDVD und PowerDVD Ultra registrieren ja H.264 Dekoder mit unterschiedlicher CLSID)

 

So etwas hatte ich auch bereits in Verdacht. Aber wie stelle ich nun sicher, dass der richtige, sprich der einzig vorhandene H.264 Dekoder korrekt eingebunden wird. Gibt es hierzu einen Registry-Eintrag?

 

Gruß,

searge

Link to comment

@Moses - der gute Helfer

 

so, jetzt ich nochmal.

 

Aus reiner langer Weise (bekomme ich eigentlich für´s Beta-Testen irgend etwas? - ach nee - hättest ja die Software nicht kaufen müssen, oder wie? - jetzt weiss ich auch, warum es keine Demoversion gibt - sag ich mal ganz zünisch) habe ich mir mal

Windows Vista 32, NVidia 158.24, PowerDVD 7.3.2911 mit einer Geforce 8600GT auf meinem AMD X2 4600 mit 2GB und dem Asus M2N32-SLI Deluxe installiert (viel besser geht nun wirklich nicht mehr), und jetzt rate mal, na, ja, genau, stottttteeeerrrrt immmmmmmaaa nnnnnooocchhhhhh.

Meine CPU grooved bei 40-50 Prozent rum, und ja, isch habe beide Kerne an.

Und weil ich noch mehr lange Weile hatte, hab ich auch mal das Board Bios auf den neusten Stand gebracht. Ergebnis: Schön, bringt zwar nix, außer ein gutes Gefühl, aber is ja auch schon etwas.

 

Ich vermute jetzt mal sehr dringend den DVB Source Filter. So wie es aussieht, fängt der immmmmeeeerrr annnnn zzzzuu stotttteeerrrnn, wenn die Bitrate so über 6 Mbit geht. Sollte DVBViewer etwa doch nicht für HD, sondern nur für SD geeignet sein???

 

 

Werde aber auch noch mal sehr gerne zu eurer Beunruhigung einen anderen PowerDVD installieren, aber mit dem CoreAVC geht es auch nicht!!!

 

 

P.S.: Schon germerkt: Es tauchen immer mehr Fehlermeldungen im Forum auf von Leuten, die sich über Bildruckeln, Stottern oder auch in english Jitter im HD Bereich beschweren.

Und: meine Freundin kann es nicht mehr hören. Jetzt is es soweit: Ehekriese. Dankeschön.

 

 

 

P.P.S.: Griga verwendet doch auch den DVB Source Filter, na und, ja, rate mal, stottert damit auch - soviel nun dazu

Edited by pappnase_01
Link to comment

Also Pappnase,

 

deine "Ehekrise" und sonstige Äußerungen kommentiere und werte ich jetzt einmal nicht...

 

Ich sehe 2 Möglichkeiten:

 

-> DVBViewer GE verwenden und Enhanced Video Renderer einstellen. Somit sollte DXVA2 und damit die PureVideo HD 2 Engine deiner GeForce 8600GT zum Einsatz kommen ('DxVA' muss im CyberLink H.264 Dekoder Filter aktiviert sein). Es geht hier nicht darum die CPU zu entlasten, sondern die CyberLink Dekoder Algorithmen zu umgehen...

 

-> MainConcept H.264 Dekoder probieren. Den Link sowie einen Hinweis zur Installation habe ich bereits gepostet.

 

Beides funktioniert bei mir 1A. Auch ich habe Probleme mit dem CyberLink H.264 Dekoder im reinen Software-Modus. Der DVBSource-Filter handelt die Streams IMHO wunderbar.

Edited by CiNcH
Link to comment
Ich vermute jetzt mal sehr dringend den DVB Source Filter. So wie es aussieht, fängt der immmmmeeeerrr annnnn zzzzuu stotttteeerrrnn, wenn die Bitrate so über 6 Mbit geht. Sollte DVBViewer etwa doch nicht für HD, sondern nur für SD geeignet sein???

*ROTFL* Ich habe samples mit 41mbps. Läuft butterweich.. ..ist zwar mpeg2 aber auch bei den gängigen (alle, die ich kriege) H.264 streams gibt es null probleme ^_^;)

Link to comment
-> MainConcept H.264 Dekoder probieren. Den Link sowie einen Hinweis zur Installation habe ich bereits gepostet.

Ich wollte dazu mal was loswerden. Hab den auch mal probiert (Vista 32bit, 7050PV, FW162.15, AMD X2 3800+ X2), nur leider bin ich mit dem MainConcept bei astra hd (und das is der sender der bei mir am wenigsten last erzeugt) bei >90% last, beide cores in benutzung und HW Accel an. Der Cyberlink macht 50-65% last. Ich weiss nicht ob es von belang ist, aber ich nutze den Overlay Mixer als renderer.

Link to comment
Ich wollte dazu mal was loswerden. Hab den auch mal probiert (Vista 32bit, 7050PV, FW162.15, AMD X2 3800+ X2), nur leider bin ich mit dem MainConcept bei astra hd (und das is der sender der bei mir am wenigsten last erzeugt) bei >90% last, beide cores in benutzung und HW Accel an. Der Cyberlink macht 50-65% last. Ich weiss nicht ob es von belang ist, aber ich nutze den Overlay Mixer als renderer.

Der 7050PV sollte doch eine ähnliche H264 Beschleunigung haben wie die neuen ATIs, daher sollte die CPU-Last bei max. 20% Auslastung liegen, je nach Bitrate. Wie siehts denn mit der Auslastung bei H.264-Trailern aus (also kein Live-TV)? Vielleicht hat noch jemand den 7050PV und könnte was dazu loswerden...

 

mfg

alfonxs

Link to comment

Jo die 7050PV ist, wie der name schon sagt, eine GF7 mit PureVideo. Dass die das selbe kann wie eine 8600er ist leider ein trugschluss (glaube ich zumindest). Jedenfalls beschleunigt die wohl nur bis 720p. Aber ich lade mir grade mal von www.nerodigital.com die beiden auf der startseite angepriesenen AVC trailer runter (720p und 1080p) und poste mal das ergebnis.

 

edit:

 

Mit PowerDVD 7.3:

 

720p - min 34% max 60% Auslastung

1080p - min 80% max 98% Auslastung

 

Da aber das ganze DVB-S2 gedöns aber in 1080i ist, werden ja nur 540 zeilen die 1920px lang sind angezeigt, was minimal mehr performance brauchen sollte als 720p. Bei dem MainConcept tippe ich da dann zudem noch einfach auf die fehlende unterstützung bzw. erkennung der 7050PV.

Edited by RocketChef
Link to comment

@CiNcH, Derick, Moses - danke für die Unterstützung

 

so, da bin ich wieder.

 

IHR HABT ALLE SO RECHT GEHABT!!!

 

das Problem lag am PowerDVD 7.3.(2911). Finger weg davon. Wie Cyberlink so etwas passieren kann, bleibt ist ein Rätsel.

 

Habe mir zuerst einmal den Elecard heruntergeladen. Der funktioniert auch sehr gut, erzeugt aber mindestens (oder so um die) 60% Prozessorlast.

Dann habe ich noch irgendwo eine PowerDVD 7.2 gefunden und sieht da, kein Ruckeln mehr (bis jetzt nach mind. 1 Std. Laufzeit und der Prozessor zeigt auch max. 30% Last an. Das Ganze mit der guten, alten GF6600GT. Im Filter nennt sich der H.264 Codec dann auch PDVD6.X und nicht wie bei der 7.3 PDVD7.x.

 

Weitersagen erwünscht.

Vielleicht kann man im Board irgendwo ganz, ganz oben eine entsprechende Meldung dazu machen. Dann müssen die anderen nicht mehr suchen.

Edited by pappnase_01
Link to comment
Im Filter nennt sich der H.264 Codec dann auch PDVD6.X und nicht wie bei der 7.3 PDVD7.x.

 

ich hab auch powerDVD 7.2 installiert (vorher 7.3) aber da steht auch 7.x!

Link to comment

Ich hab 7.2 auch grad probiert und PDVD6.x steht drin, aber nach wie vor das selbe mit dem geruckel.

 

Mal ne andere (etwas OT) frage: Welcher nVidia treiber aktiviert PureVideo HD unter XP? Will den vista kram hier mal (als mögliche fehlerquelle) loswerden :bye:.

Link to comment

Bei mir hat sich jetzt das Problem mit dem ruckeln und stocken mit der Deinstallation des allten ATI Catalyst 7.x für meine 1800XT und Installation des neuen Catalyst 7.6 Treiber der auch die WHQL von MS hat gelöst.

 

Allerdings habe ich immernoch extremen Jitter bei schnellen Bildscenen und -wechseln so das man eigenlich gar nicht von HD reden kann. Den Jitter habe ich aber glaube schon seit der Installation des Cyberlink 7.3. Hier macht es aber auch keinen unterschied ob ich DXVA aktiviert habe oder nicht.

Edited by ectomorph
Link to comment

Hi,

 

ok, hatte ich vergessen zu schreiben. Mit PowerDVD 7.2 funktiniert es leider nur unter Windows XP.

Unter Vista ist das Ruckeln nicht wegzubekommen, oder?

Außer man benutzt den MainConcept/Elecard-Decorder. Dann geht es.

Das ist alles sehr merkwürdig.

(Ihr habt nicht zufällig einen geheimen Deal mit dieser Firma abgeschlossen?)

Link to comment

Also bei mir ist das permanente Ruckeln seit dem hochsetzen der AGPApertureSize tatsächlich Vergangenheit, ich habe jetzt nur noch das Problem das ich bei den HD-Sendern (egal ob PTV oder FTA!) zwischendurch Discontinuities habe. Tritt ein Disc. auf, dann hakt das Bild kurz und der Codec braucht danach scheinbar 2-3s um sich wieder "zu fangen" in denen das Bild (ähnlich dem oben immer wieder beschriebenen Ruckeln) ruckelt.

Um das Problem zu klären habe ich mal alles Mögliche ausprobiert: Plugins entfernt, CI entfernt, andere DVBSource-Einstellungen, Änderungen der PCI-Latency und Änderungen der Codecs. Leider blieben die Disc. die ganze Zeit unverändert. Danach habe ich dann mit Transedit den Transponder analysiert aber dort nichts feststellen können: Nach über einer Stunde nicht ein einziges "Missing Packet". Beim normalen Schauen via DVBViewer Pro hätte ich in der gleichen Zeit 20-30 Disc. gehabt! Danach habe ich dann mal die akt. Beta des DVBV-GE (2.3.0) getestet: Keinerlei Discontinuities - dafür war ganz sporadisch das "Codec-Ruckeln" wieder da....

 

Ich schliesse daraus folgendes:

-Das permanente Ruckeln entsteht durch eine Kombination aus Codec-Version und falschen Hardware-/BIOS-Einstellungen.

-Die Discontinuities werden durch irgendwas im DVBViewer Pro verursacht.

Link to comment

was mir auch völlig unerklärbar ist, ist, dass ich ca. 30 Sekunden ein ganz sauberes Bild habe und erst dann fängt es an zu ruckeln, so als ob einfach irgendwo ein pufferüberlauf stattfinden wurde und dann das ganze klemmt.

vielleciht stimmt hier ja doch etwas nicht zwischen Cyberlink-Filter und DVBViewer-Schnittstelle zum Filter.

Sonst müßte es doch von anfang an ruckeln, oder?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...