Jump to content
wedok

LAV Filters

Recommended Posts

goldfield

@ coolzero

Ich nutze die Version 0.50 mit einer ATI-HD5450.

CPU ist ein Phenom-II X550.

Prozessorlast ist bei 576p/720p/1088p immer unter 20%.

 

Hardware Beschleunigung habe ich die Modi DXVA2 copy back eingestellt

Ich nutze DXVA2-native.

Keine Ahnung, ob das unter XP funktioniert.

Share this post


Link to post
gwr

Hallo,

 

ich nutze die Version V0.50.1 unter Windows XP SP3 zusammen mit einer ATI HD5670.

Das Bild läuft ruckelfrei, aber die Prozessorlast liegt sehr hoch (SD ~40% und HD über 70%).

Hardware Beschleunigung habe ich die Modi DXVA2 copy back eingestellt. Renderer im DVBViewer steht auf EVR.

Overlay bringt bei mir nur Streifenkino, VMR usw bringen auch keine bessere Prozessorlast.

 

Gleiche Konfig unter PowerDVD10 habe ich bei HD eine Prozessorlast von ~10%.

Verwendeter Grafikkartentreiber ist Catalyst 10.8.

 

Wie bekomme ich die hohe Prozessorlast runter, hat jemand einen Tipp für mich?

 

meines Wissens gibt es unter Windows XP kein DXVA 2, ob da EVR eingestellt ist oder ein anderer Renderer.

Der LAV bekommt es aber anscheinend hin trotz Software-dekodierung den Videorenderer bzw. die Grafikkarte zum bestmöglichen

Deinterlacing zu bewegen. Zumindest bei SD ist das hier so, bei HD vermutlich auch, aber da kommt mein alter Kasten ohne DXVA nicht mit.

Share this post


Link to post
awehring

Der LAV Filter 0.50.1 funktioniert auf meinem Atom Doppelkern / Nvidia Ion System ausgezeichnet.

 

Im Vergleich mit dem Cyberlink PDVD10 ergibt sich bei mir folgendes Bild:

 

Bei SD und HD 720p Sendern sind keinerlei Unterscheide zu erkennen, beim direkten Umschalten zwischen beiden (mit Video A / B ).

 

Mit HD 1080i Sendern (z. B.: Servus TV HD) ist der LAV um eine Winzigkeit weniger gut:

 

Wenn man das Senderlogo, insbesondere den schwungvollen Unterstrich, genau betrachtet, tauchen beim LAV (DirectX native) bei schnell wechselnden Bildinhalten gelegentlich kleine Ausfransungen in der Grösse von einem Pixel auf. Mit DirectX copy back sind diese etwas häufiger und stärker.

Mt Cyberlink PDVD10 treten keine Ausfransungen auf.

 

Die Prozessorlast ist mit LAV ca. 40 - 45 %, mit PDVD10 minimal geringer (ca. 40%).

 

 

Bild-in-Bild mit zwei HD Sendern schaffen beide nicht, die Prozessorlast geht gegen 100 %, mit Bildstörungen und Rucklern. (Das ist der Preis für einen günstigen, kleinen und praktisch unhörbaren HTPC.)

 

 

Der Fortschritt von LAV 0.50.1 gegenüber meiner zuletzt installierten Version 0.13 ist enorm. Mit der alten Version hatte ich bei HD immer Ton-Asynchronitäten und Ruckler. Die Bildrate schwankte auch immer zwischen 40 und 45 Hz. Sie erreichte nie stabile 50 Hz, wie es mit der aktuellen Version der Fall ist (ebenso wie mit PDVD10).

 

Insgesamt sehr erfreulich, dass es einen so guten freien Video Decoder gibt :)

Ich werde den LAV jetzt ein Zeit lang verwenden, mal sehen, ob mir noch was auffällt.

 

 

Mein System:

Eeebox 1501, Atom Dualcore (1.6 GHz), Nvidia Ion

Windows 7, 32 bit

DVBViewer 4.9.0

Grafiktreiber 295.73

Full HD Monitor und Beamer (Klon-Modus)

DVB Receiver: TechnoTrend connect S-2 3650 CI

 

LAV Einstellung: alle Default ausser: DirectX (native)

Edited by awehring

Share this post


Link to post
nuts

Neue Version: 0.50.2

http://forum.doom9.org/showthread.php?t=156191

 

- Fixed a deadlock on dynamic format changes with DXVA2 Native

Könnte interessant sein.

Edited by nuts

Share this post


Link to post
Craig77

Die neue Version 0.50.2 funktioniert bei mir so stabil wie die 0.49. Wer bei 0.50.1 und 0.50 Probleme hatte, sollte die neue Version ausprobieren!

Share this post


Link to post
darky
Changelog

0.50.5 - 2012/05/12 - Release Notes

Code:

 

LAV Video

- Fixed a crash in DXVA2-Native decoding (introduced in 0.50.4)

 

Share this post


Link to post
test

für mich ist der LAV Video Decoder leider seit einigen Releases nicht mehr zu gebrauchen. Hat massivste Probleme beim Deinterlacing, was man besonders gut bei der N24 Laufschrift sieht :( ... 0.49 funktioniert, ebenso PDVD12, einwandfrei.

Share this post


Link to post
Hame

In the last 24 hours ;)

 

LAV Filters 0.50.3

 

LAV Splitter

- Fixed playback of raw PCM in AVI streams

- Fixed a rare misdetection of MPEG-2 as VC-1

 

LAV Video

- QuickSync: Fixed playback of some H.264 streams that would run out of sync on newer drivers

- Fixed a memory leak when playing H.264 RGB (and some other formats)

- Improved behaviour for H.264 and MPEG-2 on Live TV channel changes

 

LAV Audio

- Added support for Speex (via libspeex)

- Improved support for AMR-NB/WB (using OpenCore decoder)

LAV Filters 0.50.4

 

LAV Video

- Fixed seeking with QuickSync running in madVR Exclusive Mode

LAV Filters 0.50.5

 

LAV Video

- Fixed a crash in DXVA2-Native decoding (introduced in 0.50.4)

Share this post


Link to post
alex.ba
für mich ist der LAV Video Decoder leider seit einigen Releases nicht mehr zu gebrauchen. Hat massivste Probleme beim Deinterlacing, was man besonders gut bei der N24 Laufschrift sieht ... 0.49 funktioniert, ebenso PDVD12, einwandfrei.

 

nur rein Interesseshalber 2 Fragen dazu

 

1) Welche Grafikkarte mit welchen Treibern verwendet su auf welchem OS

2) Hat der PDVD12 nicht Probleme mit ZDF HD und anderen HD Kanälen auf diesem TRanspondern (Bei SAT Empfang)

 

Grüße

 

Alex

Share this post


Link to post
test

siehe meinen Footer. Da steht alles drin :)

Share this post


Link to post
alex.ba

Hatte ich (aus welchem Grund auch immer :-) ) übersehen. Du hast eine 4*** Karte ich verwende gerade ne 6*** allerdings mit dem 12.03 da ich mit dem 12.04 Probleme hatte. Das sind die einzigen Unterschiede denn ansonsten würde ich sagen dass es mit dem LAV (aktuelle.05 noch nicht probiert) sehr stabil läuft.

 

Grüße

 

Alex

Share this post


Link to post
darky

Habe eine ATI Grafikkarte und habe das Problem, dass ich bei 1080p Sendern immer so Mikrorucker habe, d.h. es gibt immer mal wieder kurze Ruckler, die 3-4 Sek. dauern und dann ist wieder alles in Ordnung. Kann das jmd. bestätigen oder hat jmd. Abhilfe? Mit dem Cyberlink Codec tritt dies nicht auf...

Edited by darky

Share this post


Link to post
Tjod

Wo gibt es 1080p Sender?

Share this post


Link to post
darky

ich meine natürlich 1080i

Share this post


Link to post
v!rus

Ich habe auch mit allen 0.50er LAVs Frame Drops bei Live TV im DVBViewer.

Bin erstmal wieder zurück zum 0.48er. Der läuft ohne Probleme.

Share this post


Link to post
max73a

Ich habe Lav Cuvid probiert und die HD sender sind doch mehr brillanten :-)

Share this post


Link to post
filmgetter

Wie installiere ich neue Versionen vom LAV.

 

Drüberbügeln oder vorher deinstallieren. Und welchen brauche ich von der LAV-Seite?

 

http://1f0.de/downloads/

 

Habe bisher immer den Installer für 32 und 64 bit versucht und bekomme eine Meldung, das der irgendeine dll nicht finden kann.

 

Danke für die Hilfe.

Share this post


Link to post
Innuendo

Habe bisher immer den Installer für 32 und 64 bit versucht und bekomme eine Meldung, das der irgendeine dll nicht finden kann.

 

Danke für die Hilfe.

 

Wenn Dein Footer noch stimmt (W7HPx86) kann die x64 nicht funktionieren.

hier gibts den installer und infos: http://forum.doom9.org/showthread.php?t=156191

 

Ich habe zuletzt bei der Installation über eine vorhandene reset konfig ausgewählt

 

Innu

Share this post


Link to post
dbraner

Zu den Einstellungen des LAV habe ich noch folgende Fragen:

 

1) was bringt "aggressive deinterlacing"?

 

2) welchen Rgb Ausgabemodus sollte man bei Ausgabe auf einen Fernseher wählen? Erster Gedanke wäre eigentlich TV. Jedoch erkennen manche Fernseher einen PC bzw. haben eine spezielle PC Einstellung. Wäre in diesem Fall dann PC 0-255 besser? Oder doch lieber "unchanged"?

Share this post


Link to post
nuts

Bulletpoint changes:

- Changed "Field Order" and "Force Deinterlacing" to global options

- Added "Aggressive Deinterlacing" option

 

That means that all those options not only apply to the CUVID deinterlacer now, but also to deinterlacing when its done in the renderer.

 

Aggressive deinterlacing is similar to CoreAVCs aggressive checkbox - it forces deinterlacing if the stream indicates interlaced coding is used, even if not all frames are coded as such. Alot of broadcasts seem to be broken that way.

 

Force Deinterlacing foces deinterlacing on all streams, even if the whole stream is marked progressive. Not sure that option is still needed, i have no sample which would require it.

 

Bei der RGB Checkbox ist mir auch nicht so ganz klar was der LAV-Decoder da macht.

EVR Custom arbeitet intern mit RGB (0-255) und somit muss irgendwann sowieso konvertiert werden.

Bei DXVA2 dürfte die Einstellung aber sowieso keinen Effekt haben.

Edited by nuts

Share this post


Link to post
vonMengen

Ich habe auch mit allen 0.50er LAVs Frame Drops bei Live TV im DVBViewer.

Bin erstmal wieder zurück zum 0.48er. Der läuft ohne Probleme.

 

Yepp auch hier -der decoder funktioniert hier recht gut -auch das deinterlacing bei SD sendern ist ordentlich.

 

Leider ist der sync schon nach weniger als 10 minuten vorüber ....

 

EDIT: Der Tip mit 0.48 war gut -- sync ist deutlich besser.

 

nette Grüsse

 

armin

Edited by vonMengen

Share this post


Link to post
schindi77

wo habt ihr denn die 0.48 her?

hab auch sync-Probleme und finde auf die schnelle keinen Downloadlink....

 

edit: sorry, hat sich erledigt....war zu blöd zum tippen

Edited by schindi77

Share this post


Link to post
ferrari987

Ich kann eigentlich erstmal nur sagen: Hut ab, dass es endlich einen kostenlosen Decoder gibt mit DXVA Support :)

 

Ich habe aktuell die 0.50.2 laufen, da aber das Problem dass ab und an Ruckler entstehen (CPU-Last, Ram-Auslastung sind im unkritischen Bereich). Mit der 0.50.5 wurde dann Bild/Ton zunehmend asynchron (AC3-Filter->SP-DIF), sodass ich erstmal zurückgeschwenkt bin.

 

Hat jemand ähnliche Erfahrungen mit der 0.50.5 gemacht?

 

(Intel G530 CPU, W7 32bit)

Share this post


Link to post
darky

0.48 probiert?

Share this post


Link to post
Innuendo

asynchrone Ursache war bei mir der ac3filter (1.63b/2.1a/2.2a). Mit dem aktuellen fddshow audio decoder habe ich bislang keine Probleme (Passthrough an AVR, kein lipsync, kein dvb clock). Ich bin über Tage hinweg bis auf 0.48 heruntergegangen und subjektiv sind in der Version die wenigsten Video Probleme. Die Umschaltzeiten sind schlechter, als in der 0.50.5 (ccc 12.4, Realtek HDMI Audio)

Edited by Innuendo

Share this post


Link to post
ferrari987

jop, genau das gleiche. Nach ca. 30 Minuten fängt es an zu ruckeln :(

Share this post


Link to post
ZappoB

Ich habe wenig bis keine Probleme, ich verwende aber auch den LAV Audio-Codec, vllt. verbessert der das Problem der Asynchonität.

Share this post


Link to post
ferrari987

Also das mit der Asynchronität ist nur bei der allerneusten 0.50.5, bei allen älteren Versionen tritt das Problem nicht auf. Unterstützt der LAV-Audio denn AC3 passthrough SPDIF?

Share this post


Link to post
Craig77

Ich glaube ja, müsste der Punkt "Bitstreaming (S/PDIF,HDMI)" sein oder?

Share this post


Link to post
ferrari987

Alles klar, dann warte ich mal die nächste Version ab und teste dort den Audio-Dekoder mal mit :)

Share this post


Link to post
Virtualizer

Ich habe die schon erwähnten Sync Probleme beim DVBViewer mit den LAV Video Codecs schon seit den ersten Versionen die ich getestet hatte (ab v0.13).

Es betrifft AMD sowie NVidia Karten und es ist unabhängig der eingesetzten (DVBViewer möglichen) Renderer oder Audio Codecs.

Dass es bei der ein oder anderen Version mal besser war könnte sein, jedoch ist das Problem definitiv immer da.

Und auch wenn es nur im Millisek. Bereich liegt geht das gar nicht.

Die Microsoft Video Decoder von Win7 sind bisher immer noch am stabilsten für LiveTV (inkl. DXVA).

Edited by Virtualizer

Share this post


Link to post
vonMengen

Hab mich gestern mal mit dem oft beschriebenem Audio/Video offsync des LAV beschäftigt.

 

Mit den folgenden settings ist in meiner Konfiguration (v.0.48) auch nach 2 Stunden kein Offsync mehr feststellbar :

post-8436-0-08386100-1339844320_thumb.jpg

Share this post


Link to post
dbraner

Hab mich gestern mal mit dem oft beschriebenem Audio/Video offsync des LAV beschäftigt.

 

Mit den folgenden settings ist in meiner Konfiguration (v.0.48) auch nach 2 Stunden kein Offsync mehr feststellbar :

 

D.h. Du hast bei Dir einen Konstanten Versatz von 150 ms. Leider ist es bei mir nicht konstant.

Share this post


Link to post
vonMengen

D.h. Du hast bei Dir einen Konstanten Versatz von 150 ms. Leider ist es bei mir nicht konstant.

 

Hatte ich am Anffang auch gedacht. Allerdings in meiner Konfiguration funktioniert der kontinuierliche Versatz mit 150 ms bestens . Getestet mit Phoenix HD für 2 Stunden -

 

Aero on/DVB clock on/DXVA native .

Share this post


Link to post
Diwo

Der LAV unterstützt offensichtlich nur DXVA V2.

 

Was unterstützt der Cyberlink? DXVA V1 und DXVA V2, oder nur DXVA V1?

 

Was wäre der theoretisch wahrnehmbare Unterschied zwischen DXVA V1 und DXVA V2?

Share this post


Link to post
test

LAV 0.51 ist die absolute KATASTROPHE bei interlaced Material (normales SD Live TV)

 

Das Deinterlacing ist definitiv mehr als kaputt :(

Share this post


Link to post
vonMengen

LAV 0.51 ist die absolute KATASTROPHE bei interlaced Material (normales SD Live TV)

 

Das Deinterlacing ist definitiv mehr als kaputt :(

 

Auch in der zur Verfügung gestellten dxva 2 testversion. Geht nur mit Yadif deinterlacing. Auch die Umschaltung SD > HD ist verzögert.

Share this post


Link to post
dbraner

Ggf. gibt es heute noch die 0.51.1

( siehe doom forum )

 

Ups: und schon ist sie da

Edited by dbraner

Share this post


Link to post
nuts

Auch die Umschaltung SD > HD ist verzögert.

Versuche mal die "Videovoraberkennung" zu aktivieren.

 

Bezüglich des Deinterlacings: Hab ihr auch einen Jitter von ~20ms (s. EVR Custom)?

Komischerweise nur bei SD? HD (h.264 / 1080i) sieht gut aus.

So richtig rund läuft 0.50.1 bei mir auch nicht.

Edited by nuts

Share this post


Link to post
test

bei mir ist der Jitter ~1 ms.

 

0.51.1 ist bezüglich Deinterlacing auch Abfall.

Share this post


Link to post
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...