Jump to content

DVBViewer hangs up at start after upgrading to Windows 10

Recommended Posts


Couple of days ago I've upgraded from Windows 8.1 to 10 and so far DVBViewer is the only program I have a problem with (everything else seems to work fine).

The problem is that it just hangs up at start. Popup picture of DVBViewer shows up and that's it. The progressbar does not even start moving. Furthermore, I cannot even kill the process. The only way to get rid of the hanging picture on the screen is to reboot. And it also happens for Wizard, Debug and Safe modes, and even for SupportTool and TransEdit (except they do not show any popup window). Tried reinstalling the program (ver. 5.3.2) but it didn't help. After hours of searching on Internet and experimenting I found that the program cannot start only when Lenovo ThinkPad USB 3.0 dock is connected to my laptop (Dell XPS 12). As soon as I switch the dock off or disconnect it DVBViewer continues starting and successfully starts eventually. I can switch on or reconnect the dock and everything works fine. The same happens for SupportTool and TransEdit. So basically the workaround is: switch off and then on the dock. You don't even need to wait until DVBViewer finishes starting. You can turn on the dock in 1 sec, as soon as the progress bar starts moving.

I tried DVBViewer ver. 5.3.2, 5.4.1 and 5.5.0.

I used the latest official DisplayLink Manager. Then installed Release candidate for Windows 10 - no difference.

I tried to connect USB devices (that are connected to the dock) directly to the laptop - worked fine, so apparently DVBViewer does not like the dock itself. But since the program works fine afterwards it looks like DVBViewer is doing something not really critical at startup, but this something causes it to hang up deeply (it cannot even be killed).

I attach support.zip file here. But as I said, SupportTooll could only start after switching off the doc so I'm not sure if it contains the state when the dock is on.


Link to comment
26.07.15 21:34:01.185 USceneRender Failed initializing D3D: missing client window handle

26.07.15 21:34:01.187 USceneRender Failed initializing D3D: missing client window handle

26.07.15 21:34:01.188 USceneRender Failed initializing D3D: missing client window handle

So there is a problem with Direct3D initialization.

Is your graphic card driver up to date (Windows 10 ready)?

Link to comment

OK if I'm correct the ThinkPad USB 3.0 Dock is besides other things a USB 3 graphics card.

Though the graphic card driver of the ThinkPad USB3.0 Dock and the interaction with you internal graphic card is the interesting part.


Try the Mirror mode for the Dock graphic card. And Single-display mode > off

Has that any effete?

Link to comment

I believe it is (see the attached files).

You know, this ThinkPad USB 3.0 dock station behaves as a graphic card as well. 2 monitors are connected to it. It might be that something has changed there in relation to Direct3D after Win10 migration. How can I test it?

Anyway after DVBViewer eventually starts it works fine on the monitors that are connected to the dock station. Apparently if Direct3d is really the problem it is not used anyway.





Link to comment
So there is a problem with Direct3D initialization.


Maybe a secondary error caused by something that went wrong before. TransEdit doesn't use D3D and is also affected.


Which DVB devices are supposed to be used by TransEdit and DVBViewer? USB? Are they connected to the dock? There is no DVB device appearing in the support.zip, which means, none has been detected up to now.


but this something causes it to hang up deeply (it cannot even be killed).


This mostly means that it hangs at driver (kernel) level. Maybe due to the DVB hardware detection process performed by DVBViewer and TrandEdit on startup. But that's just a guess...

Link to comment

Thank you for replies guys.

Tried the Mirror mode, single monitor, no monitors at all - same result.

Yes, I also feel like it is related to the drivers somehow but even if something is wrong with them it looks like DVBViewer is too strict about drivers, even without severe reason. Other multimedia programs works fine.



Just found the latest official DisplayLink Manager v. 7.9M0 that is supposed to support Windows 10. Even though the version seems to be the same as the Release Candidate I tried before I installed it. No difference

Edited by mak73
Link to comment

Are any TV cards connected to the dock or laptop?


Are there any USB devices connected to the dock?


Have you tried different TV applications?


To determined if there is a problem in the DVBViewer an if it could be changed. It need to be clear what exactly is causing the problem.

Link to comment

I disconnected my TechniSat CableStar Combo HD CI card from the doc (it definitely has a driver problem on Windows 10 - causes Blue Screen if I try to use it but this is different story). So now DVBViewer only uses Unicast Network Device (Recorder Service installed on another PC). But even if the list of devices is empty the problem still persists.


There are just 2 active USB devices connected - a keyboard and a dongle for wireless mouse. A printer is connected as well but it is turned off. Anyway, I tried to disconnect all USB devices but it does not help. And I tried to connect them directly to the laptop while the dock is disconnected. In this case DVBViewer starts normally. So it must be something with the dock itself.


No, I didn't try different TV apps. What would you suggest to try?

NOTE: since I cannot use my CableStar Combo HD card I doubt I can use anything else but DVBViewer to connect to RS. However I can test if it can start at least.

Edited by mak73
Link to comment

Tried Digital TV program that is supposed to work with CableStar Combo HD card. The app is able to start. It causes Blue Screen though when it really tries to use the card (scanning the channels) But the same happens with DVBViewer as well. Even if dock is disconnected an the card is connected directly to the comp. So CableStar is a different story.

Link to comment
  • 3 weeks later...

Good news - the problem is solved.

Bad news - i don't know how.

It suddenly started to work as expected. I can only guess that it might be connected to network somehow (Lenovo Thinkpad USB3.0 dock also acts as a network adapter). It started to work (at least I noticed it) when I've lost Internet connect due to technical problem at my provider side. I switched off/on my router. It didn't restore the connection at that moment, but I've noticed that DVBViewer can start normally now. And it still does since then.

Link to comment
  • 2 weeks later...



I have the exact same problem, with technisat cablestar combo hd ci. but i cannot manage to make it work!!, can you tell me what driver you use?



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...