Jump to content
NeMiLose

DVB-C Subtitles not detected

Recommended Posts

NeMiLose

Hi,

I have USB device Hauppauge WinTV-soloHD and I use it for DVB-C.

I have been using DVBViewer Pro with the Recording service to watch some channels on a remote location, and it works perfectly.

Recently, I wanted to record a movie on some other channel and then I realized that the subtitles are not recorded. In fact, subtitles are not detected in DVBViewer (Subtitles menu option is grayed-out in the right-click menu), but in the recorded TS video MPC-HC shows all available subtitles (11 of them), but none of them are working. DVBViewer is also not showing EPG for this channel. Something else I have noticed. It is not important for me, but maybe it is important for the problem. There are main audio language and two more languages. DVBViewer correctly shows them in the menu, but only main audio reproduces sound. All of these issues are not present when I watch that channel on LG TV. It shows all subtitles, EPG works and all three audio languages are working.

On some other channel, I was able to see subtitles in DVBViewer and also in the recording.

Here is an example of recorded not-working channel: https://we.tl/t-mSq0GiZosD

Here is an example of recorded working channel: https://we.tl/t-VacaTglL1W

I have also attached support.zip.

support.zip

Share this post


Link to post
Griga

Please open the DVBViewer Channel Editor and check the Service ID of the channel in question. For HD Eurochannel it should be 59. The Stream ID should be 17002. If not, correct it, click apply and try...

 

Please note that the changed channel list must be saved in DVBViewer and your Recording Service stopped and restarted for loading it.

 

Share this post


Link to post
NeMiLose

Thanks a lot! That fixed the problem! Service ID was 34 before.

Can you tell me how did you know correct values? Off course, if it is not complicated to explain :)

 

Share this post


Link to post
Griga

I've used the TransEdit Analyzer:

 

Zwischenablage02.png

 

The right side shows the streams that are actually contained in the recording. The tree view on the left shows the content of the recorded SI tables. Since DVBViewer did not have the correct Sevice ID, it could not spot the PMT (Program Map Table) belonging to the channel, that lists all video/audio/subtitle/teletext etc. streams of the channel. It could only record video and audio with packet identifiers (PIDs) indicated by your channel list.

 

TransEdit can be downloaded from the members (download) area. If you are interested, you can read more about DVB SI tables here.

 

The easiest way to repair a channel affected by wrong channel data is to delete it and let DVBViewer find it again by using a channel search.

 

Share this post


Link to post
NeMiLose

Thanks again for the explanation!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • BZD
      By BZD
      For years I have been using the Terratec Cinergy HTC Stick on Windows 7/8 computer and using DVBViewer Pro without issues, however moving to a new computer with Windows 10 I could not get the Cinergy HTC Stick drivers to work so I acquired the Hauppauge WinTV-soloHD.
       
      Unfortunately the WinTV-soloHD / DVBViewer combination is giving me grief. Through the forum I learned that there was a Hauppauge service which I needed top stop running as it blocked DVBViewer from using the WinTV-soloHD, however having solved that I now find that the only a fraction of the TV channels available are found and no radio channels at all(list is included).
       
      What to do?
       
      I'm located in Denmark and using cable with Yousee as the cable provider. If I run the WinTV V10 software that came with WinTV-soloHD there is no problem accessing all the usual channels, same ones I also had with the Cinergy HTC/DVBViewer combination on my old computer. A list of those channels as they shown with the WinTV is attached. Needless to say, apart from finding all the channels WinTV is a program that is severely lacking.


      support.zip
    • PeteD
      By PeteD
      Hi,
       
      Nachdem mein PCTV Quatro 510e USB-Stick den Geist aufgegeben hatte (Gerät wird nicht mehr erkannt, auch auf anderen Rechnern), und man diesen offensichtlich nicht mehr nachkaufen kann, habe ich mich für einen Hauppauge WinTV DualHD USB-Stick entschieden.
       
      Leider scheint es im Zusammenspiel mit DVBViewer Pro 6.1.5.2 Empfangsprobleme zu geben. Ein Sendersuchlauf gegen Cable-All hat offiziell keine Sender gefunden (Anzeige gelb/dunkelrot und 0/0 im Suchlauf), die Senderliste namens Cable-All ist aber gefüllt. Wenn ich danach einzelne Stationen aufrufe, bleibt das Bild schwarz, in der Statusleiste werden gelb hinterlegt 35% bis 39% angezeigt.
       
      Wenn ich dagegen in der proprietären Hauppauge-Software den Sendersuchlauf mache, findet er alles und habe ich ein gestochenes Bild. Da deren Software vom Funktionsumfang allerdings weit hinter dem DVBViewer zurück liegt und ich auch zufrieden bin, will ich die Software nicht wechseln.
       
      An welchen Schrauben muss ich drehen?
       
      Gruss - Peter
    • Palomino3000
      By Palomino3000
      HI,
      I have win10-64 bit and I have a big problem.
      I have done multiple installations of dvbviever.
      Program Files\DVBViewer     ----> CMUV\DVBViewer   (sat usb card)
      Program Files\DVBViewer 2   ----> CMUV\DVBViewer 2  (sat pci card)
      Program Files\DVBViewer 3   ----> CMUV\DVBViewer 3 (dvdT usb card)
      Program Files\DVBViewer 4   ----> CMUV\DVBViewer 4  (use only for iptv)
      .....
      etc etc
      .....
      Program Files\DVBViewer 8   ----> CMUV\DVBViewer 8 (use only for iptv)
      Program Files\DVBViewer 9   ----> CMUV\DVBViewer 10 (use only for iptv)
      .....
      the problem is if I launch DVBViewer 1 - 2 - 3 - 4 - 5 -6 - 7 -8 start all OK,
      then the (9) nine installation don't start!!! Even 10 and following....
      only 8 instances of dvbviwer at the same time!!!!
      why???
       
      is there a way to solve the problem?
       
      thanx!!
       
    • muggel8378
      By muggel8378
      Hallo,
      zuerst einmal: ich bin absoluter Neuling hier im Forum.. daher verzeiht bitte, wenn ich die hier üblichen Geflogenheiten noch nicht so kenne.
      Nun zu meinem Problem:
      ich habe jahrelang DVBViewer mit DVB-T genutzt..bis zur Abschaltung.
      Inzwischen sind wir umgezogen und haben hier nun Kabel.
      Mein PC; ein ASUS all-in-one ET2701INKI, hat eine eingebaute TV-Karte, die im DVBViewer als "AW-CA 100" angezeigt wird. Leider bekomme ich nicht heraus, welche Karte tatsächlich verbaut wurde.
      Nun habe ich heute DVBView 6.1.0 installiert, unter Einstellungen -> Hardware die AW-CA 100 ausgewählt, Tunertyp Kabel, alle Sendergruppen aktiviert und einen Suchlauf mit der Option "Nach weiteren Frequenzen suchen" durchgeführt. Leider hat er keinen Sender gefunden.
      An unserem Samsung TV hat er mehr als 360 Kanäle gefunden...
      Kann mir jemand sagen, was ich falsch gemacht habe?
       
      LG,
      M.P.
    • NetRider
      By NetRider
      Hallo,
       
      ich bin neu hier und möchte euch kurz mein Problem schildern, in der Hoffnung das Ihr mir helfen könnt.
       
      Aufgrund eines Mainboardwechsels konnte ich meine alte PCI Technisat DVB-S2 Karte nicht mehr verwenden.
       
      Ich habe mich daraufhin für die DVBSKy S950 entschieden und diese heute installiert.
       
      Gleich vorweg, ich habe den Stromanschluss an der Karte nicht angeschlosen, da der LNB komplett versorgt ist.
       
      Nach der Installation sind leider nur die öffnentlich rechtlichen ARD, ZDF usw. inkl. deren HD Versionen zu empfangen. Diese laufen sehr gut und ohne Probleme.
       
      Sobald ich VOX, ProSieben o.ä. also einen Privatsender anschalte kommt jedoch kein Bild.
       
      Kennt jemand das Problem? Einstellung falsch? Ich stehe hier gerade ein wenig auf dem Schlauch ...
       
      Vielen Dank schon mal im voraus für eure Hilfe.
       
      MfG
      Marcus
×
×
  • Create New...