Jump to content
Guest Lars_MQ

TVInfo Plugin

Recommended Posts

hmpf99

... GE 2.2.6 ...

Share this post


Link to post
Lars_MQ

...for Pro and Rec Service... (steht direkt unter dem Titel im Mitgliederbereich).

mit der GE gehts nicht.

Share this post


Link to post
hmpf99

sorry... ich hatte die empfehlung aus dem forum bekommen genau für die anwendung

die ge version zu verwenden ...

 

ich habe einen server, der immer läuft und ich möchte mit wenig systemlast eine möglichkeit

schaffen, sendungen per internet zu programmieren und aufzunehmen.

 

hast du denn nochmal einen "richtigen" tipp, was ich dazu brauche ?

 

vielen dank, frank

Share this post


Link to post
Lars_MQ

Naja, da dich mein tipp mit dem recording service nicht interessiert hatte, hab ich keinen anderen für dich.

Share this post


Link to post
hmpf99

... sorry ich bin wohl doch zu wenig entwickler für diese software. sie gefällt mir gut und

sie läuft gut. aber ich bin leider kein sw-entwickler, sondern ein anwender. und scheinbar

trete ich hier mit jeder frage jemandem auf die füsse. ich weiss leider bis jetzt nicht, was

der recording service ist. ich habe alle vorschläge bisher brav ausprobiert und bin allen

anleitungen gefolgt. wenn ich einen eintrag verpasst habe in einem thread von 8 seiten

tut es mir leid ... jetzt setzte ich gerade alles nochmal neu auf und versuche nach wie vor

einfach nur mal eine aufstellung zusammenzustellen, was ich brauche ...

 

vielen dank, frank

Share this post


Link to post
hmpf99

hallo !

 

ich habe jetzt die pro version installiert. dazu das tvinfo plugin im plugin verzeichnis

zusammen mit der tvinfoDVBV.ini die ich aus der sample datei umbenannt habe.

ein "run" auf das plugin holt wunderbar die daten von tvinfo ab :-)

 

dazu habe ich die stand alone version in form der tvinfoDVBV.exe ins root vom DVBViewer

gelegt. dazu im root die tvinfoDVBV.ini . scheinbar greift die exe aber nicht auf die ini

im root zu, sondern auf die ini im plugin verzeichnis. seit ich das plugin dort zu laufen

gebracht habe, läuft auch die exe und holt den merkzettel ab. die tvinfoDVBV.ini im root

habe ich gelöscht.

 

der DVBViewer service ist auch installiert und aktiv, wenn der viewer aus ist. jetzt hoffe

ich nur noch, dass der service auch die aufnahme startet. ohne DVBViewer.

 

vielen dank an alle, dir mir geholfen haben. auch wenn ich dumme fragen gestellt habe.

ich dachte eben, dass ein forum dazu da ist :-)

 

happy day und dank, frank

 

@lars: dein tipp war übrigens: "Der recordingservice könnte sowas noch besser, aber das

tvinfo plugin versteht sich mit dem noch nicht... "

 

daher habe ich es nicht weiter verfolgt ...

Edited by hmpf99

Share this post


Link to post
Moses
der DVBViewer service ist auch installiert und aktiv, wenn der viewer aus ist. jetzt hoffe

ich nur noch, dass der service auch die aufnahme startet. ohne DVBViewer.

 

Sollte er eigentlich tun, da er genau dazu da ist ;)

 

@lars: dein tipp war übrigens: "Der recordingservice könnte sowas noch besser, aber das

tvinfo plugin versteht sich mit dem noch nicht... "

 

daher habe ich es nicht weiter verfolgt ...

 

Jaaa... da hast du dich aber nicht auf dem laufenden gehalten... der Lars hat extra eine neue

Version des Plugins erstellt, die mit dem Service zusammen funktioniert :blink:

 

vielen dank an alle, dir mir geholfen haben. auch wenn ich dumme fragen gestellt habe.

ich dachte eben, dass ein forum dazu da ist :-)

 

Ich denke, das war ok.. deine Fragen waren auch nicht dumm. >_<

Achja, sorry für den falschen Tip.. :)

 

Gruß

Moe

Share this post


Link to post
chrissi099

Hi,

ich habe ein "Problem". Ich habe ein Tool, das die Timers.XML ausliest und den PC (allgemeiner Server, der tagsüber dauerhaft läuft, d.h. Recording-Service dürfte haarscharf an meinen Anforderungen vorbeigehen) erst dann runterfährt, wenn keine Aufnahme ansteht. Dafür hab ich DVBViewer 3.6.1.20 installiert, da hier ja die Timers-Datei bei Änderungen aktuell auf Platte geschrieben wird. Nur bei Aufruf der TVInfo-Plugins wird die Timers-Datei nicht aktualisiert :-( Gibt es einen Trick oder könnte der Programmierer bitte bitte dieses Feature auch im Plugin aktivieren?

 

 

Danke für Infos,

Gruß, Christian

Share this post


Link to post
Lars_MQ
Gibt es einen Trick

DVBViewer ausschalten, dann schreibt er in die timers.xml. Ansonsten gibt es keine direkte möglichkeit. Es sei denn Dein programm nutzt die COM schnittstelle vonm viewer, dann ist es ganz aktuell.

Share this post


Link to post
chrissi099
DVBViewer ausschalten, dann schreibt er in die timers.xml. Ansonsten gibt es keine direkte möglichkeit. Es sei denn Dein programm nutzt die COM schnittstelle vonm viewer, dann ist es ganz aktuell.

Bis jetzt lese ich die Timers.xml, für XML hatte ich noch Quellcode rumliegen. Naja, muß ich mich mal mit der COM-Schnittstelle auseinandersetzen. Danke für den Tip.

Gruß, Christian

Share this post


Link to post
swerner
Ein Update (1.1) des TVInfo Import Standalone tools liegt in der Membersarea -> Tools.

 

- Hinzugefügt: Unterstützung für den Recordigservice.

 

Bedeutet das, das vorhergehende Versionen keine Aufnahmen mittels recording Service ausgelöst haben?

 

Bei mir startet der PC aber es wird keine Aufnahme durchgeführt.

 

S.

Share this post


Link to post
Lars_MQ

Das bedeutet, das die vorige version nicht den DVBService informiert hat, nur den DVBViewer bzw direktzugriff auf die timers.xml.

 

das letztere ist natürlich blödsinnig, wenn der service läuft, weil der von der änderung der timers.xml nichts mitbekommt.

Share this post


Link to post
No_One

Hi,

 

bei mir werden von Tvinfo-Plugin nur maximal 30 Einträge importiert.

 

Ist das korrekt bzw. könnte man daran etwas ändern?

 

Gruß

Share this post


Link to post
Lars_MQ

Das ist eine beschränkung durch tvinfo.de selber. Daran kann man nichts ändern.

Share this post


Link to post
arcobaleno
Ein Bug im aktuellen TVinfo Plugin:

 

Wenn der Name der Sendung einen neue Zeile oder Leerzeilen enthält (<br> enthalten), dann wird bei der Übernahme in die Timerliste der Text an dieser Stelle abgebrochen - stattdessen erscheint dann das <br> am Ende.

 

So geschehen bei den Terra X-Folgen auf Phoenix.

 

Gruß, dgdg

 

Ich habe dasselbe Problem bei Sendungen in Br-Alpha enthält manchmal der Name einer Sendung eine Leerzeile und auch bei mir erscheint <br>.

 

Ist der bug mittlerweile behoben ? Im Forum habe ich nichts gefunden. Falls doch irgendwo die Lösung steht und ich Sie übersehen haben sollte wäre ich dankbar, wenn man mir sagen könnte wo ich Sie finden.

support.zip

Share this post


Link to post
Marco Ertel

Hallo,

ich habe die aktuelle (1.1) des TVInfo plugins (und die exe) zusammen mit dem DVBViewer 3.8.0.0. Zu Beginn hat es auch funktioniert, aber jetzt werden keine Aufnahmen mehr eingefügt. Egal ob ich das plugin verwende (TVInfo Data request complete kommt dann) oder die Standalone. Egal ob der Recording Service läuft oder nicht.

Ist das etwas bekanntes, oder was mache ich falsch?

Danke und viele Grüsse

Marco

Share this post


Link to post
Dirk Hartstein

Hallo zusammen,

 

wie stelle ich die Premiere Sender in TVinfo.ini ein? Wenn ich mich bei tvinfo.de einlogge, kann ich Premiere HD und Discovery HD auf den Merkzettel setzen. Nur stehen diese Sender nicht in der ini Datei drin, so dass ich diese auch nicht zuordnen kann.

 

Hat jemand eine Lösung?

 

Gruß

Dirk Hartstein

Share this post


Link to post
hmpf99

hallo und guten tag !

 

ich habe auch die aktuelle version des DVBViewer (3.8.0.0) heute aufgespielt und das tvinfo import moudul 1.1. leider klappt jetzt der import nicht mehr. wenn ich die tvinfoDVBV.exe mit "run" starte kommt: "ungültiges argument".

 

was mach ich falsch ?

 

happy day und dank, frank

Share this post


Link to post
Ronaldo

Hallo zusammen,

 

bei mir passiert in etwa das gleiche:

 

Beim Ausführen des Plugins erscheint ein Fehler mit dem Wortlaut:

 

"Could not read the data"

 

Ich habe überprüft, ob tvinfo Daten zurückgibt.

(Aufruf des Url=http://www.tvinfo.de/share/openepg/schedule2.php?username=xyz)

 

Die Antwort schaut so aus:

 

Neues aus der Anstalt - Politsatire mit Priol und Schramm Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=51375342Utz Weber Ina Müller und Band: 'Weiblich, ledig, 40' Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=51198783 Hans Liberg: 'Die Neunte' Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=51198781 Matthias Deutschmann: 'Die Reise nach Jerusalem' Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=51198699 Bodo Wartke: 'Noah war ein Archetyp' Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=51198697 Deutsch-Türkisch, Türkisch-Deutsch Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=51198695 Urban Priol: 'Tür zu!' Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=51198693 extra 3 Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=51290524 extra 3 Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=51290504 extra 3 Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=51290484 Das große Kleinkunstfestival Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=51719313 Lange Nacht der Kleinkunst Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=51375604 3satfestival 2007 - Horst Schroth: 'Nur die Größe zählt' Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=50798673 3satfestival 2007 Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=50798683 Prix Pantheon 'Reif & Bekloppt': Jürgen Becker Theater Magazin http://www.tvinfo.de/exe.php3?target=popup&sidnr=51241559 OLM unterwegs Comedy Show http://www.tvinfo.de/exe.php3?target=popup&sidnr=51237183

 

Hat sich dort etwas geändert?

Wäre nett, wenn jemand reinschauen würde.

 

Schöne Grüße,

Ronaldo

Share this post


Link to post
Lars_MQ

trag als urli n die ini mal

Url=http://www.tvinfo.de/share/openepg/schedule.php?username=

ein.

Share this post


Link to post
Lars_MQ

Ausserdem müsste das so aussehen:

 <epg_schedule_entry uid="77959371" channel="Sci Fi" starttime="2007-09-11 20:15:00 +0200" endtime="2007-09-11 21:05:00 +0200" eventtype="rec">
<title>
<![CDATA[ Stargate Kommando SG-1 - Kollateralschaden (Collateral Damage)
 ]]> 
 </title>
 <nature>Science-Fiction</nature> 
 <format>Serie</format> 
 <deeplink>http://www.tvinfo.de/exe.php3?target=popup&sidnr=51101524</deeplink> 
 <cast_director>William Waring</cast_director> 
 <cast_actors>Ben Browder, Michael Shanks, Amanda Tapping, Christopher Judge, Beau Bridges, Claudia Black, Gary Jones</cast_actors> 
 </epg_schedule_entry>

Hast Du das im dem Konto auch richtig eingestellt bei tvinfo? recording device -> open epg

Share this post


Link to post
Ronaldo

Hallo Lars,

 

danke für deine schnelle Antwort.

Habe den URL angepasst, open epg ist auch eingestellt, die Antwort von tvinfo ist auch im richtigen Format, habe mich vorhin dummerweise nicht den Quelltext kopiert :bye:

Leider kommt die Fehlermeldung immer noch.

 

Hatte vergessen zu erwähnen, dass dieses Problem auch erst seit ~1 Woche auftritt.

Vorher hat es problemlos funktioniert. Am DVBViewer habe ich seitdem nichts geändert.

 

Gruß,

Ronaldo

Share this post


Link to post
Lars_MQ

Schau mal in die readme vom tvinfo plugin, es gibt ne commandline, um nen dump vom empfangenem dokument zu erstellen. mach das mal bitte und schick es mir per PM zu. Wahrscheinlich liegt es an irgendeinem eintrag, weil das ganze läuft bei mir problemlos...

Share this post


Link to post
Ronaldo

Hmm, ich weiß nicht genau, woran es liegt, aber auf nem anderen Rechner funktioniert das Plugin problemlos.

Auf meinem legt er nicht mal die tvinfo.xml an.

 

Aber vielen Dank für deine Hilfe soweit.

Share this post


Link to post
Simbart

Hallo zusammen,

 

zuerst mal vielen Dank für dieses tolle Plugin. Ich habe es die letzten Monate prima nutzen können.

Leider verdoppelt, verdreifacht, ... es die Aufnahmen seit einiger Zeit (möglicherweise nach einem Update des DVBViewers?).

 

Details:

Die Exe wird nachts per Task ausgeführt. Eine Minute später startet der DVBViewer um das EPG einzulesen (ich nutze noch das EPGPlus Plugin).

Schaue ich in die Rekorderprogrammierung, so habe ich - je nach dem wie viele Tage es her ist, dass ich die Sendung in tvinfo.de programmiert habe - n mal die gleiche Aufnahme eingetragen.

 

Ich habe das ganze mal manuell nachgestellt. Das Positive daran ist, dass der DVBViewer daraus nur einen Task macht.

Hat jemand das gleiche Problem? Gibt es eine Möglichkeit dies abzustellen?

Braucht wer noch mehr Info (support.zip, o.ä)?

 

Danke schon mal für die Hilfe.

 

Gruß

Stephan

Share this post


Link to post
Lars_MQ

Teste das bitte mal ohne epgplus. TVInfo läuft hier permanent ohne jegliche duplikatserzeugung.

Share this post


Link to post
Simbart

Hallo,

 

auch ohne das TVInfo Plugin besteht das gleiche Problem. Beide Plugins liefen monatelang problemlos zusammen. Ich werde mal neu installieren und berichten.

 

Bis denne

Stephan

 

Leider ist nach der Neuinstallation keine Besserung eingetreten. Die Einträge werden weiterhin vervielfacht.

Edited by Simbart

Share this post


Link to post
dgdg
Die Exe wird nachts per Task ausgeführt. Eine Minute später startet der DVBViewer um das EPG einzulesen (ich nutze noch das EPGPlus Plugin).

Schaue ich in die Rekorderprogrammierung, so habe ich - je nach dem wie viele Tage es her ist, dass ich die Sendung in tvinfo.de programmiert habe - n mal die gleiche Aufnahme eingetragen.

 

Das ist doch ein bekanntes Verhalten des Plugins und wurde hier im Forum auch schon mehrfach berichtet. Es kam aber bisher nie eine Rückmeldung zu dem Fehler von Lars.

 

Bei mir macht das Plugin das schon seit der ersten Version, die ich installierte hatte und völlig unabhängig von anderen Plugins. Und bei anderen Usern ist das auch so.

Der Fehler ist sowohl in der Plugin-Version als auch in der EXE-Version vorhanden (unabhängig voneinander).

 

Als Work-around wurde auch schon mehrfach empfohlen, die timer-Datei vor dem Import komplett zu löschen. Leider ist das keine Lösung, wenn man neben TVinfo auch noch andere Quellen für die Programmierung benutzt, z.B. das EPG.

 

Siehe z.B.:

http://www.DVBViewer.info/forum/index.php?showtopic=19260

http://www.DVBViewer.info/forum/index.php?showtopic=15704

http://www.DVBViewer.info/forum/index.php?...st&p=117956

 

Ich fände es ja völlig ok, wenn Lars antworten würde, dass er im Moment keine Zeit und keine Lust hat, den Fehler zu beheben. Dann weiss man wenigstens Bescheid. Aber stattdessen zieht Lars es vor, offensichtliche Fehler einfach zu ignorieren. Soll sich doch jeder User einen Wolf suchen, weil er denkt, es läge an seiner Konfiguration...

Edited by dgdg

Share this post


Link to post
Simbart

Hallo,

 

ich dachte, dass der Fehler mit der neuesten Version behoben sei. So hatte ich es zumindest noch aus den vorherigen Posts dieses Threads in Erinnerung. Möglicherweise irre ich mich auch und sollte noch mal nachlesen.

Nichtsdestotrotz lief es monatelang gut, und es wundert mich halt, dass es plötzlich nicht mehr funktioniert. Die Ursache (irgendein Update, etc.) konnte ich bislang nicht herausfinden. Ich hätte das Problem gerne behoben und bin gerne bereit dabei mitzuhelfen.

 

Ich finde, dass teilweise ein bißchen offensiv an die Sache herangegangen wird, was den Ton der einzelnen Posts angeht und wünschte mir etwas mehr Gelassenheit. Da es sich bei dem Plugin um das Engagement einer Privatperson handelt, finde ich es unfair diese so anzugehen. Just my 2 cents ...

 

Also, was kann ich dazu beisteuern, damit wir das Problem beheben können?

 

Danke

Stephan

Share this post


Link to post
Lars_MQ

@dgdg

Ich weise an dieser stelle ausdrücklich auf die nutzungsbedingungen des tvinfoplugins und standalone hin:

Verbesserungen und neue Versionen werden nach Möglichkeit zur Verfügung gestellt. Jegliche Ansprüche auf Updates, Support oder Fehlerbeseitigung sind jedoch speziell für das TVInfo Import Plugin explizit ausgeschlossen. Die Benutzung erfolgt auf eigenes Risiko.

Solltest Du damit nicht einverstanden sein, muss ich Dich auffordern das plugin unverzüglich zu löschen und Dir meine genehmigung dies zu nutzen entziehen.

 

@Simbart

Also, was kann ich dazu beisteuern, damit wir das Problem beheben können?

Wie gesagt, läuft das bei mir problemlos, also müssen wir versuchen einzukreisen, wo es schief läuft. Kannst Du mir PM Deine kanalliste und timers.xml gezipped zukommen lassen (hilfe -> konfigordner) und 2 oder 3 von den sendungen benennen, die Du über TV info programmierst?

Share this post


Link to post
dgdg
Ich finde, dass teilweise ein bißchen offensiv an die Sache herangegangen wird, was den Ton der einzelnen Posts angeht und wünschte mir etwas mehr Gelassenheit. Da es sich bei dem Plugin um das Engagement einer Privatperson handelt, finde ich es unfair diese so anzugehen. Just my 2 cents ...

 

User, die sich hier im Forum mit Problemen melden, werden oft im gleichen Ton abgefertigt. Also wie man in den Wald ruf...

Der Ton hier im Forum ist leider sehr rau. Schau dir mal einige Threads und Reaktionen auf Fehlermeldungen an.

 

Ich erwarte nicht, dass jeder Fehler zeitnah behoben wird. Ich erwarte aber, dass mehrfach gemeldete Fehler zumindest mal zur Kenntnis genommen und nicht reflexartig immer auf Konfigurationsprobleme beim User geschoben werden.

Edited by dgdg

Share this post


Link to post
Simbart

Hallo,

 

ok, das ist mir auch aufgefallen und ich hatte es in meinem letzten Post nicht deutlich genug wiedergegeben. Ich meinte beide Seiten.

Aber ich glaube wir kommen etwas vom Thema ab :huh:

 

@Lars

Ich werde Dir die Daten so schnell wie es geht schicken, weiß aber nicht, wann ich das nächste mal am heimischen PC sitzen werde.

 

Gruß

Stephan

 

[edit]Die Vervielfältigung geschieht nur dann, wenn zwischendurch der DVBViewer gestartet wird.

@Lars_MQ: Ich darf leider kein Mail innerhalb des Forums verschicken. Somit kann ich Dir die Dateien zunächst nicht zur Verfügung stellen :rolleyes:[/edit]

Edited by Simbart

Share this post


Link to post
Lars_MQ

Ein Update für beide tvinfo programme ist im Mitgliederbereich.

 

Fix:

- Duplizieren von Timern.

 

Achtung:

Die Struktur innerhalb der zip Datei wurde geändert. Als Basisverzeichnis wird jetzt immer der DVBViewer Programmpfad vorausgesetzt. Bitte die Datei unter Beibehaltung der Pfade entpacken. Alle Liesmich-Dateien werden im Ordner DVBViewer\Docs abgelegt.

Share this post


Link to post
Simbart

Hallo,

 

bei mir geht's nun.

 

Vielen Dank!

 

Gruß und ein schönes Restwochenende

Stephan

Share this post


Link to post
dgdg

Hier klappt's auch. Damit hat sich die Usability des Plugins und damit des gesamten DVBViewer bei mir um mindestens 50% gesteigert.

 

Jetzt kann ich den Import endlich automatisieren. :bye:

Share this post


Link to post
dgdg

Tja, wie gewonnen, so zerronnen.

 

Das Thema tvinfo dürfte sich auf absehbare Zeit erstmal erledigt habe. Mit dem Komplettausfall der wichtigsten Funktionen wie OpenEPG und der Agenten ist für mich die gesamte Funktionalität DVBViewer + vollautomatische Programmierung über Internet erstmal dahin.

 

Also zurück zu tvtv und zur manuellen Programmierung jeder einzelnen Sendung über EPG - zurück in die Steinzeit. :blink:

Share this post


Link to post
Lars_MQ

Ja einfach in der tvinfoDVBV.ini ändern.

 

[Main]
Username=
Password=
Triggeraction=16384
Url=http://www.tvinfo.de/classic/share/openepg/schedule.php?username=

 

 

dgdg neigt einfach nur zur panikmache :blink:

Share this post


Link to post
quinten41

Wenn alles so einfach wäre!

 

DANKE! :blink:

Share this post


Link to post
Marco Ertel
Ja einfach in der tvinfoDVBV.ini ändern.

 

[Main]
Username=
Password=
Triggeraction=16384
Url=http://www.tvinfo.de/classic/share/openepg/schedule.php?username=

dgdg neigt einfach nur zur panikmache :blink:

 

hmm. Bei mir funktioniert es trotzdem nicht. Solange ich in der standalone exe ein passwort eintrage bekomme ich eine Fehlermeldung (und in der tvinfo.log einen 404). Sobald ich das password und configuration leer mache bekomme ich zwar keine Fehlermeldung mehr, aber leider auch kein tvinfo.log oder das xml file (trotz save oder verbose option).

Sollte in der .ini Username leer bleiben wie im Beispiel, oder soll da das richtige rein? Soll die url wirklich nach username= aufhören oder soll ich die komplette url inkl. md5 passwort verwenden (so wie sie auch im Browser funktioniert und mir eine sinnvolle xml Datei liefert)?

Vielen Dank und viele Grüsse

Marco

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...