Jump to content
Tüftler

iMonPad & MCE Konfigdateien

Recommended Posts

12die4

@desweil: Nein, das ist es nicht. Wenn die Übertragung eine AC3 Tonspur hat, dann macht es keinen Unterschied, weil das Signal einfach durchgeschleift wird. Bei normalem MPEG Stereo wird die Lautstärke vor dem Übertragen via SP/DIF aber entsprechend der Einstellung im DVBViewer angepasst. Das hat zur Folge, dass ich den Ton versehentlich leise stelle und mich dann wundere, warum es trotz hoher Lautstärke am AVR noch nicht wie gewünscht ist. Stört einfach, dass der DVBViewer da anspringt.

 

@Tjod: Hmm. Kenne mich mit VBScripts leider überhaupt nicht aus. Hat jemand eine Idee, inwiefern ich das abändern muss? Ideal wäre natürlich die entsprechende Codezeile, die rein muss...

Share this post


Link to post
12die4

Hey, ich nochmal. Ich habe eine Frage wegen der Steuerung. Bin mir nicht sicher, ob es nur an der FB-Belegung liegt oder vielleicht an etwas anderem, daher zunächst mal meine Konfiguration:

 

DVBViewer 4.2.1

OSD Skin Concinnity v2.1

iMon Pad eingebunden wie hier angeboten (Version 4), nur die Audio-Taste ist anders verknüpft (siehe oben) und die Tasten "TaskSwitcher" und "AppLauncher" habe ich im DVBViewer ebenfalls zugewiesen. Waren vorher ungenutzt. Ansonsten alles gleich.

 

Und zwar habe ich mehrere Nachrichten-Quellen für den DVBViewer eingestellt. Eine, die erste ist Spiegel Online. Gehe ich jetzt über das OSD Menü zu den Nachrichten, werden mir die Nachrichten von Spiegel Online angezeigt. Funktioniert soweit super. Nur ist es mir nicht möglich zu den anderen Newsanbietern zu wechseln. Unten in der Skin-Leiste wird das Spiegel-Logo angezeigt mit Pfeilen nach rechts/links zum Durchwechseln. Ich komme mit dem Pfeiltasten auf dem iMon Pad dort aber nicht hin und kann nur "neu laden".

 

thumb_newsmode.png

 

Habe schon alle Tasten auf der FB ausprobiert. Skip Back/Fwd, Kanal +/-, alle Farbtasten, alles. Es gibt scheinbar keine Verknüpfung dazu. Und mit den Pfeiltasten kann ich mich wie gesagt auch nicht dort hin klicken. Weiß jemand Rat??

 

 

EDIT: *Args* Kommando zurück. Jetzt hab ichs gecheckt. :) Man muss von der Nachrichtenliste erstmal nach links (auf Neu laden), dann nach unten, wodurch dann das Auswahlfenster angewählt wird, obwohl es nicht darunter sondern daneben angeordnet ist und man die Markierung kaum sieht, und dann kann man mit Re/Li den Newsanbieter durchwechseln. Mann, ist das bescheuert. :blush:

Edited by 12die4

Share this post


Link to post
Innuendo
also ich habe meine Imon auch mit ner Harmony ersetzt. kein problem. Empfänger ist der eingebaute vom IMON Display. Man muss höchstens die Wiederholrate in der Imon software runterdrehen und oder in der harmony software die wiederholungsgeschwindgkeit anpassen. Dann klappt alles!

 

Hallo,

zu dem Thema hätte ich doch gern mal grad eine Frage.

Mein System: Harmony 785, iMon Konfig ist mit der Logitech Software eingerichtet (aktueller Stand), iMON LCD als Empfänger.

Es funktionieren auch alle Tasten, nur der OK Button sendet sehr oft 2 Signale. Das ist beim durchzappen von Musikfiles oder in den Favs etwas nervig.

In der iMon Software habe ich auf der Seite Geschwindigkeit sämtliche Kombinationen ausprobiert: keine Änderung

In der Logitech SOftware habe ich die Tastenverzögerung ausprobiert: keine Ändeurng

Unter WIndows 7 Systemsteuerung Tastatur die Wiederholrate verändert: keine Änderung.

Muss man mit diesem Fehler leben oder gibt es einen Trick?

 

Innu

Share this post


Link to post
Innuendo
Muss man mit diesem Fehler leben oder gibt es einen Trick?

 

Es scheint eine Inkompatibilität zw Logitech Harmony und iMon Pad zu bestehen. Diese Inkompatibilität macht sich in Tastenwiederholungen bemerkbar. Nachzulesen hier: http://forums.logitech.com/t5/Harmony-Remo...iver/m-p/311637

Der vorgeschlagene Lösungsweg aus diesem Forum lautet: umstellen von Pad auf MCE (und damit verbunden Protokollumstellung).

 

Innu

Share this post


Link to post
Tüftler

Meine 300'ter (siehe >hier<) hatte glaubig selbsttätig diese Umstellung ausgelöst, denn danach funktionierte das iMonPad nicht mehr als Gerät. Es musste erst ein Neustart gemacht werden.

Im übrigen bin ich vom Logitech Support stark entäuscht, denn auf meine Fragen habe ich Null Reaktion bekommen. :angry:

Ich bin jedenfalls wieder zurück auf das iMonPad gegangen denn meine bessere Hälfte ist eher lernunwillig wenn es um neue Gerätschaften geht. Außerdem sind die Tastenbezeichnungen beim Pad wesentlich logischer und HTPC-typischer zu belegen, siehe auch mein verlinkter Beitrag.

Share this post


Link to post
12die4

Ich habe grade ein seeehr merkwürdiges Problem. Ich glaube mein iMon Modul mag mich nicht mehr. Bis vor 2 Stunden lief alles noch einwandfrei, jetzt nimmt der HTPC plötzlich keine FB-Befehle mehr an - egal was ich drücke oder wie lange ich drücke.

Zuerst dachte ich, es liegt an der Beta-Version von der iMon Software, die ich verwende. Habe darauf hin die aktuellste non-Beta installiert (vorher die Beta sauber deinstalliert). Damit ist es aber genauso. Die iMon Software läuft natürlich im Hintergrund (genauso wie das seit vorgestern endlich funktionierende iMon VFD Plugin). Öffne ich die Einstellungen von iMon und klicke dort herum, kommt es vor, dass die Befehle plötzlich wieder erkannt werden. Das Problem ist aber: Ich mache alle Wartungen am HTPC über eine Remote-Desktop Verbindung. Bei beenden der Verbindung muss ich neustarten, damit er mich nicht nach dem Passwort des Win Benutzeraccounts fragt (was ich für eben diese RDP-Verbindung brauche). Nach dem Neustart funktioniert es aber schon wieder nicht. Wenn die RDP-Verbindung besteht, hilft es auch den iMon Manager neuzustarten.

 

Hat noch jemand das Problem? Wie bekomme ich es weg? Es ist unglaublich nervig, weil ich gar keine Kontrolle über den HTPC habe (keine Tastatur etc).

 

EDIT: ---------------. Ich habe das Problem eingegrenzt und es liegt definitiv an der Kooperation iMon und iMon Plugin. Hau ich das Plug-In aus dem Autostart raus, funktioniert die Fernbedienung. Zu früh gefreut. Scheißkiste...

Edited by 12die4

Share this post


Link to post
Tüftler

Weiteres Update der 4.3xxBeta_Testversion >Klick<

 

- Überarbeitung der Farbtastenfunktionalität im MiniEPG (Grün & Gelb funktionierten nicht!)

- Farbtaste Gelb funktioniert jetzt wie im DVBViewer Standard

- Globales Zurück für >OSD-Skin BluFuzz< hinzugefügt -> wirkt in anderen Skins wie die normale Zurückfunktion!

-> Achtung! Die iMonPadVersion4Beta.remote muss neu importiert werden, voher bitte die Standardwerte laden. Derzeit sind die MCE-Profile noch nicht eingearbeitet!

Edited by Tüftler

Share this post


Link to post
Guppy79

Hallo zusammen,

 

ich habe mich nun ein wenig mit dem Gedanken befasst, doch meine Harmony mit meinem HTPC zu verbinden. Ich habe hier auch schon einiges gelesen, aber ich finde das doch etwas zu kompliziert, da in auf 14 Seiten wirklich viel steht.

 

Als erstes möchte ich gerne erfahren, welche HW ich noch brauche. Also ich habe zu Hause bereits die Harmony One, nutze die aktuelle DVBViewer Version mit dem Conc... 3D Skin. Beim Tower habe ich dieses iMonPad dabei bekommen und auch diese Imon Software ist für das Display installiert. Jedoch wüsste ich nicht, dass im Tower ein IR Empfänger vorhanden wäre.

 

Ich möchte jetzt halt meine Harmony mit dem PC bzw. DVBViewer in Einklang bringen. Was benötige ich hierzu alles an Software und ggf. noch an Hardware?

 

Danke

Share this post


Link to post
skeal

Also wenn du ein Imon Pad dabei hattest, dann ist auch ein ir-empfänger mit drin.

Wenn du Imon installiert hast, kannst du mit der Anleitung von Tüftler deine Harmony zum laufen bekommen. Am besten aber im MCE-Modus. Da sparst du dir Probleme mit wiederholenden Tastenbefehlen etc...

Share this post


Link to post
Tüftler

Hallo Guppy79,

lass dich mal nicht von der Seitenzahl der Anleitung abschrecken. Für dich ist, wie auch Skeal geschrieben hat, der MCE-Modus empfehlenswert. Die meisten Sachen in der PDF sind auch nur als unmissverständliche Anleitung so ausführlich beschrieben und die Belegungstabelle ist aus Interesse bzw. zum Nachvollziehen/Vergleichen der verschiedenen Versionen dabei.

Der IR-Empfänger ist in dem Display verbaut, das sollte auch in der Anleitung so drin beschrieben sein. Aber das ist auch von Hersteller zu Hersteller unterschiedlich.

Mit dem Erscheinen des nächsten DVBViewer Release werde ich ältere Versionen, also die jetzigen, nicht mehr pflegen.

Die aktuelle 4.3xxBeta_Testversion >Klick< wird dann die anderen ersetzen. Das MCE-Profil werde ich wohl spätestens nächste Woche nachreichen.

Share this post


Link to post
Guppy79

Dann habe ich den IR Empfänger sicherlich damals nicht eingebaut. Wie sieht so nen Teil denn aus? Leider war damals beim Gehäuse keine Anleitung dabei. Sagen wir ich habe den jetzt nicht mehr, was brauche ich dann für einen Empfänger? Ist das so nen Rc6 IR Empfänger als USB Microstick? Habe so einen bei Ebay gesehen. Und wenn ich den dann angeschlossen habe, habe ich dann überhaupt noch was mit dem IMonPad zutun? Welche Config brauche ich dann für den MCE Empfänger?

 

Gruß

Share this post


Link to post
Tüftler

Also nochmal, wenn du zu deinem iMonPad ein Display bekommen hast dann ist intern in diesem die IR-Diode eingebaut.

Die iMonSoftware funktioniert nur wenn das Display oder ein ähnlicher Empfänger, bspw. iMonKnob, angeschlossen ist.

Eine RC6 sollte mit der Harmony gehen, musst halt das Profil des Empfängers dann laden. In diesem Falle benötigst du keine iMonSoftware und kannst mein MCE-Profil trotzdem nutzen.

Share this post


Link to post
Guppy79

Also mein Gehäuse hat ein Display, allerdings habe ich damals beim Bau des ganzen HTPC nichts vom Display an das Mainboard angeschlossen, meine ich so dass ein IR funktionieren würde. Ne Idee wie ich das testen kann? Also mein Windows zeigt mir im Gerätemanager nichts in Bezug auf IR an.

DIe Original FB habe ich auch noch hier, kann ich mit der evtl. etwas testen?

 

Was ist ein ImonKnob bzw. evtl. heißt es Knopf...?

 

Was muss ich wie, wo und wann laden? Wie gesagt, ich habe keine Ahnung von so komplexen Sachen bzw. kann mich darein arbeiten, aber zur Zeit habe ich halt nur die Harmony und mehr nicht.

Share this post


Link to post
Tüftler

Schon mal was von Google gehört? Da hättest du gleich als erstes das gefunden ->

:whistle:

Weiterhin kann ich dir nur sagen das bei mir die IR-Diode im Display verbaut ist und was anderes habe ich noch nicht gesehen.

Du brauchst also irgendein IR-Empfänger den du am Besten per USB anstöpselst damit er die Fernbedienungsbefehle deiner Harmony weiterleiten kann.

 

Das gute bei den iMonDisplays ist das die den Rechner per Schaltsignal auf dem Mainboard starten können. Das Funktioniert immer!

Bei USB-IR-Geräten muss das dagegen nicht immer der Fall sein.

Share this post


Link to post
@lex

nabend

 

ich geb mal meinen senf dazu und mach bissl werbung

 

im mce forum verkauft der user AEOne RC6 IR-Empfänger

gute empfänger... ich habe zwei bei ihm gekauft... bezahlung und versand innerhalb einer woche

 

den kann ich empfehlen

 

ich steuere den schlafzimmer pc (harmony one) und den wohnzimmer pc (harmony 900) mit je einem empfänger & eventghost

klappt wunderbar...

 

als profil ist auf beiden harmonys "Windows Media Center SE" haste reichlich tasten und fertig is

 

auf einer harmony hatte ich mal testweise das imon pad "simuliert" das klappt mit dem imon empfänger meines htpc gehäuses auch wunderbar (der ir empfänger vom gehäuse ist jetzt aber deaktiviert)

 

grüße @lex

 

@Tüftler

Schon mal was von Google gehört?

 

das kannste hier und in fast jeden anderen forum leider als einleitungssatz für fast jeden post nehmen

Edited by @lex

Share this post


Link to post
michael0612

Hallo gemeinde, hallo Tüftler ,

 

habe mit begeisterung deine vorgefertigte ´´iMonPad_MCE_Konfig´´ VERSUCHT zu installieren. leider GRANDE KATASTROPHE....oder ich mache was falsch.....gehe nach deiner anleitung vor nur ist der inhalt der DVBViewer.imo LEER ??

Du schreibst.....Einstellungen“ > „Programm-Befehl“, bei DVBViewer, > „Importieren“ klicken und dort die

DVBViewer.imo auswählen. habs so gemacht........aber da stehen auf deinem bild alle befehle drin.....bei mir nix....also LEER.......Bitte um hilfe oder fehlerfreie imo. Danke gruß micha.

Share this post


Link to post
Tüftler

Hallo michael0612,

welche DVBViewer Version nutzt du, welche iMon-Version (>iMonManager >Option >Version) und welches Betriebssystem sowie welche Fernbedienung (MCE oder iMonPad)?

Wenn du die DVBViewer.imo mit dem Editor öffnest steht da was drin?

Edited by Tüftler

Share this post


Link to post
michael0612

Hallo tüftler, danke für die schnelle antwort.

DVBViewer 4.2.1, Betriebdsystem Win7 64. Gehäuse Thermaltake DH101 mit lcd display und die dazugehörige FB ( nicht die phillips).Habe gerade die dateien mit dem editor geöffnet....und...LEER...kein wunder das es nicht klappt....obwohl er als größe 22k anzeigt. hast du eine idee? ACHSO...version medialab istallations cd, irgendwas mi 6.x.x.x. habe schon wieder deinstalliert. die einstellungen waren aber EXACT wie von dir beschrieben, nur wenn das verzeichnis leer ist kann´s nicht klappen.

gruß micha

Share this post


Link to post
Tüftler

Dann lade dir das Pack nochmal aus dem 1. Post und überschreibe die vorhandene DVBViewer.imo in deinem Soundgraph Ordner.

Mehr kann ich dir nicht sagen.

Share this post


Link to post
michael0612

Danke, werds nochmal versuchen. berichte dann.

gruß micha, schönen abend

Share this post


Link to post
michael0612

Hallo Tüftler, hat funktioniert ,alles bestens.

Share this post


Link to post
Tüftler

>Update der 4.3xx_Beta_Testversion<

 

- Aktion der Farbtaste Blau im Falle einer laufenden Diashow geändert -> Bei der Diashowwiedergabe war es nicht mehr möglich über die Farbtaste Blau in den Bilderordner zu gelangen ohne die Wiedergabe abzubrechen. Prozedur: Die Farbtaste Blau ruft als erstes das Diashowmenü auf, ein erneutes drücken auf Blau wechselt dann wieder in den Bilderordner.

- Der Standardwert für die Suche nach Audiodateien in der Playlist, im Zusammenhang mit der Diashowwiedergabe, wurde von 20 Titeln auf 10 Titel geändert.

- Scriptstruktur überarbeitet

Share this post


Link to post
wiwe

Hallo,

habe den iMonPad bisher auf Win XP mit Erfolg benutzt. Nun habe ich auf Windows 7 x64 gewechselt und es rührt sich nichts mehr!

 

Konfiguration:

DVBViewerPro Beta 177

iMon Retail-Version von Zalmann

VFD von Zalmann

iMonPad Beta 4.3xx von Tüftler

 

Kann es sein, dass der Plug sich nicht mit einer x64 verträgt?

 

Schon mal Dankeschön im voraus für jeden Tipp!

 

wiwe

Share this post


Link to post
wiwe

Hat sich erledigt. Fehler lag in der Config für iMonPlugin!

Share this post


Link to post
Tüftler

Weiteres >Update der 4.3xx_Beta_Testversion<, kleine Erweiterung hinzugefügt:

 

- Farbtaste Grün öffnet auf Sky das PortalSelect Menü, außer das MiniEPG ist sichtbar. -> PortalSelect kann ich selbst, mangels einer Abokarte, nicht testen!

Share this post


Link to post
woipadina

hallo,

ich muss zuerst mal sagen, dass diese Fernbedienungsprofile hier der absolute hammer sind. echt top.

ich hätte noch zwei kleine sachen, die bei mir nicht so funktonieren, wie ich es gerne hätte.

und zwar zum einen, wenn das miniepg da ist, dann sollte man mit den farbtasten infos zu der sendung öffnen können. hier wäre, wie beim normalen osd auch schön, wenn die farbtasten die originalen funktionen hätten.

außerdem kann man ja mit der * und # taste bei aktiviertem bild in bild den ton oder das bild wechseln. ich habe aber immer timeshift aktiviert, und deswegen wirde bei drücken von einer der beiden tasten das bild in bild ausgeschaltet und die video-/audioausgabe umgeschaltet. es wäre hier schön, dass wenn bild in bild aktiviert ist, bei den beiden tasten die normalen funktionen, wie wenn timeshift aus ist vorherrschen würden.

vielleicht ist das ja ohne besonders großen aufwand realisierbar.

ich muss noch dazu sagen, dass ich die version vom juli drauf habe, weil ich die aufgeführten verbesserungen zur neuesten version bis jetzt noch nicht brauche.

Share this post


Link to post
Tüftler

Hallo woipadina,

wenn ich das richtig verstehe benutzt du noch nicht die Beta-Version und hast damit die "alte" Konfig aus dem 1.Post.

Ich habe nicht mehr vor diese Version weiter zu pflegen, da 1. der Aufwand echt überhand nimmt, 2. viele Vereinfachungen in der Beta umgesetzt wurden und 3. es nicht mehr lange dauern wird bis es eine Release Version gibt. Selbst wenn du die neuen Funktionen der Beta nicht benötigst so sind die Überarbeitungen besonders in Bezug auf PiP auch von einigen Fehlern befreit worden.

 

- zum Timeshift-PiP-Problem:

Es ist für mich derzeit nicht möglich mit VBS-Mitteln eine PiP Aktivität zu erkennen. Daher kann ich die Funktionen für * bzw. # dahingehend nicht optimieren. Ich hatte diese Anfrage schon vor rund 1 Jahr mal gestellt und es wurde dahingehend bisher nichts geändert.

 

- zum MiniEPG-Problem

In der 4.3xxBetaVersion ist das Problem gefixt

Edit 12.07.10:

- Überarbeitung der Farbtastenfunktionalität im MiniEPG (funktionierten nicht!)

Share this post


Link to post
Tüftler

@woipadina

Ich habe ein wenig bei PiP-Aktivität herumprobiert und für Timeshift bei PiP evtl. eine Lösung. Es wäre sowieso nur möglich die Audiowiedergabe umzuschalten, Bildumschaltung ist bei Timeshift eh nicht möglich.

Ich muss jetzt aber erstmal die Variationsmöglichkeiten bei Freigabe der Funktion überdenken und sehe da schon ein Problem wenn jemand diese Taste benutzt wenn kein PiP aktiv ist (könnte eine laufende Timeshiftaufnahme killen).

Im PiP geht es aber erstmal, soweit ich das überblicken kann. Wenn du auf die Beta wechselst würde ich dir eine Testversion zur Verfügung stellen.:blush:

Share this post


Link to post
woipadina

danke für die schnellen antworten. das mit den farbtasten hab ich doch glatt im changelog überlesen....

 

ich werde dann die beta mal draufspielen.

Share this post


Link to post
Tüftler

Ok, dann melde dich wenn du die Testversion ausprobieren kannst.

Share this post


Link to post
woipadina

ich habe jetzt mal die neueste beta draufgespielt. danach war es aber so, dass bei der thumbnail und der menü taste der videotext kommt. habe den tastenbefehl jetzt manuell bei der imon software eingestellt.

könnte aber jetzt deine neue version testen

Share this post


Link to post
Tüftler

@ woipadina

Ich habe dir eine PM geschickt und deine gemeldeten Fehler hoffentlich gleich mit behoben.

Share this post


Link to post
kawa-69

Hallo Tüftler,

 

zunächst mal ein großes Lob für die Konfig.......alles supi. Habe allerdings ein Problem mit der DVD Taste, wenn ich diese drücke erscheint keinerlei Menü sondern der Viewer stürzt völlig ab. Ich benutze die letzte beta einmal vom Viewer wie auch von deiner konfig. BS ist Win7 Ultimate 64. Mach ich etwas völlig falsch oder habe ich was überlesen?

Den Laufwerksbuchstaben habe ich auch angepasst in der play.vbs. Achso ich nutze eine imon RM 200, sieht eigentlich genauso aus wie das imon pad.

 

Danke schonmal für eine Antwort

Share this post


Link to post
Tüftler

Stelle mal bitte eine support.zip rein und deine play.vbs. Einen Absturz mit dieser Funktion habe ich noch nie erlebt, ich denke es ist ein Decoderproblem.

Share this post


Link to post
kawa-69

Passiert übrigens nur wenn eine BD im Laufwerk ist. In beiden anderen fällen funzt alles, aber eskommt auch bei einer DVD kein Auswahlmenü. Support.zip und die play.vbs stelle ich morgen mal ein. Schau jetzt Fußball.....

 

Danke

Share this post


Link to post
Tüftler

Es kommt auch nur das Auswahlmenü bei einer BluRay. Hast du etwa versucht eine kopiergeschützte BluRay mit dem DVBViewer abzuspielen, das muss dann ja schief gehen. -> http://de.DVBViewer.tv/wiki/M2ts/Blu-Ray

Share this post


Link to post
kawa-69

Natürlich habe ich nicht versucht eine originale BD mit dem Viewer zu öffnen, da das ja schief gehen muss....... B)

Anbei die support.zip.

Share this post


Link to post
kawa-69

und die play.vbs

 

 

Share this post


Link to post
Tüftler

Tut mir leid aber ich kann dein Absturzproblem nicht nachvollziehen.

1. Habe ich keine ungeschützte BluRay hier (oder DVD mit UDF 2.5 Dateisystem)

2. Stürzt selbst der DVBViewer nicht ab beim Versuch eine geschützte BluRay abzuspielen

 

Du kannst nur verschiedenen Decoder ausprobieren oder am Besten erstmal prüfen ob sie mit PDVD abspielbar ist (nicht VLC Player verwenden, da der seine eigenen Decoder mitbringt und das könnte vom Problem ablenken!).

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...